Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

GRUB na pendrive nie startuje pod DOSem windows 8

01 Cze 2014 10:45 1011 4
  • Poziom 7  
    Witam, zrobiłem bootowalnego pendrive (kingstone traveler 32gb) ktory nie dziala pod biosem ( posiadam windows 8 PRO). Do zrobienia bootowalnego pendriva z paroma wersjami Windowsa uzyłem 3 programów:
    1. Martik USB Disk Formatter 1.1 - formatuje pendriva (pendrive sformatowany w FAT 32 )
    2. MobaLiveCD_v2.1 - bootuje pod windowsem dla testu np. pendriva
    3. MultiBootISOs-v0.2 - bootuje pendriva z gotowymi plikami (wystarczy tylko pozmieniać scieżki itp)

    Problem polega na tym ze MobaliveCD czyta normalnie pendriva pod windowsem i wszystko dziala tak jak powinno ale gdy chce bootowac tego pendriva bezposrednio przy starcie pc-eta to juz pendriva nie widzi mimo tego ze przy stacie daje mu F12 i wybieram USB - HDD / USB - CD ROM / USB - FDD. Bootowanie w biosie jest ustawione: First USB - CD ---> Sec HDD ---> 3rd USB / CD ROM

    Pendrive
    kod z pliku menu.lst:

    default 0
    timeout 30
    color white/blue yellow/black

    title WINDOWS 8 PRO
    map /iso/win8.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)
    boot

    title WINDOWS 7
    map /iso/win7.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)
    boot

    title HIREN BOOTCD 1.2
    map /iso/hiren.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)
    boot

    title TEST HDD
    map /iso/hdd.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)
    boot

    title RESTART
    reboot

    title WYJSCIE
    halt

    kod z pliku syslinux.cfg"

    default grub
    LABEL grub
    KERNEL grub.exe

    Jestem w tym zielony i szukałem najprostszej drogi do zrobienia tego pendriva. Jeśli ktos ma jakies propozycje jak naprawić tego pendriva bardzo prosze o pomoc. Dodam ze kiedyś ten pendrive normalnie sie bootował...
  • Poziom 18  
    Witaj.
    Na początek sprawdź w BIOSie czy masz włączoną opcję "secure boot" (albo podobnie).
    Masz Windows 8 więc na pewno jest to włączone. Wyłącz i zobacz czy ci uruchomi z pendrive'a. Jak nie znajdziesz opcji w BIOSie, to napisz model płyty głównej, ewentualnie model komputera / laptopa.
    Pozdrawiam
    Marcin
  • Poziom 7  
    Podam cała specyfikacje mojego komputera:

    Płyta Główna:
    Gigabyte GA-H67MA-USB3-B3 (2 PCI-E x1, 2 PCI-E x16, 4 DDR3 DIMM, Audio, Video, Gigabit LAN)

    BIOS:
    Typ BIOS'u Award Modular (03/31/11)

    Porcesor:
    QuadCore Intel Core i5-2500, 3400 MHz (34 x 100)

    Pamięć RAM:
    4 Gb RAM 1333

    Karta Grafiki:
    NVIDIA GeForce GTX 660 (2 GB)

    sprawdziłem calego Biosa ale nie mam tam takiej opcji jak "secure boot" :(

    EDIT: doszedł komunikat "error boot" :/

    EDIT 2: kurcze dziwna sprawa ale raz działa a raz nie. Najgorsze jest to ze jak raz zadzaiała to pozniej odrazu kasuje cała zawartość pliku menu.lst oraz syslinux.cfg. W gratisie uszkadza plik "grub.exe" Jakiś pomysł dlaczego ?? Testuje sprawność pendriva programem "Check Flash 1.16.1", cos bede wiedział to napisze
  • Poziom 18  
    Sprawdzałeś czy ten pendrive wystartuje na innym komputerze?
  • Poziom 7  
    kubiak napisał:
    Sprawdzałeś czy ten pendrive wystartuje na innym komputerze?


    tak, przepraszam za kłopot ale okazało sie ze pendrive ma uszkodzone logiczne sektory w 70%. zrobilem innego pendrive z tym samym i dziala normalnie :] bardzo dziekuje za pomoc oraz natchnienie do znalezienia problemu :) zamknąć :)