Elektroda.pl
Elektroda.pl
X
Arrow Multisolution Day
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Op-Amp/Czujnik Ciśnienia - Czujnik Nais ADP1 + napięcie z op-amp

mineyo 05 Sie 2014 01:37 2859 8
  • #1 05 Sie 2014 01:37
    mineyo
    Poziom 6  

    EDIT: Rozwiązane głównie, nowy problem w ostatnim poście. Nie ma sensu czytać.

    Witam uprzejmie, zmagam się z jednym dość już frustrującym problemem od paru dni. Mianowicie nie mogę sobie poradzić z poprawnym podłączeniem wzmacniaczy operacyjnych (według schematu z manual'a) do czujnika ciśnienia firmy NAiS Japan. Działanie czujnika mam już rozgryzione do stopnia, że śni mi się po nocach. Czujnik pochodzi z odzysku ze starego ciśnieniomierza.

    Jako, że jestem bardzo nowy jeśli chodzi o wzmacniacze operacyjne a to dość zawiły temat to wrzucam do kategorii początkujących.

    Posługuję się instrukcją z załącznika...

    Napięcie, które uzyskuję z czujnika sięga od 4,9mV do 106mV (napompowane przy pomocy pompki, to absolutny maks jaki udało mi się uzyskać).

    Do tej pory próbowałem podłączyć wzmacniacze według schematu na dole czwartej strony instrukcji. Używam dwóch wzmacniaczy podwójnych NE5532P. Oczywiście jako nowicjusz nie wiem, czy te wzmacniacze nadają się do tego rozwiązania. Docelowo układ ma być podłączony do Arduino Nano pinu analogowego. Napięcie docelowe powinno się zawierać między 0 a 4.9V, chociaż ustawia mnie wszystko powyżej 0.5V (po prostu muszę ze słabą rozdzielczością widziec zmiany ciśnienia w układzie zamkniętym).

    Po przepuszczeniu przez dwa pierwsze wzmacniacze (równolegle) dostaję wynik rzędu 1.07V, który nie ulega już zmianie w miarę pompowania co może być spowodowane złym podłączeniem wejść bądź zasilania wzmacniacza (podłączam VCC+ jako 5V z arduino a VCC- jako GND, tak mi radził kolega chociaż on także nie miał styczności z op-amp'ami więc krótko mówiąc nie bijcie jeśli to jest podstawowy błąd. Instrukcja jawnie mówi, że powinno być minimum 5V do -5V... tego też do tej pory nie pozyskiwałem, będę wdzięczny za pomoc w rozwiązaniu podłączenia).

    Właściwie nie mam wiele więcej do powiedzenia. Bardzo dziękuję za wszelkie życzliwe podpowiedzi.

    PS: Łączę to wszystko na płytce stykowej przy pomocy kabli więc w tym gąszczu mogłem coś pomieszać. Sprawdzałem kilka razy... ale zawsze...

    0 8
  • Arrow Multisolution Day
  • Pomocny post
    #2 05 Sie 2014 06:56
    alagner
    Poziom 25  

    Z pojedynczym zasilaniem podany przez Ciebie sposób nie ma szans zadziałać. Poza tym nie podajesz wartości elementów. No i pamiętaj, że schemat w datasheecie sensora jest tylko poglądowy.

    Jeżeli koniecznie chcesz zasilać wzmacniacz od 0 do 5V to wykorzystaj jakiś rail to rail, np. TLC2272. O obejmij go odp. sprzężeniem.

    Co do schematu: http://www.eng.yale.edu/ee-labs/morse/compo/sloa058.pdf
    Fig. 2 i Fig. 10.
    A warto przeczytać całość. I na przyszłość jeszcze to:
    http://www.siongboon.com/projects/2008-04-27_...for%20everyone%20%28Texas%20Instrument%29.pdf
    http://www.ti.com/lit/an/sloa030a/sloa030a.pdf
    i to http://www.ieee.li/pdf/essay/single_supply_op_amp_design.pdf

    Pozdrawiam

    0
  • Arrow Multisolution Day
  • #3 09 Wrz 2014 22:54
    mineyo
    Poziom 6  

    EDIT: Rozwiązane głównie, nowy problem w ostatnim poście. Nie ma sensu czytać.

    No dobrze, sugerując się uwagami z postu powyżej zmieniłem częściowo podejście do mojego układziku. Postawiłem na split supply uzyskiwane dzięki inwerterowi napięcia z 6V na -6 jednak nie wiem czy dobrym pomysłem jest późniejsza stabilizacja napięcia na 5 do -5V. Zdaję sobie sprawę z tego, że mogę mieć spadki przez stalibilzatory do wartości poniżej 4.8V. Załączam schematy by pokazać ideę, bardzo się ucieszę z konstruktywnej krytyki osób z doświadczeniem, w końcu to mój pierwszy projekt z własną elektroniką.

    Op-Amp/Czujnik Ciśnienia - Czujnik Nais ADP1 + napięcie z op-amp

    Jak się okazało w praktyce (tę płytkę mam już złożoną) mam tu skoki napięć, przy starszych bateriach pompka nie zaskakiwała (wymagała około 5V, arduino mi się resetowało) co rozwiązałem wymianą baterii. Pytanie tylko czy takie rozwiązanie może być stabilne? Zasilania to 4 baterie 1.5V, VCC przy nowych bateriach to jakies 6.4V. Zastanawiałem się nad dodaniem jeszcze jednej baterii ale martwię się, że mogło by to uszkodzić zawór i pompkę, oba są na 6V.

    Wyjście oznaczone jako "Czujnik" prowadzi do drugiej płytki, nad którą obecnie pracuję.

    Op-Amp/Czujnik Ciśnienia - Czujnik Nais ADP1 + napięcie z op-amp

    Jak widać po wyjściu od zasilania dodałem inwerter, uzyskuję -6V. I tutaj pojawia mi się pierwsze pytanie z problemem, który napotkałem robiąc to na płytce prototypowej. Mam stabilizator L7905CV, na który jak rozumiem powinienem podać na IN -6V, GND = 0 (GND...) jednak po takim połączeniu coś mi nie działa, dostaję wyjściowo -0.8V i nie bardzo rozumiem o co chodzi. Możliwe, że zdążyłem go kiedyś zepsuć... dlatego chciałem spytać czy coś źle podłączam? Bo w specyfikacji na piny patrzyłem wielokrotnie i raczej marne szanse, że je pomyliłem.

    Drugie pytanie, czy robienie split power supply po inwercji napięcia w celu stabilizacji to mocne przekombinowywanie? Zwykły stabilizator na 5V a potem odwracanie powinno wystarczyć? Czy takie rozwiązanie jak wpisałem jest błędem? Dostanę to 5 i -5V? Czy powinienem spodziewać się spadków większych? Zależy mi na w miarę równomiernym rozkładzie, muszę w układzie uzyskać offset najbliższy 0 bo nieszczęsny czujnik ciśnienia tak wymaga.

    Trzecie i ostatnie pytanie dotyczy wzmacniacza operacyjnego, ustawiłem go jak widać na gain = 51. Czujnik daje napiecia rzędu 5-105mV co wręcz idealnie pasuje mi do arduino z takim wzmocnieniem. Nie pamiętam jak to się tłumaczy na polskie więc powiem tak, zależy mi by był to non-inverting input. Czy dobrze to połączyłem? Nie powinno się to jakoś odnosić do wyjścia minusowego z czujnika?

    Z góry dziękuję za pomocne odpowiedzi i przepraszam za długą lekturę. :D

    0
  • #4 17 Wrz 2014 23:14
    mineyo
    Poziom 6  

    Dobrze, to już zapewne ostatnie moje pytanie (mam nadzieję).

    Otóż doszedłem do takiego schematu:

    Op-Amp/Czujnik Ciśnienia - Czujnik Nais ADP1 + napięcie z op-amp

    Legenda:
    Zielony - stabilizator napięcia na 5V.
    Czerwony - dzielnik napięcia z 5V na 2.5V (2k na 2k)
    Niebieski - wspomniany we wcześniejszych postach czujnik ciśnienia
    Fioletowy - wzmacniacz operacyjny, gain 51 (nie wiem czy dobrze podłączony)

    Pozostałe dwa układy to inwertery napięcia (jakby ktoś się nie spotkał).

    gdzie PCB wygląda tak:

    Op-Amp/Czujnik Ciśnienia - Czujnik Nais ADP1 + napięcie z op-amp

    Wytrawiona, jakość całkiem niezła, polutowana...

    I teraz problem, otóż po polutowaniu i podłączeniu do dzielnika napięcia wszystko wygląda dość dobrze (sprawdzane miernikiem) ale tam gdzie z dzielnika miało wychodzić 2.5V wychodzi 1.1V około a rezystory w układzie zmieniają wartości z 2k na 0.9k i 1.3k. Co się mogło wydarzyć, bo siedziałem cały dzień i jestem po prostu w kropce.

    Dodatkowe pytanie dla ambitnych, czujnik ciśnienia powinien dawać od 5-110mV, daje 110+mV co jest po prostu przyjętą przeze mnie wcześniej wartością maksymalną. Czy to może być spowodowane tymi innymi napięciamy Vcc i Vdd doprowadzonymi do czujnika?

    Z góry dziękuję, bardzo tego potrzebuję. Boję się, że przez jakieś połączenie w schemacie coś popsułem i tego po prostu nie widzę. Czekam na wprawne oko mistrza!

    Pozdrawiam wszystkich pomocnych.

    0
  • Pomocny post
    #5 18 Wrz 2014 14:40
    EuroGenio
    Poziom 17  

    Układ podłączony do dzielnika pobiera zbyt dużo prądu aby przy obecnych wartościach rezystorów zapewnić odpowiednie napięcie.
    Tu chyba powinna być dioda Zenera 2,5V do GND zasilana przez rezystor do VCC ok. 0,47k..1k (zależnie od pobieranego prądu)

    0
  • #6 18 Wrz 2014 22:07
    mineyo
    Poziom 6  

    Rzeczywiście dziś po dłuższej analizie wyszło mi, ze te inwertery też dostarczają niewielki prąd i czujnik po prostu nie dostaje go dostatecznie dużo. A jak miałbym zmniejszyć te rezystory w dzielniku? Im mniej Ohm tym więcej prądu przejdzie tak? Czy 100 Ohm rezystory poradziły by sobie?

    I co rozumiesz przez podłączenie diody zenera? Jak to by miało wyglądać w schemacie bo z diodami jestem noga.

    No i dziękuję za odpowiedź, to potwierdza moje obawy.

    0
  • Pomocny post
    #7 19 Wrz 2014 23:49
    EuroGenio
    Poziom 17  

    Górny rezystor w dzielniku zastąp taki o wartości od 470ohm do 1k (nie mniej niż 220 ohm) a dolny diodą zenera 2,5V podłączoną anodą do GND.

    0
  • #8 20 Wrz 2014 23:04
    mineyo
    Poziom 6  

    Hmm, jeszcze nie ogarniam dzielników napięcia i szczerze powiedziawszy z tego co widzę rezystorów też nie do końca...

    Mówisz, że jesli dam rezystor 470ohm (na ile Wat by miał być? Bo tutaj zastosowałem teraz dzielnik z 2x47ohm i rzeczywiście prąd płynie i układ działa ale się grzeją... myślałem, żeby dać 2x47 5W) i zamiast drugiego diodę zenera (w necie znalazłem tylko 2V7 nie ma 2V5 ale ustawia mnie trochę wyższe napięcie, byle nie powyżej 3V i -3V) to będzie to działało jak ten mój dzielnik napięcia ustawiający napięcie na 2.5V i dający większy prąd na wyjściu?

    W jaki sposób to działa? Bardzo dziękuję za wytłumaczenie jeśli znajdziesz czas.

    No i co ważniejsze, wielkie dzięki za zawuażenie tego problemu z dzielnikiem. Nie sprawdzałem głupi prądu w układzie wcześniej, dzięki Tobie uratuję ten projekt. Bardzo mi pomogłeś!

    0
  • Pomocny post
    #9 21 Wrz 2014 04:59
    EuroGenio
    Poziom 17  

    Używasz zbyt małej rezystancji w dzielniku, grozi to uszkodzeniami wszystkich elementów!!! (tak ogólnie)
    Kierujesz się logiką (zmniejszenie rezystancji w gałęzi stabilizuje prądowo podział napięcia), ale jest to rozwiązanie absolutnie niepraktyczne, i prawie nigdzie nie stosowane.

    Użyte przez Ciebie rezystancje powodują bardzo duże prądy pobierane ze źródła zasilania, które zresztą w znacznej większości są tracone (zmieniane w ciepło).
    Nie tędy droga.
    Dlatego pisałem o co najmniej diodzie Zenera

    W związku z tym co piszesz, szczerze polecam lekturę Internetu.
    Tematy: rezystancja, dzielnik napięcia, stabilizator.

    Ponieważ:
    Dzielniki napięcia służą głównie do zadania/polaryzacji wejścia jakiegoś układu konkretnym napięciem, z założeniem, że rezystancja wejściowa układu do którego jest doprowadzane napięcie z dzielnika jest zdecydowanie wielokrotnością wartości rezystorów użytych w dzielniku.
    W innym przypadku rezystancja wejściowa układu zasilanego przez dzielnik jest jego istotnym składnikiem i ZMIENIA STOPIEŃ PODZIAŁU napięcia co wystąpiło u Ciebie w pierwotnym układzie.

    Na podstawie napięcia zmierzonego u Ciebie na wyjściu dzielnika oceniłem rezystor zasilający diodę Zenera na 470..1000ohm, zastosowanie mniejszego raczej spali DZ (w diodzie Z. wydziela się ciepło o mocy obliczanej jak w rezystorze, {oczywiście poza przypadkami w.cz. - ale to chyba Ciebie nie dotyczy})

    0