Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

MikroTik - Przekierowanie www na serwer wewnątrz sieci

24 Aug 2014 21:56 1812 2
  • Level 26  
    Witam, mam pewien problem. Chodzi o to, że chciałbym niektórym klientom przekierować ruch www na adres w sieci wewnętrznej. Klienci mają adresy 192.168.0.0/24, a serwerek 192.168.0.100/24. Próbowałem sposobów z innych for, ale działają one na serwer w "internecie". Na serwerze mam NAT'a. Testowałem instrukcję: https://www.elektroda.pl/rtvforum/download.php?id=475803, ale niestety nie chce mi działać w sieci wew.
  • Level 43  
    MT musi miec adres publiczny na WAN-ie.

    dstnat - musi działać, jak nie działa to cos innego blokuje, bez całej konfiguracji MT nikt ci raczej nie powie.

    na początke pokaż (wkelj do sekcji spoiler)

    /ip firewall export

    Dodano po 14 [minuty]:

    Klienci próbuj wejść na swój server www z LAN przez adresu publiczny (zewnętrzny) ?
  • Level 26  
    Wrzucam kod źródłowy:

    Code:

    /ip firewall address-list
    add address=192.168.0.245-192.168.0.254 comment="" disabled=no list=\
        AdresyNieuzywane
    add address=192.168.0.125 comment="" disabled=no list=Test
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
        tcp-close-wait-timeout=10s tcp-established-timeout=1d \
        tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
        tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
        tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s

    /ip firewall mangle
    add action=mark-packet chain=postrouting comment="" disabled=no dst-address=\
        192.168.0.2 new-packet-mark=IP_192.168.0.2_Download passthrough=no
    add action=mark-packet chain=postrouting comment="" disabled=no dst-address=\
        192.168.0.3 new-packet-mark=IP_192.168.0.3_Download passthrough=no

    add action=mark-packet chain=prerouting comment="" disabled=no \
        new-packet-mark=IP_192.168.0.2_Upload passthrough=no src-address=\
        192.168.0.2
    add action=mark-packet chain=prerouting comment="" disabled=no \
        new-packet-mark=IP_192.168.0.3_Upload passthrough=no src-address=\
        192.168.0.3

    /ip firewall nat
    add action=dst-nat chain=dstnat comment=AutoGaz1 disabled=no dst-address=\
        25.21.222.66 dst-port=1125 protocol=tcp to-addresses=192.168.0.2 \
        to-ports=1125
    add action=dst-nat chain=dstnat comment=AutoGaz2 disabled=no dst-address=\
        25.21.222.66 dst-port=554 protocol=tcp to-addresses=192.168.0.3 \
        to-ports=554

    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no