Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

(Dell Inspiron) Ubuntu 12.04 LTS - Brak połączenia WiFi po aktualizacji

mikis_21 03 Sep 2014 15:57 2883 15
  • #1
    mikis_21
    Level 8  
    Witam,
    Po ostatniej aktualizacji mój laptop z Ubuntu ma problemy z wifi.
    Próbowałem już re-instalacji sterowników i powrotu z użyciem backportów:
    Code: text
    Log in, to see the code

    jednak bez rezultatów.
    System : Ubuntu 12.04 LTS 64-bit
    Laptop Dell Inspiron 3521



    Polecenie
    Code: text
    Log in, to see the code
    daje w wyniku
    Code: text
    Log in, to see the code


    Polecenie
    Code: text
    Log in, to see the code
    daje w wyniku
    Code: text
    Log in, to see the code

    Oczywiście polecenie
    Code: text
    Log in, to see the code
    daje w wyniku
    Code: text
    Log in, to see the code

    Macie jakieś pomysły jak sobie z tym poradzić ?
  • Helpful post
    #2
    szafarz
    Level 19  
    Już dawno się nie spotkałem z kartą WiFi nie obsługiwaną ze standardowej instalacji.
    Na początek podaj wynik dmesg po modprobe ath5k.
    A dodatkowo przydało by się lspci (bez filtrowania, żeby było widać co to za karta WiFi).
  • #3
    mikis_21
    Level 8  
    modprobe ath5k
    Code: text
    Log in, to see the code

    dmesg
    Code: text
    Log in, to see the code

    Dane karty
    Code: text
    Log in, to see the code
  • Helpful post
    #4
    szafarz
    Level 19  
    Drobny szczegół:
    sudo modprobe ath5k (bez sudo masz Operation not permitted)

    W katalogu /etc/modprobe.d/ masz pliki o nazwie blacklist*.conf
    W jednym z nich wpisz coś takiego:
    blacklist b43
    potem wyrzuć moduł b43 z jądra (sudo rmmod b43) i w ustawieniach systemowych znajdź dodatkowe sterowniki i każ mu poszukać. Zainstaluj i powinno działać.
  • #5
    mikis_21
    Level 8  
    ok, dmesg po sudo modprobe ath5k daje
    Code: text
    Log in, to see the code


    Po dopisaniu w blacklist.conf i próbie wyrzucenia modułu mam:
    Code: text
    Log in, to see the code

    Dodatkowych sterowników nie znajduje.
  • Helpful post
    #6
    szafarz
    Level 19  
    Tą kartę prawdopodobnie obsługuje ath9k.

    Wpisz:
    sudo modprobe ath9k
  • #7
    mikis_21
    Level 8  
    Dostaję coś takiego:
    Code: text
    Log in, to see the code


    Dając dmesg | grep ath9k mam:
    Code: text
    Log in, to see the code
  • #8
    szafarz
    Level 19  
    Sprawdź dysk na okoliczność błędów i wystartuj ubuntu ze starszym jądrem (powinieneś mieć poprzednie wciąż zainstalowane).

    W międzyczasie podaj jeszcze wynik polecenia:
    lspci -nnk
  • #9
    mikis_21
    Level 8  
    Wynik lspci -nkk
    Code: text
    Log in, to see the code
  • #10
    szafarz
    Level 19  
    Code:
    Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)



    Na pewno obsługuje ta kartę ath9k.

    Gdzies masz zapisany jakiś argument do modułu. Prawdopodobnie znajdziesz go tak:
    Code:
    sudo grep ath9k /etc/modprobe.d/*
    
    sudo grep ath9k /etc/modprobe.conf


    jak zobaczysz "options ath9k......" - zakomentuj to i potem
    Code:
    sudo modprobe ath9k


    Zeby znaleźć nazwy plików w których występuje ath9k dodaj "-l" do grep:
    Code:
    sudo grep -l ath9k /etc/modprobe.d/*
  • #11
    mikis_21
    Level 8  
    W ten sposób nie znajduje:
    Code: text
    Log in, to see the code


    Spróbuję jeszcze zrobić raz numer z backportem tylko z tym z ath9k a nie jak na początku robiłem ath5k.
  • #12
    szafarz
    Level 19  
    Jak nie masz /etc/modprobe.conf to na pewno masz /etc/modprobe.d/* i tam jest rozwiązanie.

    Nowe moduły (z backports) niczego nie zmienią, bo opcja powodująca błąd dotyczy modułu "ath9k", obojętnie skąd pochodzi.
    Masz juz w systemie właściwe sterowniki, ale system ich nie załaduje, bo ma wpisany gdzieś nieprawidłowy argument:

    Code:
    WARNING: Error inserting ath9k_common (/lib/modules/3.2.0-68-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko): Invalid argument
    
    WARNING: Error inserting mac80211 (/lib/modules/3.2.0-68-generic/updates/net/mac80211/mac80211.ko): Invalid argument
    FATAL: Error inserting ath9k (/lib/modules/3.2.0-68-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko): Invalid argument
  • #13
    mikis_21
    Level 8  
    Dałem mu
    Code: text
    Log in, to see the code

    a następnie
    Code: text
    Log in, to see the code

    i ożył.
    Jeszcze tylko zrestartuję, żeby mieć pewność, że to nic mu się nie odmieni.

    Teraz polecenie
    Code: text
    Log in, to see the code
    nie wyrzuca tych błędów co ostatnio.

    Wielkie dzięki za pomoc. Sporo się dziś nauczyłem. :)

    Co warto teraz sprawdzić, żeby mieć pewność, że jest wszystko OK ?
  • #14
    szafarz
    Level 19  
    Nieodmiennie dmesg na pierwszym miejscu...
  • #15
    mikis_21
    Level 8  
    Ok. Jeszcze raz dzięki.
  • #16
    pilar3
    Level 1  
    Cześć,

    mam podobny problem - dotyczy Della Inspiron 3521 z preinstalowanym ubuntu 12.04 LTS, problemem jest podobnie utrata opcji połączeń bezprzewodowych. Sieci sąsiadów było widać po instalacji, przez mój internet z USB zrobiłam aktualizację systemu* i już wi-fi ani mobilnego połączenia nie było...

    Pomocy :D
    Nie znam się zupełnie na linuksowych komendach, co udało mi się wyczytać z tego wątku, to że mój Network controller to Broadcomm.


    * najpierw aktualizację 12., potem z iso instalowałam też 14.04
    Internet nie działa, do ethernetu dostępu nie mam, mogę jedynie coś pobrać i przekopiować na pendrive do Della.