Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

(Dell Inspiron) Ubuntu 12.04 LTS - Brak połączenia WiFi po aktualizacji

03 Wrz 2014 15:57 2598 15
  • Poziom 6  
    Witam,
    Po ostatniej aktualizacji mój laptop z Ubuntu ma problemy z wifi.
    Próbowałem już re-instalacji sterowników i powrotu z użyciem backportów:
    Kod: text
    Zaloguj się, aby zobaczyć kod

    jednak bez rezultatów.
    System : Ubuntu 12.04 LTS 64-bit
    Laptop Dell Inspiron 3521

    Polecenie
    Kod: text
    Zaloguj się, aby zobaczyć kod
    daje w wyniku
    Kod: text
    Zaloguj się, aby zobaczyć kod


    Polecenie
    Kod: text
    Zaloguj się, aby zobaczyć kod
    daje w wyniku
    Kod: text
    Zaloguj się, aby zobaczyć kod

    Oczywiście polecenie
    Kod: text
    Zaloguj się, aby zobaczyć kod
    daje w wyniku
    Kod: text
    Zaloguj się, aby zobaczyć kod

    Macie jakieś pomysły jak sobie z tym poradzić ?
  • Pomocny post
    Poziom 18  
    Już dawno się nie spotkałem z kartą WiFi nie obsługiwaną ze standardowej instalacji.
    Na początek podaj wynik dmesg po modprobe ath5k.
    A dodatkowo przydało by się lspci (bez filtrowania, żeby było widać co to za karta WiFi).
  • Poziom 6  
    modprobe ath5k
    Kod: text
    Zaloguj się, aby zobaczyć kod

    dmesg
    Kod: text
    Zaloguj się, aby zobaczyć kod

    Dane karty
    Kod: text
    Zaloguj się, aby zobaczyć kod
  • Pomocny post
    Poziom 18  
    Drobny szczegół:
    sudo modprobe ath5k (bez sudo masz Operation not permitted)

    W katalogu /etc/modprobe.d/ masz pliki o nazwie blacklist*.conf
    W jednym z nich wpisz coś takiego:
    blacklist b43
    potem wyrzuć moduł b43 z jądra (sudo rmmod b43) i w ustawieniach systemowych znajdź dodatkowe sterowniki i każ mu poszukać. Zainstaluj i powinno działać.
  • Poziom 6  
    ok, dmesg po sudo modprobe ath5k daje
    Kod: text
    Zaloguj się, aby zobaczyć kod


    Po dopisaniu w blacklist.conf i próbie wyrzucenia modułu mam:
    Kod: text
    Zaloguj się, aby zobaczyć kod

    Dodatkowych sterowników nie znajduje.
  • Pomocny post
    Poziom 18  
    Tą kartę prawdopodobnie obsługuje ath9k.

    Wpisz:
    sudo modprobe ath9k
  • Poziom 6  
    Dostaję coś takiego:
    Kod: text
    Zaloguj się, aby zobaczyć kod


    Dając dmesg | grep ath9k mam:
    Kod: text
    Zaloguj się, aby zobaczyć kod
  • Poziom 18  
    Sprawdź dysk na okoliczność błędów i wystartuj ubuntu ze starszym jądrem (powinieneś mieć poprzednie wciąż zainstalowane).

    W międzyczasie podaj jeszcze wynik polecenia:
    lspci -nnk
  • Poziom 6  
    Wynik lspci -nkk
    Kod: text
    Zaloguj się, aby zobaczyć kod
  • Poziom 18  
    Code:
    Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)



    Na pewno obsługuje ta kartę ath9k.

    Gdzies masz zapisany jakiś argument do modułu. Prawdopodobnie znajdziesz go tak:
    Code:
    sudo grep ath9k /etc/modprobe.d/*
    
    sudo grep ath9k /etc/modprobe.conf


    jak zobaczysz "options ath9k......" - zakomentuj to i potem
    Code:
    sudo modprobe ath9k


    Zeby znaleźć nazwy plików w których występuje ath9k dodaj "-l" do grep:
    Code:
    sudo grep -l ath9k /etc/modprobe.d/*
  • Poziom 6  
    W ten sposób nie znajduje:
    Kod: text
    Zaloguj się, aby zobaczyć kod


    Spróbuję jeszcze zrobić raz numer z backportem tylko z tym z ath9k a nie jak na początku robiłem ath5k.
  • Poziom 18  
    Jak nie masz /etc/modprobe.conf to na pewno masz /etc/modprobe.d/* i tam jest rozwiązanie.

    Nowe moduły (z backports) niczego nie zmienią, bo opcja powodująca błąd dotyczy modułu "ath9k", obojętnie skąd pochodzi.
    Masz juz w systemie właściwe sterowniki, ale system ich nie załaduje, bo ma wpisany gdzieś nieprawidłowy argument:

    Code:
    WARNING: Error inserting ath9k_common (/lib/modules/3.2.0-68-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko): Invalid argument
    
    WARNING: Error inserting mac80211 (/lib/modules/3.2.0-68-generic/updates/net/mac80211/mac80211.ko): Invalid argument
    FATAL: Error inserting ath9k (/lib/modules/3.2.0-68-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko): Invalid argument
  • Poziom 6  
    Dałem mu
    Kod: text
    Zaloguj się, aby zobaczyć kod

    a następnie
    Kod: text
    Zaloguj się, aby zobaczyć kod

    i ożył.
    Jeszcze tylko zrestartuję, żeby mieć pewność, że to nic mu się nie odmieni.

    Teraz polecenie
    Kod: text
    Zaloguj się, aby zobaczyć kod
    nie wyrzuca tych błędów co ostatnio.

    Wielkie dzięki za pomoc. Sporo się dziś nauczyłem. :)

    Co warto teraz sprawdzić, żeby mieć pewność, że jest wszystko OK ?
  • Poziom 18  
    Nieodmiennie dmesg na pierwszym miejscu...
  • Poziom 6  
    Ok. Jeszcze raz dzięki.
  • Poziom 1  
    Cześć,

    mam podobny problem - dotyczy Della Inspiron 3521 z preinstalowanym ubuntu 12.04 LTS, problemem jest podobnie utrata opcji połączeń bezprzewodowych. Sieci sąsiadów było widać po instalacji, przez mój internet z USB zrobiłam aktualizację systemu* i już wi-fi ani mobilnego połączenia nie było...

    Pomocy :D
    Nie znam się zupełnie na linuksowych komendach, co udało mi się wyczytać z tego wątku, to że mój Network controller to Broadcomm.


    * najpierw aktualizację 12., potem z iso instalowałam też 14.04
    Internet nie działa, do ethernetu dostępu nie mam, mogę jedynie coś pobrać i przekopiować na pendrive do Della.