Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Strona przycina się przy ładowaniu elementów

ciapaty 30 Sep 2014 08:46 870 4
  • #1
    ciapaty
    Level 12  
    Witam, buduję stronę w oparciu o szablon. W sumie jest prawie gotowa, aktualnie staram się to trochę zoptymalizować. Zauważyłem że czasem przy ładowaniu elementów potrafi się to przyciąć na 30 sekund.
    Adres gdzie to wisi testowo jest http://test2.gocolor.pl/index.html . Badam ładowanie w przeglądarce chrome, narzędzie 'zbadaj element', zakładka 'network'. Włączam record i przeładowuję stronę. Normalnie całość łąduje się w niecałe 3 sekundy ale czasem na jakimś obrazku (losowym) przyblokowuje się na 30 sekund. Na tajmlajnie widach wtedy fioletowe paski z opisem że coś się ładowało 30 sekund (np. obrazek 94 kb). Jest to uciążliwe, strona dużo nie waży więc powinna szybko wskakiwać.
  • #2
    pawel-jwe
    Level 30  
    U mnie strona ładuje się w ok. 4,5sek. (max z jakiś 20 prób to 6,5sek.). Przeglądarka Mozilla Firefox 26.0
    A internet (według testu z http://www.speedtest.pl/ ) taki:
    Download 53.33Mb/s
    Upload 31.24Mb/s
    Ping 52ms
    Sądząc po parametrach internetu strona powinna załadować się mgnieniu oka, więc ewentualne opóźnienia są raczej związane z samą przeglądarką (podejrzewam, że u Ciebie też tak jest) - ewentualnie któryś element przeglądarki (jakiś dodatek/wtyczka) może się przywiesza. Warto by porobić aktualizację.
    Testowałeś może to na innych przeglądarkach?
  • #3
    oskar_dyjas
    Level 25  
    Wg Opera Dragonfly (niezastąpione narzędzie dla mnie, którego nie ma w najnowszej Operze) strona generuje 214 żądań, pobrało się łącznie 4,5 MB, i w 15 sekund. Elementy które ładują się najdłużej to
    - 5PAogIi8kTQ?rel=0 (chyba embed youtube) 5PAogIi8kTQ?rel=0
    - zdjęcia/obrazki png i jpg typu http://test2.gocolor.pl/img/cname-icon.png chyba następuje kilkukrotna próba ich załadowania. Spróbuj zmniejszyć ich rozmiar o ile to możliwe

    Najbardziej obciążające mogą być wszystkie obrazki, skrypty i zewnętrzne elementy od YouTube i SoundCloud.

    Chyba przez to, że strona jest one-page i wszystkie elementy są ładowane naraz to tyle to trwa. Nie popieram tego typu stron, ale już taki jest to nowoczesny trend.

    Ogólnie żadnych błędów nie zauważyłem (tylko rzuciłem oko, nie wnikałem głęboko), oprócz tego że adresy czcionek, które mają być dołączane, mają zły adres URL (nie znajduje się tam nic, jest 404).
  • #4
    User removed account
    Level 1  
  • #5
    ciapaty
    Level 12  
    W sumie to mam chroma, foxa, opere, safari i iE. Ale tylko na Chrome mam te przycięcia do 30 sekund. Chroma używam jako podstawowej przeglądary i mam tam trochę plugów, być może coś tam się gryzie i dlatego potrafi zamulić. Na innych przeglądarach strona faktycznie wchodzi błyskawicznie (net mam 10/1 Mb).
    W js nie pogrzebię, za słaby na to ja :) Te 6 sekund to w sumie jest ok, siedzi tam materiał z YT, SC i jeszcze mapa się czyta z mapboxa.

    Dziękować!