Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ploter CNC 3040T-DJ problem z aktywacją ukrytych funkcji

prosim 09 Lis 2014 17:23 3063 5
  • #1 09 Lis 2014 17:23
    prosim
    Poziom 12  

    Witam, a więc do rzeczy:) Mam chiński ploter 3040T-DJ, ploter ma sterownik w którym prędkość wrzeciona jest sterowana potencjometrem, jako że mam program mach 3 postanowiłem dorobić sterowanie PWM. Po otwarciu okazało się że płyta sterownika wygląda tak:

    Ploter CNC 3040T-DJ problem z aktywacją ukrytych funkcji

    Sterowanie wrzecionem jest na dość egzotycznym procesorze : STC12C5616AD.
    Do płyty oczywiście idzie sygnał PWM z macha, oraz PIN1 enable czyli aktywacja wrzeciona (oryginalnie kabelek był przecięty)

    Wygooglowałem napis na płycie głównej jp-3163d i znalazłem

    http://item.taobao.com/item.htm?id=35174768666

    Mój sterownik i ten z linka to ta sama płyta - różnica to wyświetlacz LED oraz 3 przyciski - w mojej płycie jest złącze do którego powinien być podłączony LED oraz przycyski.

    Złącze ma 8 pinów

    Pierwszy pin to +5V, drugi trzeci i czwarty to LED podłączony do 595 (sprawdzałem oscyloskopem daje typowe sygnały dla rejestru) kolejny to masa oraz 3 ostatnie piny które wskazywałyby że są to piny trzech przycisków.

    Jednak zwarcie tych pinów do masy nie powoduje żadnej reakcji sterowniki. Nie chce mi się wierzyć że chińczyk wyłączył w programie te przyciski skoro sygnały wyświetlacza pracują. Więc pytanie co podać do tych pinów żeby aktywować PWM.

    Jedyne co znalazłem o tym procesorze to ten schemat (w załączniku)

    Będe wdzięczny za jakąkolwiek pomoc, pozdrawiam

    0 5
  • #3 27 Sty 2015 19:33
    redfenix78
    Poziom 9  

    Witam
    Podłączę się pod temat sterownika gdyż posiadam podobny model chińczyka (jp-3163b) na tych samych układach toshiba i od nowości mam problem z osią Z (cały 3 układ na płytce) mianowicie gdy skonfiguruję odpowiednie piny na wyjściu oś zawsze interpretuje jeden ruch silnika osie x-y działają prawidłowo. Próbowałem zmienić piny np. x-a piny dać na Z i te piny z osi Z na X i konfiguracja się sprawdza (silnik na pinach z osi Z działa bo interpretuje ją układ scalony z osi X, a piny z osi X zadane na układ scalony Z dają tylko jeden ruch silnika - więc coś jest skopane w w płytce wymieniłem układ na szybko scalony toshiby ale efekt ten sam, może ma ktoś jakiś pomysł lub miał podobną sytuację? (Z góry dziękuję za sugestie).

    0
  • #4 28 Sty 2015 11:08
    prosim
    Poziom 12  

    redfenix78 napisał:
    Witam
    Podłączę się pod temat sterownika gdyż posiadam podobny model chińczyka (jp-3163b) na tych samych układach toshiba i od nowości mam problem z osią Z (cały 3 układ na płytce) mianowicie gdy skonfiguruję odpowiednie piny na wyjściu oś zawsze interpretuje jeden ruch silnika osie x-y działają prawidłowo. Próbowałem zmienić piny np. x-a piny dać na Z i te piny z osi Z na X i konfiguracja się sprawdza (silnik na pinach z osi Z działa bo interpretuje ją układ scalony z osi X, a piny z osi X zadane na układ scalony Z dają tylko jeden ruch silnika - więc coś jest skopane w w płytce wymieniłem układ na szybko scalony toshiby ale efekt ten sam, może ma ktoś jakiś pomysł lub miał podobną sytuację? (Z góry dziękuję za sugestie).


    Nie za bardzo zrozumiałem w czym problem. Co to znaczy że oś interpretuje zawsze jeden ruch silnika?

    0
  • #5 01 Lut 2015 13:16
    redfenix78
    Poziom 9  

    Tak dokładnie,w machu 3, (zmieniałem ustawienia itp. nic nie pomogło jak pisałem wyżej) kierując prawo, lewo silnik powinien zmienić obroty (jak to robi w osi X Y) lecz zawsze w tej osi Z daje ruch obrotowy silnika w jedną stronę a nie powinien, pewnie układ gdzieś skopany jak to w chińczykach, może ktoś mnie nakieruje, czy porostu zamawiać drugiego?

    0
  Szukaj w 5mln produktów