Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Attiny2313A - Po zapisie Fuse Bitów nie można go odczytać

majtek007 13 Lis 2014 17:20 690 5
  • #1 13 Lis 2014 17:20
    majtek007
    Poziom 14  

    Witam
    Przechodząc od razu do sedna: układ Attiny2313A, programator USBasp, oprogramowanie Extreme Burner AVR i mkAVRcalculator (nakładka Avrdude). Wgrałem hex - poszło OK.
    Czy to normalne, że po ustawieniu fusebitów w poniższy sposób, wszelkie programy przestały widzieć/odczytywać flash mikrokontrolera:
    Attiny2313A - Po zapisie Fuse Bitów nie można go odczytać
    Czy dzieje się tak dlatego, że ustawiłem zewnętrzny zegar?

    0 5
  • Pomocny post
    #2 13 Lis 2014 17:24
    dondu
    Moderator Mikrokontrolery Projektowanie

    majtek007 napisał:
    Czy dzieje się tak dlatego, że ustawiłem zewnętrzny zegar?

    Tak, podaj na pin XTAL1 sygnał zegarowy wygenerowany w jakikolwiek cyfrowy sposób.
    By programator mógł mieć kontakt z mikrokontrolerem, ten musi być taktowany.

    0
  • #3 13 Lis 2014 17:44
    vonar
    Poziom 28  

    dondu napisał:
    sygnał zegarowy wygenerowany w jakikolwiek cyfrowy sposób.

    A analogowy to już nie? :D

    0
  • #5 13 Lis 2014 18:48
    tmf
    Moderator Mikrokontrolery Projektowanie

    majtek007 Przy okazji przeczytaj:
    http://mikrokontrolery.blogspot.com/2011/03/A...io-zalety-wspolpracujacych-programatorow.html
    W AS masz konfigurator fusebitów, w którym w sposób opisowy wybierasz co potrzebujesz - np. źródło zegara, a on ci obliczy wymagane wartości fusebitów. Dzięki temu naprawdę się nie pomylisz. Działa to także w drugą stronę - wpisujesz mu wartości hex fusebitów i odczytujesz wybraną konfigurację MCU. Oczywiście instalowanie narzędzia mającego 700 MB tylko do tego celu to lekki bezsens, ale warto na AS się przestawić także z innych powodów.

    0
  • #6 13 Lis 2014 20:11
    majtek007
    Poziom 14  

    Dziękuję za wszystkie odpowiedzi. Temat do zamknięcia. Za radą kolegi dondu podłączyłem kwarc do zacisków XTAL1 XTAL2 (+ 2 kondensatory: XTAL1-GND i XTAL2-GND). Wszystko śmiga aż miło :)

    0