Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

iframe w You Tube - Nie można umieścić filmu z YT na stronie (joomla cms)

wiatraczek.nl 04 Gru 2014 16:11 1329 4
  • #1 04 Gru 2014 16:11
    wiatraczek.nl
    Poziom 6  

    Witam!
    Myślę że to właściwy dział forum, więc szybko w skrócie: gdzie nie wejdę (bo problem nie jest nowy) żeby czegoś się dowiedzieć piszą, że kod "iframe" z założenia nie jest dobry, pytanie więc dlaczego chcąc umieścić na stronie video z YT mam do dyspozycji obecnie wyłącznie taką formę. Kiedyś była możliwość użycia kodu "object" opisanego zresztą przez YT "użyj starego kodu umieszczania..." - ale od pewnego czasu nie ma już takiej opcji (a przynajmniej u mnie się nie wyświetla). Będę wiec musiał zlikwidować kilka modułów strony, bo moja joomla zdecydowanie nie chce "iframe". Poradzicie coś?
    Dziękuję :|

    0 4
  • #2 04 Gru 2014 22:27
    rachman
    Poziom 10  

    Cytat:
    kod "iframe" z założenia nie jest dobry

    Co wg Ciebie oznacza nie dobry?
    W HTML5 nadal istnieje i nadal można go używać. To że googiel ma problemy z indeksowaniem stron w ramkach nie oznacza że jest konieczne unikanie ich. Jak nie potrzeba to nie używać a powodów jest kilka ale jak trzeba to się używa i tyle w temacie.

    0
  • #3 05 Gru 2014 07:08
    wiatraczek.nl
    Poziom 6  

    To nie ja stwierdziłem "niedobry" - takie opinie znalazłem w necie szukając już wcześniej rozwiązania problemu. Nie zmienia to jednak faktu że niczego z YT nie jestem w stanie wyświetlić na stronie u siebie... :/

    0
  • Pomocny post
    #4 05 Gru 2014 09:18
    yojoe
    Poziom 11  

    wiatraczek.nl napisał:
    Witam!
    Będę wiec musiał zlikwidować kilka modułów strony, bo moja joomla zdecydowanie nie chce "iframe". Poradzicie coś?
    Dziękuję :|

    Wejdź w rozszerzenia -> wtyczki -> tinymce
    W polu blokowanych elementów usuń iframe, zapisz i gotowe.

    0
  • #5 05 Gru 2014 09:49
    wiatraczek.nl
    Poziom 6  

    Wszedłem, jednak z blokowanych elementów jest tutaj tylko applet - nie ma iframe...

    EDIT 06-12-2014

    Pomysł ze zmianą ustawień edytora nasunął mi inne rozwiązanie, a mianowicie zmianę edytora. JCE ma funkcję wstawiania kodu i iframe daje się umieścić, należy tylko od razu zapisać moduł lub artykuł. W przeciwnym razie, korzystając jeszcze z "podglądu", lub ponownie edytując, kod znika. Pomimo że jest to tymczasowe rozwiązanie, dziękuję za natchnienie i próbę pomocy ;)

    0