Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wzmacniacz na kd502-palący sie opornik i tranzystor z układu zabezpieczeń

koma2000 31 Gru 2014 11:43 3951 54
  • #1 31 Gru 2014 11:43
    koma2000
    Poziom 16  

    Witam!
    Jakiś czas temu złożyłem sobie wzmacniacz na tranzystorach KD502 i mam z nim pewien kłopot. Już trzeci raz podczas słuchania muzyki spalił mi się tranzystor Q8 i rezystor R19. Po wymianie tych elementów wzmacniacz działa dalej tylko co może być przyczyną tego. Nic oprucz tych elementów nie ulega uszkodzeniu. Dołączam schemat wzmacniacza.

  • #2 31 Gru 2014 16:39
    krzysztof723
    Poziom 28  

    Jest źle podłączony rezystor R20.

    Wzmacniacz na kd502-palący sie opornik i tranzystor z układu zabezpieczeń

  • #4 31 Gru 2014 18:03
    jarek_lnx
    Poziom 43  

    Spalenie R19 jest interesujące bo do tego potrzeba sporego napiecia którego w pobliżu brak (przy sprawnym układzie), skoro wzmacniacz działa a mimo to rezystor się pali to może przyczyną jest któtkotrwałe zwarcie lub przerwa w jakimś elemencie - może zimny lut?

    Sprawdź R22 czy jest tam szanasa na przerwę, a może R16 ma zwarcie?

    Układ ma wadę, gdy zadziała zabezpieczenie prądowe, ma prawo się palić Q8 lub Q3, dlatego że Q3 powinien mieć ograniczenie prądowe o którym ktoś zapomniał.

  • #5 31 Gru 2014 18:20
    koma2000
    Poziom 16  

    R22 nie ma przerwy R16 też sprawny. Dzisiaj jak mi się znów to stało wzmacniacz na chwilę lekko chyba przesterowalem, czy to mogło być przyczyną tego?

  • #6 31 Gru 2014 19:05
    krzysio61
    Poziom 18  

    Witam. Proponuję sprawdzić kondensatory C2, C4, C5.

  • #7 31 Gru 2014 19:53
    andrzej_25
    Poziom 13  

    Witam
    Między D3 a D4 jest połączenie z "masa WY" ?
    Bo tak troszkę dziwnie jest na tym schemacie.
    Skoro zasilacz symetryczny to powinno być podłączenie do masy (0) zasilania.

    Pozdrawiam

  • #8 31 Gru 2014 20:05
    koma2000
    Poziom 16  

    Tak między D3 a D4 jest masa.

  • #9 31 Gru 2014 20:18
    jdubowski
    Specjalista - urządzenia lampowe

    koma2000 napisał:
    R22 nie ma przerwy


    To musi jest przerwa w rezystorach emiterowych tranzystorów końcowych albo gdzieś indziej w tej okolicy, skutkiem tego tranzystor drivera napędza głośnik.

  • #10 01 Sty 2015 01:08
    koma2000
    Poziom 16  

    Posprawdzam wszystko jutro jeszcze raz, może faktycznie gdzieś mam przerwę, jutro zdam relację. Szczęśliwego nowego roku :-)

  • #11 01 Sty 2015 12:29
    andrzej lukaszewicz
    Poziom 38  

    jarek_lnx napisał:
    Układ ma wadę, gdy zadziała zabezpieczenie prądowe, ma prawo się palić Q8 lub Q3, dlatego że Q3 powinien mieć ograniczenie prądowe o którym ktoś zapomniał.

    Przecież Q3 i R9 stanowia źródło prądowe i nie puszczą prądu wiecej niz... Więc zabezpieczenie nic nie uszkodzi.
    Jeśli wzmacniacz działa poprawnie, to moim zdaniem autor ma problem z samym montażem na płytce ( jakiś błąd w połaczeniach, zamiana koncówek tranzystora, polaryzacji diody itp) bo jak Kolega Jarek słusznie zauważył nie ma tam takich różnic napięć by uszkodzić tranzystor, a tym bardziej spalic rezystor. Tego typu awarie zdarzają się tylko podczas awarii tranzystorów końcowych/sterujacych i to nie zawsze.
    Skoro awaria sie powtarza to na próbę wylutuj D1 i obserwuj , czy awaria się powtórzy a jak trzeba to inne elementy- zawęzisz obszar poszukiwań.

  • #12 01 Sty 2015 20:13
    koma2000
    Poziom 16  

    Posprawdzalem dzisiaj wszystko i nigdzie przerwy nie ma ale polutuje jutro tranzystory koncowe i ich rezystory jeszcze raz. Układ zabezpieczenie pradowego jest złożony według schematu, sprawdzalem przed chwilą jeszcze raz. A co z rezystorem R20 mam zostawić tak jak jest? Jutro jak dokupię rezystor 22ohm to odlutuje diode D1 i zobaczę co się będzie dziać.

  • #13 02 Sty 2015 01:35
    E.L.O.
    Poziom 28  

    R19 = R18 = 220Ω to zdecydowanie za mała wartość. Przy przesterowaniu duży prąd (duże napięcie impulsowe) idzie przez R19 ---> baza Q8 --->Emiter Q8 --->masy co powoduje spalenie Q8 (zwarcie B-E) a następnie spalenie R19. Zmień R19 i R18 na co najmniej 1kΩ...1,5kΩ.

  • #14 02 Sty 2015 09:14
    koma2000
    Poziom 16  

    Zaraz idę dokupić potrzebne rezystory, jak wrócę to wlutuję 1kohm i zobaczę czy będzie teraz dobrze. A czy po takim zabiegu to zabezpieczenie prądowe będzie działać poprawnie?

  • #15 02 Sty 2015 09:28
    jarek_lnx
    Poziom 43  

    Cytat:
    R19 = R18 = 220Ω to zdecydowanie za mała wartość.
    Wg mnie nie prawda.
    Po pierwsze R19 i R18 nie mozna tak sobie zmienić, nie zmieniając też R16 i R17 bo razem decyduja o charaktrystyce zabezpieczenia pradowo-napieciowego.
    Po drugie te rezystory mogły by być zastąpione zworą a ujemne sprzężenie zwrotne i tak nie dopuści do spalenia tranzystorów (oczywiście charakterystyka zabezpieczenia sie zmieni)

    Cytat:

    Przy przesterowaniu duży prąd (duże napięcie impulsowe) idzie przez R19 ---> baza Q8 --->Emiter Q8 --->masy co powoduje spalenie Q8 (zwarcie B-E) a następnie spalenie R19. Zmień R19 i R18 na co najmniej 1kΩ...1,5kΩ.

    Zeby spalić złącze BE potrzeba >200mA czyli 44V na R22, Zeby spalić rezystor 220Ω 0,25W w miarę szybko potrzeba 1W czyli 15V na R22.

    Bzdura, żeby było możliwe spalenie rezystora R19 prąd płynący przez R22 powinien przekraczać 100A, żeby spalić złącze w tranzystorze prąd R22 powinien przekraczać 300A - przez dłuższy czas (kilka minut) E.L.O. czy uważasz że to możliwe bez uszkodzenia innych elementów? Zapewne prąd zwarciowy zasilacza nawet tyle nie osiąga.
    Cytat:

    Przecież Q3 i R9 stanowia źródło prądowe i nie puszczą prądu wiecej niz... Więc zabezpieczenie nic nie uszkodzi.
    Racja więcej niż 80-90mA nie popłynie to było by zagrożeniem dla Q3 gdyby zwarcie było długotrwałe i tranzystor pracował bez radiatora.

  • #16 02 Sty 2015 09:28
    krzysztof723
    Poziom 28  

    Do koma2000

    Zmień podłączenie rezystora R20 według schematu z postu # 2. Pozostałe podłączenia elementów układu zabezpieczeń (D!, D2, D3, D4, Q8, Q7, R16, R17, R18, R19) są prawidłowe i tutaj nie trzeba nic poprawiać.
    W żadnym wypadku nie zmieniaj wartości rezystorów R19 i R18. Te wartości są prawidłowe.
    Jeżeli chcesz być pewny dalszej bezawaryjnej pracy układu zabezpieczeń to możesz zamienić tranzystor Q8 (BC107) na tranzystor BD139/16, a tranzystor Q7 (BC177) na tranzystor BD140/16.

  • #17 02 Sty 2015 09:43
    jarek_lnx
    Poziom 43  

    Cytat:
    Zmień podłączenie rezystora R20 według schematu z postu # 2.
    A co to zmieni?
    Cytat:

    Jeżeli chcesz być pewny dalszej bezawaryjnej pracy układu zabezpieczeń to możesz zamienić tranzystor Q8 (BC107) na tranzystor BD139/16, a tranzystor Q7 (BC177) na tranzystor BD140/16.
    Tranzystor będzie mocniejszy więc możliwe że przestanie się uszkadzać, ale błąd w układzie pozostanie niewykryty.

  • #18 02 Sty 2015 10:01
    krzysztof723
    Poziom 28  

    jarek_lnx napisał:
    Cytat:
    Zmień podłączenie rezystora R20 według schematu z postu # 2.

    A co to zmieni?
    Cytat:
    Jeżeli chcesz być pewny dalszej bezawaryjnej pracy układu zabezpieczeń to możesz zamienić tranzystor Q8 (BC107) na tranzystor BD139/16, a tranzystor Q7 (BC177) na tranzystor BD140/16.

    Tranzystor będzie mocniejszy więc możliwe że przestanie się uszkadzać, ale błąd w układzie pozostanie niewykryty.


    No właśnie szukamy błędów, a zauważalnym błędem jest żle podłączony rezystor R20.

  • #19 02 Sty 2015 10:49
    krzysio61
    Poziom 18  

    Witam. Może pomiar napięć na Q8 coś wyjaśni.

  • #20 02 Sty 2015 11:33
    andrzej lukaszewicz
    Poziom 38  

    E.L.O. napisał:
    R19 = R18 = 220Ω to zdecydowanie za mała wartość. Przy przesterowaniu duży prąd (duże napięcie impulsowe) idzie przez R19 ---> baza Q8 --->Emiter Q8 --->masy co powoduje spalenie Q8 (zwarcie B-E) a następnie spalenie R19. Zmień R19 i R18 na co najmniej 1kΩ...1,5kΩ.

    Kolego spójrz dobrze na schemat i oceń jakie napięcie moze sie pojawić pomiedzy rezystorem 0,15R a wyjściem wzmacniacza .
    krzysztof723 napisał:
    No właśnie szukamy błędów, a zauważalnym błędem jest żle podłączony rezystor R20.

    Nie jest to zaden błąd, tylko jest identycznie jak w ujemnej gałęzi , czyli prawidłowo. Twoja zmiana niczego nie wnosi

  • #21 02 Sty 2015 11:36
    jarek_lnx
    Poziom 43  

    Cytat:
    No właśnie szukamy błędów, a zauważalnym błędem jest żle podłączony rezystor R20.
    Dlaczego uważasz że to błąd?


    Cytat:
    Witam. Może pomiar napięć na Q8 coś wyjaśni.
    Racja, warto pomierzyć Ube i Uce w tym tranzystorze.

  • #22 02 Sty 2015 11:49
    andrzej lukaszewicz
    Poziom 38  

    @koma2000 Wrzuć zdjęcie z płytki w dwóch stron z tymi podejrzanymi elementami- cały czas uważam, że masz jakiś błąd ścieżek ,montażowy.
    Kiedyś walczyłem z jakimś swoim wzmacniaczem i kilka godzin szukałem przyczyny nieprawidłowej pracy ( z bardzo nietypowymi objawami) i jak sie okazało to wlutowałem BC 313 zamiast BF 257 w stopień napieciowy końcówki zasilanej +-55V. Wlutowałem wyjmując z szufladki z wieloma tranzystorami BC 257 jedną niewłaściwą sztukę, która trafiła tam przez pomyłkę tylko ze względu na identyczna obudowę.

  • #23 02 Sty 2015 14:26
    krzysztof723
    Poziom 28  

    andrzej lukaszewicz napisał:
    Nie jest to zaden błąd, tylko jest identycznie jak w ujemnej gałęzi , czyli prawidłowo.


    Opornik R20 jest źle podłączony i to jest błąd. Ujemna gałąź jest podłączona w inny sposób, bo tam występują tranzystory przeciwstawne.
    A jeżeli zmontowałeś tego typu wzmacniacz z takimi zabezpieczeniami końcówki mocy i zasilaniem symetrycznym to powinieneś o tym wiedzieć...

    andrzej lukaszewicz napisał:
    Twoja zmiana niczego nie wnosi

    Podobnie mogę odnieść się do Twojej wypowiedzi "Twoja porada niczego nie wnosi"

  • #24 02 Sty 2015 14:58
    andrzej lukaszewicz
    Poziom 38  

    Nie chce mi się z Toba polemizowac, właśnie dlatego, że ta zmiana zasadniczo niczego nie wnosi do działania układu poza tym , ze spowoduje wieksze ( niepotrzebne) zmiany w prądzie spoczynkowym tranzystora sterującego i jego mocy strat.
    W układzie quasi komplementarnym pierwszy schemat jest prawidłowy.
    Parę tranzystorów mocy traktujesz jako jeden własnie wraz z Re. A rezystor Rb właśnie powinien byc podłaczony do tego węzła jak i jest to zrobione w gałęzi ujemnej stopnia mocy. Można tak podłaczać Rb jak proponujesz , ale w układach w pełni komplementarnych.
    Rezystor 0,15 jest tu tylko do celów zabezpieczenia i mozna go usunąć w rozważaniach teoretycznych samego wzmacniacza.
    Za błędne uważam zastosowanie bd 139/140 jako tranzystory sterujące dwoma tranzystorami mocy starego typu ( niskie Hfe) oraz za dużą wartość rezystora Rb. W praktyce przyjmuje si,e 50-100Ω na jeden tranzystor mocy, czyli tu powinno być 22-51Ω. A to wymusza zastosowanie mocniejszych stopni sterujących.
    Nadal twierdzę , że Twoja "odkrywcza" porada niczego nie wnosi do układu, a tym bardziej do rozwiazania problemu autora.

  • #25 02 Sty 2015 16:14
    krzysztof723
    Poziom 28  

    jarek_lnx napisał:

    Cytat:
    No właśnie szukamy błędów, a zauważalnym błędem jest żle podłączony rezystor R20.

    Dlaczego uważasz że to błąd?


    Kiedyś na początku lat 90 dla znajomego zbudowałem podobny wzmacniacz z identycznymi zabezpieczeniami końcówki mocy i z podłączonym rezystorem w emiterze tranzystora sterującego do masy - rezystor ten był odpowiednikiem rezystora R20.
    Wzmacniacz pracował wiele lat bez żadnej awarii, aż został wymieniony na nowszy model.
    Bardzo prosta uniwersalna konstrukcja. Wzmacniacz można było zasilać napięciem symetrycznym od +/-14V do +/-38V. Zmiana napięcia zasilania powodowała zmianę mocy zasilacza od Pwyj.=15W do Pwyj.=120W przy zniekształceniach 0,4% w paśmie f=50Hz...16KHz przy mocy minimalnej i maksymalnej. Podczas wyboru mocy i napięcia zasilania trzeba było zmienić nieznacznie wartości elementów. Ja zatrzymałem się na mocy 60W, bo tam chodziło o moc kolumny i ograniczoną wartość napięć uzwojeń wtórnych transformatora.
    Ciekawostką było zabezpieczenie termiczne tranzystorów mocy zbudowane na jednym tranzystorze i termistorze umieszczone na wejściu wzmacniacza.

    Dlatego uważam, że w przypadku opornika R20 jest błąd w podłączeniu.
    Nie można jednoznacznie przyjąć, że błąd w podłączeniu R20 jest przyczyną problemu jaki przedstawia autor tematu (nigdzie o tym nie napisałem), ale warto to sprawdzić.

    PS.Nadmieniam, że układ wzmacniacza, który wykonałem to konstrukcja opracowana przez Firmę Siemens.

  • #26 02 Sty 2015 16:42
    andrzej lukaszewicz
    Poziom 38  

    krzysztof723 napisał:
    Dlatego uwazam, że w przypadku opornika R20 jest błąd w podłączeniu.

    Nie chce robic off topa, ale wytłumacz konkretnie na czym polega ten błąd...

  • #27 02 Sty 2015 19:50
    krzysztof723
    Poziom 28  

    andrzej lukaszewicz napisał:
    Za błędne uważam zastosowanie bd 139/140 jako tranzystory sterujące dwoma tranzystorami mocy starego typu ( niskie Hfe) oraz za dużą wartość rezystora Rb. W praktyce przyjmuje si,e 50-100Ω na jeden tranzystor mocy, czyli tu powinno być 22-51Ω. A to wymusza zastosowanie mocniejszych stopni sterujących.


    Jeżeli dotyczy to mojej wypowiedzi to ja nie pisałem o tranzystorach (Q9, Q10) sterujących tranzystory mocy tylko o tranzystorach (Q7, Q8) pracujących w zabezpieczeniach tranzystorów mocy.
    Rezystory R19, R16 i R17, R18 dobiera się w stosunku 1:10 i tutaj taka zależność została zachowana.
    Tranzystory BD139/16 i BD140/16 mogą pracować w układach zabezpieczających bez szkody dla wzmacniacza nawet z rezystorami w bazach po 220 Ohm.
    Można ewentualnie te rezystory dobrać w granicach 100...300 Ohm.

    andrzej lukaszewicz napisał:
    Rezystor 0,15 jest tu tylko do celów zabezpieczenia i mozna go usunąć w rozważaniach teoretycznych samego wzmacniacza.


    Autor tego wzmacniacza poświęcił dużą część konstrukcji na zabezpieczenie prądowe wyjścia wzmacniacza i nie byłoby dobrym pomysłem usuwać te rezystory nawet teoretycznie...

    andrzej lukaszewicz napisał:
    Nie chce robic off topa, ale wytłumacz konkretnie na czym polega ten błąd...


    Masz rację nie warto robić off topa i dlatego odsyłam Cię do książki pt. "Wzmacniacze elektroakustyczne" Maciej Feszczuk, wyd.III, gdzie wszystko dokładnie jest wytłumaczone.
    Przy okazji zerknij na post # 16 , w którym dodałem kilka słów wyjaśniających, a dotyczących także Twojego problemu z R20 (jezeli będzie Ci się chciało).

  • #28 02 Sty 2015 20:33
    andrzej lukaszewicz
    Poziom 38  

    krzysztof723 napisał:

    andrzej lukaszewicz napisał:
    Za błędne uważam zastosowanie bd 139/140 jako tranzystory sterujące dwoma tranzystorami mocy starego typu ( niskie Hfe) oraz za dużą wartość rezystora Rb. W praktyce przyjmuje si,e 50-100Ω na jeden tranzystor mocy, czyli tu powinno być 22-51Ω. A to wymusza zastosowanie mocniejszych stopni sterujących.


    Jeżeli dotyczy to mojej wypowiedzi to ja nie pisałem o tranzystorach (Q9, Q10) sterujących tranzystory mocy tylko o tranzystorach (Q7, Q8) pracujących w zabezpieczeniach tranzystorów mocy.

    A ja napisałem o wadach układu i dotyczą one właśnie tranzystorów sterujących , a nie zabezpieczających i to miałem na myśli -bez zwiazku o rozważaniach nad przyczynami uszkodzenia.
    Oczywiście w zabezpieczeniu mogą być BD 139/140, ale tranzystory małej mocy nie maja prawa tam sie uszkadzać w prawidłowo zmontowanym układzie.
    krzysztof723 napisał:
    dlatego odsyłam Cię do książki pt. "Wzmacniacze elektroakustyczne" Maciej Feszczuk, wyd.III, gdzie wszystko dokładnie jest wytłumaczone.

    No właśnie nie ma nigdzie w tej książce takiego podłączenia o jakim piszesz. Jeśi jest podaj strone i nr rysunku.
    Kolego cały czas mylisz rezystor zabezpieczający 0,15R z razystorem Re. I dlatego poleciłem Ci byś go usunął teoretycznie z rozwazań i wyjdzie Ci , że schemat nr 1 jest prawidłowy.

  • #29 02 Sty 2015 20:34
    Alemucha
    Poziom 28  

    R20 zostawić jak był. Stanem rzeczywistym R22 i jego podłączeń zająć się. Grzanie powoduje jego destrukcję a nawet wylutowywanie się. To nie jest rezystor zabezpieczający tylko pomiarowy zabezpieczenia! Bez niego wszystko chce walić przez BE Q8 i R19 więc prawidłowo odlatują zamiast chałupy.
    Zastąpienie R22 solidną zworą jest równoważne odlutowaniu R19, czyli zdjęciu "górnego" zabezpieczenia.

  • #30 02 Sty 2015 21:15
    krzysztof723
    Poziom 28  

    andrzej lukaszewicz napisał:
    No właśnie nie ma nigdzie w tej książce takiego podłączenia o jakim piszesz. Jeśi jest podaj strone i nr rysunku.


    Ależ jest... Jezeli dobrze poszuksz to na pewno znajdziesz schemat wzmacniacza z takim zabezpieczeniem, jakie jest tu omawiane.
    Po za tym w książce są inne praktyczne przykłady wzmacniaczy z zabezpieczeniami wyjść przed zwarciem.

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME