Elektroda.pl
Elektroda.pl
X

Search our partners

Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Płyta ceramiczna Siemens - ET77050EU/01 uszkodzony moduł sterujący

prataj 04 Jan 2015 23:14 5043 4
  • #1
    prataj
    Level 10  
    Witajcie,

    Dziś po przygotowaniu śniadania nie udało się już przygotować obiadu na naszej płycie ceramicznej Siemens ET77050EU/01. Uszkodzenie wyglądało tak, że sterowanie działało, tylko pola grzejne się nie załączają.

    Po zdemontowaniu płyty i wyjęciu moduły sterującego ukazały się następujące uszkodzenia:
    - spalony tranzystor załączający sterowanie dla wszystkich przekaźników sterujących polami grzejnymi
    - spalony jeden z przekaźników (brak przejścia na cewce)
    - stopiona ścieżka między wspomnianym tranzystorem a przekaźnikiem.
    Generalnie wygląda to jak na poniższych zdjęciach:
    Płyta ceramiczna Siemens - ET77050EU/01 uszkodzony moduł sterujący Płyta ceramiczna Siemens - ET77050EU/01 uszkodzony moduł sterujący



    Po analizie podłączenia wychodzi, że to będzie tranzystor PNP (+ zasilania podłączony na emiter w obudowie SOT223), zamówiłem takie:
    bcp53-16t1g

    Niestety nie udało mi się odszyfrować przekaźnika. Intensywne googlanie niczego nie przyniosło. Zamówiłem aktualnie te przekaźniki z TME: rm50-3011-85-1024

    Niestety nie wiem, czy stykną jeśli chodzi o napięcie sterujące. Jak pomierzyłem rezystancję cewki na sprawnym wyszło niewiele ponad 1.5kOhm. Jak szukałem po tym parametrze w TME znajduje praktycznie same na 24V i też taki zamówiłem z rezystancją cewki około 1.6kOhm
    Jak patrzę na wejście zasilania tej elektroniki to mam duże trafo z dwoma uzwojeniami pierwotnymi i wtórnymi z wyjściami 12V, które są połączone szeregowo.Za mostkiem prostowniczym mam około 36V stąd mój dylemat. Cewki przekaźników z drugiej strony są sterowane przez ULN2003, ale nie udało mi się wykonać pomiarów na elektronice pracującej na płycie.

    Z góry dziękuję za wszelkie sugestie co do tego przekaźnika
    Płyta ceramiczna Siemens - ET77050EU/01 uszkodzony moduł sterujący

    Pozdrawiam serdecznie,
    Paweł
  • Helpful post
    #2
    machefi
    Home appliances specialist
    prataj wrote:

    Jak patrzę na wejście zasilania tej elektroniki to mam duże trafo z dwoma uzwojeniami pierwotnymi i wtórnymi z wyjściami 12V, które są połączone równolegle.
    Chyba szeregowo?
    Przekaźnik można rozszyfrować porównując jego napięcie pracy z którymś wylutowanym z pozostałych, podłączając ten sprawny wylutowany pod zasilacz regulowany i ustalić napięcie pracy jego cewki, najpewniej będzie to 24V DC, podejdzie każdy o tym napięciu pracy i tym rozstawie wyprowadzeń. Miałbym też duże podejrzenie co do sprawności ULN 2003 po tym wybuchu tranzystora i spaleniu ścieżek.
  • #3
    prataj
    Level 10  
    machefi wrote:
    prataj wrote:

    Jak patrzę na wejście zasilania tej elektroniki to mam duże trafo z dwoma uzwojeniami pierwotnymi i wtórnymi z wyjściami 12V, które są połączone równolegle.
    Chyba szeregowo?

    Oczywiście szeregowo ... moje wieczorne zamotanie. Już poprawiam w wiadomości.
    machefi wrote:

    Przekaźnik można rozszyfrować porównując jego napięcie pracy z którymś wylutowanym z pozostałych, podłączając ten sprawny wylutowany pod zasilacz regulowany i ustalić napięcie pracy jego cewki, najpewniej będzie to 24V DC, podejdzie każdy o tym napięciu pracy i tym rozstawie wyprowadzeń. Miałbym też duże podejrzenie co do sprawności ULN 2003 po tym wybuchu tranzystora i spaleniu ścieżek.


    Dziękuję za sugestie. Tego scalaka też profilaktycznie zamówiłem w TME.

    Pozdrawiam,
    Paweł
  • #4
    prataj
    Level 10  
    Witam,

    Dziś dojechały elementy więc przystąpiłem do ich wymiany. W sumie aktualnie na wymianę załapały się:
    - wspomniany tranzystor PNP
    - profilaktycznie ULN2003
    - spalony przekaźnik

    Przed wlutowaniem przekaźnika zrobiłem pomiary na jednym ze sprawnych. Napięcie zasilające około 33V. Zgodnie z dokumentacją zakupionego elementu roboczy zakres napięcia zasilania cewki jest w przedziale od 18V do 31,2V więc troszkę brakuje. Niemniej element został wlutowany na testy.

    Pierwsza próba załączenia i zonk ... nic nie działa. Okazało się, że jedna z tasiemek łączących płytki (bo są 3 piętrowo połączone) całkowicie się przerwała przy lutach zachowując swój kształt i położenie.

    Po zstąpieniu tasiemki przewodami kolejna próba ...

    Na pierwszy rzut oka wszystko ładnie startuje. Dokładne testy i niestety jeden z 4 palników nie załącza grzałki. Aktualnie nie wiem od którego przekaźnika, bo już się późno zrobiło na dalsze dłubanie. Być może to też druga tasiemka idąca do ULN2003 załapała pęknięcie a być może to ten nowy przekaźnik, albo uszkodzony jeszcze któryś. Dodatkowo w jednym polu nie ma możliwości zmniejszania mocy. Pole dotykowe "-" zdaje się nie reagować.

    Przy kolejnym podejściu planuję też dolutować równolegle do cewek przekaźników diody zabezpieczające. Zastanawiam się też nad dolutowaniem szeregowo jakiegoś rezystora (tak z 300Ohm) do cewki nowego przekaźnika, co powinno go wprowadzić w akceptowalny przedział napięć sterujących.

    Dalsze testy będą pewnie w piątek, ale mam pytanie. Ponieważ podłączanie i testowanie sterownika bezpośrednio w płycie jest lekką upierdliwością zastanawiam się nad testowaniem go na zewnątrz. Niestety jak odpalałem go "na krótko" podłączając fazę i zero na konektory zasilające elektronika się podnosiła, ale nie byłem w stanie niczego zrobić. Dotykając "placki ", gdzie są rejony pół dotykowych nie było żadnej reakcji na dotyk. Czy to normalne, czy jest jakiś patent na wymuszenie reakcji takiego pola też poza płytą?

    Z góry dziękuję za wszelkie dalsze sugestie.

    Pozdrawiam serdecznie,
    Paweł
  • #5
    prataj
    Level 10  
    Witam,

    Płyta została finalnie podniesiona do pełnej sprawności, niestety z małym ale, o którym później.

    Wymieniłem wszystkie przekaźniki, bo po rozebraniu jednego ze sprawnych styki przełączające były w fatalnym stanie. W sumie od 98 roku troszkę już pochodziły. W szereg z cewkami dodałem rezystory 300 Ohm, dzięki czemu napięcie na cewkach przy włączeniu spadło do akceptowalnych 27V. Dodałem też równolegle do cewek diody zabezpieczające.

    Przyczyną niedziałania jednego z pól okazał się zimny lut na jednym z wyprowadzeń sterujących ULN2003.

    Całą płytkę przylegająca od strony płyty ceramicznej wyczyściłem IPA oraz odgiąłem sprężynujące blaszki dla lepszego dociśnięcia płytki.

    Po zmontowaniu wszystko zaczęło działać. Niestety po pierwszym gotowaniu i nagrzaniu się płyty przestało działać sterowanie jednego z pól, a po chwili dołączyły następne objawy, ale o tym problemie już w nowym wątku.

    Pozdrawiam serdecznie,
    Paweł

    EDIT1:
    Ten problem jest zamknięty więc zamykam wątek.