Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

brak wyboru systemu przy uruchamianiu komputera-odpala się ubuntu

marcin011 09 Sty 2015 22:18 3810 35
  • #1 09 Sty 2015 22:18
    marcin011
    Poziom 8  

    Na początek zaznaczę, że mój komputer jest wyposażony w 2 dyski, 120GB SSD oraz 1TB HDD.
    Na dysku ssd trzymałem system i sterowniki, a na dysku HDD swoje pliki.

    Zainstalowałem z bootowalnego pendriva ubuntu, przy instalacji początkowo pomyliłem dzielenie partycji i do tego chyba wybrałem zły system plików. Partycję dysku hdd podzieliłem na 2 części z czego na nowej zainstalowałem ubuntu, a starą ustawiłem jako swap.

    Po ponownym uruchomieniu od razu odpalił się windows i nie dał mi wyboru systemu przy uruchamianiu. Odpaliłem komputer jeszcze raz z pen drivem, tym razem z partycji którą wcześniej oznaczyłem jako swap wydzieliłem 6GB, która miała być od teraz swap, a na pozostałej części chciałem ustawić typ pliku ntfs, aby była ona dostępna dla windowsa, jednak nie było takiej opcji więc po prostu zostawiłem ją nie ruszoną. Partycje wydzieloną dla ubuntu, na której system został już zainstalowany kazałem sformatować i zainstalowałem system od nowa. Ustawiłem też żeby program rozruchowy został odpalony właśnie z tej partycji.
    Po pełnej instalacji systemu wyłączyłem komputer, wyjąłem pendrive i odpaliłem system. Niestety nie dał mi wyboru systemu, tylko od razu odpalił się ubuntu.


    Szukałem w sieci rozwiązania problemu, ale u większości ludzi dzieje się w drugą stronę, tzn. odpala się win bez możliwości wejścia do ubuntu.
    Wersja ubuntu to 14.04 lts
    Wersja windows to Win7

    0 29
  • #4 10 Sty 2015 08:47
    namok
    Poziom 25  

    W terminalu wykonaj

    Kod: bash
    Zaloguj się, aby zobaczyć kod

    Wynik zapisz gdzieś do pliku. Jeśli po restarcie nie pojawi się windows w menu gruba to wynik wklej na forum.[/code]

    0
  • #5 10 Sty 2015 11:03
    marcin011
    Poziom 8  

    Code:
    Generating grub configuration file ...
    
    Uwaga: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
    Znaleziono obraz Linuksa: /boot/vmlinuz-3.13.0-43-generic
    Znaleziono obraz initrd: /boot/initrd.img-3.13.0-43-generic
    Znaleziono obraz Linuksa: /boot/vmlinuz-3.13.0-32-generic
    Znaleziono obraz initrd: /boot/initrd.img-3.13.0-32-generic
    Found memtest86+ image: /boot/memtest86+.elf
    Found memtest86+ image: /boot/memtest86+.bin
    Znaleziono Windows 7 (loader) na /dev/sda1
    gotowe


    Menu wybory się pojawiło, jednak po wybraniu windows wisi na czerwonym ekranie z ubuntu bez żadnego logo czy tekstu.

    0
  • #6 10 Sty 2015 12:00
    namok
    Poziom 25  

    Podaj wynik polecenia

    Kod: bash
    Zaloguj się, aby zobaczyć kod

    0
  • #7 10 Sty 2015 12:28
    marcin011
    Poziom 8  

    Code:
    System plików  rozm. użyte dost. %uż. zamont. na
    
    /dev/sdb5       367G  4,7G  344G   2% /
    none            4,0K     0  4,0K   0% /sys/fs/cgroup
    udev            7,9G   12K  7,9G   1% /dev
    tmpfs           1,6G  1,2M  1,6G   1% /run
    none            5,0M     0  5,0M   0% /run/lock
    none            7,9G   76K  7,9G   1% /run/shm
    none            100M   44K  100M   1% /run/user

    0
  • #8 10 Sty 2015 13:41
    namok
    Poziom 25  

    Zainstaluj gruba w MBR dysku sdb:

    Kod: bash
    Zaloguj się, aby zobaczyć kod
    a następnie sprawdź czy system wystartuje z tego dysku(sdb). Jeśli tak to idziemy dalej.
    Zainstaluj lilo
    Kod: bash
    Zaloguj się, aby zobaczyć kod
    a następnie zainstaluj go w MBR dysku sda:
    Kod: bash
    Zaloguj się, aby zobaczyć kod

    Zrestartuj komputer i sprawdź czy windows wystartuje prawidłowo(start z dysku sda).

    0
  • #9 10 Sty 2015 14:08
    marcin011
    Poziom 8  

    Po wpisaniu pierwszej komendy nie podnosi sie żaden system. Wobu wisi na fioletowym ekranie.

    0
  • #10 10 Sty 2015 14:33
    namok
    Poziom 25  

    marcin011 napisał:
    Wobu wisi na fioletowym ekranie.

    Opisz dokładnie co przez to rozumiesz.
    Podaj ponownie wynik bootinfoscript.

    0
  • #11 10 Sty 2015 14:56
    marcin011
    Poziom 8  

    Przy uruchamianiu komputera, po wybraniu systemu operacyjnego, pojawia się fioletowe tło (ten charakterystyczny kolor Ubuntu) i nic więcej się nie dzieje.
    Póki nie załaduje się system nie odpale terminala, chyba że jest jakiś inny sposób. Dlatego nie podam wyniku bootinfoscript.
    Dla ścisłości miałem na myśli "w obu" (systemach)

    0
  • #12 10 Sty 2015 15:00
    namok
    Poziom 25  

    marcin011 napisał:
    Póki nie załaduje się system nie odpale terminala, chyba że jest jakiś inny sposób. Dlatego nie podam wyniku bootinfoscript.

    A teraz z czego piszesz? jeśli z livecd to podaj wynik skryptu.

    0
  • #13 10 Sty 2015 15:06
    marcin011
    Poziom 8  

    Z telefonu, to mam odpalić system z pendrivem do instalacji, wybrać "wypróbuj bez instalacji" i tam wpisać skrypt?

    0
  • #14 10 Sty 2015 15:07
    namok
    Poziom 25  

    marcin011 napisał:
    Z telefonu, to mam odpalić system z pendrivem do instalacji, wybrać "wypróbuj bez instalacji" i tam wpisać skrypt?

    Tak ale nie wpisać skrypt tylko uruchomić bootinfoscript.

    0
  • #16 10 Sty 2015 15:31
    namok
    Poziom 25  

    Wyłącz komputer, wypnij taśmę dysku z windows i uruchom komputer(ma być podpięty tylko jeden dysk). Jeśli uruchomi się Ubuntu to ok, jeśli nie to uruchom komputer z livecd i podaj wynik

    Kod: bash
    Zaloguj się, aby zobaczyć kod

    0
  • #17 10 Sty 2015 15:47
    marcin011
    Poziom 8  

    Dobrze rozumiem, że mam rozkręcić komputer? Gdzie jest dysk hdd to wiem ale gdzie mam ssd na którym znajduje się windows to nie mam pojęcia.

    0
  • #18 10 Sty 2015 16:05
    namok
    Poziom 25  

    marcin011 napisał:
    Dobrze rozumiem, że mam rozkręcić komputer? Gdzie jest dysk hdd to wiem ale gdzie mam ssd na którym znajduje się windows to nie mam pojęcia.

    Jeśli komputer nie jest na gwarancji to tak.
    Jeśli nigdy tego nie robiłeś i nie czujesz się pewnie to nie rozkręcaj. Można próbować przywrócić systemy do użytku bez rozkręcania ale tak byłoby prościej.
    Swoją drogą to laptop czy desktop?

    0
  • #19 10 Sty 2015 16:34
    marcin011
    Poziom 8  

    Laptop i jest jeszcze na gwarancji. Juz to kiedys robilem, ale ten jest troche innej generacji, 2 dyski, 2 karty graficzne, boje sie zeby czegos nie namotac. Jednak wolalbym dzialac myszka i klawiatura niz srubokretem :)
    Slyszalem, ze wcale nie traci sie gwarancji po rozkreceniu laptopa, a zaklejanie obudowy paskami z ostrzezeniem mozna calkowicie zlekcewazyc.

    0
  • #20 10 Sty 2015 16:43
    namok
    Poziom 25  

    To proponuję nie rozkręcać.
    Chciałbym wrócić jeszcze do postu #9. Nie chce mi się wierzyć aby instalacja gruba na dysku sdb popsuła Ubuntu tak że nie startuje prawidłowo przy wyborze dysku sda jako startowy.
    Upewnij się że dysk ssd jest wybrany w biosie jako startowy i sprawdź czy Ubuntu wystartuje.

    0
  • #21 10 Sty 2015 17:07
    marcin011
    Poziom 8  

    Nie robiłem nic w biose, po prostu spróbowałem jeszcze raz odpalić ubuntu i tym razem się uruchomił. Ciekawe bo wcześniej próbowałem 2 razy.
    Po wykonaniu operacji z 8 postu, windows odpala się normalnie, natomiast nie ma wyboru systemu przy uruchamianiu, od razu odpala windowsa.

    Nie widzę też partycji która miała być dla windowsa na dane, jest tylko dysk ssd.

    0
  • #22 10 Sty 2015 17:36
    namok
    Poziom 25  

    marcin011 napisał:
    Nie robiłem nic w biose, po prostu spróbowałem jeszcze raz odpalić ubuntu i tym razem się uruchomił. Ciekawe bo wcześniej próbowałem 2 razy.
    Po wykonaniu operacji z 8 postu, windows odpala się normalnie, natomiast nie ma wyboru systemu przy uruchamianiu, od razu odpala windowsa.

    Nie widzę też partycji która miała być dla windowsa na dane, jest tylko dysk ssd.

    Po tym co napisałeś to nie mam pewności czy wykonujesz to o co proszę czy to co się Tobie podoba.
    Jeśli czegoś nie rozumiesz to wyraźnie to napisz.
    Pisząc "uruchom komputer z dysku sda lub sdb" miałem na myśli abyś w biosie ustawił start z tego dysku(ska lub sdb)!!!
    Jaki jest teraz stan?
    Uruchom kolejno komputer z dysku sda i sdb i dokładnie opisz co działa a co nie. Dla pewności sprawdź to kilkakrotnie aby znowu nie było że "teraz działa". Podaj też wynik bootinfoscript(obojętnie czy z livecd czy z zainstalowanego Ubuntu).

    0
  • #23 10 Sty 2015 17:47
    marcin011
    Poziom 8  

    Na razie nie potrafię odpalić ubuntu. Jestem teraz na windowsie, a przy odpalaniu nie ma menu wyboru. Partycja na dysku HDD na dane dla windows również nie działa. Proszę, żebyś opisał krok po kroku co mam zrobić bo ustawienie w biosie startu z danego dysku to dla mnie nie zrozumiałe polecenie.
    Nie jestem w stanie podać wyniku bootinfoscript, chyba, że na windowsie też to mogę zrobić.

    0
  • #24 10 Sty 2015 18:30
    namok
    Poziom 25  

    marcin011 napisał:
    Nie jestem w stanie podać wyniku bootinfoscript, chyba, że na windowsie też to mogę zrobić.
    Przecież już wcześniej pisałem że możesz to zrobić z livecd.

    Cytat:
    Jestem teraz na windowsie, a przy odpalaniu nie ma menu wyboru.
    Nie ma bo wykonałeś 2 ostatnie polecenia z postu #8. Taki był ich cel(chciałem sprawdzić czy z windowsem jest wszystko OK)

    Cytat:
    Na razie nie potrafię odpalić ubuntu.
    To efekt tych dwu poleceń. Pierwsze polecenie miło zapewnić start z dysku sdb ale na razie nie wiadomo czy działa.

    Cytat:
    Partycja na dysku HDD na dane dla windows również nie działa.
    Partycja działa i ma się dobrze tyle że Ty nie bardzo rozumiesz co robisz. Jak rozumiem chodzi o partycję sdb6 która ma system plików ext4 i dlatego nie jest widziana przez windows. Użyj gparted z livecd, sformatuj ją na ntfs i będzie widziana przez oba systemy. Możesz użyć też do tego windows ale obawiam się że przy okazji zniszczysz Ubuntu. W gparted powinna być widziana jako sdb6.

    Cytat:
    Proszę, żebyś opisał krok po kroku co mam zrobić bo ustawienie w biosie startu z danego dysku to dla mnie nie zrozumiałe polecenie.
    Jak to zrobić znajdziesz w dokumentacji do laptopa. Ustawienia te mogą się nazywać "Boot order", "Advanced boot" itp. Generalnie jeśli nie masz doświadczenia to lepiej nie grzeb w biosie. Bezpieczniej będzie spróbować zmienić kolejność startu dysków podczas uruchamiania komputera. U mnie do tego służy przycisk F8 ale może to być dowolny inny. Podaj model laptopa to google powinno nam pomóc.( w dokumentacji też to będzie ;)).

    0
  • #26 11 Sty 2015 12:30
    namok
    Poziom 25  

    marcin011 napisał:
    "novo key" sluzacy do wejscia do biosa znajduje sie obok gniazda ladowarki.

    A dokładniej
    Cytat:
    When the computer is off, press this button to start the Lenovo OneKey Recovery system or the BIOS setup utility, or to enter the boot menu.
    strona 7 dokumentacji(Left-side view w menu).
    Masz jeden przycisk "do wszystkiego".

    0
  • #27 11 Sty 2015 13:05
    marcin011
    Poziom 8  

    Narazie chyba od 3 godzin czekam az gparted skonczy prace, cos dlugo to trwa.
    W zalaczniku wynik bootinfoscript i fdisk o ktore prosiles (z live cd). Jak gparted w koncu skonczy sprobuje zmienic kolejnosc odpalania dyskow w boot managerze i dam znac.

    0
  • #28 11 Sty 2015 21:04
    marcin011
    Poziom 8  

    W boot menu były 3 opcje (dysk1(win), dysk2(ubuntu) i jakiś web boot czy coś takiego). Domyślam się, że jeden dysk to sda, a drugi to sdb. W każdym razie pierwszy (z windowsem) odpala się normalnie, natomiast przy drugim, po jego wybraniu, ekran robi się czarny(ale się nie wyłącza) i nic więcej się nie dzieje.

    0
  • #30 12 Sty 2015 19:47
    marcin011
    Poziom 8  

    Próbowałem chyba wszystkich możliwych ustawień z tego programu, za każdym razem z tym samym skutkiem.
    Pojawiła się lista systemów przy odpalaniu, jedna po wybraniu ubuntu, pojawia się czarny ekran z migającym podkreślnikiem w lewym górnym rogu ekranu. Przy kilku ustawieniach też program się wysypuje ("program przestał działać" kiedy próbuje dodać nowy wpis). Nie wiem czy to normalne czy wina słabo ostatnio działającego windowsa (wygląda na to, że został zainfekowany).
    Wydaje mi się, że też w ustawieniach zaawansowanych należy wybrać dysk E dla ubuntu, jednak i tak nic to nie dało.

    0