Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Fatek FBs-24MA - Hamulec mobac załączany przez fatek tylko dla 1 parametru

Kampaj 12 Jan 2015 13:13 1989 2
  • #1
    Kampaj
    Level 9  
    Posiadam program jak na schemacie 1 oraz 2 do zarządzania zasilaczem hamulca tylu mobac. Model FP-25/1 230V. Karta katalogowa: http://www.cantonigroup.com/files/fp25_pl.pdf
    Przeprowadzam modernizację i zauważyłem, że hamulec działa jedynie przy nastawach z wiersza 60, czyli konwersji liniowej. Gdy program dochodzi do tego momentu, zaczyna poprawnie obsługiwać hamulec. Jednak przy innych wartościach rejestru R206 daje wartość 0 na wyjściu.
    Tak więc dla aktywnej linijki M70(NO), X8(NO),M56(NZ)
    oraz dla linijki M8(NZ).
    Podczas pracy oraz podczas symulacji, wartość z linii kodu jest poprawnie wprowadzana do modułu HSPWM w linii 60 pod rejestr R206.
    Fatek FBs-24MA - Hamulec mobac załączany przez fatek tylko dla 1 parametru
    Fatek FBs-24MA - Hamulec mobac załączany przez fatek tylko dla 1 parametru
    Jak widać ze schematu 3, hamulec jest ciągle zasilany i załączony(nie zależy od pracy silnika).
    Fatek FBs-24MA - Hamulec mobac załączany przez fatek tylko dla 1 parametru

    Gdzie może być problem?
    Wygląd panelu do wprowadzania danych i schemat połączeń sterujących zasilacza na rysunku 4:
    Fatek FBs-24MA - Hamulec mobac załączany przez fatek tylko dla 1 parametru
  • Helpful post
    #2
    pafciowaw
    Automation specialist
    W N56 masz M55 ze zboczem - coś kojarzę (ze szkolenia) że takie coś może nie "chodzić" poprawnie; spróbuj M55 zwykłe NO a za nim zbocze narastające - będzie to samo ale inaczej :)
  • #3
    Kampaj
    Level 9  
    Dzięki za uwagę. Za chwile wypróbuje. Czasami też kolejnośc linijek kodu ma znaczenie zauważyłem. Tylko to też nie jest tak, że załączanie funkcji 08.MOV nie dziala. Bo wartość poprawnie jest przenoszona do rejestru R206. Funkcja HSPWM interpretuje jednak tylko wtedy wartość R206, gdy pochodzi ona z funkcji, będącej wyżej, czyli konwersji liniowej 33.LCNV. Sama konwersja działa poprawnie z wartościami.

    Dodano po 2 [godziny] 6 [minuty]:

    Problem rozwiązany. Okazuje się, że zasilacz daje tak małe impulsy PWM dla wartości nastaw 0,2 ze sterownika fatek, że jest to interpretowane przez woltomierz prądu zmiennego jako 0V. Wystarczyło zwiększyć wartości i system działa. Temat zostawiam, może się komuś przyda.