Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Apache - Xampp virtualne hosty

Rafq25 18 Sty 2015 17:38 891 8
  • #1 18 Sty 2015 17:38
    Rafq25
    Poziom 16  

    Witam stawiam w ramach laboratoriów serwer www na xamppie
    Wszystko na lokalu działało fajnie
    Chodzi o virtualne hosty jedną stronę miałem na localhost a drugą na test.local. Wszystko było po konfigurowane okej skorodziałało.
    Teraz jak chce udostępnić stronę na świat wirtualne hosty przestają działać mam zmienne ip więc korzystam z noip.com

    Pomoże ktoś mi rozwiążać problem ?

    Code:

    <VirtualHost ip z no.ip :80>
        ServerName  nazwa mojej domeny na noip.com
       DocumentRoot "C:/xampp/htdocs/strona"
    </VirtualHost>

    <VirtualHost  ip z no :80>
        ServerName nazwa mojej domeny na noip.com
     DocumentRoot "C:\xampp\htdocs\strona1"
    </VirtualHost>

    0 8
  • #2 18 Sty 2015 18:17
    rikardo67
    Poziom 21  

    Rafq25 napisał:
    Witam stawiam w ramach laboratoriów serwer www na xamppie
    Wszystko na lokalu działało fajnie
    Chodzi o virtualne hosty jedną stronę miałem na localhost a drugą na test.local. Wszystko było po konfigurowane okej skorodziałało.
    Teraz jak chce udostępnić stronę na świat wirtualne hosty przestają działać mam zmienne ip więc korzystam z noip.com

    Pomoże ktoś mi rozwiążać problem ?
    Code:

    <VirtualHost ip z no.ip :80>
        ServerName  nazwa mojej domeny na noip.com
       DocumentRoot "C:/xampp/htdocs/strona"
    </VirtualHost>

    <VirtualHost  ip z no :80>
        ServerName nazwa mojej domeny na noip.com
     DocumentRoot "C:\xampp\htdocs\strona1"
    </VirtualHost>


    A po co takie kombinacje z tym "ip z no.ip", wpisujesz ip routera wewnętrzne lub " * " jak będzie tak :
    Cytat:
    VirtualHost *:80>
    ServerName nazwa mojej domeny na noip.com
    DocumentRoot "C:/xampp/htdocs/strona"
    </VirtualHost>

    <VirtualHost * :80>
    ServerName nazwa mojej domeny na noip.com
    DocumentRoot "C:\xampp\htdocs\strona1"
    </VirtualHost>
    To bedzie działać na localu i na zewnątrz, oczywiscie trzeba jeszcze otworzyć port 80 na świat, nie miałem do czynienia z xamppem, ale chyba konfig do apacha jest taki sam.

    0
  • #3 18 Sty 2015 18:25
    Rafq25
    Poziom 16  

    Tak konfiguracja jest taka sama.
    port 80 mam przekierowane na kompa na którym jest apache.

    w pliku httpd.conf muszę ustawić i tak wszystko jak bym miał jedną stronę
    czyli na documentRoot na strone

    potem w nim mam ustawione żęby czytał httpd-vhosts
    i w nim mam te ustawienia z virtualnymi hostami.
    Strona pierwsza się wczytuje przez internet niestety, strona druga wczytuje się tak samo jak strona pierwsza.

    0
  • #4 18 Sty 2015 19:43
    przeqpiciel
    Poziom 30  

    Witaj, jestem pełen podziwu takich fal tematów. Niemalże identyczny problem wypłynął ze dwa dni temu. Lekko użyć szukajki i voila !

    https://www.elektroda.pl/rtvforum/viewtopic.php?t=2968256&highlight=

    Dodano po 2 [minuty]:

    jeżeli już to potrzebujesz dwóch domen lub domeny no-ip i wystawienia na adresie IP - co jak widze przy zmiennym adresie może być słabe

    0
  • #5 18 Sty 2015 20:52
    Rafq25
    Poziom 16  

    Próbowałem wszystkiego dla tego piszę na forum.
    Mam dojście do stałego ip

    i mogę wykorzystać noip domeny tak ?
    Jak to skonfigurować poprawnie ??

    0
  • #6 18 Sty 2015 20:55
    przeqpiciel
    Poziom 30  

    to jest tak ze ustawiasz servername. gdy przychodzi zadanie to apache sprawdza do ktorej domeny jest zadanie (servername) wtedy podejmuje decyzje ktora zawartosc wyswietlic.

    dlatego potrzebujesz domeny i adresu ip publicznego badz min 2 domen

    0
  • #7 19 Sty 2015 18:13
    Rafq25
    Poziom 16  

    Udało mi się doprowadzić do sytuacji gdzie strona pierwsza działa poprawnie
    a przy łączniu się z druga domena otrzymuje komunikat "Zabroniony dostęp"

    0
  • #8 19 Sty 2015 20:09
    rikardo67
    Poziom 21  

    Plik lub folder nie ma odpowiednich praw

    0
  • #9 19 Sty 2015 20:45
    Rafq25
    Poziom 16  

    Faktycznie. działa
    Jest odpowiednio skonfigurowane ? Czy jakoś pobawić się uprawnieniami ?
    <Directory />
    Require all granted
    </Directory>

    0