Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

huawei hg553 e3131 - podłączyć modem e3131 do routera hg553, widzi, nie łączy

tom1eczek 25 Jan 2015 23:58 3684 12
Optex
  • #1
    tom1eczek
    Level 20  
    witam. mam problem ze skonfigurowaniem routera huawei hg553 vodafone do pracy z modemem e3131 nie hilink - zwykły z play z karta sim play. przez internet chce puścić monitoring także musi być router z wyjściem rj45. modem i karta działają w pc.

    początkowo oprogramowanie było dlinka i na nim udało mi się uruchomić kartę play w modemie e160e. 70kbps uploadu nie pociągnie mi transmisji. ustawienie:
    vendor id 12d1
    prod id 1003


    skanowanie z modemem 3131
    T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh= 0
    D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=12d1 ProdID=14fe Rev= 1.02
    S: Manufacturer=HUAWEI
    S: Product=HUAWEI Mobile
    C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
    I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    I: If#= 1 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

    modem e3131 ustawienie tak jak wynika ze skanowania
    vendor id 12d1
    prod id 14fe

    przy probie połączenia, pudło.
    Connection log:

    Detected key: Vendor ID 12d1, Product ID 14fe
    Waiting for ZeroCD to disable (about 20 secs) <<nie rozumiem tego
    Loading serial module
    No ttyUSB0 detected: Vendor ID 12d1, Product ID 14fe

    w modemie komendami at przez topnetinfo wyłączyłem cdrom i kartę sd - nie pomogło.

    zmieniłem oprogramowanie na huawei od jednego z użytkowników elektrody. Pewnhym trickiem (eksport ustawień edycja pliku i import ustawiłem odpowiednie pola których nie chciał router przepuścić przez przeglądarkę - user i hasło) modem zadziałał, 1mbps uploadu. ale nic tam nie można ustawić ddns, firewalla (odrzuca pingi z zewnątrz), poblokowane porty nie da rady dostać sie do rejestratora cctv.

    Próbowałem wgrać openwrt - router zbrickował się na jakiś czas po czym odpuścił i dał sobie wgrać z powrotem dlinka ru-10.


    Mam do Was pytanie walcze dwie noce już. jak przestawić ten modem żeby chciał pracować z tym routerem? vendor id na 14fe coś czytałem że na 1506 by zadziałał - wpisywałem, nie znajduje.
    lub opcja B, potrzebuję openwrt dla tego routera wersja na włochy italy. może zadziała
  • Optex
  • #2
    mbo
    VIP Meritorious for electroda.pl
    Sprawdzałeś jakie dostajesz IP przy takim połączeniu ?
    Druga sprawa to standardowo zapewne masz zablokowane połączenia przychodzące.
  • Optex
  • #3
    tom1eczek
    Level 20  
    ip zaewnetrzne było 46.112.51.235 z tego co pamiętam i nie dało się pingować z zew. Dlatego wróciłem do softu dlinka tam może uda sie odblowakać porty

    .....jak zadziała modem. a trzeba podobno kolejność portów pozmieniać, modem na poczatku. na chomiku lesiolo (dobra strona) znalazłęm taki kawałek:

    modyfikując odpowiednio komende AT^SETPORT=A1,A2;x1,x2,x3,x4,A1,A2 i wysyłając ją do modemu
    gdzie x1 - ttyUSB0, x2 - ttyUSB1, x3 - ttyUSB2, x4 - ttyUSB3
    (ustawia się zmieniając wartości po średniku, licząc od zera, to co przed średnikiem zostawiamy w spokoju)
    Ważne! niczego nie ujmujemy ani nie dodajemy, przestawiamy tylko kolejność !
    Przykład AT^SETPORT=A1,A2;1,16,3,2,A1,A2 gdzie kolejno
    1 to Modem = ttyUSB0
    16. NCM = ttyUSB1
    3. DIAG (Application Interface) = ttyUSB2
    2. PCUI (PC UI Interface, AT Commands) = ttyUSB3
    A1. CDROM
    A2. SD Card
    Legenda do wartości setport
    A1 CDROM, A2 SD, A BLUE TOOTH, B FINGER PRINT, D MMS, E PC VOICE
    1 MODEM, 2 PCUI, 3 DIAG, 4 PCSC, 5 GPS, 6 GPS CONTROL, 16 NCM
  • #4
    mbo
    VIP Meritorious for electroda.pl
    Połączenia z zewnątrz standardowo blokuje operator - dopytaj u niego o pakiet/APN bez tej blokady.
  • #6
    tom1eczek
    Level 20  
    raz: Dostałem do testów inny modem e398 lte. jutro Zobaczymy.

    Dwa: a DDNS? router kiedy zmienia ip, melduje do ddns'a. Wtedy ja wbijam ip ddns on przekierowuje mnie na moje aktualne zmienne ip i co, ściana? sieć nie pozwoli wejść? W taki razie jak serwery wysyłają do me dane? Skąd klient poczty wie, że przyszedł do mnie właśnie email? Serwer poczty chyba mu melduje? Jak sieć rozróżnia kierunek ruchu?

    Trzy: Wpadłem na taki pomysł. modem odbiera i wysyła sms. Prawda to? Można by to wykorzystać do zapoczątkowania transmisji. Albo wykorzystać maila. Rejestrator zresztą ma funkcje meldowania o ruchu na maila (np z ip) którego odebrałbym na androidzie. Nie wiem.
  • #7
    mbo
    VIP Meritorious for electroda.pl
    DDNS tylko pozwala obejść problem zmiennego IP.

    W podanym przykładzie transmisja inicjowana jest z łącza w świat - klient e-mail wysyła zapytanie do serwera.
    SMS nic tutaj nie daje - to zupełnie iny rodzaj transmisji.

    Aby to działało potrzebowałbyś punktu pośredniczącego z którym zawiązana byłaby transmisja z rejestratora np. VPN.
  • #8
    tom1eczek
    Level 20  
    okej. czyli robie tunel vpn między chałupą,a obiektem monitorowanym z tym nieszczęsnym internetem mobilnym? W chałupie mam zmienne ip. Czy vpn działa między dwoma zmiennymi ip?
  • #9
    mbo
    VIP Meritorious for electroda.pl
    Może działać - to tylko kwestia odpowiednich ustawień.
  • #10
    rimk
    Level 10  
    @tom1eczek możesz napisać co dokładnie zrobiłeś, żeby e3131 zadziałał na hg553? próbowałem wyłączyć cd i sd, ale ciągle zielona dioda i brak reakcji...
  • #11
    tom1eczek
    Level 20  
    Powiem Wam co i jak. Na omawianym routerze hg553 kolega zainstalował openwrt co umozliwiło podłączenie jakiś rozsądnych modemów. Wgranie openwrt czasem jest problemem są rózne wersje tego routera, czasem się brickuje. Przy czym on m jakby dwie kieszenie na soft. jesli na nowym nie moze wystartować po kilku próbach startuje ze starego. Ustawia sie te open wrt przez konsolę więc nie pomogę. Później openwrt z internetu pobiera sterowniki do danego modemu. Czasem nie da się czegoś zrobić z gui nawet przez konsole i trzeba wyeksportować plik config otrzorzyć to archiwum edytować plik i wrzuci spowrotem n router. Na przykład jak apn uzytkownika i hasło do sieci się ustawia.

    w każdym razie do tego podłączyłem huawei e398 lte. Modem na dwie antenki (jedną antene mam podłączoną), z plusa był bez simlocka. Do modemu włożyłem wykupiona w t- mobile kartę ze stałym i publiczym ip 30gb transferu na firmę 40 pare złotych. Lte działa w mojej zapadłej podwarszawskiej dziurze. W dzień 8Mbit w nocy 16Mbit. open wrt umożliwił ustwienie forwardingu na firewallu i monitoring działa.

    Coś jescze muszę poblokować porty bo mam jakiś dziwny ruch na wanie ok 6gb transferu na kilka dni, a na lanie już niema tego ruchu znaczy ktoś się dobija od zewnątrz.

    Pozdrawiam, Tomek
  • #12
    tzok
    Moderator of Cars
    Jestem zdziwiony, bo do niedawna w żadnym LTE w Polsce nie było opcji publicznego IP, wszystko szło przez NAT i nie dało się uruchomić serwera. Zostawało tylko HSDPA, tam np. w Orange można było użyć APN: vpn.

    Co do dziwnego ruchu to Open/DD-WRT ma sysloga i iptables...
  • #13
    tom1eczek
    Level 20  
    po prędkości wychodziłoby, że jest to lte bo podłączałem modem do laptopa jak router nie działał to prędkość połączenia wyświetlał 43mbps, rzeczywiste oczywiście te 8-16. ale nie istotne.

    jak ma się wykupiona usługę stałe ip w tmobile to wtedy w apn trzeba zamiast internet wpisać data.

    Właśnie nie mogę znaleźć, a nawet nie wiem czego szukać w tych logach openwrt jeśli chodzi o ten transfer danych o stronie wan.

    Tomek