Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ładowarka rowerowa USB - podaje napięcie i nie ładuje

27 Sty 2015 23:23 1869 11
  • Poziom 18  
    Witam,
    zmajstrowałem ładowarkę wg tego projektu: http://www.gregorkarnas.com/radio/projekt/usb/index.htm
    podłączyłem do dynama 6V i na mierniku pokazało się napięcie - 4,5V oraz prąd około 300mA. Ładowarka niestety nie ładuje telefonów ani GPS, sprawdziłem 4 urządzenia oraz 2 dynama (jedno z uziemieniem w ramie, drugie w dynamie).

    Nie chcąc tracić czasu, wykonałem podwajacz napięcia, z tego linku: http://www.gregorkarnas.com/radio/projekt/bikecharger/index.htm
    do niego podłączyłem ładowarkę samochodową i dopiero wtedy urządzenie ładowanie. Dioda w ładowarce się świeci, telefony nie ładują się, a GPS ciągle zaczyna ładowanie i przerywa (tak jakby zbyt małe napięcie było podawane, ten sam objaw kiedy ładowarkę samochodową zasiliłem napięciem 3V stabilizowane). Druga ładowarka ma na wyjściu 12V.

    Gdzie leży problem, chciałbym coś sam wykonać zanim będę zmuszony kupić ładowarkę KEMO za 150zł. Może coś z gniazdem USB, może trzeba zewrzeć piny albo coś takiego?
    Pozdrawiam

    Edit: W ładowarce na 12V zastosowałem L7812 zamiast LM7812.
  • Poziom 11  
    Tak strzelam, że np przy połączeniu MiniUSB masz oznaczenie 1 2 3 x 4. Może problem jest w tym. Czwarty styk to styk detekcji podłączenia..
    PS. Standardowe napięcie USB to 5V..

    PS. Znalazlem jeszcze ze napiecie ladowania powinno miec ok. 5.2V. Sproboj jeszcze tak polaczyc:
    Ładowarka rowerowa USB - podaje napięcie i nie ładuje
  • Poziom 30  
    Te 300mA płynie przy podłączonym GPSie? Czy zwarłeś ze sobą linie D+ i D- ?
  • Poziom 18  
    OK, zrobiłem dokładnie pomiary i tak:
    Napięcie jakie wychodzi z ładowarki to 4,4V... Nie wiem dlaczego tyle, próbowałem wyjąć diodę D6 i dalej to samo.
    Jeżeli chodzi o prąd to: bez obciążenia 540mA a przy obciążeniu spada do 180mA.
    Zwierałem linie DATA do uziemienia przy pomocy rezystorów, zwierałem je też ze sobą i nic to nie zmienia..

    Pozdrawiam
  • Poziom 30  
    maciek1221 napisał:
    Napięcie jakie wychodzi z ładowarki to 4,4V

    Nic nie piszesz jakie masz wtedy napięcie na C1, a musisz mieć tam przynajmniej 8V.
    Czy układ działa prawidłowo jeśli zamiast dynama zasilany jest bezpośrednio z zasilacza (o nap. min. 8V)?
    Jak robisz pomiar prądu bez obciążenia? Zwarcie amperomierzem?
  • Poziom 18  
    Na C1 mam 4,4V, oczywiście cały czas rozmawiamy o ładowarce z USB czyli tej z pierwszego linka.
    Podłączyłem układ do zasilacza i nawet na 12V nie działa prawidłowo, daje te same odczyty pomiarowe.
    Pomiar prądu robię tak, że amperomierz stawiam na plusie i minusie gniazda zasilania. To samo robię kiedy jest podpięty np.: GPS.
    Kiedy podpinam urządzenie do ładowarki, to dioda sygnalizująca pracę gaśnie, ewentualnie bardzo lekko się 'tli'.
  • Poziom 30  
    Coś mi się nie zgadza.
    Gdzie dokładnie wpinasz się z tymi 12V? Przed mostkiem, czy bezpośrednio na wejście LM317? Przy pomiarach nie mylisz czasem C1 z C4?
    Ładowarka rowerowa USB - podaje napięcie i nie ładuje

    Jeśli amperomierz łączysz szeregowo to robisz zwarcie.
  • Poziom 18  
    Rozwiązałem problem! :) Problemem było gniazdo USB, wystarczyło je wlutować odwrotnie, od strony druku. Nie wiem dlaczego tak jest, było to gniazdo z wylutu z płyty głównej laptopa. Wpadłem na to przeglądając zdjęcia z polaryzacją gniazd USB na googlach i nijak się to miało do mojego gniazda w ładowarce.
    Sprawdziłem i ładuje mi wszystkie urządzenia, teraz czas sprawdzić jak ma się sprawa z wydajnością ;). Dzięki za udział w dyskusji i pozdrawiam.
  • Poziom 30  
    Napisz jeszcze jakie masz dynamo. Butelkowe, czy w piaście?
  • Poziom 18  
    Butelkowe 6V. Wszystkie testy przeprowadzałem na pożyczonym rowerze z dynamem, ponieważ w swoim nie mam. Teraz będę zamawiał dopiero dla siebie dynamo, również butelkowe i również 6V.
  • Poziom 30  
    Butelkowe ma małą sprawność i stawia duże opory toczenia. Lepiej pomyśl nad takim w piaście.
  • Poziom 18  
    Dynamo w piaście jest ciężkie i ciągle pracuje. Do tego musiałbym kupować całe koło, bo kupić samą piastę, później zmieniać szprychy itd to gra nie warta świeczki.
    Butelkowe załączam kiedy mi potrzebne i gitara, a do tego takie dynamo na allegro z wysyłka to około 10zł ;)
    Pozdrawiam i zamykam ;)