Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Instalator systemu Windows Server 2012 nie wykrywa dysku

niesuch 11 Feb 2015 23:24 2790 11
  • #1
    niesuch
    Level 10  
    Witam,
    zakupiłem serwer fizyczny do mieszkania i po miesiącu zabrałem się za jego uruchomienie. Z uczelnianej platformy MSDNAA ściągnąłem Windows Server 2012, "wypaliłem" obraz na pendrive i zabrałem się za instalacje systemu. Po przejściu kilku kroków instalacji przyszedł ten w którym trzeba było wybrać partycję na której ma zostać zainstalowany świeży system. Instalator nie wykrywał
    żadnego dysku przez co nie było możliwe przejście do następnego kroku. Czytałem różnego rodzaju wątki na forach i wykonałem poniższe procedury w celu zlikwidowania błędu.

    1. Sprawdziłem poprzez zewnętrzne kable czy dysk działa - działa lecz wolno startuje
    2. Kupiłem drugi dysk
    3. Serwer posiada 8 kieszeni, dyski sprawdzałem na wszystkich ośmiu
    4. Próbowałem dograć sterowniki SATA lecz żaden nie był odpowiedni
    5. Formatowałem oba dyski ręcznie na drugim komputerze za pomocą zewnętrznych kabli



    Żadna z tych prób nie powiodła się zatem proszę o pomoc w rozwiązaniu problemu.

    Parametry serwera:
    Procesor: Intel Xeon UP 4x2,67GHz
    RAM: 4GB
    2x dysk Seagate 1TB i 160GB

    Onboard SATA Controller: Enable
    Configure SATA: IDE
  • #3
    Matuzalem
    Level 43  
    A moze jednak zacząć całkiem zwyczajnie? - Od ponownego "wypalenia" obrazu (przede wszystkim z niższą prędkością i o ile zgadza się sum a kontrolna tego co pobrałeś z tym co na serwerze leży).
    Oczywiście są i inne możliwe przyczyny, ale ta jest najbardziej trywialna i chyba mimo najłatwiejsza do weryfikacji.
  • #4
    niesuch
    Level 10  
    dt1, modelu płyty głównej nie mogę znaleźć ani na płycie ani w BIOSie. Przełączenie trybu pracy kontrolera nic nie daje, taki sam efekt - nie wykrywa żadnego dysku.

    Matuzalem, ponownie nagrałem obraz na pendrive i niestety to nie to.
  • #5
    Robert B
    Level 43  
    niesuch wrote:
    "wypaliłem" obraz na pendrive

    Matuzalem wrote:
    Od ponownego "wypalenia" obrazu (przede wszystkim z niższą prędkością)

    Hmmm... A da się tak?:)
  • #6
    Artur34
    Level 14  
    Zaczął bym od przywrócenia biosu do ustawień standardowych (reset), i sprawdzenia czy dyski są wykrywane przez bios.
    I spróbował załadować inny system np: uruchomił Linuksa z płyty.
    Albo na próbę spróbować zainstalować inny system.
  • #7
    Matuzalem
    Level 43  
    Nie, Robert B., nie da się. W zw. z tym koryguję
    Matuzalem wrote:
    ...przede wszystkim z niższą prędkością...
    korzystając z nagrywarki DVD i przeznaczonego dla tego celu nośnika - płyty DVD R (+/- to bez znaczenia).

    Czy teraz jesteś zadowolny, że udało Ci się zrobić tumana z... Autora wątku, który nie potrafi zrozumieć tego typu, jak moja poprzednia, wypowiedzi?

    Zawsze wydawało mi się, że poziom forum polega m.in. na tym, że wszelki instrukcje step by step, o ile w ogóle, to są udzielane w Piaskownicy, bo w działach serwisowych... "mądrej głowie dość dwie słowie", ale widać myliłem się.

    Wracając do sprawy - dość powszechne są wątki opisujące kłopoty z MSDN AA i najczęściej właśnie po stronie użytkowników leżą ich przyczyny.
    Czy zamiast "wypalać" obraz ponownie pokusiłeś się choćby o sprawdzenie sumy kontrolnej, by mieć pewność, że w transmisji żadnych przekłamań nie było? - Jeżeli ta suma się zgadza, to naprawdę sugeruję użycie "standardowego" nośnika i skorzystanie z opcji instalacji przy jego użyciu.
  • #8
    dt1
    Admin of Computers group
    niesuch wrote:
    dt1, modelu płyty głównej nie mogę znaleźć ani na płycie ani w BIOSie. Przełączenie trybu pracy kontrolera nic nie daje, taki sam efekt - nie wykrywa żadnego dysku.

    Skorzystaj z programu CPU-Z -> http://www.cpuid.com/downloads/cpu-z/cpu-z_1.71.1-en.exe
    lub zrób wyraźne zdjęcie płyty i je tu zamieść. Aby wiedzieć, dlaczego kontroler czy też dysk pracujący na nim nie działa trzeba się dowiedzieć, jaki kontroler na tej płycie się znajduje.
  • #9
    niesuch
    Level 10  
    Artur34, zresetowałem BIOS i dyski nadal nie są wykrywane ani przez instalator Debiana/Windowsa/Linuksa ani przez sam BIOS. Wszystkie systemy były uruchamiane z pendrive'a bo nie inwestowałem jeszcze w napęd DVD.

    Matuzalem, jak sprawdzić sumę kontrolną?

    dt1, nie mam możliwości zrobić tego przez program bo serwer nie ma na sobie żadnego systemu (nie odczytuje żadnego z dwóch dysków). Zatem wrzucam zdjęcia, mam nadzieję że wystarczą.
    ZDJĘCIA
  • #10
    Artur34
    Level 14  
    Dobra, ile masz dysków podpiętych do tego serwera? Czy tylko te dwa, co wymieniłeś w pierwszym poście?

    Druga sprawa, gdzie są te dyski podpięte ten kabel sata gdzie idzie?

    Jak dobrze widzę masz kilka złączy sata, możliwe, że akurat to jest uszkodzone albo jest na innym kontrolerze.
    Podłącz do gniazda SATA_0.

    W biosie dyski widzisz powinna to być pierwsza zakładka tam gdzie ustawia się czas systemowy, na dole powinny być widoczne dyski podłączone do komputera.

    Spróbuj wyciągnąć dysk z kieszeni i po prostu podłączyć dysk ja w zwykłym komputerze.
    Jeśli Linux tego nie widzi, to albo jest uszkodzona płyta, albo jedno z złączy.

    Możliwe też, że ta płyta (nie widzę modelu to tylko przypuszczenie) nie widzi dysków sata 2 i trzeba ograniczyć szybkość dysku do sata 1.
  • #11
    Robert B
    Level 43  
    Przecież ta płyta jest na jakichś starych kontrolerach.
    Przestaw dyski w tryb SATA I, to je zobaczy.


    Artur34 wrote:
    Możliwe też, że ta płyta (nie widzę modelu to tylko przypuszczenie) nie widzi dysków sata 2 i trzeba ograniczyć szybkość dysku do sata 1.

    Nawet na pewno :)
  • #12
    niesuch
    Level 10  
    Przepiąłem kabel do gniazda SATA_0 i działa. Dzięki wielkie za pomoc w rozwiązaniu problemu.

    Pozdrawiam.