Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Muzykant 3 - jak poprawić błędy w asemblacji

muzyk22 13 Lut 2015 15:14 702 5
  • #1 13 Lut 2015 15:14
    muzyk22
    Poziom 4  

    Witam, podczas asemplacji pliku ze strony http://as.elte-s.com/zrob/muzykant_3.htm napotkałem problem asembler tworzy plik o błędach ale nie wiem jak je poprawić. Oto błędy:
    ASM51 PAGE 1

    1 MZ— znaczek wskazuje na -
    ****--------------------------^
    ****ERROR #1: Illegal character
    2
    3 U‹ě¸ znaczek wskazuje na <
    ****-------------------------^
    ****ERROR #1: Illegal character
    4 |ÇFţ znaczek wskazuje na |
    ****------------------------^
    ****ERROR #1: Illegal character
    5 ş@RPč5ƒÄ¸# znaczek wskazuje na s
    ****------------------------^
    ****ERROR #1: Illegal character
    6 &ÇB znaczek wskazuje na &
    ****------------------------^
    ****ERROR #8: Illegal assembly line
    7 ˙6Đ znaczek wskazuje na '
    ****------------------------^
    ****ERROR #1: Illegal character

    VERSION 1.2k ASSEMBLY COMPLETE, 7 ERRORS FOUND

    ERROR SUMMARY:
    Line #1, ERROR #1: Illegal character
    Line #3, ERROR #1: Illegal character
    Line #4, ERROR #1: Illegal character
    Line #5, ERROR #1: Illegal character
    Line #6, ERROR #8: Illegal assembly line
    Line #7, ERROR #1: Illegal character
    Line #8, ERROR #6: Missing END directive
    ASM51 PAGE 2

    MZ . . . . . . . . . . . . . . . UNDEFINED NOT USED
    U. . . . . . . . . . . . . . . . UNDEFINED NOT USED




    Proszę o pomoc. W jaki sposób to rozwiązać?

    0 5
  • #2 13 Lut 2015 16:41
    BANANvanDYK
    Poziom 38  

    Korzystałeś z kompilatora zamieszonego na tamtej stronie?
    Widać że Twój kompilator ma problem ze zgodnością kodu.
    Po drugie nie pasuje zestaw znaków.

    0
  • #3 13 Lut 2015 16:48
    muzyk22
    Poziom 4  

    Tak, program jak i asembler pobrałem z tamtej strony. To w takim razie co mam robić?

    0
  • Pomocny post
    #4 13 Lut 2015 17:15
    vania
    Poziom 22  

    muzyk22 napisał:
    Tak, program jak i asembler pobrałem z tamtej strony. To w takim razie co mam robić?


    U mnie on nie działa. Ja kompiluję tym ASEM-51
    W załączniku masz skompilowany plik, wymagał on poprawki w linii z $nomod na $nomod51 oraz w linii 3069 z mov p0, #111111101b na mov p0, #11111101b

    To co Ty wysłałeś wygląda mi na próbę kompilacji kompilatora (pliku exe) ;) znaki MZ na początku.

    -1
  • #5 13 Lut 2015 17:23
    muzyk22
    Poziom 4  

    Ooo dziekuję bardzo serdecznie. Zaraz zabiorę się za programowanie.

    0
  • #6 22 Lut 2015 14:00
    muzyk22
    Poziom 4  

    Witam!
    Programując układ pasek postępu zatrzymał się przed końcem i tam został. Z tego względu że pojawił się napis 100% odłączyłem układ. Gdy go podłączyłem do przejściówki midi<=>usb zielona lampka tylko raz mrugnęła. Komputer nie odbiera sygnału. A gdy mam podłaczony tą przejściowką keyboard zielona dioda mruga. Co może być nie tak? Może kwarc?

    0