Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

WDC WD10EZRX-00L4HB0 - Nowiutki dysk, wolne kopiowanie, ukryte obciążenie CPU

andrzejlisek 23 Lut 2015 00:03 936 6
  • #1 23 Lut 2015 00:03
    andrzejlisek
    Poziom 28  

    Zakupiłem dysk podany w tytule, podłączyłem go pod SATA do płyty głównej.

    Zrobiłem szybkie formatowanie NTFS, przenoszę na niego ok. 120 GB danych.

    Problem w tym, że kopiowanie trwa niezmiernie długo, jak na tę ilość danych (moim zdaniem powinno trwać ok. 1 do dwóch godzin, a nie całą dobę). Na obudowie kontrolka od dysku nie świeci się światłem ciągłym, tylko błyska.

    Menedżer zadań podczas kopiowania wykazuje obciążenie 20-25%, ale według listy procesów obciążenie jest na poziomie 1%, jest jakaś niezgodność. W czasie kopiowania komputer pracuje ociężale, szczególnie, jak ma cos odczytać z któregoś dysku (np. uruchomienie notatnika lub painta, otwarcie "Zapisz jako" itp), ale się wstrzyma kopiowanie, to pracuje normalnie.

    Na czas kopiowania plików wyłączyłem antywirusa, a przy włączonym było tak samo.

    Wyrywkowo sprawdziłem kilka plików i nie stwierdziłem nieprawidłowości w dotychczas przeniesionych plikach.

    Co może być tego przyczyną?

    0 6
  • #2 23 Lut 2015 00:12
    sosarek

    Poziom 43  

    Sterowniki chipsetu zainstalowane w systemie?
    Dysk nie przestawił się przypadkiem w tryb pracy PIO?

    0
  • #3 23 Lut 2015 00:40
    andrzejlisek
    Poziom 28  

    Dysk źródłowy
    WDC WD10EZRX-00L4HB0 - Nowiutki dysk, wolne kopiowanie, ukryte obciążenie CPU

    Według HD Tune, obydwa dyski są w UDMA. Jest jeszcze trzeci dysk, również w UDMA wg HD Tune.

    WDC WD10EZRX-00L4HB0 - Nowiutki dysk, wolne kopiowanie, ukryte obciążenie CPU

    Natomiast w menedżerze urządzeń dwa razy jest kanał podstawowy IDE i dwa razy kanał pomocniczy IDE. We wszystkich czterech jest ustawione tryb "DMA jeżeli dostępne".
    Natomiast bieżący tryb transferu jest pokazany następujący na poszczególnych pozycjach
    Pierwszy podstawowy: Tryb PIO, Tryb PIO
    Drugi podstawowy: Nie dotyczy, Nie dotyczy
    Pierwszy pomocniczy: Nie dotyczy, Nie dotyczy
    Drugi pomocniczy: Ultra DMA tryb 5, Nie dotyczy

    Wygląda na to, że znaleźliśmy przyczynę. Tylko jak przestawić PIO na DMA?


    Sterowniki do chipsetu dawno zainstalowane, w każdym razie w menedżerze urządzeń nie ma żadnych wykrzykników. W kontrolerach ATA/ATAPI są jeszcze takie dwie pozycje:

    Intel(R) ICH10 Family 2 port Serial ATA Storage Controller 2 - 3A26
    Intel(R) ICH10 Family 4 port Serial ATA Storage Controller 1 - 3A20

    0
  • #4 23 Lut 2015 07:22
    andrzejlisek
    Poziom 28  

    Dzisiaj przenoszenie zostało przerwane i był komunikat, ze opóźniony zapis nie powiódł się na którymś pliku.

    Zauważyłem, że przy podłączonym tym dysku system Windows dłużej się uruchamia. Podłączyłem ten dysk za pomocą innego przewodu SATA do innego gniazda SATA i nadal jest problem. Czasem komputer się zawieszał zupełnie.

    W rzeczywistości kupiłem dwa dyski WDC WD10EZRX-00L4HB0. Podłączyłem ten drugi, uruchamiam komputer, żeby go sformatować, ale w tym przypadku Windows też się długo uruchamia, a w menedżerze zadań jest to samo ukryte obciążenie CPU, o którym wspominałem.

    Dodano po 16 [minuty]:

    Znalazłem taki artykuł: http://www.hotfix.pl/sprawdzenie-trybu-pracy-dysku-dma-pio-a348.htm

    Tak, jak tam jest napisane, odinstalowałem podstawowy i pomocniczy kanał IDE (przy czym, jak odinstalowałem podstawowy, to nie zniknął z menedżera urządzeń), zrestartowałem komputer i w menedżerze urządzeń wszędzie jest pokazany bieżący tryb transferu Ultra DMA lub Nie dotyczy. Wyłączyłem komputer, podłączyłem pierwszy dysk (ten, na który już przeniosłem część danych) i kontynuuję przenoszenie. Obciążenie CPU jest minimalne, słychać dużo intensywniejszą pracę dysków, dioda HDD świeci się światłem ciągłym.

    Wygląda na to, że problem jest rozwiązany.

    0
  • #5 23 Lut 2015 22:28
    Phantom69
    Poziom 16  

    W ogóle jaki to system?
    Do jakiego kontrolera podłączasz ten dysk? Zdajesz sobie sprawę że to SATA III i nie z każdym kontrolerem będzie prawidłowo działał?

    0
  • #6 24 Lut 2015 01:20
    DriverMSG
    Admin grupy komputery

    andrzejlisek napisał:
    Według HD Tune, obydwa dyski są w UDMA
    Jak doczytasz uważnie, to zauważysz, że jeden z nich pracuje w trybie 7, którego nie wspiera. Definitywnie jest coś nie takk z konfiguracją dysków i/lub kontrolerem dysku.

    0
  • #7 24 Lut 2015 06:38
    andrzejlisek
    Poziom 28  

    Phantom69 napisał:
    W ogóle jaki to system?
    Do jakiego kontrolera podłączasz ten dysk? Zdajesz sobie sprawę że to SATA III i nie z każdym kontrolerem będzie prawidłowo działał?


    System to jeszcze Windows XP SP3 32-bit (cała ta akcja jest po to, żeby zrobić nowe partycje, sformatować i zainstalować Windows 8 64-bit).
    Płyta główna: Intel dp45sg
    Kontroler SATA to Intel ICH10R

    Jeżeli płyta główna ma SATA II, a dysk to SATA III, to sprzęt moim zdaniem powinien umieć porozumieć się w standardzie SATA II. Nie spotkałem się z sytuacją, żeby konieczna była wymiana płyty głównej z powodu wymiany dysków SATA II na SATA III. Po odinstalowaniu kontrolera wydaje się działać poprawnie, przeniosłem ostatnie pliki i wszystko działało poprawnie.

    0