Elektroda.pl
Elektroda.pl
X
PLC Fatek
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PCB zvs flyback driver - nie działa.

kuba1912 23 Lut 2015 21:45 3747 29
  • #1 23 Lut 2015 21:45
    kuba1912
    Poziom 7  

    Temat klepany od dawna, ale chyba nie dałem sobie z nim rady :/

    Posiłkując się tym schematem.
    PCB zvs flyback driver - nie działa.

    Na płytce drukowanej, flamastrem olejnym narysowałem oto taki układ, a następnie wytrawiłem go.
    PCB zvs flyback driver - nie działa.

    Całość po zlutowaniu wygląda tak.
    PCB zvs flyback driver - nie działa.

    Zamiast IRFP250 użyłem IRF640. Zasilanie ok. 19V DC.
    Jednakże po podłączeniu cewek nawiniętych na rdzeniu trafopowielacza nic się nie dzieje.
    Sprawdziłem napięcie i prąd na cewkach. Na jednej wynosi coś ok 18 V i prąd 8 A, a na drugiej 7 V i prąd 300 mA. Grzeją się rezystory 470ohm.

    Nie wiem co zrobiłem źle, proszę o radę :(

    0 29
  • Semicon
  • #2 24 Lut 2015 07:18
    lodzik1990
    Poziom 18  

    Czy uzwojenie pierwotne zostało poprawnie nawinięte? Zamieść zdjęcie pierwotnego. Podaj symbol diod jakie zastosowałeś. Kondensator rezonansowy do sprawdzenia, gdyż widzę że pochodzi z demontażu.

    0
  • #3 24 Lut 2015 08:11
    bambus94
    Poziom 21  

    Daj dokładne zdjęcie obu stron płytki. Diody poprawnie wlutowane? Sprawdź czy tranzystory jeszcze żyją. Dren tego tranzystora po prawej to jest gdzieś podłączony? Na płytce nie mogę dojrzeć a na schemacie nie jest.

    0
  • #4 24 Lut 2015 08:49
    piwkooo
    Poziom 23  

    Witam.
    Te dwie diody opisane 'fast' to jakie dokładnie zastosowałeś?
    Pozdrawiam

    0
  • #5 24 Lut 2015 17:35
    bambus94
    Poziom 21  

    piwkooo napisał:
    Witam.
    Te dwie diody opisane 'fast' to jakie dokładnie zastosowałeś?
    Pozdrawiam

    To nie jest kluczowa sprawa, ja w swojej przetwornicy mam zwykłe 1N4007 i jakoś się spisuje.
    Układ jest dosyć prosty, jak nie działa to znaczy że coś jest uszkodzone lub źle podłączone.

    0
  • Semicon
  • #6 24 Lut 2015 20:08
    kuba1912
    Poziom 7  

    To uzwojenie.
    PCB zvs flyback driver - nie działa.

    Jedna strona płytki...
    PCB zvs flyback driver - nie działa.

    ... i druga.
    PCB zvs flyback driver - nie działa.

    "Fast" to 1N4007, a kondensator AFP684.
    Na schemacie ten po lewo rezystor jest ciepły i mogą zmierzyć na nim spadek napięcia natomiast na tym po prawo miernik nic nie wykazuje :/

    0
  • #7 24 Lut 2015 21:41
    piwkooo
    Poziom 23  

    bambus94 napisał:
    To nie jest kluczowa sprawa, ja w swojej przetwornicy mam zwykłe 1N4007 i jakoś się spisuje.

    Taa, tak samo jak rodzaj zastosowanego transformatora, jak też kierunek nawijania zwojów na rdzeniu, jak rodzaj użytego kondensatora na wyjściu, jak wydajność źródła zasilania tego układu ( bo dławik wydaje się być zgodny z zaleceniami), dlatego pytam!
    Kolego bambus94 tu wszystko ma znaczenie, dlatego pytamy o podstawy.
    To, że u ciebie zadziałało nie znaczy, że u wszystkich zadziała!
    Omawiamy układ w którym występują duże napięcia i prądy, które w połączeniu z partaniną potrafią zniechęcić niejednego do budowy podobnych układów.
    W tym przypadku mogło dojść nawet do uszkodzenia tranzystorów mosfet już na poziomie montażu (ładunek) choć nie przypuszczam.
    Ale spoglądając na fotki płytki, to w zasadzie już wiem dlaczego nie działa :D
    Pozdrawiam

    0
  • #8 24 Lut 2015 21:47
    jdubowski
    Specjalista - urządzenia lampowe

    piwkooo napisał:
    Ale spoglądając na fotki płytki, to w zasadzie już wiem dlaczego nie działa


    A ja spojrzałem na transformator i tam też skaszanione - kierunki nawijania obu połówek uzwojenia są przeciwne.

    0
  • #9 24 Lut 2015 22:34
    kuba1912
    Poziom 7  

    Mógłby mi ktoś wszytko po kolei wyjaśnić?
    Już nawijam dobrze :D

    0
  • Pomocny post
    #10 24 Lut 2015 22:49
    lodzik1990
    Poziom 18  

    Nawiń uzwojenie pierwotne w jednym kierunku bez dzielenia środka. Tak przypuszczałem, że masz uzwojenie niepoprawnie nawinięte. Jak już skończysz nawijać te 10 zwojów to na sam koniec odizoluj kawałek żyłki po środku uzwojenia i przylutuj tam kawałek linki miedzianej.

    0
  • #11 24 Lut 2015 22:56
    bambus94
    Poziom 21  

    Odlutuj przewody od mosfetów i sprawdź czy są sprawne (tranzystory, nie przewody) zakładam że masz multimetr, kolejne są diody, potem napięcia na bazach i na drenach.
    A i bardzo ważną sprawą jest kierunek nawijanie uzwojenia, robi się to tak:
    Nawijasz 5zw, robisz zakładę ok 10cm, i nawijasz kolejne 5zw w tym samym kierunku, żeby pierwsza i druga część uzwojenia tworzyły "sprężynkę" lub spiralę, jak zwał tak zwał.

    A co do diod przy bramkach to wiem że w niemal każdym takim projekcie są stosowane szybkie diody, ale z moich obserwacji wynika że to nie ma znaczenia.
    A układ jest tak prosty (dla obytych z elektroniką) że nawet dwa różne modele tranzystorów, niesymetryczne uzwojenie (np 4 i 6zw), czy też różne rezystory zasilające bramki nie są wstanie uniemożliwić pracy. Przerabiałem wszystkie te przypadki w różnych kombinacjach.

    A i jak się obawiasz że coś ci się spali (o ile już tego nie dokonało) to w szereg ze źródłem zasilania wstaw żarówkę 12V 55W.

    0
  • #12 25 Lut 2015 14:11
    DVDM14
    Poziom 35  

    Te ścieżki są stanowczo zbyt wąskie, pocynuj je, albo lepiej - przylutuj od spodu drut miedziany, bo je upalisz...

    bambus94 napisał:


    A co do diod przy bramkach to wiem że w niemal każdym takim projekcie są stosowane szybkie diody, ale z moich obserwacji wynika że to nie ma znaczenia.


    Mają mają, a to, że jakieś 1n4007 działają jest pomiędzy szczęściem a przypadkiem. :) Bramki muszą być szybko rozładowywane z częstotliwością dziesiątek kHz, tam, powinny być diody (ultra)fast, np. UF4007.

    Tak jak mówili poprzednicy - pierwotne do poprawy. Nie wiem, czemu tyle ludzi popełnia ten błąd przy jego nawijaniu. :) Tranzystory do sprawdzenia, pewnie i tak już jeden jest uszkodzony...

    Kondensator nie taki zły (OKAYA AFP), sam kiedyś takich używałem, ale może się grzać.

    Przy 19V Mazzilli się nudzi, jak już go uruchomisz daj mocniejsze tranzystory (IRFP250) i zasilanie >35VDC 15A, w tedy zobaczysz na co go stać. :)

    PS

    bambus94 napisał:
    Odlutuj przewody od mosfetów i sprawdź czy są sprawne (tranzystory, nie przewody) zakładam że masz multimetr, kolejne są diody, potem napięcia na bazach i na drenach.


    Bramkach, nie bazach. ;)

    0
  • #13 25 Lut 2015 21:12
    piwkooo
    Poziom 23  

    bambus94 napisał:
    i jakoś się spisuje.
    bambus94 napisał:
    Układ jest dosyć prosty
    bambus94 napisał:
    A co do diod przy bramkach to wiem że w niemal każdym takim projekcie są stosowane szybkie diody, ale z moich obserwacji wynika że to nie ma znaczenia.
    A układ jest tak prosty (dla obytych z elektroniką) że nawet dwa różne modele tranzystorów, niesymetryczne uzwojenie (np 4 i 6zw), czy też różne rezystory zasilające bramki nie są wstanie uniemożliwić pracy. Przerabiałem wszystkie te przypadki w różnych kombinacjach.

    Kolego, z twoich i moich obserwacji ( i twoich tematów na temat tej przetwornicy) wynika jedno, robisz wszystko na odpie....rdol ! ((przepraszam moderatorze).
    Zmontuj ten układ zgodnie z 'zaleceniami' i zobaczysz różnicę :D
    Może po części masz rację, że pytającemu nie chodzi o wydajność, a o samo działanie, ale nie mam złudzeń montaż na poziomie amatora, a układ wbrew pozorom wymagający!
    Pozdrawiam.

    0
  • #14 26 Lut 2015 14:15
    kuba1912
    Poziom 7  

    UF4004 nie dadzą rady?

    0
  • #16 26 Lut 2015 20:21
    kuba1912
    Poziom 7  

    Kurde, uzwojenie nawinięte poprawnie, diody zamienione na uf4004, tranzystory na pewno sprawne, ale nadal nie działa!
    Napięcia na tranzystorach mają różne wartości.
    Czy napięcia na wyjściu, na cewki powinny mieć odmienne wartości?

    0
  • Pomocny post
    #17 26 Lut 2015 20:31
    DVDM14
    Poziom 35  

    Pocynuj solidnie wszystkie ścieżki, bo są tragiczne... Chcesz puszczać prądy przekraczające 10A przez cieniutkie, podziurawione wstążki miedzi, to nie ma prawa się spisać. Tak wyglądać powinna płytka:

    PCB zvs flyback driver - nie działa.

    Pierwotne na pewno nawinięte w tą samą stronę?

    Mierzenia napięcia na pierwotnym jest bezcelowe - sprawna przetwornica naprzemiennie przepuszcza impulsy prądu przez połówki pierwotnego, jednocześnie przepuszczając przez całe uzwojenie sinusoidę obwodu rezonansowego. Multimetr Ci tego nie pokaże.

    Jak mierzyłeś tranzystory? Pracowały na zwarciu, wielce wątpię w ich sprawność...

    0
  • #18 26 Lut 2015 20:36
    kuba1912
    Poziom 7  

    Sprawdzałem tranzystory multimetrem jako diodę.

    0
  • #19 26 Lut 2015 20:55
    piwkooo
    Poziom 23  

    kuba1912 napisał:
    Na schemacie ten po lewo rezystor jest ciepły i mogą zmierzyć na nim spadek napięcia natomiast na tym po prawo miernik nic nie wykazuje :/

    A zamień teraz te tranzystory miejscami i sprawdź czy na tym drugim oporniku możesz zmierzyć napięcie.
    Jeśli tylko jeden padł to upewnisz się, który z tych tranzystorów jest przebity.

    0
  • #20 26 Lut 2015 20:59
    kuba1912
    Poziom 7  

    Dobra działa. Dzięki wszystkim za pomoc :)

    0
  • #21 26 Lut 2015 21:02
    piwkooo
    Poziom 23  

    kuba1912 napisał:
    Dobra działa.

    Co było? Bo nie zasnę :D

    0
  • #22 26 Lut 2015 21:02
    DVDM14
    Poziom 35  

    I jakie wyniki? Co mierzyłeś i co otrzymałeś? Najprostszy pomiar wygląda tak:

    -Sprawdzasz bramkę do pozostałych. Nie powinno być żadnego przepływu.
    -Zwierasz bramkę i źródło. Przykładasz czarny kabel do S, czerwony do D, nie powinno być przepływu.
    -Ładujesz bramkę do kilku V, np. baterią "płaską" 4,5V, plus dajesz na bramkę, minus do źródła. Miernik podłączasz jak wcześniej, powinien wykazać przepływ.

    EDIT:\\\

    piwkooo napisał:
    kuba1912 napisał:
    Dobra działa.

    Co było? Bo nie zasnę :D


    Dołączam się do pytania. :D

    Przypominam o wzmocnieniu ścieżek, bo będzie dym...

    0
  • #23 26 Lut 2015 21:06
    piwkooo
    Poziom 23  

    DVDM14 napisał:
    -Sprawdzasz bramkę do pozostałych. Nie powinno być żadnego przepływu.
    -Zwierasz bramkę i źródło. Przykładasz czarny kabel do S, czerwony do D, nie powinno być przepływu.
    -Ładujesz bramkę do kilku V, np. baterią "płaską" 4,5V, plus dajesz na bramkę, minus do źródła. Miernik podłączasz jak wcześniej, powinien wykazać przepływ.

    No w tym sedno.
    Większość myśli, że mosfet'a sprawdzimy jak bipolarnego 'na przejście' :D
    Pozdrawiam.

    0
  • #24 26 Lut 2015 21:21
    jarek_lnx
    Poziom 43  

    Cytat:
    Sprawdziłem napięcie i prąd na cewkach. Na jednej wynosi coś ok 18 V i prąd 8 A, a na drugiej 7 V i prąd 300 mA. Grzeją się rezystory 470ohm.
    Napiecia na cewkach? przecież to kikadziesiat cm grubego drutu przy takiej mocy ten drut by zadymił (albo tranzystor jeśli to napiecie na tranzystorze)

    Na cewkach z kilku zwojów nie ma prawa być znaczącego spadku napiecia, ale niezależnie gdzie to zmierzyłaś, jeśli jest taka asymetria układ nie ma prawa sie wzbudzić i trzeba sprawdzic co jest przyczyna pomierz napiecia na drenach i bramkach.

    Rezystory sie grzeją - tak musi być, to koszt pewnego uproszczenia układu.

    P.S. Z tymi szybkimi diodami, ja stosowałem szybkie małej mocy - bez zastanowienia, tak jak wy teraz piszecie że muszą być szybkie, po dokładniejszym przeanalizowaniu wygląda na to że jest to jedyny układ w którym kiepskie Qrr diody pozytywnie wpływa parametry układu, a konkretnie na szybkość włączania tranzystorów, dyletanci mogą z tego wyciągnąć błędne wnioski że stosowanie szybkich diod (w ogóle) nie ma sensu.

    0
  • #25 26 Lut 2015 21:37
    piwkooo
    Poziom 23  

    jarek_lnx napisał:
    Z tymi szybkimi diodami, ja stosowałem szybkie małej mocy - bez zastanowienia, tak jak wy teraz piszecie że muszą być szybkie, po dokładniejszym przeanalizowaniu wygląda na to że jest to jedyny układ w którym kiepskie Qrr diody pozytywnie wpływa parametry układu, a konkretnie na szybkość włączania tranzystorów, dyletanci mogą z tego wyciągnąć błędne wnioski że stosowanie szybkich diod (w ogóle) nie ma sensu.

    Sorry, mógłbyś jaśniej? Bo w tym wpisie sam sobie zaprzeczasz! :D

    0
  • #26 26 Lut 2015 22:23
    kuba1912
    Poziom 7  

    Miałem wyprowadzony kabel z minusa na trafopowielaczu i na nim sprawdzałem czy nastąpi przebicie powietrza, ale nie zgadniecie co się stało...
    ... przylutowałem nie na tym wyjściu -,-
    Tyle nerwów przez moją ogromną głupotę!
    W każdym razie dziękuję za wszystko :D

    0
  • #27 26 Lut 2015 23:44
    jarek_lnx
    Poziom 43  

    Cytat:
    Sorry, mógłbyś jaśniej? Bo w tym wpisie sam sobie zaprzeczasz! Very Happy
    Skoro widzisz w moim tekscie sprzeczność to rzeczywiście trzeba ci prosto tłumaczyć. Jeśli będziesz się upierał i pokażesz mi gdzie wydaje ci sie że widzisz sprzeczność to ci mogę wytłumaczyć dlaczego jej tam nie ma :)

    Ładunek Qrr w tym układzie płynie do bramki czyli przyśpiesza ładowanie pojemności bramki MOSFET'a, w ten sposób powolna dioda przyśpiesza działanie układu, jak bedę miał chwilę to przetestuję jaka jest różnica w praktyce.

    0
  • #28 27 Lut 2015 10:01
    DVDM14
    Poziom 35  

    Niby tak, ale przecież dioda musi szybko zareagować na odwrócenie się polaryzacji, a pamiętajmy, że układ Mazzilliego to nie tylko zasilanie trafopowielaczy - ja np. z powodzeniem używałem go jako mini nagrzewnicy indukcyjnej, gdzie częstotliwość "jałowa" sięgała 130kHz - tu już raczej dioda musi się pośpieszyć...

    PCB zvs flyback driver - nie działa.

    Zwłaszcza, że używam zmodyfikowanego układu:

    http://teslacoil.pl/generatory-wysokiego-napiecia/zvs-flyback-reverse-by-mania-c-t313.html


    PCB zvs flyback driver - nie działa.



    Edytuj

    Tu chyba czas reakcji diody jest jeszcze ważniejszy.

    0
  • #29 01 Mar 2015 21:05
    piwkooo
    Poziom 23  

    jarek_lnx napisał:
    Skoro widzisz w moim tekscie sprzeczność to rzeczywiście trzeba ci prosto tłumaczyć. Jeśli będziesz się upierał i pokażesz mi gdzie wydaje ci sie że widzisz sprzeczność to ci mogę wytłumaczyć dlaczego jej tam nie ma :)


    Poproszę.

    jarek_lnx napisał:
    P.S. Z tymi szybkimi diodami, ja stosowałem szybkie małej mocy - bez zastanowienia, tak jak wy teraz piszecie że muszą być szybkie, po dokładniejszym przeanalizowaniu wygląda na to że jest to jedyny układ w którym kiepskie Qrr diody pozytywnie wpływa parametry układu, a konkretnie na szybkość włączania tranzystorów, dyletanci mogą z tego wyciągnąć błędne wnioski że stosowanie szybkich diod (w ogóle) nie ma sensu.

    Zaznaczyłem!
    DVDM14 napisał:
    Niby tak, ale przecież dioda musi szybko zareagować na odwrócenie się polaryzacji, a pamiętajmy, że układ Mazzilliego to nie tylko zasilanie trafopowielaczy - ja np. z powodzeniem używałem go jako mini nagrzewnicy indukcyjnej, gdzie częstotliwość "jałowa" sięgała 130kHz - tu już raczej dioda musi się pośpieszyć...

    To jest dla mnie jasne!
    Pozdrawiam.

    0
  • #30 14 Mar 2015 11:31
    jarek_lnx
    Poziom 43  

    piwkooo napisał:

    jarek_lnx napisał:
    P.S. Z tymi szybkimi diodami, ja stosowałem szybkie małej mocy - bez zastanowienia, tak jak wy teraz piszecie że muszą być szybkie, po dokładniejszym przeanalizowaniu wygląda na to że jest to jedyny układ w którym kiepskie Qrr diody pozytywnie wpływa parametry układu
    Wadą układu Mazziliego widoczną przy dużych częstotliwościach, jest ograniczona szybkość ładowania bramek tranzystorów przez rezystory, dioda która będzie się powoli wyłączać, w pewnym stopniu zniweluje tą wadę i przyśpieszy załączanie tranzystora, oczywiście nie można przesadzić i trzeba to sprawdzić na oscyloskopie, czy dioda nie wyłącza sie zbyt długo, co stwarza ryzyko uszkodzenia diod Zenera, dioda "wolna" ma też dłuższy czas włączania ale ten można poprawić łącząc ją równolegle z diodą szybką mniejszej mocy (co da długi czas wyłączania ale któtki czas włączenia takiego zestawu ).

    Tu przykład jak "wolna" dioda przyśpiesza włączenie i to znacznie ponad 10x ! test był zrobiony w układzie rezystor-dioda-tranzystor symulującym przełaczanie MOSFET'a w ZVS. (jak będę miał trochę czasu do zmarnowania to sprawdzę o ile poprawia pracę nagrzewnicy indykcyjnej opartej na tym układzie - budowałem taką, ale czas przełączania poprawiłem tranzystorami).
    PCB zvs flyback driver - nie działa.

    piwkooo napisał:

    jarek_lnx napisał:

    dyletanci mogą z tego wyciągnąć błędne wnioski że stosowanie szybkich diod (w ogóle) nie ma sensu.

    Zaznaczyłem!

    Powyżej pisałem o wyjątku od reguły (to nie to samo co sprzeczność), tu zwracam uwagę, że amatorzy pochopnie mogą uznać to za ogólną zasadę, co oczywiście będzie błędem, jak poniżej:
    Cytat:
    A co do diod przy bramkach to wiem że w niemal każdym takim projekcie są stosowane szybkie diody, ale z moich obserwacji wynika że to nie ma znaczenia.

    0