Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
OptexOptex
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Mikrotik - Mam zestawiony VPN a nie działa mi usługa Wake On Lan

26 Feb 2015 11:15 5565 11
  • Level 17  
    Witam
    mam na sztywno zestawiony tunel VPN L2TP pomiędzy dwoma Mikrotikami 951. Jeden mikrotik jest serwerem (stałe publiczne IP) drugi ma ustawiony VPN Client L2TP (zmienny adres) i na stałe się zapina.

    Będąc w domu mogę się dostać do routera w firmie poprzez lokalny adres więc VPN mi działa. Natomiast nie mogę zdalnie włączyć serwera stojącego w firmie przy wykorzystaniu usługi WakeOnLan (aplikacja WakeMeOnLan 1.68).

    Będąc w firmie aplikacja WOL działa poprawnie i uruchamia serwer a będąc połączonym po VPN usługa nie działa.

    Poniżej ustawienia:
    Firewall Mikrotika w Biurze
    Mikrotik - Mam zestawiony VPN a nie działa mi usługa Wake On Lan

    Ruting Mikrotik w Biurze
    Mikrotik - Mam zestawiony VPN a nie działa mi usługa Wake On Lan


    Firewall Mikrotik Dom
    Mikrotik - Mam zestawiony VPN a nie działa mi usługa Wake On Lan

    Ruting Mikrotik Dom
    Mikrotik - Mam zestawiony VPN a nie działa mi usługa Wake On Lan
  • OptexOptex
  • Level 38  
    Bo WOL dziala w warstwie 2. Router jej nie przekaze do innej podsieci.
    Po obu koncach tunelu musisz miec chyba ta sama podsiec, zeby WOL przelazl.

    Mozesz sie zalogowac do routera po SSH i z palca puscic WOL.
    Na mikrotiku pewnie mozesz tez napisac skrypt ktory pusci WOL gdy nawiaze sie okreslone polaczenie VPN.
  • OptexOptex
  • Level 17  
    W nie można by tego załatwić np jakimś zwykłym wpisem w rutingu przy przekierowaniem portów?
  • Level 38  
    gkmaster wrote:
    W nie można by tego załatwić np jakimś zwykłym wpisem w rutingu przy przekierowaniem portów?

    WOL dziala poziom ponizej adresow IP, portow itd. Tam gdzie dziala WOL nie ma jeszcze portow.
    Dziala na ramkach ethernotowych. PRzelazi przez swtich, britdge, ale nie przez routing. Powinien przelezc przz tunel VPN jesli to jest tunel w warstwie drugiej, ale jak pisalem, po obu stronach konca musza byc adresacje z tej samej podsieci, zeby tego router nie zatrzymal.

    Jak nie masz tej samej adresacji to trzeba kombinowac.
    Tu jest jakis przyklad chyba, jak pusicic WOL gdy zostanie wykryty konkretny ruch.
    KOmbinuj w taki sposob

    http://wiki.mikrotik.com/wiki/Wake_on_Lan_before_connection_to_Remote_Desktop
  • Level 11  
    Użyj Mikrotikowego tunelu EoIP i połącz odpowiednie interfejsy po obu stronach w bridge. Tunel będzie dla innych urządzeń widoczny jak zwykłe połączenie warstwy 2.
  • Level 31  
    Potwierdzam tunel EoIP dziala doskonale. Multiroom tez spokojnie przelatuje ;)
  • Level 17  
    kurcze - u mnie to nie ruszyło - być może coś nie tak ustawiam. Ma ktoś jakąś instrukcję/z rzuty z ekranu jak należy popranie skonfigurować ten tunel?
  • Level 1  
    Temat może i stary, ale komuś się przyda zapewne.

    gkmaster napisał:
    Quote:
    W nie można by tego załatwić np jakimś zwykłym wpisem w rutingu przy przekierowaniem portów?
    Można. Wystarczy przekierować port 7 UDP
    Quote:

    WOL dziala poziom ponizej adresow IP, portow itd. Tam gdzie dziala WOL nie ma jeszcze portow. (...)
    Bzdura.

    WOL działa na porcie 7, który nasłuchuje tzw. magic pakietów.

    A ja mam tak i działa:

    1) Musisz mieć przydzielony statycznie IP maszyny, którą chcesz wzbudzać (albo ustawiony tzw. statyczne DHCP - zawsze ten sam adres przydziela).
    2) w IP/ARP dodaj statyczny wpis tego IP i jego MAC
    3) Na konieć reguła do NAT:

    Code:
    /ip firewall nat add action=dst-nat chain=dstnat dst-address=<adres publiczny/zewnętrzny> dst-port=7777 \
    
        protocol=udp to-addresses=<adres lokalnej maszyny> to-ports=7


    I teraz możesz użyć jakiejś apki i z zewnąrz sieci używając publicznego IP wzbudzać kompa za routerem. Możesz też zmienić port zewnętrzny na jakikolwiek inny, według uznania.
  • Level 17  
    a jeśli mam zestawionego VPN-a to jaki powinienem wpis zrobić? bo tak naprawdę mam połączenie do routera do którego jest podłączony komputer ze stałym IP ale funkcja WOL nie działa.
  • Level 20  
    @voytazon
    Potwierdzam działa.
    W moim wypadku sprawa wyglądała tak: Telefonem Lumia 535 WP 8.1 chciałem wybudzać serwer. W wp 8.1 można łączyć się z siecią VPN IkeV2 oraz L2tp IPSec. Postawiłem serwer na MT l2tp z ipsec.
    Problem był z aplikacjami WOL na WP. Jest ich kilka, ale z tego co zauważyłem tylko jedna działa w "WAN" VoiceWake Lite, reszta przy połączeniu VPN nie wysyła Magicpakiet(przy LAN nie ma z nimi problemu)
    Warto sprawdzić na MT czy pakiety docierają, jeśli nie trzeba spróbować inną aplikacją.
  • Level 17  
    Zrezygnowałem z tej funkcji bo MT doprowadzał mnie do szału. Wyrzuciłem ten router z sieci bo notorycznie miałem z nim problemy (być może mała moja wiedza na temat tego routera) ale ciągle miałem głoszenia od użytkowników, że jakaś strona www nie działa. Np. strona ING Bank-u - MT bardzo często ją blokował nie wiedzieć czemu, podobnie było ze stronami np. Satel-a, Rogera czy Techdaty. Przesiadłem się na Draytek-a i życie stało się prostsze :).
  • Level 20  
    Witam,

    Problem podobny więc nie będę zakładać nowego wątku.
    Sieć lokalna dostaje IP z klasy 192.168.88.0, NAS ma na sztywno przypisane IP 192.168.88.3 wpis w tablicy ARP jest dodany.
    Tunel VPN po PPTP dostaje IP z puli 192.168.89.0. dodane do maskarady
    Do budzenia NAS używam programu Wake on LAN Aquila Tech z taką konfiguracją HOST:
    Broadcast: 192.168.88.255
    IP: 192.168.88.3
    Port: 9
    TTL: 128

    Nie rozumiem dla czego przy budzeniu z sieci lokalnej muszę odwołać się po adresie lokalnym natomiast przy budzeniu przez połączenie VPN po adresie Broadcast.
    Byłbym wdzięczny za wytłumaczenie.