Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel 2010 - po wykonaiu funcji "jeżeli"&"jeżeli" zapisu

19 Mar 2015 16:57 798 5
  • Poziom 11  
    Hej,

    postaram się wyjaśnić ten dość zawiły temat.
    Potrzebuję aby excel w zależności od wartości liczbowej jaka jest wpisana w komórce sumował odpowiednie zakresy komórek a wynik podawał oczywiście w wybranej komórce.

    Co zrobiłem:
    Załóżmy że jeżeli w komórce B1 wpiszemy wartość 14 to w komórce B3 ma być wynik sumujący komórki z zakresu C15:C28 - czyli jest to suma 14 komórek.
    Ale jeśli w komórce B1 wpiszemy wartość 13 to w komórce B3 ma być wynik sumujący komórki z zakresu C15:C27 - czyli jest tu suma 13 komórek itd.

    Wpisałem następującą formułę:
    JEŻELI(B1=14;SUMA(C15:C28);"")&JEŻELI(B1=13;SUMA(C15:C27);"")&JEŻELI(B1=12;SUMA(C15:C26);"")&JEŻELI(B1=11;SUMA(C15:C25);"")&JEŻELI(B1=10;SUMA(C15:C24);"")&JEŻELI(B1=9;SUMA(C15:C23);"")&JEŻELI(B1=8;SUMA(C15:C22);"")&JEŻELI(B1=7;SUMA(C15:C21);"")&JEŻELI(B1=6;SUMA(C15:C20);"")&JEŻELI(B1=5;SUMA(C15:C19);"")&JEŻELI(B1=4;SUMA(C15:C18);"")&JEŻELI(B1=3;SUMA(C15:C17);"")&JEŻELI(B1=2;SUMA(C15:C16);"")&JEŻELI(B1=1;SUMA(C15:C15);"")

    Wszystko ładnie działa ale wynik sumy podawany w komórce jest podawany jako tekst i nie nadaje się do daoszej obróbki. Jak to zrobić aby ten teks stał się liczbami. Może używam złej funkcji?


    pozdrawiam
  • Pomocny post
    Specjalista - VBA, Excel
    Witaj
    =SUMA(PRZESUNIĘCIE($C$15;0;0;B1))
  • Poziom 34  
    Jedyne co mi w tej formule brakuje to znaku = przed pierwszym JEŻELI....
  • Poziom 22  
    Możesz też tak:
    =SUMA(C15:ADR.POŚR(ZŁĄCZ.TEKSTY("C";B1+14)))

    Przesunięcie i rozszerzanie okna a'la @JRV jest jednak ładniejsze ;)
  • Poziom 11  
    Dziękuję JRV. nie znałem tej funkcji.
    Do czego ona jeszcze może służyć ?
  • Specjalista - VBA, Excel
    W zasadzie do wszystkiego. Jeśli wiesz, jak to działa.(F1)
    Wygodny do dynamicznego zakresu.