Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

22 Mar 2015 16:30 1608 22
  • Poziom 12  
    Witam,
    Jako amator, hobbysta elektroniki robię co jakiś czas proste projekty w zaciszu domowym. Jakiś czas temu zrobiłem banalnie prosty zasilacz regulowany na LM317T

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Schemat (gdzieś zapodziałem faktyczny schemat ale ten jest praktycznie taki sam)
    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie


    Bez obciążenia (z malutkim obciążeniem jakie generuje oscyloskop) zasilacz wacha się około 20mV w obie strony, problem pojawia się pod obciążeniem.

    W pierwszym momencie pod obciążeniem ~~10V 0.6A (matryca led)
    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Po kilku sekundach zaczyna się rozjazd:
    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Aż kończy się tak jak na ostatnim obrazku, wskazania woltomierza na froncie obudowy skaczą cały czas po różnych wartościach.

    Sam układ LM317T mam przyczepiony do dość dużego radiatora, między układem a radiatorem jest pasta termoprzewodząca, pod tak relatywnie małym obciążeniem układ nawet nie grzeje się jakoś tragicznie, można trzymać go palcem.

    Z czego może wynikać takie zachowanie?
  • PCBway
  • Moderator - Na Wesoło HydePark
    Wzbudza się. Skoro faktycznie są kondensatory ceramiczne na wejściu i wyjściu układu ( powinny być jak najbliżej LM317), to powodem mogą być te strasznie długie przewody do potencjometru. Kondensator na wyjściu stanowczo za mały.
  • Poziom 12  
    arturavs napisał:
    Wzbudza się. Skoro faktycznie są kondensatory ceramiczne na wejściu i wyjściu układu ( powinny być jak najbliżej LM317), to powodem mogą być te strasznie długie przewody do potencjometru. Kondensator na wyjściu stanowczo za mały.



    Spróbuję przelutować je pod układem bezpośrednio obok nóżek LM317T, czy mogę zrobić na wyrost np. kondensator 10000uF na wyjściu czy przesadzać też nie jest dobrze?
  • PCBway
  • Poziom 28  
    touchthis napisał:
    czy mogę zrobić na wyrost np. kondensator 10000uF na wyjściu czy przesadzać też nie jest dobrze?


    Aż tak przesadzać nie ma potrzeby. Przyjmuje się, że daje się 1000µF/1A. Więc tu wystarczy kondensator 2200µF. W pierwszej kolejności skróć przewody od potencjometru, bo teraz są strasznie długie.

    Ps. Jaki to model oscyloskopu?

    Pozdrawiam.
  • Poziom 12  
    kaka0204 napisał:
    touchthis napisał:
    czy mogę zrobić na wyrost np. kondensator 10000uF na wyjściu czy przesadzać też nie jest dobrze?


    Aż tak przesadzać nie ma potrzeby. Przyjmuje się, że daje się 1000µF/1A. Więc tu wystarczy kondensator 2200µF. W pierwszej kolejności skróć przewody od potencjometru, bo teraz są strasznie długie.

    Ps. Jaki to model oscyloskopu?

    Pozdrawiam.


    Zaraz się zabieram za to, oscyloskop to Rigol DS1104Z
  • Moderator - Na Wesoło HydePark
    Kondensatory ceramiczne 47 - 100nF. 470 uF na wyjściu spokojnie wystarczy.
  • Poziom 32  
    Na wyjściu nie ma potrzeby dawać kondensatorów większych jak 100µF jest to nawet szkodliwe bo wydłuża czas odpowiedzi układu na gwałtowną zmianę na wyjściu, za to na wejściu wskazany jest jak największy.
  • Poziom 12  
    arturavs napisał:
    Kondensatory ceramiczne 47 - 100nF. 470 uF na wyjściu spokojnie wystarczy.


    Wlutowałem kondensator praktycznie obok nóżek układu, na wejściu dałem 2000uF bo akurat nie miałem nic innego na 35V, skróciłem przewody potencjometru praktycznie do absolutnego minimum żeby można było otworzyć puszkę, zaizolowałem wszystkie wystające styki. Włączyłem zasilacz i podłączyłem obciążenie, najpierw 0.6A, później 1.25A i wcześniejszy efekt nie wystąpił już, 15 minut trzymałem zasilacz pod obciążeniem 1.25A 9V.

    Przebieg pod obciążeniem 1.25A 9V:
    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Wygląda, że wszystkie zabiegi pomogły :-)
  • Poziom 43  
    Jeśli częstotliwość jest 50Hz albo 100Hz to nie jest wzbudzenie, ale poprostu przydźwięk przechodzi z wyjścia na wejście, ale tężstabilizator dodaje "coś od siebie" podłącz jednen kanał oscyloskopu na wejście drugi na wyjście i wtedy obserwuj.

    Cytat:
    Wygląda, że wszystkie zabiegi pomogły Smile
    Tego nadal nie można nazwać działajacym stabilizatorem.


    Cytat:
    Przyjmuje się, że daje się 1000µF/1A.
    Tylko nie próbuj stosować tej "reguły" dla niższych napięć transformatora.
    W tym przypadku 2200µF wystarczy przy 1,5A da ok 5Vpp tętnień. Na zdjęciu jest 1000µF więc tętnienia będą większe co ograniczy trochę zakres napięć, 10000µF nie ma sensu dawać, bo to zwiększa tylko obciążęnie diod i straty w uzwojeniu
  • Poziom 12  
    jarek_lnx napisał:
    Jeśli częstotliwość jest 50Hz albo 100Hz to nie jest wzbudzenie, ale poprostu przydźwięk przechodzi z wyjścia na wejście, ale tężstabilizator dodaje "coś od siebie" podłącz jednen kanał oscyloskopu na wejście drugi na wyjście i wtedy obserwuj.

    Cytat:
    Wygląda, że wszystkie zabiegi pomogły Smile
    Tego nadal nie można nazwać działajacym stabilizatorem.


    Cytat:
    Przyjmuje się, że daje się 1000µF/1A.
    Tylko nie próbuj stosować tej "reguły" dla niższych napięć transformatora.
    W tym przypadku 2200µF wystarczy przy 1,5A da ok 5Vpp tętnień. Na zdjęciu jest 1000µF więc tętnienia będą większe co ograniczy trochę zakres napięć, 10000µF nie ma sensu dawać, bo to zwiększa tylko obciążęnie diod i straty w uzwojeniu



    Co jeszcze mógłbym zrobić żeby można było nazwać to działającym stabilizatorem?
  • Poziom 30  
    touchthis napisał:
    Co jeszcze mógłbym zrobić żeby można było nazwać to działającym stabilizatorem?


    Dołącz (np. od strony druku) do swojego zasilacza jeszcze elementy, które są oznaczone czerwoną kropką na poniższym schemacie.

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie
  • Poziom 43  
    Cytat:
    Co jeszcze mógłbym zrobić żeby można było nazwać to działającym stabilizatorem?

    Ja bym zalecał sprawdzić napiecie pomiędzy wyjściem a nóżką ref przy różnych nastawach napiecia wyjściowego, powinno być 1,25V, chciał bym wykluczyć sytuacje że układ jest wadliwy, a jak z płytką? pokaż projekt, należało by sie upewnić że nie masz błedów w montażu.
    Oglądałeś oscylogramy przed i za stabilizatorem?
  • Poziom 12  
    Ścieżka mi się oderwała podczas manewrowania i postanowiłem porzucić tą płytkę pcb i zrobić tak jak powinno być na nowo, według proponowanych schematów z noty katalogowej skleiłem coś takiego:

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie


    Cytat:

    C1 1000uF 35V
    C2 1000uF 35V
    C3 0.1uF
    C4 10uF
    D1 1N4004
    D2 1N4004
    PIN AK300/2 AK300/2
    R2 360OHM
    R3 10K POT
    U1 V_REG_317SINK
    X1 AK300/2 AK300/2


    Czy zawarłem absolutne minimum dla niskiej klasy zasilacza regulowanego na LM317T? :D
  • Poziom 28  
    Ścieżki powinny być zdecydowanie szersze.
  • Poziom 43  
    Scieżki daj szersze, pamiętaj że rezystancja ścieżek nie jest zerowa (0,5mΩ/kwadrat dla 35µm) więc ma znaczenie z którego punktu ciągniesz ścieżkę, ta masa nie powinna iść do wyjścia na około z punktu w ktorym są największe tętnienia, powinna iść od punktu względem którego stabilizator stabilizuje - tam gdzie do masy jest podłaczony potencjometr, wersji z wylaną powierzchnią masy to też dotyczy. Duże tętnienia (200mVpp) mogą być spowodowane złym prowadzeniem masy.

    Radiator z pierwszego zdjęcia to jakis ogryzek z ATX'a? Za mały jak na tą moc zasilacza i jeszcze zamknięty w ciasnej obudowie bez otworów wentylacyjnych.
  • Poziom 12  
    jarek_lnx napisał:
    Scieżki daj szersze, pamiętaj że rezystancja ścieżek nie jest zerowa (0,5mΩ/kwadrat dla 35µm) więc ma znaczenie z którego punktu ciągniesz ścieżkę, ta masa nie powinna iść do wyjścia na około z punktu w ktorym są największe tętnienia, powinna iść od punktu względem którego stabilizator stabilizuje - tam gdzie do masy jest podłaczony potencjometr, wersji z wylaną powierzchnią masy to też dotyczy. Duże tętnienia (200mVpp) mogą być spowodowane złym prowadzeniem masy.

    Radiator z pierwszego zdjęcia to jakis ogryzek z ATX'a? Za mały jak na tą moc zasilacza i jeszcze zamknięty w ciasnej obudowie bez otworów wentylacyjnych.


    Dokładnie tak, ogryzek z ATX'a. Postaram się jutro poprawić wszystkie błędy i wrzucić aktualizację. Znalazłem również prostokątny radiator z wystającymi łopatkami ale raczej będę go musiał dopasować ze względu na ograniczone miejsce, sprawdzę na końcu termoparą jakie to praktyczne temperatury osiąga i w razie konieczności zamontuję wentylator malutki z termistorem.
  • Poziom 43  
    Zapytam z ciekawości - Czy liczyłeś jakie straty występują na LM 317 przy obciążeniu go prądem 0,6A i ustawionym napięciu 10V?
    Wielkość radiatora nie ma wielkiego znaczenia jeśli całość zamknięta jest w szczelnej obudowie.
  • Poziom 30  
    Do kolegi touchthis:
    Jeżeli masz problemy z napięciem tętnień na wyjściu zasilacza to pominołeś ważny element na swoim schemacie jakim jest kondensator elektrolityczny 10uF dołączony równolegle do potencjometru.
    Zajrzyj do noty katalogowej stabilizatora LM317T dlaczego warto taki kondensator zamontować.
    Natomiast wstawileś diodę D2, która nie pełni żadnej waznej funkcji.w takiej konfiguracji połączeń elementów. Ta dioda jest potrzebna wtedy, gdy jest zamontowany kondensator 10uF.
  • Poziom 12  
    krzysztof723 napisał:
    Do kolegi touchthis::
    Jeżeli masz problemy z napięciem tętnień na wyjściu zasilacza to pominołeś ważny element na swoim schemacie jakim jest kondensator elektrolityczny 10uF dołączony równolegle do potencjometru.
    Zajrzyj do noty katalogowej stabilizatora LM317T dlaczego warto taki kondensator zamontować.
    Natomiast wstawileś diodę D2, która nie pełni żadnej waznej funkcji.w takiej konfiguracji połączeń elementów. Ta dioda jest potrzebna wtedy, gdy jest zamontowany kondensator 10uF.


    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Dobrze rozumiem?

    Dodano po 5 [minuty]:

    398216 Usunięty napisał:
    Zapytam z ciekawości - Czy liczyłeś jakie straty występują na LM 317 przy obciążeniu go prądem 0,6A i ustawionym napięciu 10V?
    Wielkość radiatora nie ma wielkiego znaczenia jeśli całość zamknięta jest w szczelnej obudowie.


    ~~8W, na papierze.
  • Poziom 30  
    Nie rezygnuj z kondensatora 10uF podłączonego na wyjściu zasilacza tylko dodaj jeszcze jeden kondensator 10uF podłączony równolegle do potencjometru
  • Poziom 12  
    No więc tak, zbudowałem od nowa układ. Właśnie skończyłem lutować płytkę, dałem wszędzie dużo cyny na ścieżkach.

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie

    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie


    Chłodzenie zamontowałem aktywne, trzymałem zasilacz 7 minut na 10.26V 0.85A, trzymał napięcie jak skała, wcześniej nigdy tego aż tak dobrze nie robił.

    Załączam jeszcze przebieg pod obciążeniem (po 7min - 10.26V 0.85A)
    Zasilacz na LM317T po kilku sekundach rozjeżdża się całkowicie
  • Poziom 38  
    touchthis napisał:

    Załączam jeszcze przebieg pod obciążeniem

    Właśnie tak to powinno wyglądać , zatem trochę staranności i osiągnąłeś sukces ! :D
  • Poziom 12  
    brofran napisał:
    touchthis napisał:

    Załączam jeszcze przebieg pod obciążeniem

    Właśnie tak to powinno wyglądać , zatem trochę staranności i osiągnąłeś sukces ! :D


    Victoria!