Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Samsung Omnia i900 - Brak ładowania z przetwornicy

cmsydney 06 May 2015 12:43 693 4
  • #1
    cmsydney
    Level 14  
    Witam
    Posiadam przetwornicę na 5V z wyjściem usb. Do wtyku podpięte jest tylko zasilanie i masa (pin 1 i 4 + obudowa). Przetwornica jest sprawna. Inny telefon samsunga na kablu microusb ładuje bez problemu.
    W przypadku omnii podłączenie powoduje jedynie pikniecie i wyjście z uśpienia. Po odłaczeniu kabla również jest piknięcie. Telefon więc wykrywa napięcie. Przetwornica nie pobiera pradu więc i telefon nic nie pobiera. Napięcie na wyjściu przy podłączeniu cały czas jest. Do podłączenia używam oryginalnego kabla. Jest sprawny gdyż po podłączeniu do komputera bez problemu ładuje. Innego kabla nie posiadam gdyż jak wiadomo telefon posiada niestandardowe wejście.
    Czy jest to problem z kablem? Czy on ma coś specjalnego?

    pozdrawiam
    Kamery 3D Time of Flight - zastosowania w przemyśle. Darmowe szkolenie 16.12.2021r. g. 10.00 Zarejestruj się
  • #2
    nemo333
    Level 29  
    Omnia jeśli dobrze pamiętam ładuje się tylko gdy ma w komputerze załadowane sterowniki.
    Rozwiązaniem jest poszukać uniwersalnych kabli do ładowania (są takie pakiety, wtyczka USB i 10 wtyczek do różnych telefonów) albo przeróbka kabla z ładowarki na wtyk USB.
    Możliwe że tam podłączone jest osobno prąd z USB i osobno z ładowarki.
  • #3
    cmsydney
    Level 14  
    Chyba tak gdyż po podłączeniu do komputera ładowanie rozpoczyna się w momencie zainstalowania urządzenia w systemie.

    Tylko jaki to ma związek z ładowaniem w przypadku braku jakiejkolwiek transmisji przez linie danych?
    Ładowarka sieciowa na wtyczce ma podłączone dwie żyły: zasilanie i masa. Piny od danych są niepodłączone.
    W przypadku mojej przetwornicy jest prawie tak samo. Podłączone piny masy i zasilania. Piny od danych niepodłączone. Jedyna różnica polega na tym, że ładowarka od wyjścia z przekształtnika do wtyczki ma dwie żyły. W mojej przetwornica jest podłączona do telefonu przez kabel ze wszytkimi żyłami. Ale żyły danych są niepodłączone od strony przetwornicy. Czyżby te żyły danych były jakoś połączone z masą lub zasilaniem w samym kablu?
  • #4
    nemo333
    Level 29  
    Zobacz sobie schemat - http://pinoutsguide.com/CellularPhones-P-W/samsung_d800_pinout.shtml

    Piny od ładowania w kablu USB są podłączone na 2 (-) i 18 (+) pin w gnieździe, ładowarka za to wykorzystuje 19 i 20. Dzięki temu telefon wie kiedy dostaje prąd z USB i kiedy z ładowarki sieciowej i nie zacznie się ładować jeśli nie dostanie sygnału o zainstalowaniu sterowników w komputerze.

    Musisz stworzyć albo zdobyć taki kabel aby piny z wtyczki USB były podłączone do pinów ładowania żeby telefon myślał że jest ładowany normalnie z kontaktu.
  • #5
    cmsydney
    Level 14  
    I wszystko jasne. Nie pomyślałbym, że zasilanie z usb idzie na inny pin niż zasilanie z ładowarki. Czemu to ma służyć? Możliwości wyłączenia ładowania z usb?