Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Mio spirit 6900 lm zawiesza się na logo

04 Cze 2015 00:46 8097 12
  • Poziom 9  
    Witam.
    Przepraszam jak zły dział. Bawiłem się w odblokowanie mio spirit 6900 lm. Chciałem to zrobić bez karty sd. Wynik taki, że navi zawiesza się na logo Mio i dalej nie ma reakcji. Xp nie rozpoznaje urządzenia. Na linuxie nie wyskakuje nic. Da się to odratować?
    Dzięki za pomoc.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 23  
    W zależności co wykonałeś.
    Obsługa portu USB jest realizowana w nawigacji przez specjalną aplikację (albo AppStartup, albo SmartCE). Jeżeli uruchomienie tych aplikacji nie jest możliwe, połączenie USB z komputerem działać nie będzie. Jeżeli zmieniłeś nazwę aplikacji/folderu lub przeniosłeś go w inne miejsce to jest to do odratowania bez większych problemów. Jeżeli usunąłeś je fizycznie i nie masz backupu to pozostanie Ci wgrać firmware w serwisie.
  • Poziom 9  
    Witam,

    Mam podobną prośbę... Chciałem zainstalować na urządzeniu Mio Spirit 6900 LM Automapę. Niestety, zamiast wcześniej doczytać sposób z TATA... Zainstalowałem, ale na wewnętrznym dysku flash - było dosyć miejsca na wersję PL. Potem, wzorem innych nawigacji - np. Clarion, poszukałem pliku który staruję oryginalną nawigację Mio (tutaj Navman/AppStartup.exe) i podmieniłem go... na plik uruchamiający AM. Na szczęście nie nadpisałem, ale cały oryginalny katalog Navman zachowałem na urządzeniu - zmieniając jego nazwę na Navman_. Folder Automapy nazwałem pierwotną nazwą, tj. Navman i w nim plik uruchamiający AM przechrzciłem na AppStartup.exe. Teraz po uruchomieniu urządzenia AutoMapa pięknie startuje. Działa także ok, poza wyłączaniem - tutaj zawiesza urządzenie i potrzebne jest ponowne włączenie. A co nie działa? Nie ma komunikacji z urządzeniem przez USB... Po prostu włączenie nawigacji uruchamia Automapę nawet przy podłączonej nawigacji pod port USB. Reasumując pliki oryginalne są, potrzebuję tylko sposobu, aby dostać się na urządzenie i przywrócić pierwotną strukturę katalogu (Total Commander, etc.). Podejrzewam, że podmnieniony plik AppStartup.exe inicjuje komunikację USB na urządzeniu. Szukałem informacji o tym jak wejść w tryb serwisowy. Kombinacja klawiszy - RESET i POWER ON/OFF nic nie daje, zresztą naciskałem na ślepo, bo nie znalazłem żadnej informacji na ten temat. Zgrałem także archiwum "Odblokowanie MioSpirit na SEEKER-mini.zip", przegrałem na kartę licząc, że wystaruje z pliku TATA3_5000/auto.exe (tutaj TotalCommander), ale ponownie wita mnie AutoMapa... Teraz czekam na rozładowanie urządzenia... jeszcze tego nie próbowałem. Znalazłem również plik: "Mio 6900_SD_MP3.zip" gdzie jest odblokowanie z panelami, ale nie próbowałem tego jeszcze, bo jak nie działa sposób z TATA3_5000/auto.exe na SD, to i to nie będzie działać. Proszę o pomoc! Soft do wgrania firmware, restart hard urządzenia, sterowniki do wgrywania firmware... cokolwiek... aby móc odpalić na urządzeniu Total Commandera lub dostać się na nie z poziomu PC... Chcę tylko przywrócić oryginalną postać katalogu Navman... :(

    Pozdrawiam serdecznie,

    Krzysiek
  • Poziom 23  
    ten_chrupek napisał:
    Witam,
    Teraz po uruchomieniu urządzenia AutoMapa pięknie startuje. Działa także ok, poza wyłączaniem - tutaj zawiesza urządzenie i potrzebne jest ponowne włączenie.


    Nie wiem o co chodzi. Pozycja pośrednia OFF to uśpienie nawigacji i jest obsługiwane w zasadzie tylko przez Navmana. Automapa nie powinna w ogóle reagować - u mnie przynajmniej ignorowała. Pozycja RESET wyłącza urządzenie.
    Generalnie masz szczęście, zazwyczaj zabiegi, które wykonałeś kończą się wizytą z nawigacją w serwisie celem przeprogramowania pamięci wewnętrznej.

    Cytat:

    A co nie działa? Nie ma komunikacji z urządzeniem przez USB... Po prostu włączenie nawigacji uruchamia Automapę nawet przy podłączonej nawigacji pod port USB. Reasumując pliki oryginalne są, potrzebuję tylko sposobu, aby dostać się na urządzenie i przywrócić pierwotną strukturę katalogu (Total Commander, etc.).
    Podejrzewam, że podmnieniony plik AppStartup.exe inicjuje komunikację USB na urządzeniu.

    Bardzo dobrze podejrzewasz. AppStartup odwala całą robotę aby działała komunikacja po USB. I dlatego nawigacje MIO tak łatwo uszkodzić.
    Na forum Elektrody są podobne tematy z załączonymi plikami, które należy wgrać na kartę pamięci (jest tam też Total Commander). Wgrywasz na kartę, wkładasz kartę, włączasz nawigację i jeżeli zaskoczy to zamiast AutoMapy wystartuje Total Commander.

    Cytat:

    Szukałem informacji o tym jak wejść w tryb serwisowy. Kombinacja klawiszy - RESET i POWER ON/OFF nic nie daje

    A skąd pomysł, że taki tryb istnieje i używa się do tego przycisków POWER i RESET? To nie Android tylko WinCE.

    Cytat:
    Znalazłem również plik: "Mio 6900_SD_MP3.zip" gdzie jest odblokowanie z panelami, ale nie próbowałem tego jeszcze, bo jak nie działa sposób z TATA3_5000/auto.exe na SD, to i to nie będzie działać.

    Trochę się spóźniłeś. Od tego trzeba było zacząć na samym początku. Zamiast TATA3_5000 użyj nazwy folderu DEFAULT. Może pomóć.
    Rozładowanie urządzenia raczej nie przywróci jego sprawności.

    Cytat:
    Chcę tylko przywrócić oryginalną postać katalogu Navman... :(

    Było już trochę tego na forum i nikt się chętny do reprogramowania urządzeń MIO nie zgłosił. Ale jest sporo firm, które naprawiają takie usterki. Wystarczy poszukać w sieci.
  • Poziom 9  
    Kroovka napisał:
    Nie wiem o co chodzi. Pozycja pośrednia OFF to uśpienie nawigacji i jest obsługiwane w zasadzie tylko przez Navmana. Automapa nie powinna w ogóle reagować - u mnie przynajmniej ignorowała. Pozycja RESET wyłącza urządzenie.
    Generalnie masz szczęście, zazwyczaj zabiegi, które wykonałeś kończą się wizytą z nawigacją w serwisie celem przeprogramowania pamięci wewnętrznej.


    W tym modelu są tylko dwa przyciski - RESET oraz drugi, jak napisałeś, do USYPIANIA/BUDZENIA. Mój błąd w określeniu jego działania.

    Cytat:
    Bardzo dobrze podejrzewasz. AppStartup odwala całą robotę aby działała komunikacja po USB. I dlatego nawigacje MIO tak łatwo uszkodzić.
    Na forum Elektrody są podobne tematy z załączonymi plikami, które należy wgrać na kartę pamięci (jest tam też Total Commander). Wgrywasz na kartę, wkładasz kartę, włączasz nawigację i jeżeli zaskoczy to zamiast AutoMapy wystartuje Total Commander.


    Kombinuję nieco inaczej. Ten model nawigacji odczytuje kartę pamięci po włożeniu jej do slotu przy włączonym urządzeniu. A włączone urządzenie w moim przypadku to uruchomiona Automapa. Poza nią nic nie ma... Teraz należy się zastanowić jak ubić Automapę i uruchomić oryginalny AppStartupSec.exe aby przywrócić komunikację przez USB. Zamiast AppStartupSec.exe można by uruchomić np. Explorera... Chciałem "zminimalizować" Automapę, jednak to nie działa. Podczas wkładania i wyjmowania karty pamięci na ekranie Automapy pojawia się charakterystyczna klepsydra WinCE. Na karcie mam skrypt odblokowujący, jednak nie wiem jakiej składni mam użyć, aby zrealizować powyższe scenariusze. Składnia jak poniżej nie przynosi rezultatu...

    Kod: bash
    Zaloguj się, aby zobaczyć kod



    Cytat:
    Trochę się spóźniłeś. Od tego trzeba było zacząć na samym początku. Zamiast TATA3_5000 użyj nazwy folderu DEFAULT. Może pomóć.
    Rozładowanie urządzenia raczej nie przywróci jego sprawności.


    Niestety, zmiana nazwy folderu na DEFAULT nic nie wniosła. Myślę, że obie są poprawne, bo po włożeniu karty zaczyna kręcić klepsydrą. Problem tylko w tym jak ubić proces Automapy i uruchomić np. Total Commandera, Explorera, etc. Tutaj przy okazji mam pytanie. Czy jeżeli zmieniłem nazwę pliku rozruchowego AM wceam.exe na AppStartupSec.exe to pod taką nazwą będzie on na liście uruchomionych procesów? Nie znam na tyle WinCE... Szukam sposobu na ubicie AM...

    Cytat:
    Było już trochę tego na forum i nikt się chętny do reprogramowania urządzeń MIO nie zgłosił. Ale jest sporo firm, które naprawiają takie usterki. Wystarczy poszukać w sieci.


    Jeszcze chcę powalczyć. Muszę poznać trochę WinCE... :|

    ps. Jak przenieść temat do działu z Nawigacjami?

    Dziękuję serdecznie za odzew.

    Pozdrawiam,

    Krzysiek
  • Poziom 23  
    ten_chrupek napisał:
    Kombinuję nieco inaczej. Ten model nawigacji odczytuje kartę pamięci po włożeniu jej do slotu przy włączonym urządzeniu. A włączone urządzenie w moim przypadku to uruchomiona Automapa.


    Myślę, że Automapa wykrywa włożenie karty i sprawdza czy jest na karcie coś co ją interesuje - np: dodatkowe pliki map czy coś takiego. Najlepiej napisz do supportu Automapy, czy posiadają funkcję wywołania okna konsoli do wprowadzenia własnej komendy? Wówczas twój plan byłby możliwy do realizacji.
  • Poziom 9  
    Witam po dłuższej przerwie,

    Kroovka napisał:
    Myślę, że Automapa wykrywa włożenie karty i sprawdza czy jest na karcie coś co ją interesuje - np: dodatkowe pliki map czy coś takiego. Najlepiej napisz do supportu Automapy, czy posiadają funkcję wywołania okna konsoli do wprowadzenia własnej komendy? Wówczas twój plan byłby możliwy do realizacji.


    Masz rację, zapewne tak było. Przepraszam za milczenie, ale Navi nie była moja i musiała służyć jako nawigacja. Mimo, iż ją "popsułem", dzielnie przez dwa tygodnie pracowała z wgraną Automapą. Teraz najważniejsze, UDAŁO MI SIĘ SAMEMU ją naprawić! :) Z pomocą przyszło archiwum Minishell service.zip (załączam do postu). Wystarczy przegrać zawartość do katalogu głównego karty MicroSD i w odpowiednim momencie włożyć do nawigacji (zaraz po wystartowaniu loga). Uruchamia nam się fajny panel z narzędziami, m.in. mamy wirtualną klawiaturę oraz Windows Commandera. Przywróciłem oryginalną postać katalogu Navman i nawi działa jak złoto. Temat zamykamy. :) Pozdrawiam!
  • Poziom 9  
    Witam, miałem ten sam problem co autor tematu, czyli zawieszające się logo. Widzę że kolega zamieścił plik z rozwiązaniem, ja dodatkowo zamieszczę przygotowany folder z aplikacją samej transmisji danych do komputera, po wrzuceniu na kartę pamięci wypakowanego folderu, wkładamy kartę do nawigacji, włączamy ją i szybko wyjmujemy i wsuwamy kartę pamięci, najlepiej mieć już podłączoną nawigację z komputerem :) Tym sposobem po chwili odpali się sama transmisja z komputerem i będziemy mieć dostęp do pamięci wewnętrznej i karty pamięci, może komuś ułatwi to życie, pozdrawiam :D
  • Poziom 23  
    Wg kolegi ten_chrupek znaczenie jest kiedy wsuniemy kartę. W przypadku nieuszkodzonej nawigacji MIO kartę można wsunąć przed włączeniem urządzenia, w przypadku usunięcia krytycznych dla działania urządzenia plików kartę należy wsunąć dopiero po uruchomieniu urządzenia. Podejrzewam, że wszystkie paczki zamieszczone w tym temacie zadziałają stosując metodę kolegi ten_chrupek.
  • Poziom 9  
    Witam, w moim przypadku nawigacja zawieszała się całkowicie po animowanym logo MIO, karta pamięci musiała być włożona przed uruchomieniem urządzenia, a gdy tylko pokazało się logo MIO trzeba było szybko ją wysunąć i włożyć, wtedy nawigacja odpala z karty pamięci z podstawowego folderu Default plik o nazwie auto.exe Więc odpali każdą aplikację, wystarczy zmienić nazwę na auto.exe :) karta zostanie wyczytana jeżeli włożymy ją przed zakończeniem animacji MIO, po tym czasie odpali się domyślna aplikacja z folderu Pamięci wewnętrznej/Program Files/Navman/AppStartupSec.exe Ta aplikacja odpowiada nie tylko za włączenie nawigacji MIO ale też za transmisję danych z komputerem, dla tego jak w przypadku kolegi ten_chrupek odpalała się automapa i już nie można było połączyć się z komputerem. Kroovka z tego co pamiętam to przy uszkodzonej nawigacji karta musiała być włożona przed włączeniem, potem szybko wyciągnięta i ponownie włożona, gdy włożyło się ją po włączeniu, nie startowała aplikacja z folderu Default, tak jakby nawigacja nie widziała karty pamięci, w przypadku nieuszkodzonej jak i uszkodzonej nawi, ten sposób wymusza odpalenie jako pierwszej aplikacji z karty pamięci, na sprawnej nawigacji to też ma znaczenie, gdy włożymy kartę później to pierwsza domyślna aplikacja MIO będzie działać w tle, to tyle w temacie, pozdrawiam :)
  • Poziom 12  
    ten_chrupek napisał:
    Przywróciłem oryginalną postać katalogu Navman i nawi działa jak złoto.

    W jaki sposób przywróciłeś oryginalny katalog Navman?
  • Poziom 24  
    ten_chrupek napisał:
    Minishell_service.zip
    Pobrałem Twój plik. Wrzuciłem na kartę. Uruchamia się nowy pulpit. Tylko jak przywrócić teraz ten katalog Navman? Pomożesz Ty lub ktoś inny?
  • Poziom 7  
    Witam, podniosę temat.
    W moim Mio Spirit 487 z rok temu spaprałem pliki startowe (chyba to xml-e były) i odpala mi się tylko wgrany do wewnętrznej pamięci NavigatorFree.
    Nie ma kontaktu z urządzeniem jako pamięć masowa (a pliki oryginalne zachowałem wewnątrz na wspomnianym urządzeniu zresztą i tak to bez znaczenia na ten moment) .
    Zawartość Minishell_service.zip wgrałem na SD i przy odpaleniu jest zmiana (bo zaczyna grać muzyczka) ale znowu odpala się NavigatorFree po czym na około dwie sekundy pojawia się okno z jakąś appką z karty SD (nie działa żadne klikanie w buttony tego menu nawet w te miejsca gdzie dopiero się pojawią) po czym znowu na ekranie pojawia się NavigatorFree i zostaje jako aktywna aplikacja.
    Jest w jego menu wyjście ale po uruchomieniu pojawia mrugnięcie na monitorku jakby wychodził i ponownie się uruchamiał ale już jest zwiecha nic nie działa czyli jak bez tego starto z kartą SD.
    Nie chce dawać urządzenia do serwisu bo się nie opłaca ale jakby ktoś kiedyś sobie z tym poradził i dał info byłbym wdzięczny.

    Dodano po 59 [minuty]:

    Sprawa rozwiązana po około 8 wyjściach wyjściach z FreeNavigatora i równocześnie restartach urządzenia pojawiło się aktywne okno apki z karty SD o którym wcześniej napisałem że jest nieaktywne .
    Przywróciłem oryginalne pliki i nawigacja startuje po staremu, u mnie temat zamknięty.