Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Segate - Klonowanie macierzy RAID0

gorg81 04 Jun 2015 16:02 1680 18
  • #1
    gorg81
    Level 12  
    Panowie wiem że tematów trochę było, ale czytam i czytam i mózg mi się lasuje.

    Więc tak mam w firmie serwer, niestety nie ja go zakładałem od razu piszę, ale jeden z dysków macierzy RAID0 daje w panelu błąd non disk, co dziwniejsze chodzi serwer normalnie, włącza wyłącza, ale bład tak czy tak trzeba usunąć.
    Wykonałem taki myk że pozamieniałem taśmy, czy sloty SATA ale dysk nadal daje te sam dysk błąd, sprawdzałem to aby wykluczyć uszkodzenie taśmy czy płyty głównej w postaci slotu SATA czy kontrolera raid.

    Zatem, serwer ma System Windows Serwer 2013 Small .... . Dwie macierze, RAID0 z dyskami seagate 500GB i 1000 GB, a druga macierz lata na WD 500GB i WD500GB, o ile macierz RAID1 mnie nie interesuje, są tam pliki itd.... wewnętrzne dyski sieciowe i takie tam, to na macierzy RAID0 mamy przedewszystkim SQL-a i Symfonie. Błąd pokazuje się na mcierzy RAID0 i dysku 1000GB.
    Co chcę zrobić ??
    Chcę podmienić dysk 1000GB, ba kupiłem nawet ten sam, pytanie moje brzmi jak to wykonać.



    Pierwsza opcja jest taka że zrobię kopię, tzw. recovery z macierzy całej systemowej widzianej jako dysk C: i odtworzenie jej na macierz RAID0 po podmianie dysku, ale jeśli zrozumiałem dobrze artykuły jest to nie wykonalne.

    Ewentualnie posektorówkę jednego dysku, czyli tego z błędem (1000GB) i odtworzenie go na powrót.

    Na czym mi zależy:

    Na 0% utraty danych, już mówię dlaczego, nie chodzi o samo postawienie systemu czy wgranie symfoni, ale problem w tym że poprzedni informatyk udał się do UK i nijak ma ochotę odpisywać na nasze maile, a my tak naprawdę nie mamy dostępu do konta admina, panelu admina w symfoni, niestety nie mamy generalnie dostępu do kont admina, używamy tego komputera na koncie zwykłego użytkownika. Rozbrojeniem systemu admina i konta zajmę się później ale na chwilę obecną muszę pozbyć się błędu macierzy.

    Co mi możecie w tej sytuacji poradzić, przyznam szczerze że nie jestem laikiem w dziedzinie komputerów czy robienia kopi i odtwarzania ale nie robiłem tego nigdy na macierzach, niestety, wolę zapytać niż płakać.
  • #2
    jdubowski
    Tube devices specialist
    gorg81 wrote:
    RAID0 daje w panelu błąd non disk, co dziwniejsze chodzi serwer normalnie,


    Jakim "panelu"?
    I zaiste to dziwne, może dysk startuje z opóźnieniem.

    Sugeruję najpierw zająć się odzyskaniem haseł, bo bez tego trudno będzie opanować sytuację w razie niepowodzenia operacji żonglerki dyskami, przecie bez dostępu administratorskiego nie zrobisz nawet porządnego backupu.
    Po drugie radzę nie leczyć syfilisu pudrem i wyeliminować stripe'a z rozwiązania.

    BTW - nie piszeszjak są te wolumeny zrobione - raid jest sprzętowy czy na poziomie systemu?
  • #3
    gorg81
    Level 12  
    Panelu Intela Matrix Storage Console

    Nie wiem jak startuje, daje w Biosie już błąd Error Occurred
    Hasła nie są problemem, przynajmniej te do Windowsa.

    Raid wbudowany w płytę główną.

    Daję zrzut błędu, a w załaczniu raport z konsoli intela. Może to coś Wam rozjaśni.
    Nie znam się na macierzach RAID.

    Segate - Klonowanie macierzy RAID0


    Są dwie partycje: C - system itd.... i D - pliki firmowe.
  • #4
    jdubowski
    Tube devices specialist
    gorg81 wrote:
    Nie znam się na macierzach RAID.


    Lektura: http://pl.wikipedia.org/wiki/RAID

    Oba wolumeny są mirrorami (RAID1), widać to wyraźnie w raporcie, nie ma tam wolumenu RAID0:
    Quote:
    Volume_0000
    Stan: Niekompletny
    Wolumin systemowy: Tak
    Pamięć podręczna z opóŸnionym zapisem dla woluminu włšczona: Nie
    Poziom RAID: RAID 1 (dublowanie)
    Całkowita pojemnoœć: 465.7 GB
    Rozmiar sektora fizycznego: 512 B
    Rozmiar sektora logicznego: 512 B
    Liczba dysków twardych: 2
    Składowy dysk twardy 1: ST31000524AS
    Składowy dysk twardy 2: ST3500630AS
    Tablica nadrzędna: Array_0000


    Kontroler powinien odbudować wolumen po podmianie dysku albo samodzielnie albo po wyborze odpowiednich opcji w BIOSie kontrolera - pownieneś mieć dostęp po zakończeniu POST przed załadowaniem systemu. Tyle teorii, pamiętaj że backup przyjacielem człowieka, zobacz czy masz możliwosc zrobienia backupu posektorowego wolumenów (oprogramowanie którego użyjesz musi miec sterownik obsługujący twój kontroler macierzowy).
  • #5
    gorg81
    Level 12  
    Średnio zrozumiałem co piszesz :). Jeśli jegnak coś skumałem to co mam podmienić dysk i on się odbuduje ???
    Jutro będę miał fizycznie dostęp do tego serwera bo teraz nie mam, ale faktycznie przed rozpoczęciem pojawiają się opcje.
    Zrozumiałem że obie pary dysków są ustawione w RAID1 a nie jak myślałem RAID 0 i RAID1, tak to jest jak się czegoś nie rozumie do końca.
    Ok, z wiki się zapoznam, ale mogłbyś mnie nakierować jak mam wykonać ten backup. Wiem że backup przyjacielem człowieka, ale jak go mam wykonać, posektorowo obu dysków ?? czy mam zrobić kopię bezpieczeństwa partycji systemowej.

    Jeszcze jedna sprawa ustwienia RAID w Biosie w zasadzie tego się najbardziej boję, czy tam się nic nie posypie jak podmienie dysk.
    Z tego co mniej więcej wiem, to RAID1 to jest zapis na wilu dyskach w czasie rzeczywistym, ale jeśli jest błąd na pierwszym dysku to pozostałe zapisy też są błędne, czyli jeśli na dysku 1000GB jest błąd to nie ma pewności że na drugim volumenie dane są spójne ??

    Sory może za laickie pytania, ale przyznaję że styczność z RAID poza czysto teoretycznym czytaniem co to jest z ciekawości, to fizycznie pierwszy raz mam styczność.
  • #6
    jdubowski
    Tube devices specialist
    gorg81 wrote:
    Średnio zrozumiałem co piszesz . Jeśli jegnak coś skumałem to co mam podmienić dysk i on się odbuduje ???


    Rozważ wynajęcie fachowca, który co prawda skasuje pieniążki ale za to robotę zrobi tak że nie będziesz się w poniedziałek zastanawiał jak fakturę z bloczka wystawić.

    gorg81 wrote:
    Jeśli jegnak coś skumałem to co mam podmienić dysk i on się odbuduje ???


    Tak, o ile wszystko pójdzie OK.

    gorg81 wrote:
    Zrozumiałem że obie pary dysków są ustawione w RAID1 a nie jak myślałem RAID 0 i RAID1,


    Tak.

    gorg81 wrote:
    Ok, z wiki się zapoznam, ale mogłbyś mnie nakierować jak mam wykonać ten backup. Wiem że backup przyjacielem człowieka, ale jak go mam wykonać, posektorowo obu dysków ??


    Nie - posektorowo całego wolumenu.

    gorg81 wrote:
    czy mam zrobić kopię bezpieczeństwa partycji systemowej.


    Nie zaszkodzi, dodatkowo kopię stanu systemu ("system state").

    gorg81 wrote:
    Z tego co mniej więcej wiem, to RAID1 to jest zapis na wilu dyskach w czasie rzeczywistym, ale jeśli jest błąd na pierwszym dysku to pozostałe zapisy też są błędne, czyli jeśli na dysku 1000GB jest błąd to nie ma pewności że na drugim volumenie dane są spójne ??


    Mechanizm polega na tym że dane są zapisywane równolegle na obu dyskach.
    Jeden dysk jest definitywnie uszkodzony, na drugim dane sa w jakimś tam stanie ktory kontroler uznaje za prawidłowy - lepszych danych nie masz.
  • #7
    gorg81
    Level 12  
    Quote:
    Rozważ wynajęcie fachowca, który co prawda skasuje pieniążki ale za to robotę zrobi tak że nie będziesz się w poniedziałek zastanawiał jak fakturę z bloczka wystawić.


    Rozważałem, oczywiście zawsze jest to metoda najprostrza. Nie gniewaj się na mnie, ale skoro rada miała się skłaniać do tego że mam wynająć fachowca, zamiast podać konkretnie co mam zrobić, to chyba nie o to mi chodziło. Kopię z symfoni mam, w najgorszym wypadku padnie cała macierz, co nie przeszkadza mi potem podmienić dysku wgrać wszystko od nowa itd.... Zgadza się ?.

    Quote:
    Tak, o ile wszystko pójdzie OK.

    Ok rozumiem, ale co może pójść nie tak skoro założenie tego typu RAID -u (RAID1) właśnie są takie aby mieć kopię ?? To wyczytalem w wikipedii.


    Quote:
    Nie - posektorowo całego wolumenu.


    Dziekuję bardzo za radę, reszty się dowiem jak wykonać tą kopię i najlepiej jakim narzędziem, to już nie jest problem.

    Quote:
    Nie zaszkodzi, dodatkowo kopię stanu systemu ("system state").


    Dzięki za radę, wykonam, zawsze mogę potem odbudować z tegoo co wyczytałem w necie nawet na jeden dysk pozbywająć się macierzy RAID1.


    Quote:
    Mechanizm polega na tym że dane są zapisywane równolegle na obu dyskach.
    Jeden dysk jest definitywnie uszkodzony, na drugim dane sa w jakimś tam stanie ktory kontroler uznaje za prawidłowy - lepszych danych nie masz.


    I to mnie właśnie martwi najbardziej ponieważ nie wiem jak to wygląda w kwestii spójności wszystkich danych. Trudno będziemy kombinować, najpierw zrobimy zrzut symfoni bo to jest najważniejsze, więcej w zasadzie nie ma na partycji C:, czyli pierwszym wolumenie.

    W każdym razie i tak dziękuję za pomoc, kwestię fachowca oczywiście rozważę, jednak uważam że on kiedyś też nie był fachowcem i musiał się tego nauczyć, to dlaczego ja nie mogę się tego nauczyć na własny użytek. Powiem tak 10 lat temu nie umiałem zainstalować windowsa, pojęcie kopi bezpieczeństwa też było dla mnie obce, 5 lat temu linux był magią, 2 lata temu wykonując sieć od podstaw też się uczyłem.
    Jeszcze raz dziękuję za czas i chęć pomocy, resztę mam nadzieję doczytam ze zrozumieniem.
  • #8
    jdubowski
    Tube devices specialist
    gorg81 wrote:
    Nie gniewaj się na mnie, ale skoro rada miała się skłaniać do tego że mam wynająć fachowca, zamiast podać konkretnie co mam zrobić, to chyba nie o to mi chodziło.


    Nie miała się do tego sprowadzać, to tylko sugestia. Co do konkretów to nie mam twojego sprzętu przed sobą, ani z takim kontrolerem nigdy bezpośredniej styczności, więc ich nie bedzie.

    gorg81 wrote:
    Kopię z symfoni mam, w najgorszym wypadku padnie cała macierz, co nie przeszkadza mi potem podmienić dysku wgrać wszystko od nowa itd.... Zgadza się ?.


    Tylko że ilosc pracy na SBSie może byc powalająca, to przecie nie tylko "SYFMONIA" ale też domena, userzy itp itd.

    gorg81 wrote:
    ale co może pójść nie tak skoro założenie tego typu RAID -u (RAID1) właśnie są takie aby mieć kopię ?? To wyczytalem w wikipedii.


    Ano przypadkiem klikniesz "recreate" zamiast "rebuild" i masz 2 dyski w mirrorze, ale puste. Albo kierunek odbudowy ci się pomyli i odbudujesz pusty dysk na pełny.

    gorg81 wrote:
    Dziekuję bardzo za radę, reszty się dowiem jak wykonać tą kopię i najlepiej jakim narzędziem, to już nie jest problem.


    A to trzeba pokombinować co podpasuje.
    http://en.wikipedia.org/wiki/List_of_disk_cloning_software

    gorg81 wrote:
    I to mnie właśnie martwi najbardziej ponieważ nie wiem jak to wygląda w kwestii spójności wszystkich danych. Trudno będziemy kombinować, najpierw zrobimy zrzut symfoni bo to jest najważniejsze, więcej w zasadzie nie ma na partycji C:, czyli pierwszym wolumenie.


    Nie obawiał bym się - gorzej niż jest nie będzie. Po to jest mirror by padnięcie jednego dysku nie naruszało spoistości danych. Jesli dane są rozkopane to ewentualnie z innej niż pad dysku przyczyny.
  • #9
    gorg81
    Level 12  
    A zatem ponowie dziś dostałem się do serwera, jako że przyszedł dysk zabrałem się do wykonywania kopie posektorowej, ale coś dziwnego mnie spotkało, a może nie spotkało o ile sam tego nie spieprzyłem.

    Więc tak, po odpaleniu chciałem dokładnie spisać wszystkie dane, numery dysków itd..., klikając na uszkodzony dysk wyskczył opcje oznacz jako właściwy i jeszcze jedna, chcą się wycofać kliknąłem oznacz jako właściwy, i poszło :(

    Teraz mam tak w biosie

    Segate - Klonowanie macierzy RAID0
    oraz w konsoli intela

    Segate - Klonowanie macierzy RAID0

    Co robić dalej czekać aż się zakończy ?? czy olać temat i podmieć dysk ??
  • #12
    gorg81
    Level 12  
    Wasilkowski wrote:
    Zostaw, niech się odbuduje.
    Najważniejsza rzecz po odbudowie i od czego należało zacząć - SMART wszystkich dysków.


    Tak wiem że należalo, jestem laikiem i nie było mowy nawet o wyłączeniu czy odłączeniu serwera z uwagina strach utraty danych, jak wsponiałem wcześniej, jestem laikiem w dziedzinie RAID-ów.
    Dziś serwer został odłączony pierwszy raz chyba od dwóch tygodni :).

    jdubowski wrote:
    Zostawić, czekać na skutek.


    Skutek zamieszczam poniżej :),

    Segate - Klonowanie macierzy RAID0
    teraz podłączyłyłem pozostałe dyski, sprawdzam spójność danych itd... następnie biore się za SMART i zdecydujemy czy dysior padł faktycznie, czy może czysty błąd sterownika, który się dosyć często zdarza z tego co wyczytałem na RAID-zie typu płyta główna.

    Panowie, dajcie mi z godzinkę i będą wyniki kondycji dysków.
    ----------------------------------------------------------------------------------------------------------------------------
    edit:
    No i poczekamy na smarta dłużej, niestety. Po podłączeniu drugiego volumenu, odbudowa .....

    Segate - Klonowanie macierzy RAID0
  • #13
    jdubowski
    Tube devices specialist
    gorg81 wrote:
    Po podłączeniu drugiego volumenu, odbudowa .....


    Trochę sobie działania utrudniłeś odpinając dyski drugiego wolumenu..
    Co do przyczyn problemu z pierwszym wolumenem to niekoniecznie winny kontroler, problem może tkwić w dysku - okresowo niedostępnym albo w zasilaczu nie nastarczającym z wydajnością prądową.
  • #14
    gorg81
    Level 12  
    jdubowski wrote:
    gorg81 wrote:
    Po podłączeniu drugiego volumenu, odbudowa .....


    Trochę sobie działania utrudniłeś odpinając dyski drugiego wolumenu..
    Co do przyczyn problemu z pierwszym wolumenem to niekoniecznie winny kontroler, problem może tkwić w dysku - okresowo niedostępnym albo w zasilaczu nie nastarczającym z wydajnością prądową.


    Odpiąłem dyski poniekąd z powodów które poczytałem jak mi radziłeś i aby zminimalizować ryzyko pomyłki przy podmianie dysku :) ,ale coż nikt mnie nie goni, serwer sobie chodzi, że odbudowuje i tyle, tyle mogę zrobić, poczekać.

    Jesteś jasnowidzem ?? Właśnie wczoraj wymieniłem zasilacz który raz startował raz nie, zaniepokoiły mnie sygnały UPs-u że są błędy w zasilaniu, całkiem mi to z głowy wyleciało żeby napisać.

    Poczekam zrobię smarta, jeśli bedzie wszystko OK, dysku nie podmieniam tylko ewentualnie podepnę jako backup do wszystkich plików, zrobię bat-a żeby na wszelki wypadek kopiował na ten nowy 1TB i będzie już chyba wszystko OK, mam nadzieję.
  • Helpful post
    #15
    jdubowski
    Tube devices specialist
    gorg81 wrote:
    Jesteś jasnowidzem ??


    Nie, to tylko praktyka;)

    gorg81 wrote:
    Właśnie wczoraj wymieniłem zasilacz który raz startował raz nie, zaniepokoiły mnie sygnały UPs-u że są błędy w zasilaniu, całkiem mi to z głowy wyleciało żeby napisać.


    UPS jedno a zasilacz drugie, UPS jest włączony przed zasilaczem więc raczej o problemach zasilacza nie raportuje.

    gorg81 wrote:
    Poczekam zrobię smarta,


    SMART na dyskach spiętych w RAID raczej się nie uda - system widzi wolumeny macierzowe kontrolera a nie pojedyncze dyski. Do zbadania SMART dyski sugeruję przepinać pojedynczo do innego peceta.

    gorg81 wrote:
    ewentualnie podepnę jako backup do wszystkich plików, zrobię bat-a żeby na wszelki wypadek kopiował na ten nowy 1TB i będzie już chyba wszystko OK, mam nadzieję.


    Tam masz w ogóle pewien bałagan - dyski 1TB i 500GB spięte w mirror, skutkiem tego połowa większego się marnuje...
  • #16
    gorg81
    Level 12  
    Quote:
    Nie, to tylko praktyka;)


    Jakże to jest cenne :)

    Quote:
    UPS jedno a zasilacz drugie, UPS jest włączony przed zasilaczem więc raczej o problemach zasilacza nie raportuje.


    Tutaj Cię zaskoczę, mam oprogramowanie PowerSoft, UPS spięty z kompem Rs232 :) , raportuje, raportuje. Fajna sprawa.
    Quote:

    SMART na dyskach spiętych w RAID raczej się nie uda - system widzi wolumeny macierzowe kontrolera a nie pojedyncze dyski. Do zbadania SMART dyski sugeruję przepinać pojedynczo do innego peceta.

    To wiem, doczytałem w necie.

    Quote:
    Tam masz w ogóle pewien bałagan - dyski 1TB i 500GB spięte w mirror, skutkiem tego połowa większego się marnuje...


    To niestety też wiem. Jak pisałem wcześniej niestety nie mam pojęcia jak, kto i kiedy tworzył ten serwer. Z tego co wiem serwer był składany. Co do zamiarów Pana twórcy, nie mam pojęcia czemu akurat tak to ustawił, może akurat dysponował takimi dyskami. W każdym razie jak tylko się uporam z tym aby te błędy poznikały (co zresztą się już stało) to mam zamiar jednak zapiąć ten 1TB nowy jako drugi w mirror z zamian tej 500GB i będzie ok.

    Teraz mnie tylko martwi, niemartwi, w zasadzie spodziewałem się że Volumen1 będzie się dłużej odtwarzał ale przyznam szczerze że aż tyle nie.

    Spójność danych Volumenu0 już dawno się skończyła, a ten ma nadal 1%, jak widać na załączonym obrazku.
    Segate - Klonowanie macierzy RAID0

    Nic chyba poczekam, choć wyczytałem że można spokojnie wyłączyć serwer, przenieść, bla bla bla i włączyć a rebulding się będzie kontynuował ?.
  • #18
    gorg81
    Level 12  
    Mój błąd, chodzi o zasilanie.

    Póki co czekamy na odtworzenie Volemnu001 i się zobaczy, ale już bardzo dziękuję za pomoc, bardzo dużo mnie nakierowałeś.
  • #19
    gorg81
    Level 12  
    A zatem Panowie, niestety przy odbudowie Volumenu001 już nie jest tak kolorowo, po całonocnym rebuldingu rano przywitał mnie komunikat :(

    Segate - Klonowanie macierzy RAID0

    Rozpinam ten RAID1 i robię diagnostykę dysków.
    --------------------------------------------------------------------------------------------
    Więc tak Panowie, z uwagi na czas dopiero teraz piszę.
    Jak się okazało odtworzenie samego drugiego dysku nie było problemem, zrobiło się w zasadzie samo jak zresztą koledzy pisali i jak mówią wszelkie internetowe źródła.

    Volumen001 niestety jak widać na wcześniejszym załaczniku jednak się nie poddał bez walki i suma sumarum doszło do podmiany dysku bo jeden z macierzy 0001 okazął się padnięty.

    Podsumowując, wszystko prawdopodbnie jest przyczaną uskzodzonego zasilacza, ponieważ po jego wymianie i poprawnym zeskanowaniu Volumen000 okazało się że z dyskami jest wszystko OK, jak widać na załaczonym obrazku poniżej.

    Segate - Klonowanie macierzy RAID0

    Na drugim Volumenie podmieniłem uszkodzony dysk i zrobiłem odtwarzanie i też już jest OK.

    Niestety nie było czasu aby się bawić w formatowanie i przekąłdanie dysków, bo wyszło na to że taraz mam na obu volumenach śmienisznie poukałdane dyski po jednej 500GB i po jednym 1TB, ale to już później.

    Teraz skonfigirowałem sobie wszystko jak należy, kopia zapasowa itd.... Serwer już chodzi w sieci aż miło. Tak że dziekuję za pomoc i czas.