Elektroda.pl
Elektroda.pl
X
SterControl
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Omron, CX-Programmer i instrukcje SEND i RECV

rubaszny 22 Cze 2015 15:01 1464 8
  • #1 22 Cze 2015 15:01
    rubaszny
    Poziom 7  

    Witam,

    ostatnio wrzuciłem wątek w sprawie mojego problemu, z połączeniem panelu firmy Weintek i sterownika OMRON CJ2M CPU11 za pośrednictwem portu szeregowego rs232.

    Problem z komunikacją jest nadal, natomiast znam już przyczynę.
    W programie na sterowniku musi być instrukcja odebrania i wysłania danych przez port COM. SEND(90) i RECV(98). Czytałem wszystko co dostępne jest w internecie, natomiast nie rozumiem, nie wiem, jak użyć tych funkcji.

    Mam tutaj guide (strony 64-65) który mówi mi tyle co nic, bo niby gdzie mam wpisać to co jest przy C+1, C+2 itp. W oknie instrukcji mam do uzupełnienia tylko 3 pola, w dodatku nie bardzo wiem czego one się tyczą.


    PS. Uczę się sam cx'a i pracy z produktami omron, i przyznać muszę, że w porównaniu np. z TIA portalem od siemensa to cholernie ciężka sprawa.

    Dla zobrazowania screen.

    0 8
  • SterControl
  • Pomocny post
    #2 22 Cze 2015 15:33
    mawi2
    Poziom 25  

    Sorry, nie było mnie chwilowo w kraju więc nie mogłem odpowiedzieć.
    1. musisz fizycznie spiąć oba urządzenia, oba mają rs232, Uważaj Omron GND ma na pinie 9.
    2. W menu settings omrona ustawiasz parametry transmisji - jak na załączniku
    3. W weintecu ustawiasz parametry transmisji - jak w załączniku
    4. Wstawiasz bit lub słowo które chcesz czytać - jak w załączniku
    Mega proste połączenie.
    Jak coś Ci nie zadziała - pisz.

    1
  • SterControl
  • #3 23 Cze 2015 15:36
    rubaszny
    Poziom 7  

    Już sprawdziłem.

    Nic z tego.
    To znaczy, nie jest identycznie, mój przycisk odnosi się do adresów "W_bit", reszta tak samo.

    Lampka COMM świeci się gdy naciskam przyciski (pary set on i set off, toggle switcha panel mi nie wyświetla, gdy ten przypisany jest do plc'a).


    Program rozumiem, że jest zbędny, jakieś send(90) i recv(98)?
    To niżej to "program" abym widział na lampkach wynik rozmowy urządzeń, zbedny, ponieważ nadal weintek rzuca "plc no response"

    Może jest coś czego nie zrobiłem, jakaś oczywistość, ręce opadają :-x

    0
  • #4 23 Cze 2015 16:14
    mawi2
    Poziom 25  

    Podaj mi schemat kabelka łączącego oba urządzenia.

    0
  • #6 24 Cze 2015 07:55
    mawi2
    Poziom 25  

    Kabelek OK. Pytanie? Jeśli chcesz mogę wieczorem coś Ci pomóc po VPN lub innym połączeniem.

    0
  • #7 24 Cze 2015 14:38
    rubaszny
    Poziom 7  

    Byłoby super.
    Tylko oprogramowanie do plc mam na jednym kompie, a do weinteka na drugim, ale myślę, że nie będzie z tym problemu.
    W dodatku nie mam tego u siebie, dlatego fajnie jakbym wiedział chociaż, o której mniej więcej znalazłbyś czas.

    0
  • #8 25 Cze 2015 08:00
    mawi2
    Poziom 25  

    Na Priv podałem moje namiary, proszę o kontakt w celu uzgodnienia szczegółów.

    0
  • #9 29 Paź 2015 20:10
    rubaszny
    Poziom 7  

    Temat do zamknięcia, w ustawieniach urządzenia, gdzie dodawałem PLC, zamisat zostawić typ Local, ustawiłem na Remote (COM, Master-slave).

    Po przestawieniu na Local wszystko śmiga. Nalezy jednak pamiętać że w weinteku W100 odczytane będzie przez omrona jako W1.00, każdy inny adres analogicznie.
    Tak wiec bez żadnych instrukcji SEND RECV, zwyczajnie przycisk na panelu, cewka na sterowniku i działa.

    Pozdrawiam.

    0
  Szukaj w 5mln produktów