Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Kicad - Prośba o sprawdzenie płytki sterującej migomatu

Arturr300 22 Lip 2015 00:02 3306 21
  • #1 22 Lip 2015 00:02
    Arturr300
    Poziom 8  

    Witam.
    W programie Kicad zrobiłem schemat płytki sterującej migomatu. Jest to migomat z tego tematu: https://www.elektroda.pl/rtvforum/viewtopic.php?p=13493746&highlight=#13493746
    Na najwyższym biegu wg napisów na obudowie pobiera 16A.

    Ogólnie rzecz biorąc zasada działania płytki wygląda następująco: z transformatora zasilanego niezależnie idzie napięcie na mostek Graetza i kondensator. Zaraz po tym napięcie (ok. +16V) idzie na przełącznik, który po wciśnięciu załącza 7805, który załącza optotriaka (on z kolei zasila triak, a co za tym idzie główny transformator oraz dławik do spawania) oraz przekaźnik, który załącza obwód zasilacza silnika podajnika drutu (LM350). Silniczek podajnika to silniczek na 12V.

    Kicad - Prośba o sprawdzenie płytki sterującej migomatu

    Wiem, że muszę jeszcze dodać bezpiecznik.
    Czy poza tym wszystko jest dobrze? Chcę aby płytka była pewna i bezpieczna.
    Pozdrawiam :)

    0 21
  • #3 22 Lip 2015 00:13
    Arturr300
    Poziom 8  

    Porównałem teraz z datasheetem MOC3021 i nie zauważyłem błędów.
    Wiem, że mam nieustaloną wartość rezystora R2.

    0
  • #4 22 Lip 2015 01:20
    marco47
    Poziom 41  

    Jeżeli uważasz że nie ma błędu, to wklej zrzut z rysunkiem z tej noty katalogowej, na podstawie której narysowałeś Swój schemat sterowania triaka.
    Dlatego o tym piszę, bo chyba korzystamy z różnych not katalogowych.

    0
  • #7 23 Lip 2015 01:01
    Arturr300
    Poziom 8  

    A czym będzie skutkowało zostawienie tego rezystora tak jak jest? Bo chodzi o to, że tutaj wyliczyłem sobie by potencjometr miał mało jakby martwych stref - np. że drut będzie się posuwał zbyt wolno lub też całkowicie szybko - oczywiście orientacyjnie. I teraz mam regulację od 5.5 do 12.9V.
    Oczywiście jeżeli trzeba to sobie to wyliczę od nowa, tym razem z R1=240R. Tylko chcę wiedzieć dlaczego tak nie powinno być :)
    Przy okazji jeszcze zapytam: wartość rezystora (potencjometru) R2 (w tym przypadku połączenia szeregowego RV2 i R5) powinna się mieścić w jakimś przedziale? Coś mi świta w pamięci, że gdzieś czytałem, że powinien mieć wartość między 1k, a 10k.

    0
  • Pomocny post
    #8 23 Lip 2015 23:37
    marco47
    Poziom 41  

    Przeczytaj notę katalogową, a tam jest dokładnie opisane dlaczego ta wartość (240Ω)jest stosowana.

    Nic Ci nie musi świtać w pamięci :D co do wartości potencjometru.
    Tak jak wcześniej pisałem wszystko jest dokładnie opisane w nocie katalogowej.

    Tylko taką drogą, poprzez czytanie not katalogowych, można dokładnie poznać stosowany element :|

    1
  • #9 23 Lip 2015 23:57
    Arturr300
    Poziom 8  

    Ok, rozumiem, przeczytam notę.

    Tylko teraz pytanie: czy ten gasik (?) przy triaku wystarczy? Migomat bierze wg napisów na obudowie max 16A 230V. Nie będzie siało dużych zakłóceń do sieci?

    I jakie dać kondensatory do tego gasika?
    Kondensatory tego typu wystarczą? (to nie jest kryptoreklama)
    http://sklep.avt.pl/kondensator-mkt-10nf-400v.html

    0
  • #10 24 Lip 2015 22:51
    marco47
    Poziom 41  

    Może zamiast zwykłego optotriaka MOC3021, zastosujesz taki z przełączaniem w zerze np.MOC3081..3.
    Będzie zminimalizowane zakłócenie, bo przełączanie następuje przy zerowym napięciu sieci.
    Oczywiście gasik zostaw.
    Kondensator który wskazałeś może być.

    0
  • #11 27 Lip 2015 18:56
    Arturr300
    Poziom 8  

    Przepraszam za późną odpowiedź

    Przejrzałem notę LM350 (http://www.onsemi.com/pub_link/Collateral/LM350-D.PDF) i nie znalazłem dlaczego R1 musi być równe 240R. To że na schematach ma taką wartość to widzę, tylko nie wiem dlaczego :/
    Co się stanie jak dam R1 = 820R?
    Wtedy miałbym lepszy zakres sterowania.

    I może być zamiast MOC3081 układ MOC3041? Akurat taki mam w szufladzie :D

    0
  • Pomocny post
    #12 27 Lip 2015 23:35
    marco47
    Poziom 41  

    Jeżeli nota katalogowa pokazuje taką wartość w zastosowanych układach, to taką stosuj.
    Oczywiście możesz ją zmienić, ale musisz dokładnie przetestować, czy zmiana wartości rezystorów nie wpłynie na pogorszenie parametrów stabilizacji napięcia.

    Co do układu MOC3041, to oczywiście możesz taki zastosować, jeżeli masz go już w szufladzie :D

    1
  • #13 28 Lip 2015 09:06
    Arturr300
    Poziom 8  

    OK, dzięki wielkie, to chyba już wszystko. :)

    0
  • #14 28 Sty 2016 21:49
    Arturr300
    Poziom 8  

    Odświeżam temat, tym razem proszę o sprawdzenie PCB. Płytka jeszcze nie jest ukończona w 100% - muszę jeszcze poprawić m.in. rozstaw padów od mostka Graetza, bo nie pasują zbytnio i footprint kondensatora 4700uF będzie miał inną wielkość.

    Kicad - Prośba o sprawdzenie płytki sterującej migomatu

    Kicad - Prośba o sprawdzenie płytki sterującej migomatu

    0
  • Pomocny post
    #15 29 Sty 2016 06:31
    ZbeeGin
    Poziom 38  

    Niestety sekcja 230V wymaga poprawy. Schemat jest prawidłowy, ale na PCB triak jest podłączony już odwrotnie, z uwagi na niedopasowanie symbolu i obudowy.

    Co do reszty elementów to też można to jednak lepiej rozmieścić.

    0
  • #16 03 Lut 2016 18:37
    Arturr300
    Poziom 8  

    Chodzi tylko o etykietki 230V_IN i 230V_OUT? Faktycznie, już zamieniłem. Jednak tak jak było chyba też by działało. Czy nie mam racji?

    Proszę o odpowiedź, bo nie wiem czy dobrze to zrozumiałem.

    0
  • Pomocny post
    #17 03 Lut 2016 20:01
    ZbeeGin
    Poziom 38  

    Nie chodzi o etykietki. Na schemacie masz poprawne połączenie. Triak załączany jest prądem pobieranym z A2. W triaku BTA41 wyprowadzenie A2 jest wyprowadzeniem środkowym.
    Tymczasem na płytce wyprowadzenie A2 masz na pinie zewnętrznym, co jest błędem niedopasowania symbolu na schemacie i przyporządkowanej mu obudowy. Anody triaka są na płytce zamienione, co w najgorszym przypadku spowoduje, że triak nigdy się nie włączy. Trzeba poprawić symbol w bibliotece by jedno z drugim się zgrało.

    Triak który wydaje się elementem symetrycznym w istocie takim nie jest i trzeba jednak uwzględniać kierunki prądów.

    0
  • #18 03 Lut 2016 22:39
    Arturr300
    Poziom 8  

    Hmmm, moim zdaniem jest poprawnie. Z tego co widzę to optotriak jest załączany poprzez A1 (a przynajmniej tak wywnioskowałem z datasheetów).
    Dołączam screeny:

    Kicad - Prośba o sprawdzenie płytki sterującej migomatu Kicad - Prośba o sprawdzenie płytki sterującej migomatu

    Nie chcę być upierdliwy, tylko moim zdaniem jest dobrze. Proszę o odpowiedź, bo się nie znam na tym w takim stopniu żeby być tego pewnym.

    0
  • Pomocny post
    #19 04 Lut 2016 06:30
    ZbeeGin
    Poziom 38  

    To co miałem na ten temat do powiedzenia już napisałem. Resztę - czyli dlaczego tak a nie inaczej - można znaleźć w sieci. Na początku wyskakuje nawet link do konkurencji gdzie jest to ładnie opisane.

    Co do ostatniej Twojej odpowiedzi to schemat jaki zamieściłeś teraz różni się od tego jaki wskazaliśmy Ci jako poprawny (w poście #5). Napiszę to jeszcze raz: Triak załączany jest prądem pobieranym z A2.

    0
  • #20 04 Lut 2016 09:10
    Arturr300
    Poziom 8  

    Już wszystko jasne... Po prostu wziąłem nie ten plik schematu... Wziąłem ten przed poprawką i wszystko dalsze utworzyłem według niego. Faktycznie według datasheeta triak jest załączany przez A2.
    Przepraszam za kłopoty, po prostu pomyłka z mojej strony. :)

    Nie chodzi mi o to, że nie podoba mi się że triak jest załączany tak, a nie inaczej. :) Wiem że poprawne podłączenie jest ważne, bo kiedyś się męczyłem dużo czasu z włączeniem triaka zanim odkryłem że jest odwrotnie podłączony.

    Tak więc zaraz poprawiam schemat, płytkę i niedługo biorę się za wytrawianie jej.

    Dzięki wielkie za pomoc ;)

    0
  • #21 24 Lut 2016 18:16
    Arturr300
    Poziom 8  

    Jeszcze takie pytanie:
    Na jaką moc powinny być rezystory w obwodzie optotriaka/triaka?
    W obecnej chwili na projekcie płytki rezystor 39R ma 2W, natomiast pozostałe mają 0,25W.
    Te drugie mają chyba za małą moc maksymalną, prawda?

    Jeżeli są za słabe, to zmienię je, bo jeszcze płytki nie wytrawiłem, a chciałbym żeby to działało bezawaryjnie :)

    0
  • #22 29 Lut 2016 12:27
    Arturr300
    Poziom 8  

    Proszę o odpowiedź, zależy mi na czasie.

    Myślałem, żeby dać 0,5W albo 1W. Które będą lepsze?


    Edit://
    Dałem rezystory 1W albo 2W (nie pamiętam dokładnie). Płytka działa, jednak w tym wykonaniu nie pomyślałem o rozmieszczeniu radiatorów - było trochę zabawy żeby je zamontować. Niektóre pady też niezbyt duże - sporo mi się odkleiło od PCB.

    Podczas prób spawania uszkodziły się LM350 i BTA41 (oczywiście nie na raz). Możliwe że przegrzałem podczas lutowania lub uszkodziły się od wyginania podczas montażu radiatorów.
    Obydwa scalaki miały zwarte wejścia i wyjścia. Do tego BTA41 podczas spawania zaczął się lekko palić, dymić i iskrzeć.

    Po wymianie wszystko śmiga. Jednak na triaki używane jako przekaźnik trzeba uważać - w momencie uszkodzenia mogą nam puścić napięcie wejściowe (w tym przypadku 230V) na wyjście, a my o tym możemy nie wiedzieć.

    Teraz na pewno bym trochę udoskonalił PCB :) Ważne jednak że migomat w końcu jest na chodzie.

    Temat zamykam, dziękuję wszystkim którzy uczestniczyli w tym temacie.
    Pozdrawiam.

    0