Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MikroTik + Netia Spot bridge - łączy się, pobiera adres a internetu brak - cuda

13 Sie 2015 04:55 1746 12
  • Poziom 10  
    Panowie mam taki problem - przestawiam Netia Spota w tryb bridge, pięknie świeci na różowo, mikrotik się elegancko wdzwania, w logach nie ma błędów a internetu nie ma. Co ciekawe identyczna sytuacja jest w momencie kiedy ustawię Netia Spota w trybie router (bo myślałem, że chociaż częściowo załatwię sprawę robiąc dmz na mikrotika) ale nic - to samo - mikrotik pobiera adresy ale neta tak samo nie ma.

    Podpinam ten sam router do sieci obok (radiówka) na tej samej zasadzie jak powyżej i wszystko pięknie śmiga. Co więcej na dmz mam podpiętego innego mikrotika do innego netiaspota w innej lokalizacji i tam wszystko śmiga bezproblemowo.

    Nie jest to kwestia dnsów - bo wbite na stałe dalej nie działają.
    Nie jest to kwestia tych samych podsieci na mikrotiku i netiaspocie.
    Mikrotik po wdzwonieniu pinguje do bramy ale już nie dalej.
    Soft najnowszy (mikrotika). Ns też świeży.
    Próbowałem na różnych portach w MT - to samo. W NS nie zmieniałem portu (Lan1) - ale jak się wdzwania, to raczej chyba nie ma sensu próbować na innych?

    Komp podpięty bezpośrednio do netiaspota w trybie router ma neta. W trybie bridge jeszcze nie próbowałem się wdzwaniać bezpośrednio.

    Router to RB2011UiAS-2HnD-IN (ale to raczej mało ważne).

    Szukałem pół nocy ale nie znalazłem jeszcze gdzieś indziej sytuacji, żeby wszystko niby działało ale neta nie było (niczego nie rozłącza itp.). Co to może być ewentualnie co jeszcze sprawdzić? Czy może to być coś po stronie mistrzów z Netii, czy raczej grzebać u siebie?
  • PCBway
  • Specjalista Sieci, Internet
    (dostawca)===(ns-tryb-router)===(MT)

    - czy na kompie podłączonym do NS jest net ? tak ? to pokaż "ipconfig /all"

    - załacz export z MT pod NS
    - z MT konsola pokaż ping do 8.8.8.8
    - z MT pokaż tracert do 8.8.8.8
  • PCBway
  • Poziom 10  
    Więc jakimś dziwnym trafem dzisiaj przy tej samej konfiguracji działa (chyba przez te temperatury wczorajsze miał udar ... :) ) Za to mam kolejny "problem". Chcę zmusić 2 wany do agregacji, tak jak na filmiku poniżej:
    https://www.youtube.com/watch?v=ThYBtmo_bcs



    Skrypt wygląda tak:

    // wan1
    // 192.168.2.4
    //
    // wan2
    // 192.168.0.38
    // Adresy są pobierane przez dhcp (ale są stałe)


    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

    add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=bridge-local
    add chain=prerouting dst-address=192.168.0.0/24 action=accept in-interface=bridge-local

    add chain=prerouting dst-address-type=!local in-interface=bridge-local per-connection-classifier=both-addresses­and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=bridge-local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

    add chain=prerouting connection-mark=WAN1_conn in-interface=bridge-local action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=bridge-local action=mark-routing new-routing-mark=to_WAN2

    /ip route
    add dst-address=0.0.0.0/0 gateway=192.168.2.4 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.0.38 routing-mark=to_WAN2 check-gateway=ping

    add dst-address=0.0.0.0/0 gateway=192.168.2.4 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.0.38 distance=2 check-gateway=ping

    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade



    Problem polega na tym, że wany działają ale osobno - cały ruch leci przez WAN1 (szybszy) no chyba, że go ubije, to aktywuje się WAN2...

    Będę wdzięczny za sugestie :)
  • Specjalista Sieci, Internet
    google load balancing multiple wan random

    musisz mieć losowo wybierane połączenia do WAN z twojego lanu, ale z wagami odpowiadającymi przepustowości WAN-ów.

    czyli dla każdego NOWEGO wychodzącego połączenia z twojego lanu przypisujesz losowa wan
  • Poziom 10  
    Wiesz co, z tego co widać na filmiku, który wstawiłem, to gość to ma skonfigurowane nie tak, że losowo przesyła dane z odpowiedniego wana, tylko dla JEDNEGO klienta, ciągnie elegancko z 2 naraz i ja chcę zrobić dokładnie coś takiego :) Jedyna różnica (mi znana) w konfiguracji, która jest u mnie to taka, że on przekierowuje ruch na konkretny interfejs (wlan2), a ja na całego bridga lokalnego...będę próbował na pojedynczym interfejsie czy zaskoczy.
  • Specjalista Sieci, Internet
    szmalu napisał:
    JEDNEGO klienta, ciągnie elegancko z 2 naraz

    nie ma takich cudów na dwóch niezależnych WAN-ach . Taka agregacja wymagałoby współpracy drugiej strony, tzn wanu od strony dostawcy.

    Pakeity jednego połączenia (TCP/UPD) nie mogą mieć różnych adresów żródłowych a tak byłoby gdyby sobie pakiety dla danego połączenia tcp/udp leciały raz po wan1 a raz po wan2.

    EDIT:
    no chyba że masz na myśli że jeden klient (komputer) używa 2 wanów, to się zgodzę, losowy wybór wan-u dla połączeń tcp/ip powinno puszczać połączenia przez wan1/wan2 losowo.
  • Poziom 10  
    Ok, już zrobiłem tak jak chciałem - okazało się, że bruździły tu adresy wan pobierane przez dhcp. Powodowało to tworzenie nowych, dynamicznych routów (przy każdorazowym pobraniu adresu). Po ich usunięciu śmiga pięknie. Jednak przy każdym rozłączeniu sieci wan (i połączeniu na nowo) trzeba by było robić to ponownie, dlatego skonfigurowałem wany na stałych adresach. Netia dalej nie chce dać neta przy bridgu, ale na dzień dzisiejszy mam to puszczone przez dmz i chyba na tym poprzestanę.
  • Poziom 10  
    Dwa dni spokoju i problem wrócił jak bumerang:

    Pingi
    Cytat:
    SEQ HOST SIZE TTL TIME STATUS
    0 8.8.8.8 56 50 614ms
    1 8.8.8.8 timeout
    2 8.8.8.8 56 50 338ms
    3 8.8.8.8 56 50 616ms
    4 8.8.8.8 56 50 614ms
    5 8.8.8.8 56 50 240ms
    6 8.8.8.8 56 50 634ms
    7 8.8.8.8 56 50 608ms
    8 8.8.8.8 56 50 680ms
    9 8.8.8.8 56 50 606ms
    10 8.8.8.8 56 50 376ms
    11 8.8.8.8 56 50 661ms
    12 8.8.8.8 56 50 675ms
    13 8.8.8.8 56 50 643ms
    14 8.8.8.8 56 50 591ms
    15 8.8.8.8 56 50 647ms
    16 8.8.8.8 56 50 494ms


    Traceroute:
    Cytat:
    # ADDRESS LOSS SENT LAST AVG BEST WORST STD-DEV STATUS
    1 192.168.2.254 0% 2 5.9ms 3.3 0.6 5.9 2.7
    2 83.238.252.44 50% 2 timeout 136.5 136.5 136.5 0
    3 83.238.251.174 0% 2 503.7ms 286.7 69.6 503.7 217.1
    4 83.238.251.98 0% 2 595.7ms 506.6 417.4 595.7 89.2
    5 213.195.141.49 0% 2 655.5ms 516.8 378.1 655.5 138.7
    6 66.249.95.13 0% 2 642.3ms 561.2 480.1 642.3 81.1
    7 216.239.50.217 0% 2 674.9ms 647.3 619.7 674.9 27.6 <MPLS:L=783048,E=4>
    8 100% 2 timeout
    9 100% 2 timeout
    10 100% 2 timeout
    11 8.8.8.8 0% 1 600.3ms 600.3 600.3 600.3 0


    Export:
    Cytat:
    [admin@problem] > export
    # aug/18/2015 06:48:15 by RouterOS 6.23
    # software id = SQ20-1YFF
    #
    /interface bridge
    add admin-mac=4C:5E:0C:06:92:8A auto-mac=no name=bridge-local
    /interface ethernet
    set [ find default-name=ether9 ] name=NETIA
    set [ find default-name=ether10 ] disabled=yes name=WAN2
    set [ find default-name=ether6 ] name=ether6-master-local
    set [ find default-name=ether7 ] master-port=ether6-master-local name=\
    ether7-slave-local
    set [ find default-name=ether8 ] master-port=ether6-master-local name=\
    ether8-slave-local
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=\
    20/40mhz-ht-above country=poland disabled=no distance=indoors frequency=\
    auto l2mtu=2290 mode=ap-bridge ssid=WiFi tx-power=30 tx-power-mode=\
    all-rates-fixed wireless-protocol=802.11
    /ip neighbor discovery
    set ether1 discover=no
    /interface wireless security-profiles
    set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik wpa-pre-shared-key=***** \
    wpa2-pre-shared-key=*****
    /ip pool
    add name=dhcp ranges=192.168.1.100-192.168.1.220
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=bridge-local name=default
    /port
    set 0 name=serial0
    /interface bridge port
    add bridge=bridge-local interface=ether2
    add bridge=bridge-local interface=ether3
    add bridge=bridge-local interface=ether4
    add bridge=bridge-local interface=ether5
    add bridge=bridge-local interface=ether6-master-local
    add bridge=bridge-local interface=sfp1
    add bridge=bridge-local interface=wlan1
    add bridge=bridge-local interface=ether1
    /ip address
    add address=192.168.1.1/24 comment="default configuration" interface=\
    bridge-local network=192.168.1.0
    add address=192.168.2.4/24 interface=NETIA network=192.168.2.0
    add address=192.168.0.38/24 interface=WAN2 network=192.168.0.0
    /ip dhcp-server network
    add address=192.168.1.0/24 comment="default configuration" dns-server=\
    8.8.8.8,8.8.4.4 gateway=192.168.1.1 netmask=24
    /ip dns
    set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
    /ip dns static
    add address=192.168.1.1 name=router
    /ip firewall filter
    add chain=input comment="Accept established connections" connection-state=\
    established
    add chain=input comment="Accept related connections" connection-state=related
    add action=drop chain=input comment="Drop invalid connections" \
    connection-state=invalid
    add chain=input comment=UDP protocol=udp
    add chain=input comment="Allow limited pings" limit=50/5s,2 protocol=icmp
    add action=drop chain=input comment="Drop excess pings" protocol=icmp
    add chain=input comment="SSH for secure shell" dst-port=22 protocol=tcp
    add chain=input comment=winbox dst-port=8291 protocol=tcp
    add chain=input comment=WAN1 src-address=192.168.2.0/24
    add chain=input comment=WAN2 src-address=192.168.0.0/24
    add chain=input comment=LAN src-address=192.168.1.0/24
    add action=log chain=input comment="Log everything else" log-prefix=\
    "DROP INPUT"
    add action=drop chain=input comment="Drop everything else"
    /ip firewall mangle
    add action=mark-connection chain=input in-interface=NETIA \
    new-connection-mark=WAN1_conn
    add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=\
    WAN2_conn
    add action=mark-routing chain=output connection-mark=WAN1_conn \
    new-routing-mark=to_WAN1
    add action=mark-routing chain=output connection-mark=WAN2_conn \
    new-routing-mark=to_WAN2
    add chain=prerouting dst-address=192.168.2.0/24 in-interface=bridge-local
    add chain=prerouting dst-address=192.168.0.0/24 in-interface=bridge-local
    add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=bridge-local new-connection-mark=WAN1_conn \
    per-connection-classifier=both-addresses-and-ports:2/0
    add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=bridge-local new-connection-mark=WAN2_conn \
    per-connection-classifier=both-addresses-and-ports:2/1
    add action=mark-routing chain=prerouting connection-mark=WAN1_conn \
    in-interface=bridge-local new-routing-mark=to_WAN1
    add action=mark-routing chain=prerouting connection-mark=WAN2_conn \
    in-interface=bridge-local new-routing-mark=to_WAN2
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=NETIA
    add action=masquerade chain=srcnat out-interface=WAN2
    /ip route
    add check-gateway=ping distance=1 gateway=192.168.2.254 routing-mark=to_WAN1
    add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=to_WAN2
    add check-gateway=ping distance=1 gateway=192.168.2.254
    add check-gateway=ping distance=2 gateway=192.168.0.1
    /lcd interface pages
    set 0 interfaces="sfp1,ether1,ether2,ether3,ether4,ether5,ether6-master-local,\
    ether7-slave-local,ether8-slave-local,NETIA,WAN2"
    /system clock
    set time-zone-name=Europe/Warsaw
    /system identity
    set name="problem"
    /system ntp client
    set enabled=yes primary-ntp=149.156.44.126 secondary-ntp=213.199.225.30
    /tool mac-server
    set [ find default=yes ] disabled=yes
    add interface=ether2
    add interface=ether3
    add interface=ether4
    add interface=ether5
    add interface=ether6-master-local
    add interface=ether7-slave-local
    add interface=ether8-slave-local
    add interface=NETIA
    add interface=WAN2
    add interface=sfp1
    add interface=wlan1
    add interface=bridge-local
    /tool mac-server mac-winbox
    set [ find default=yes ] disabled=yes
    add interface=ether2
    add interface=ether3
    add interface=ether4
    add interface=ether5
    add interface=ether6-master-local
    add interface=ether7-slave-local
    add interface=ether8-slave-local
    add interface=NETIA
    add interface=WAN2
    add interface=sfp1
    add interface=wlan1
    add interface=bridge-local


    Co do podłączenia bezpośrednio z kompem to dane są na przykład takie:
    IP: 192.168.2.1
    Maska: 255.255.255.0
    Bramka: 192.168.2.254

    Dnsy googlowskie i śmiga jak złoto. Śmiga na dynamicznym ip, na stałym ip jak i zbridżowane z netiaspotem... Pomysły :) ?

    I nie jest to problem z portem bo podpinałem do innego i ta sama sprawa - internet praktycznie nie działa. (transfery rzędu 200kilobitów i chore! pingi) - testy oczywiście na wyłączonym WAN2.
  • Specjalista Sieci, Internet
    Z komputera pokaż

    tracert -d 8.8.8.8
    ipconfig
  • Poziom 10  
    tracert z kompa:
    Cytat:
    Śledzenie trasy do google-public-dns-a.google.com [8.8.8.8]
    z maksymalną liczbą 30 przeskoków:

    1 <1 ms <1 ms <1 ms netiaspot.home [192.168.2.254]
    2 10 ms 15 ms 34 ms 83.238.252.44
    3 8 ms 11 ms 11 ms 83.238.251.174
    4 17 ms 15 ms 15 ms WarsC001RT06-WarsH002RT22.inetia.pl [83.238.251.
    98]
    5 15 ms 48 ms 27 ms lo67-cp.pie.warszawa.sint.pl [213.195.141.49]
    6 14 ms 14 ms 15 ms 66.249.95.13
    7 33 ms 33 ms 33 ms 216.239.50.217
    8 33 ms 33 ms 33 ms 216.239.46.15
    9 * * * Upłynął limit czasu żądania.
    10 35 ms 35 ms 34 ms google-public-dns-a.google.com [8.8.8.8]

    Śledzenie zakończone.



    ipconfig z kompa:
    Cytat:
    Konfiguracja IP systemu Windows

    Karta Ethernet Połączenie lokalne:

    Sufiks DNS konkretnego połączenia : home
    Opis. . . . . . . . . . . . . . . : Intel(R) 82579LM Gigabit Network Connecti
    on
    Adres fizyczny. . . . . . . . . . : F0-AA-C3-BB-AA-11
    DHCP włączone . . . . . . . . . . : Tak
    Autokonfiguracja włączona . . . . : Tak
    Adres IPv4. . . . . . . . . . . . . : 192.168.2.1(Preferowane)
    Maska podsieci. . . . . . . . . . : 255.255.255.0
    Dzierżawa uzyskana. . . . . . . . : 18 sierpnia 2015 04:44:54
    Dzierżawa wygasa. . . . . . . . . : 19 sierpnia 2015 10:54:34
    Brama domyślna. . . . . . . . . . : 192.168.2.254
    Serwer DHCP . . . . . . . . . . . : 192.168.2.254
    Serwery DNS . . . . . . . . . . . : 192.168.2.254
    NetBIOS przez Tcpip . . . . . . . : Włączony
  • Specjalista Sieci, Internet
    Ping do 8.8.8.8 jest 35ms, zatem w czym problem ?
  • Poziom 10  
    Jak to w czym problem? :)

    W tym, że to w kompie podpiętym bezpośrednio do NS ? a potrzebuje takie w kompie za MT...
  • Specjalista Sieci, Internet
    Reset MT, podstawową konfigurację MT jako router, wan na DHCP lub static (tak jak komp teraz), podłącz

    NS == MT === KOMP

    pokaz z komputera
    tarcert -d 8.8.8.8
    ping 8.8.8.8
    ipconfig