Elektroda.pl
Elektroda.pl
X
Napad.pl
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Usunięcie serwera SBS z sieci biura

drakerc 20 Sie 2015 04:13 657 7
  • #1 20 Sie 2015 04:13
    drakerc
    Poziom 6  

    Witam,

    pomagam znajomemu w dokonaniu kilku zmian w sieci w biurze (liczącym ok. 40 komputerów + drukarki + dysk NAS). Przede wszystkim głównym celem jest usunięcie z sieci serwera bazującego na Windows SBS 2003. Jest to dość stara maszyna (z bodajże 2006r), która ciągnie mnóstwo prądu, ponadto padł jeden zasilacz. Serwer obecnie pełni tylko jedną rolę - przekazuje dostęp do internetu reszcie sieci oraz czasami sluzy do konfiguracji innych urzadzen w firmie. Stąd też chcemy zlikwidować go z sieci, bo jest praktycznie niepotrzebny
    Jeden "informatyk" był już w biurze by obadać sytuację i stwierdził, że wystarczy fizycznie odpiąc serwer i wszystko będzie OK, dostęp sieciowy ominie serwer automatycznie itd. Oczywiście w żadnym wypadku tak nie jest - po odpięciu serwera siada cały internet w firmie.

    Niestety, ale byłem dziś tylko przejazdem w biurze i mogłem na chwilę spojrzeć na konfigurację sprzętu, a raczej rzucić okiem - "serwerownia" to malutkie pomieszczenie z milionem poupychanych kabli, ponadto lecą też kable do monitoringu oraz do systemu telefonicznego oraz pagera. Czy jest to jednak możliwe, by taki konfig funkcjonował?:

    Jest internet z firmy, idzie do modemu DSL, potem z modemu internet leci do firewalla sprzętowego, a następnie z firewalla idzie do pierwszej karty sieciowej w serwerze, gdzie soft (wydaje mi się ze Microsoft NAT, czy też jest cos innego do udostępniania internetu w Windows Server 2003?) udostępnia sieć przez drugą kartę sieciową, a to idzie do switcha (48 portowy) i dalej do klientów.

    obrazowo:

    internet -> modem DSL -> firewall -> karta sieciowa serwera nr 1 -> karta sieciowa serwera nr 2 -> switch -> komputery klientów

    W takim więc wypadku wydaje mi się właśnie, że to połączenie powoduje, że po wypięciu serwera brakuje internetu w firmie.

    Czy w takim razie gdybym zastosował takie połączenie:
    internet -> modem -> firewall -> switch -> komputery klientów
    będzie ok bez serwera?

    0 7
  • Napad.pl
  • #2 20 Sie 2015 05:00
    PRL
    Poziom 34  

    Cytat:
    Czy w takim razie gdybym zastosował takie połączenie:
    internet -> modem -> firewall -> switch -> komputery klientów
    będzie ok bez serwera?


    Nie będzie, bo SBS pełni rolę routera, stąd też zamiast tej maszyny wstaw router i będzie ok. Oczywiście, jeżeli komputery logują się do domeny, to skopiuj dane z AD na dysk lokalny maszyny i zmień na pracę w grupie roboczej.

    0
  • Napad.pl
  • #3 20 Sie 2015 05:28
    drakerc
    Poziom 6  

    Tak, komputery używają domeny serwera, już większość jest odłączona i tylko korzysta z grupy roboczej zamiast tego; resztę zmienię potem.

    Czy router jest na pewno wymagany? Modem DSL podaje internet do firewalla, który z tego co pamiętam jest jednocześnie czymś w rodzaju routera (nawet w instrukcji pisze "Gigabit Firewall VPN Router" - jest to Netgear FVS336G. Więc ten firewall-router podałby łącze dalej do switcha . Czy coś takiego działałoby, czy muszę mieć dedykowany router?
    W panelu admina firewalla pamiętam nawet, że były opcje do routingu, mozna było wybrać NAT albo klasyczny routing, więc chyba starczy?

    0
  • Pomocny post
    #4 20 Sie 2015 06:54
    jprzedworski
    Specjalista Sieci, Internet

    Netgear FVS336G w zupełności wystarczy. Pytanie tylko, jak to wszystko jest skonfigurowane. Spróbuj bezpośrednio do jego wyjścia (ma 4 porty LAN) podłączyć jakiś komputer, który nie jest w domenie (czyli nie wymaga jakiegoś logowania domenowego), z kartą sieciową skonfigurowaną na "auto" i zobacz, czy będzie na nim internet. Jeśli tak, to połowa sukcesu.
    W serwerze mogą być uruchomione serwery DHCP i DNS i komputery z niego pobierają konfigurację i rozwiązują URL. W takim układzie prawdopodobnie Netgear tych funkcji nie pełni. Trzeba by wtedy skonfigurować na nim te serwery.
    A tak przy okazji - przechodzenia z domeny na grupę roboczą, przy tej liczbie sprzętu, to bardzo duże pogorszenie funkcjonalności i utrudnienie dla administratora. Ja bym zmienił na inny, nowszy, mniejszy, oszczędniejszy serwer. Ale jeśli ktoś woli jeździć rowerem zamiast samochodem ......

    1
  • #5 20 Sie 2015 16:32
    drakerc
    Poziom 6  

    Po odłączeniu serwera i podłączeniu modem -> firewall -> switch oraz podłączeniu laptopa z automatycznymi ustawieniami sieciowymi do firewalla/routera, jest połączenie na tym laptopie, ale za to switch nie ma internetu.

    Na serwerze był ustawiony DHCP, ale na odwał - ustawiłem taki sam serwer DHCP na firewallo-routerze.

    Nie mam chwilowo możliwości podłączenia się do switcha - to jakaś jednostka biznesowa, też Netgear i nie ma panelu webowego, tylko trzeba fizycznie się podłączyć i korzystać z ichniejszego softu, który ponadto jest zabezpieczony hasłem, a kolega go dopiero szuka :). Czy dobrze myślę, że powodem dla którego switch nie ma dostępu do internetu może być to, że jest skonfigurowany "na sztywno" na korzystanie z jakiegoś IP, które podawał serwer i innych ustawień sieciowych i to jest powód?

    0
  • #6 20 Sie 2015 18:10
    jprzedworski
    Specjalista Sieci, Internet

    drakerc napisał:
    switcha - to jakaś jednostka biznesowa, też Netgear
    Ma jakąś nazwę?

    0
  • #7 20 Sie 2015 19:19
    drakerc
    Poziom 6  

    Netgear GS748T

    Routero-firewall routuje internet przez NAT z WAN do LAN, a kabel LAN leci do switcha. IP routera jest na podsieci 192.168.1.x (router to 192.168.1.1). Serwer DHCP jest wyłączony, ale włączenie na odpowiedniej konfiguracji nic nie zmienia.

    Switch skonfigurowany był na pobieranie swojego IP przez DHCP, ale jako że DHCP raczej nie działało, to zawsze miał domyślne IP (192.168.0.239). Ustawiłem ręcznie, by IP było w tej samej podsieci co router, ale oczywiscie to nic nie dało (192.168.1.239).


    Druga sprawa jest następująca. Z tego co widzę na serwerze, firewall jest skonfigurowany na podsieć 192.168.1.x, natomiast klienci oraz serwer są na podsieci 192.168.16.x. A więc w obecnej konfiguracji firewall podaje internet do karty sieciowej nr 1 (o ip 192.168.1.2), która daje internet drugiej karcie na drugiej podsieci 192.168.16.x (serwer to 192.168.16.12).
    Tak więc coś się gryzie?
    Próbowałem przestawić całość na podsieć 192.168.16... Zmieniłem IP routera/firewalla oraz switcha i z wyłączonym serwerem nadal coś się gryzło - brak internetu, a nawet nie można było spingować firewalla/routera po takim czymś.

    0
  • #8 21 Sie 2015 14:05
    pioflo
    Poziom 16  

    na SBS 2003 byla pewnie uruchomiona ISA. z tego co pamietam na koncowkach trzeba bylo usunac oprogramownie od tego- to sie nazywalo Firewall Client chyba.

    Z tymi adresami nic sie nie gryzlo raczej: serwer mial brame na firewall, a klienci mieli brame na serwer.

    Jesli masz tylko 1 vlan w sieci to adres switcha nie ma wiekszego znaczenia (to tylko adres do jego zarządzania, bedzie poprawnie dzialac nawet ze zlym adresem)

    0