Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Procesor i7 - jak wymusić wyższą częstotliwość?

21 Sie 2015 19:32 3807 17
  • Poziom 6  
    Witam serdecznie,
    proszę o pomoc w ustawieniu/wymuszeniu wyższej częstotliwości pracy procesora.
    Posiadam nienajgorszy, choć może już nieco sędziwy komputer ThinkPad W510 z procesorem Intel Core i7 CPU Q720 1.6GHz. Aktualnie Windows 10 Prof.

    Problem polega na tym, że komputer podczas mało wysiłkowej pracy (przeglądarka) utrzymuje procesor na poziomie 0.91GHz przez co mocno muli (oglądanie chociażby filmów na YouTubie jest dla niego wówczas wyzwaniem), co najdziwniejsze - choć może - nie zwiększa szybkości procesora. Przy odpalaniu większych programów podwyższa taktowanie (nawet do 2.4GHz) i wszystko jest ok.
    Od razu mówię, że zmiany w ustawieniach zasilania (minimalny i maksymalny stan procesora) niczego nie zmieniają - pozostałe są domyślne. Co najdziwniejsze, przy identycznych ustawieniach zasilania bateryjnego i z sieci, komputer na zasilaniu bateryjnym działa normalnie - na sieci - zamula.
    Problem pojawia się od dłuższego czasu, na wszystkich systemach (win7, 8, 8.1, 10). Proszę o pomoc, bo już brak pomysłów i cierpliwości ;)
    Wystarczyłoby mu narzucić minimalne taktowanie na 1.5GHz albo 1.6 (jak to ma zapisane w nazwie) i byłoby świetnie, ale jak??
  • Poziom 6  
    Sterowniki zainstalowane.
    1. Dawniej - Instalując Windows7 z oryginalnych płyt z backupem (gdzie był system, wszystkie sterowniki i specjalne programy wspierające od Lenovo)
    2. W Windowsie 8 i 10 samoczynnie instaluje sterowniki.


    Z obserwacji użytkownika:
    Podczas niedużego obciążenia procesora tj. poniżej 40% CPU na taktowaniu 0.9GHz, komputer niewydala, gdy następuje skok powyżej 40% działa technologia (jak to sobie tłumaczę) i7 i zwiększa taktowanie do np. 1.34 GHz.
    Moje przypuszczenie (i obawy) są następujące:
    Mam fizycznie uszkodzony jeden z wątków i to akurat ten, na którym stale pracuje komputer, wiec gdy 'zaciąga do pracy' kolejne, wszystko wraca do normy. Ale to takie tłumaczenie zielonego. :D
  • Poziom 20  
    Mormarx napisał:
    Sterowniki zainstalowane.
    1. Dawniej - Instalując Windows7 z oryginalnych płyt z backupem (gdzie był system, wszystkie sterowniki i specjalne programy wspierające od Lenovo)
    2. W Windowsie 8 i 10 samoczynnie instaluje sterowniki.


    Z obserwacji użytkownika:
    Podczas niedużego obciążenia procesora tj. poniżej 40% CPU na taktowaniu 0.9GHz, komputer niewydala, gdy następuje skok powyżej 40% działa technologia (jak to sobie tłumaczę) i7 i zwiększa taktowanie do np. 1.34 GHz.
    Moje przypuszczenie (i obawy) są następujące:
    Mam fizycznie uszkodzony jeden z wątków i to akurat ten, na którym stale pracuje komputer, wiec gdy 'zaciąga do pracy' kolejne, wszystko wraca do normy. Ale to takie tłumaczenie zielonego.


    W planie zasilania ustaw sobie max wydajność by zwiększyć bazową częstotliwość.
  • Poziom 6  
    Jakiekolwiek zmiany opcji zasilania nie pomagają.
    Czy to niska, zrównoważona czy wysoka wydajność. Minimalny stan procesora 10, 90, czy 100% też bez skutków.

    Przy IDENTYCZNYCH ustawieniach w opcjach zasilania, dla zasilana bateryjnego i z sieci, komputer na sieci niedomaga, a na baterii działa normalnie.
  • Pomocny post
    Poziom 20  
    Mormarx napisał:
    komputer na sieci niedomaga, a na baterii działa normalnie


    Wykluczyłeś kwestię słabego zasilacza?

    Mormarx napisał:
    Minimalny stan procesora 10, 90, czy 100% też bez skutków


    U mnie na trybie "minimum" bazowa predkość to około 0.7GHz a na max wydajność skacze do 2.4GHz (otwarta opera ,8 zakładek windows 8.1, czysty system). Wprawdzie te wartości podaje z dwurdzeniowego procesora i5 czwartej generacji ale tak to powinno działać.

    Można wyłączyć funkcje SpeedStep w biosie. Testowałeś?
  • Poziom 6  
    Problemy z zasilaczem wykluczam, chociażby z tego względu, że nie sprawia problemów gdy pracuje na wyższych obrotach.

    Funkcję SpeedStepa oczywiście sprawdzałem, jednakże jej wyłączenie pozbawia mnie też wyższego taktowania (1.6-2.4 GHz), a nie o to chodzi, raczej o to by nie schodził poniżej 1.2 i będzie ok. Jak to zatem zrobić zrobić?
  • Pomocny post
    Poziom 20  
    Mormarx napisał:
    a nie o to chodzi, raczej o to by nie schodził poniżej 1.2 i będzie ok. Jak to zatem zrobić zrobić?


    Zrób diagnostykę z poziomu biosu.

    U siebie widzę różnice (windows 7 z i7 2920xm jak i na win 8.1 z i5-4200U) w taktowaniu po zmianie profilu zasilania.

    Mormarx napisał:
    Mam fizycznie uszkodzony jeden z wątków

    Wątpię bo to nie sprzętowe a programowe rozwiązanie.. Fizyczne uszkodzenie procesora to raczej rzadki problem no chyba, że coś modyfikowano ale nawet wtedy powinno zgłosić się "ostrzeżenie".

    Dobrze przetestować różne ustawienia a nie tylko ograniczać się tylko do obserwacji parametrów..zwłaszcza, że na baterii wszystko działa. Potem przywróć ustawienia fabryczne!

    Mormarx napisał:
    0.91GHz przez co mocno muli (oglądanie chociażby filmów na YouTubie jest dla niego wówczas wyzwaniem), co najdziwniejsze - choć może - nie zwiększa szybkości procesora. Przy odpalaniu większych programów podwyższa taktowanie (nawet do 2.4GHz) i wszystko jest ok.


    Niskie taktowanie nie powinno być tu problemem, zwłaszcza u ciebie. Masz cztery procesory.. zostało to wspomniane. U mnie na dwóch przy niższym (0.7GHz) nie przycina.

    Jeśli YouTube przycina to prędzej przez "internet" a nie słaby procesor. Zresztą na samej baterii "działa".. A jak wyciągniesz baterie?? Gdzieś przy okazji testów ( na baterii i baterii z zasilaczem) jakiegoś laptopa pisali, że była różnica w taktowaniu..

    Dodano po 3 [godziny] 24 [minuty]:

    Mormarx napisał:


    Funkcję SpeedStepa oczywiście sprawdzałem, jednakże jej wyłączenie pozbawia mnie też wyższego taktowania (1.6-2.4 GHz), a nie o to chodzi, raczej o to by nie schodził poniżej 1.2 i będzie ok. Jak to zatem zrobić zrobić?


    Turbo boost za to odpowiada wiec wyłącz funkcje SpeedStep.. do testów. Oczywiście nie polecam bez wydajnego chłodzenia! Docelowo nie jest to dobre rozwiązanie. Poniżej tak to wygląda (w dużym uproszczeniu) :

    <-----------------CPU szybkość---------------->
    [speed step][bazowaszybkość ][turbo boost] gdzie dla ciebie baza to 1.6 GHz (3-4 CPU ) ale 2.4GHz jest już tylko dla dwóch procesorów.
  • Poziom 6  
    Bardzo mnie Pan pocieszył stwierdzając, że to raczej softwarowy problem - zatem do rozwiązania.
    Dla przypomnienia powiem, że testowałem przeróżne ustawienia zasilania i wydajności z poziomu windowsa - bezskutecznie...
    Panie Piotrze, przykład z przycinającym youtube, był tylko przykładam i oczywiście częstotliwość pracy procesora ma wpływ na buforowanie (a więc i przycinanie się filmów), net 100Mb.

    Jeśli chodzi o diagnostykę CPU z poziomu BIOSa, to niezupełnie wiem jak, dlatego też podrzucam kilka screenów z BIOSA (z góry przepraszam za jakość)
    Procesor i7 - jak wymusić wyższą częstotliwość?
    Jak widać, wersja z 2012 roku, jednakże na stronie lenovo niczego nowszego nie ma http://support.lenovo.com/pl/pl/products/lapt...books/thinkpad-w-series-laptops/thinkpad-w510

    Config:
    Procesor i7 - jak wymusić wyższą częstotliwość?

    No i nasze CPU:
    Procesor i7 - jak wymusić wyższą częstotliwość?

    Procesor i7 - jak wymusić wyższą częstotliwość?

    Warto byłoby tu zadać pytanie pod czym kryje się technologia i7 i wspominany Speedstep?
  • Poziom 20  
    Mormarx napisał:
    Warto byłoby tu zadać pytanie pod czym kryje się technologia i7 i wspominany Speedstep?
    To trzeba sobie poszukać samemu jeśli to nie wystarczy: Udoskonalona technologia Intel SpeedStep® zapewnia wysoką wydajność przy jednoczesnym obniżeniu zapotrzebowania na energię, istotnego w przypadku systemów przenośnych. Tradycyjna technologia Intel SpeedStep® przełącza zarówno napięcie, jak i częstotliwość pomiędzy wysokimi i niskimi poziomami w odpowiedzi na obciążenie procesora. Udoskonalona technologia Intel SpeedStep® powstała w oparciu o tę architekturę z zastosowaniem takich strategii konstrukcyjnych, jak oddzielenie zmian napięcia i częstotliwości zegara oraz dystrybucja i przywracanie sygnału zegarowego.

    Na ostatnim zdjęciu zauważyłem ,że "intel hyper threading" (Technologia Intel® Hyper-Threading (Intel® HT) zapewnia dwa wątki przetwarzania na każdy rdzeń procesora. Dzięki technologii HT wielowątkowe aplikacje wykonują więcej zadań jednocześnie w krótszym czasie.) jest wyłączony a MA być włączony. O tym jest sporo informacji.

    Mormarx napisał:
    oczywiście częstotliwość pracy procesora ma wpływ na buforowanie (a więc i przycinanie się filmów), net 100Mb.


    Już pisałem , że mam jeszcze niższe taktowanie procesora dwurdzeniowego a nic mi nie przycina przy internecie 4Mb.

    Być może nie ma z poziomu biosu (diagnostyki) ale na stronie można pobrać narzędzie dla wybranego systemu :
    https://support.lenovo.com/pl/pl/lenovodiagnosticsolutions/downloads

    A tutaj trzeba pobrać to co potrzebne do nowego systemu(sterowniki) :

    http://support.lenovo.com/pl/pl/products/lapt...books/thinkpad-w-series-laptops/thinkpad-w510

    Ps jak jest problem ze sprzętem to podaje się całą specyfikację najlepiej z wersją systemu i sposobem jej instalacji oraz zainstalowanymi sterownikami. Od tego powinien zacząć się wątek.
  • Poziom 2  
    Witam panowie czy możecie opowiedzieć jak sie sytuacja zakończyła co pomogło , mam identyczny problem na W510. przy użyciu procesora powyżej 40% taktowanie spada do 930MHz i stoi a na zasilaniu z baterii wartość taktowania jest stała 1500MHz.
  • Poziom 6  
    Niestety nie znalazłem sensownego rozwiązania, wyłączyłem technologię TurboBoast (czyli coś za co zapłaciłem), osiągam stałe taktowanie 1.5, więc komp nie muli - w prostych czynnościach, ale nie pociągnie w ten sposób bardziej wymagających programów. Czyli ogólnie słabo, bo nadal nie wiadomo w czym jest problem.
  • Poziom 20  
    Wyjściowe taktowanie dla 4 rdzeni jest ok 1.7 więc to nie jest wyznacznik, że coś nie działa. Sam sobie wył możliwość wyższego taktowania. 2.8 działa ponoć tylko na jednym rdzeniu.

    2800 MHz (1 core)
    2400 MHz (2 cores)
    1733 MHz (3 or 4 cores)
  • Poziom 6  
    Problem jest inny, bo nie do końca chodzi o taktowanie.
    0.9 dla prostych czynności nie powinno być problemem.
    Natomiast z włączoną technologią Turboboast, procek oszczędza energię, zmniejsza taktowanie do 0.9, komputer się dosłownie dusi, otwarcie przeglądarki zajmuje mu kilkadziesiąt sekund, już samo uruchomienie komputera jest o nawet kilka minut dłuższe aniżeli z wyłączoną technologią (w której z dyskiem SSD komp uruchamia się w niespełna 20s),

    Aktualizacji biosa brak (ostatnia z 2012), ustawieniami windowsa (zasilania) nie udało się nic zaradzić.
    Tak więc można jedynie zmieniać ustawienia, w tym wypadku wyłączyć tę technologię, i stracić wyższe taktowania (dla generacji procków dla W510 wynosi chyba 2.1)
  • Poziom 2  
    CPU-Z wyższe taktowanie wskazuje na 4 procesorach zarówno core 0,1,2 i 3. Problem jest naprawde dziwny , ponieważ na zasilanu bateryjnym taktowanie jest 1500 dokładnie najmniejsza wartość a czasami załacza turbo jak potrzebuje duzo mocy obliczeniowej. Natomiast przy wyłaczeniu turbo ( 4 watki procesora) sytacja jest taka sama jak z turbo. Przy dysku ssd na baterii komputer dziala zadowalająco lecz na zasilaczu tragedia zasilacz nowy 135W sprawdzony miernikiem wiec wade zasilacza wykluczam.
    Sterowniki chyba juz wszystki jakie sa mozliwe z support lenovo zainstalowane.
  • Pomocny post
    Poziom 20  
    Mormarx napisał:

    Natomiast z włączoną technologią Turboboast, procek oszczędza energię, zmniejsza taktowanie do 0.9, komputer się dosłownie dusi, otwarcie przeglądarki zajmuje mu kilkadziesiąt sekund, już samo uruchomienie komputera jest o nawet kilka minut dłuższe aniżeli z wyłączoną technologią (w której z dyskiem SSD komp uruchamia się w niespełna 20s),


    Mi to na problem z dyskiem lub tym "sprawdzonym" zasilaczem wygląda a nie procesorem. Ja mam tylko dwa rdzenie w i5 , które działają na 0.76GHz i zapewnia to płynne działanie (sprawdzone teraz a mam 14-zakładek otwartych).

    Mormarx napisał:

    Natomiast z włączoną technologią Turboboast, procek oszczędza energię, zmniejsza taktowanie do 0.9,


    Chyba dalej nie wiesz o co chodzi z tymi "boostami". W skrócie ta technologia podnosi a nie obniża. Jak byś poczytał posty to byś wiedział.
  • Pomocny post
    Admin grupy audio
    Mormarx napisał:
    już samo uruchomienie komputera jest o nawet kilka minut dłuższe aniżeli z wyłączoną technologią (w której z dyskiem SSD komp uruchamia się w niespełna 20s),

    To po co Ci tam dysk SSD? Mój komputer stacjonarny ze standardowym dyskiem HDD i to jeszcze PATA uruchamia się dokładnie 47s od momentu włączenia go przyciskiem. :)

    Nie pojawiają się jakieś zwiechy albo bsody co jakiś czas? Mnie to nie wieje ani dyskiem, ani zasilaczem. Raczej skojarzyłbym to z przegrzewaniem się procesora lub chipsetu, albo może zaczyna się chipset "odklejać". Sprawdziłbym temperatury i gnał do serwisu, bo takie zachowanie normalnym nie jest. Jak pisałem wcześniej - przy taktowaniu 0.9GHz komputer powinien pracować poprawnie (i jak widać nie tylko ja jestem tego zdania).
  • Poziom 6  
    ROZWIĄZANIE PROBLEMU

    Witam wszystkich serdecznie, problem opisany powyżej (słabe parametry pracy na zasilaniu sieciowym i b.dobre na bateryjnym) ma banalne rozwiązanie - przynajmniej w tym wypadku. Podejrzewałem problemy na płycie głównej z układem sterowania zasilaniem, a okazało się że to.... zasilacz.
    Niektórzy producenci do konkretnego modelu laptopa rekomendują kilka zasilaczy. Miałem oryginalny, sprawny zasilacz lenovo 90W 20V (rekomendowany przez producenta), który to powodował ten problem. Po wymianie na oryginalny 135W 20V komputer działa nieporównywalnie szybciej. Spokojnie wchodzi na 2.8 GHz i po prostu zasuwa :D

    Jedyny problem (i zarazem powód wystąpienia tego problemu) to koszt takiego zasilacza, nowy ~400zł netto (niepewny zamiennik ~250 netto), przy dużo niższej cenie zasilaczy 90W