Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[VBA] Jak znaleźć, zsumować duplikaty a następnie usunąć zostawiając jeden

lamcpp 27 Sie 2015 21:50 663 3
  • #1 27 Sie 2015 21:50
    lamcpp
    Poziom 12  

    Mam w Excel tabelę:

    Code:
     
    
    ID   CENA  SUMA
    12   12
    73   11
    1   14
    12   17
    9   18
    11   11
    73   10

    Chciałbym, aby makro vba znajdowało wszystkie wartości, które mają takie same ID (duplikaty), sumowało ich cenę, usuwało jeden zduplikowany wiersz i zostawiało w tabeli wynikowej tylko jeden z sumą.
    Czyli manualnie w przypadku tego pliku wynik byłby taki:
    Code:
    ID  SUMA
    
    12   29
    73   21

    Jak można by to było zrobić?

    0 3
  • #2 27 Sie 2015 22:23
    -psiak-
    Poziom 32  

    C2:
    =JEŻELI(LICZ.JEŻELI(A$1:A1;"="&A2)=0;SUMA.JEŻELI($A$2:$A$8;"="&A2;$B$2:$B$8);"")
    rozciągasz do C8

    0
  • #4 28 Sie 2015 20:16
    PRL
    Poziom 33  

    Wtrącę swój kod:

    Kod: vbscript
    Zaloguj się, aby zobaczyć kod

    0