Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Jak wykonać liczenie godzin w Excelu (części dziesiętne godziny)

Ehechalth 06 Sep 2015 06:28 1884 3
  • #1
    Ehechalth
    Level 1  
    Witam.
    Mam pewien problem, probuje obliczyc godziny w excelu, i ogolnie wychodzi ok. Przykladowo, osoba pracuje od 17.00 do 5.00. Przykladowo A1-A2. Obliczenia wychodza ok. Ale jesli dana osoba pracuje od 17.30 do 5.00 ta formula juz nie zadziala... i mam pytanie, czy da rade obliczyc czac od kiedy ktos pracuje, do kiedy? I jeszcze jedna sprawa czy da rade pokazac to od 1 do 100? Przykladowo jak ktos peacuje pol godziny, zeby program liczyl to jako 0,5?
  • #2
    Zbych034
    Level 38  
    Zamieść arkusz z tym co masz.
  • #3
    markoz7874
    Level 31  
    Ehechalth wrote:
    Witam.

    Mam pewien problem, probuje obliczyc godziny w excelu, i ogolnie wychodzi ok. Przykladowo, osoba pracuje od 17.00 do 5.00. Przykladowo A1-A2. Obliczenia wychodza ok. Ale jesli dana osoba pracuje od 17.30 do 5.00 ta formula juz nie zadziala..


    Zastosuj formułę warunkowa "jeżeli":
    np.
    =JEŻELI(A2>A1;A2-A1;"24:00"-A1+A2)
    gdzie A1 - czas od
    A2 - czas do
    Zakładam, ze ktoś nie pracuje więcej niż 24h :)
  • #4
    Maciej Gonet
    VBA, Excel specialist
    Dzień dobry,
    Kilka ogólnych zasad:
    1) Excel traktuje daty i czas jak liczby: data stanowi część całkowitą, a czas część ułamkową tej liczby. Wartość czasu jest zatem w obliczeniach traktowana jak ułamek doby. Nie można wyświetlać dat ani czasów ujemnych.
    2) Aby wprowadzić czas tak, by Excel interpretował to jako czas należy oddzielić godziny i minuty dwukropkiem np. 17:30. Jeśli jest pełna godzina trzeba wpisać zero minut, np. 6:0. Excel automatycznie zastosuje format Czasu.
    3) Jeśli chcemy obliczyć różnicę czasów w obrębie tej samej doby, wystarczy zwykłe odejmowanie. Jeśli jednak ktoś pracuje od 20:0 jednego dnia do 6:0 następnego dnia, to do wyniku trzeba dodać 1. Uniwersalna formuła, która obejmuje oba te przypadki jest taka:
    Code: text
    Log in, to see the code

    4) Jeśli chcemy przeliczyć czas na godziny i ułamki godzin, należy wartość czasu pomnożyć przez 24 i zastosować format Ogólny lub Liczbowy.
    Pozdrowienia