Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Sieciówka pod win95

kondziub 24 Mar 2003 02:08 1717 9
  • #1
    kondziub
    Level 21  
    Problem wygląda następująco: po wpięciu karty i uruchomieniu systemu (win95) wykryl nowe urzadzenie i chcial sterowniki. Po zainstalowaniu z plytki obowiązkowy reset. Sprawdziłem w menadżerze urządzeń czy nie świeci się jakiś konflikt i nie było nic. Chciałem poustawiać protokoły i powpisywać wartości (kolejny reset). Niby wszystko miało być już Ok, ale niestety nie było netu pingi nie działały a protokół TCP/IP zniknął. Okazało się że menadżerze urządzeń w miejscu gdzie powinny być wyświetlone sterowniki obsługujące karte nie ma nic. Pisze że są niepotrzebne :) lub nie zostaly załadowane. Karta to D-link DRN-32TX. Po wielu godzinach zmagań (międzyczasie przeinstalowałem windowsa) nic się nie zmieniło, udało mi się tylko doczytać że problemem może być 16-bitowy sterownik czasu rzeczywistego (NIC) i że rozwiązaniem może być ustawienie karty jako niePnP programem nazywanym Softset, który powinien znajdować się na płycie instalacyjnej. Nie mam takiego programu.
    Będę wdzięczny za jakieś sugestie i pomysły
    Pozdrawiam
  • #2
    Platon
    Level 42  
    Program powinienes znalzc na stronie producenat, razem ze sterownikami. Raaczej nie ma zadnych programow uniwersalnych.
  • #3
    kondziub
    Level 21  
    Próbowałem, ale ciężko wejść na ich Ftpa :). A to że taki program może pomóc to wyczytałem w pliku tekstowym, który znajduje się w katalogu windows (bodajze network.txt)
    KARTY SIECIOWE TYPU PLUG AND PLAY ORAZ 16-BITOWE STEROWNIKI
    CZASU RZECZYWISTEGO
    ===========================================================

    Gdy użyjesz 16-bitowego sterownika czasu rzeczywistego dla
    sieciowej karty interfejsu (NIC) typu Plug and Play, może się
    wydawać, że karta taka nie działa.

    Dzieje się tak, ponieważ w większości komputerów karty typu
    Plug and Play stają się aktywne dopiero po włączeniu ich przez
    system Windows 98. 16-bitowe sterowniki NIC są ładowane, zanim
    system Windows 98 zdąży włączyć karty typu Plug and Play. Niektóre
    z tych sterowników nie rozpoznają kart typu Plug and Play (dotyczy
    to większości klonów Plug and Play typu NE2000). W takiej sytuacji,
    aby móc użyć karty Plug and Play z 16-bitowym sterownikiem NIC,
    wykonaj następujące czynności:

    1. Uruchom program Softset dołączony do karty typu Plug and Play
    i ustaw kartę na tryb "non-Plug and Play".

    2. Z listy urządzeń Menedżera plików usuń kartę sieciową: W Panelu
    sterowania kliknij dwukrotnie ikonę System, kliknij kartę
    Menedżer urządzeń, wybierz kartę sieciową, a następnie kliknij
    przycisk Usuń.

    3. Zainstaluj kartę ponownie używając ikony Dodaj nowy sprzęt
    w Panelu sterowania.

    Gdy w przyszłości zainstalujesz 32-bitowy sterownik NIC trybu
    chronionego, będzie możliwe ponowne uruchomienie programu Softset,
    co pozwoli włączyć tryb Plug and Play karty .

    To jest fragment tego pliku, tylko spod W98. Wygląda dokładnie tak samo jak tamten, ale ta karta pod W98 chodzi bez problemów, także nie wiem czy nawet jak zdobęde taki programik (o ile jest coś takiego) to nie wiem czy pomoże. Na płycie nie ma takiego programiku, czyli może nie da się przełączyć na nPnP?
    Pozdrawiam
  • #4
    Platon
    Level 42  
    Na jakiej plycie szukasz tego programu? Od Win? Tam nie bedzie. Powinien byc na dyskietce ze sterami do sieciowki (chyba ze do sieciowki masz plyte, ale przewaznie jest dyskietka, stad pytanie).
    Program nie musi sie nazywac softset ( U mnie na realteki : rlset)
    Znajduje sie przewaznie w katalogu utils (ew utilities).

    Na jakiej kosci jest ta karta? Moze jednak sie cos podpasuje?
    Poszukaj nie tylko na ftp producenta, ale na stronach se sterownikami (np http://www.driverguide.com usr: driver, ps: all ).
  • #5
    Masster
    Level 32  
    Spróbuj jeszcze zainstalować ją jako zgodną z NE2000.
  • #6
    kondziub
    Level 21  
    :arrow: Platon. Tak mam płyte instalacyjną. Na niej są sterowniki do różnych OSów, m.in.do windowsów. Programu też szukałem pod jakąś inną nazwą i nie znalazłem. Karta jest na kości realtek (coś jakoś 8361?), dokładnie nie pamiętam bo teraz nie jestem w domu i nie mam jej pod reką (musiałem sobie zrobić przerwę ;)). Udało mi się ściągnąć kilka wersji sterowników (jedna była dedykowana właśnie mojemu realtekowi) i sytuacja była taka sama. Niby się coś instalowało, driver się przekopiował, ale ro restarcie w menadzerze nic się nie załadowało. Natomiast w którymś rarze widziałem widziałem chyba coś o nazwie podobnej do rlset. Co tam mam poustawiać? Myśle że sobie poradze, ale mam pytanie czy uruchamiać go pod winda czy dosem.

    :arrow: Masster
    Quote:
    Spróbuj jeszcze zainstalować ją jako zgodną z NE2000.

    Jak tego dokonać?
  • #7
    Platon
    Level 42  
    Uruchamianie rlset: dla starszych wersji tylko pod DOS (zawiesza winde), nowsze mozna spod windowsa. Trudno powiedziec jak bedzie u ciebie.

    NE2000 to standardowy sterownik k sieciowej, jest w windowsie w podgrupie Novell
  • #8
    kondziub
    Level 21  
    :arrow: Platon
    Sprawdziłem nie mam takiego pliku. Znalazlem natomiast inny "dlkrts" z rozrzeszeniem com. Opcje jakie sa w nim dostępne załączam w screenie.
    Czy jest możliwość żebym ewentualnie użył rlset od Ciebie?
    Mój Realtek to 8139
  • #9
    Platon
    Level 42  
    8139 to karty PCI. Nie trzeba tam nic ustawiac. rlset ktore mam byly do kart ISA, ktorym ustawialo sie PnP/non Pnp, przerwania, adresy itp.
    Dla kart PCI ustawaia sie automatycznie lub w sterownikach.
    Moze problem lezy w windowsie?
  • #10
    kondziub
    Level 21  
    Udało mi się rozwiązać problem. Za bardzo sam nie wiem co się stało że się naprawiło. Na początku z W95 zrezygnowałem i zainstalowałem 98. Niestety już podczas pierwszego uruchamiania pojawił się błąd, że rejestr jest uszkodzony i że windows 98 go naprawi :D Stwierdziłem, że jak chce to niech go naprawia. Faktycznie coś tam porobił, zresetował się i uruchomił poprawnie. Zainstalowałem sterowniki do sieciówki i nastąpił reset. Jakie było moje zdziwienie, gdy po kolejnym uruchomieniu znowu pojawił się komunikat o błędzie w rejestrze i o chęci naprawy. Zresetował się, "coś" naprawił i uruchomił sie poprawnie z rejestru poprzedniego (czyli bez sieciówki). Jak się uruchomił nic nie robiąc zresetowałem go i po kolejnym uruchomieniu znów był błąd i tak w kółko. Raz na dwa uruchomienia pojawiał się błąd. W pewnym momencie po zainstalowaniu sieciówki i otoczenia sieciowego nie zresetowałem go tylko zrobiłem kopie zapasową rejestru. Trochę zabawy z rejestrem i udało mi się zrobić tak, że po "naprawie" rejestru startował z tej mojej kopii. Stwierdziłem że poinstaluje wszystko zrobię kopie rejestru i trudno będzie trzeba go uruchamiać dwa razy. No taki był plan, ale się nie udał do końca. Zainstalowałem IE5 i po skończeniu instalacji nacisnąłem przycisk OK, gdzie wcześniej nie zdążyłem doczytać, że należy wcześniej zapisać wszystkie otwarte dokumenty ;) Zresetował się. Po uruchomieniu pojawiło się tylko tło i okienko że Eksplorer wykonał nieprawidłową operację i nastąpi jego zamknięcie. Po naciśnięciu trzech magicznych przycisków pojawiało się puste okienko z możliwością wyboru zamknij system. Nie pomógł ani tryb awaryjny, ani przywracanie poprzednich rejestrów.
    W końcu zrezygnowany stwierdziłem, że spróbuje zainstalować jeszcze raz 95. Spod dosa wykasowałem cały katalog windows i zainstalowałem 95 pod innym katalogiem. Przy instalacji od razu podałem mu sterowniki do karty i po zainstalowaniu net chodzi aż miło (prawie jak miło, bo ten sprzęt to prawie zabytek;) Dzięki za porady