Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Długość skrętki i rozłaczanie internetu

07 Paź 2015 10:25 2433 34
  • Poziom 30  
    Prośba o poradę. Mam w domu router Asus rt-ac66u Do portu LAN 4 podłączony jest switch nr1 w odległości około 6m od routera. Następnie od switcha nr1 odchodzą 2 skrętki - 1 długości 15m na końcu której jest AP Asus RN12+ a drugi kabel biegnie 118m dalej. Na końcu skrętki jest Switch nr2 (3com office connect 8portowy z gigabitem ). Do switcha nr2 podłączony jest kablowo laptop oraz AP airlive wla5000ap. Problem dotyczy zaniku internetu na laptopie i AP airlive. Sprawdzałem 3 różne switche i zawsze jest to samo no może poza jednym przypadkiem kiedy to miałem podłączony archaiczny sprzęt i netu nie było bo (wszystko mam podłączone kablem prostym a nie krosowanym) Przerw w ciągłości nie ma bo sprawdzałem testerem. Docelowo chcę pozbyć się switcha nr2 i w jego miejsce wstawić jakiś AP z 4 portami LAN. Co mogę sprawdzić jeszcze? Napięcie na skrętce?

    Dodam, że jak nie ma netu na laptopie i airlive to wystarczy wypiąć na chwilę skrętkę główną ze switcha i podłączyć ją ponownie. Może switch nr1 jest wadliwy? Tylko, że chyba wtedy nie byłoby sygnału na 15m skrętce a tam problemów nie ma nigdy
  • Poziom 38  
    tomrom1985 napisał:
    drugi kabel biegnie 118m dalej.
    To o 18 metrów przekroczyłeś dopuszczalną długość połączenia.
  • Poziom 43  
    Problemem jest kabel o długości 118m.
  • Poziom 38  
    @tomrom1985 Masz możliwość podzielenia tego długiego połączenia "na pół" i wstawienia gdzieś po drodze switch'a?
  • Poziom 30  
    Myślałem o wstawieniu po środku switcha, ale też brałem pod uwagę, że switch na początku i końcu odcinka załatwi mój problem jak w przypadku zasilania w pętli. No nic będę musiał wstawić go, ale po środku może być ciężko. Mogę go wrzucić jakieś 20-25m od końca odcinka.
  • Poziom 38  
    tomrom1985 napisał:
    Mogę go wrzucić jakieś 20-25m od końca odcinka.
    Ważne by jeden odcinek nie przekraczał 100 m. Przy zbliżaniu sie do 100 m, a nawet przekraczaniu tego limitu, zaczyna być ważna jakość kabla i staranne zakończenie ich RJ'tkami.
  • Poziom 30  
    OK policzę później dokładnie ile mogę się cofnąć, albo jak inaczej poprowadzić kabel, aby może zyskać ten stracony (18m) odcinek.
  • Poziom 34  
    freebsd napisał:
    tomrom1985 napisał:
    Mogę go wrzucić jakieś 20-25m od końca odcinka.
    Ważne by jeden odcinek nie przekraczał 100 m. Przy zbliżaniu sie do 100 m, a nawet przekraczaniu tego limitu, zaczyna być ważna jakość kabla i staranne zakończenie ich RJ'tkami.
    Po raz kolejny spotykam się z wykładnią, że 100 i ani 10 cm dalej. Panowie - to jest norma i gwarantowana długość, powyżej której już nie gwarantuje się 100mbps czy 1Gbps (w zależności od kategorii kabla). Ale 10 Mbps chodzi bez problemów na 160 m na cat.5 ftp a 100Mbps miałem na 140 metrach :)
  • Poziom 38  
    VooVoo napisał:
    Po raz kolejny spotykam się z wykładnią, że 100 i ani 10 cm dalej. Panowie - to jest norma i gwarantowana długość, powyżej której już nie gwarantuje się 100mbps czy 1Gbps (w zależności od kategorii kabla). Ale 10 Mbps chodzi bez problemów na 160 m na cat.5 ftp a 100Mbps miałem na 140 metrach
    Wiesz, że dla 10BASE-T maksymalna odległość to też 100 metrów, czyli 328 stóp? I że obowiązują tu nie tylko limity "elektryczne", ale i czasowe? I jak to w życiu, raz uda się trochę nagiąć, a czasami nie.
    To co proponujesz? Do sprzętu typu: "Asus rt-ac66u" lub "3com office connect 8portowy z gigabitem" połączenie 10 mbps, czy w ciemno wymianę kabla na kat. 7, czy coś innego?
  • Poziom 30  
    Panowie pewna ciekawostka - pozbyłem się switcha nr1. Połączyłem bezpośrednio do routera a na końcu zostawiłem switcha 3com. O dziwo od około połowy dnia nie było przerwy. Pingi są na poziomie od 2 do 150ms a średnio cos około 78ms. Potestuje co bedzie. Speed test pokazuje okolo 10Mb/s a jak podlacze kabel bezpośrednio do lapka to mam wynik na poziomie 68Mb/s
  • Poziom 34  
    W uciążliwych warunkach (silne zakłócenia elektrostatyczne, duże odległości itp) położyłbym światłowód i zakończył mediakonwerterami. Rozwiązanie zdecydowanie pewniejsze. A wracając do tematu - kolega robi sieć dla siebie, a nie dla IBM, gdzie powinien być certyfikat z pomiarami wszystkich torów. Dlatego nie spinam się na sakramenckie 100 m :)
  • Poziom 30  
    Gdyby światłowód był tańszy oraz wszystkie potrzebne akcesoria to poszedłbym w tym kierunku a tak to jest to co miałem pod ręką czyli darmowa skrętka :-)
    Założenie było takie, aby uzyskać transfer na poziomie 15Mb/s

    Teraz Panowie ciąg dalszy testów. Z zostawionym na samym końcu switchem wyszła przysłowiowa "kupa". Był zaniki sygnału. Dziś o 6ej odłączyłem switcha nr2 i wpiąłem RJ bezpośrednio do AP Airlive. O dziwo wszystko działa dobrze. Awaryjnie mam już przygotowane miejsce na postawienie switcha w odległości 35m od końca skrętki, ale jeszcze się wstrzymam.
  • Poziom 38  
    tomrom1985 napisał:
    Teraz Panowie ciąg dalszy testów. Z zostawionym na samym końcu switchem wyszła przysłowiowa "kupa". Był zaniki sygnału. Dziś o 6ej odłączyłem switcha nr2 i wpiąłem RJ bezpośrednio do AP Airlive. O dziwo wszystko działa dobrze. Awaryjnie mam już przygotowane miejsce na postawienie switcha w odległości 35m od końca skrętki, ale jeszcze się wstrzymam.
    Sprawdź, czy końcówki są na 110% :-) dobrze zarobione, a przewód nie jest na całej długości zagięty i ściśnięty (coś na nim postawione, gdzieś ciasno wciśnięty, ciasno m przymocowany do czegoś).
  • Poziom 30  
    Testerem wychodzi, że rj jest dobrze zarobione. Każda żyła ma przejście. Przewód sprawdzę jeszcze pod kontem ewentualności o jakich pisałeś @freebsd
  • Poziom 38  
    tomrom1985 napisał:
    Testerem wychodzi, że rj jest dobrze zarobione. Każda żyła ma przejście. Przewód sprawdzę jeszcze pod kontem ewentualności o jakich pisałeś @freebsd
    Testerem sprawdzisz tylko ciągłość, musiał byś mieć analizator sieci ethernet.
  • Specjalista Sieci, Internet
    Sprawdź czy przewody wg standardu T568B lub T568A, nie moga iść dowolnie 1-1, 2-2...
  • Poziom 30  
    Zarabiałem je według T568B
  • Poziom 22  
    Jeśli masz możliwość (i nie będzie to przeszkadzać) wymyś na którymś końcu szybkość 10MBitów i będzie działać. Ale max 10Mbit
  • Poziom 30  
    Moge w Asusie RtAc dać regułę w QoS.
  • Poziom 22  
    Nie. Chodzi o prędkość połączenia.
  • Poziom 30  
    To niestety chyba nie mam takiej możliwości a przynajmniej nigdzie w ustawieniach urządzeń nie wiedziałem tego
  • Poziom 22  
    Bo ja zestawiłem na 10MBitów na 3 lata 100metrów jakiegoś druta... i chodziło, ale tylko na 10mbit/s :(
  • Poziom 30  
    Od 6ej rano mam podpięty kabel bezposrednio do airliva i dziala dobrze. Był podłączony telefon i laptop poprzez wifi i było OK. Potestuje jeszcze
  • Poziom 34  
    tomrom1985 napisał:
    To niestety chyba nie mam takiej możliwości a przynajmniej nigdzie w ustawieniach urządzeń nie wiedziałem tego
    To możesz ustawić we właściwościach karty sieciowej, wtedy nie będzie próbowała negocjować wyższych prędkości.
  • Poziom 14  
    Powiedz mi, tę skrętkę-118 masz której kategorii? Możesz ją wymienić, czy jest "zamurowana" na stałe?

    Jak jeden z kolegów pisał, to nie jest tak że do 100m działa a powyżej ani rusz - po prostu parametry sygnału zaczynają się pogarszać, i od pewnej długości zaczyna się tracić pakiety. Żeby sobie z tym poradzić możesz zastosować switch gdzieś po drodze (rozwiązanie pewne), albo zaryzykować i kupić lepszy kabel, np. zamiast 5e bez ekranu - kategorii 6 z ekranem. Kabel o lepszych parametrach uciągnie "dłuższe" połączenie z wystarczająco dobrymi parametrami sygnału. Jak inny kolega zauważył, znaczenie ma jakość końcówek, sposób zaciśnięcia itp - a tego nie sprawdzisz prostym testerem. Kabel inaczej zachowuje się przy prądzie stałym, jaki podaje tester, a inaczej przy wysokiej częstotliwości, jaka jest stosowana w transmisji. Hasło do googlowania w poszukiwaniu teorii: linia długa, równania telegrafistów. Jeśli chciałbyś zastosować kabel w ekranie, upewnij się, że ekran jest prawidłowo uziemiony (wtyczki z metalową wkładką, uziemienie TYLKO w jednym punkcie, żeby nie tworzyły się pętle).

    Ustawienie prędkości połączenia na niższą też powinno pomóc - ale jak to zrobić, to już zależy od sprzętu. W tanich switchach w ogóle nie masz takiej opcji, w routerach SOHO też raczej nie widuję... A jest to istotne, bo jeśli masz na końcach tego przewodu-118 takie urządzenia, to przynajmniej jedno ma mieć na sztywno ustawione 10Mbps, drugie się dostosuje - przy ustawieniu w innym miejscu na tym kablu i tak wynegocjują sobie 100Mbps, więc poprawy nie będzie.

    I jeszcze raz zapytam, nie masz tam czasem jakiś zagięć na kablu? Nie jest przycinany drzwiami, łamany, ściskany? Nie przechodzi obok jakiegoś sprzętu który może emitować silne pole?
  • Poziom 30  
    Zaginany, ściskany itd nie jest. Problem może generować sąsiedztwo w korytkach technicznych kabli od domofonów, kabli od zasilania lamp itd. Kabel mógłbym wymienić , ale nie chcę generować dodatkowych kosztów. Gdyby problem pojawiał się to zastosuje switcha po drodze. Obecnie wyeliminowałem switcha na początku i na końcu i odpukać nie rozłącza sieci. Pingi z garażu do Asusa na górze są teraz na poziomie 2-3ms. Wygląda na stabilne, ale jeszcze obserwuje. Bardzo możliwe, że będę kupował kabel ekranowany po po skrętce będę chciał podłączyć 3-4 kamery AHD do rejestratora więc wykonując już tę pracę mogę pociągnąć jeszcze kabel z mieszkania jednak ta operacja jest pod znakiem zapytania.
  • Poziom 38  
    Twoje problemy nie wyglądają (przynajmniej z opisu) na problem stosowania kabla nieekranowanego. Jak już masz wymieniać to - aż sie sam sobie dziwię, że to piszę - to wymień na kat.7, ponieważ ma grubsze żyły. Nie ma jednak pewności, że taka operacja (i koszt) cokolwiek dadzą.

    Dla jasności, normalnie nie ma żadnego, ale to żadnego uzasadnienia, dla stosowania kat.7 do gigabitowego Ethernetu. Tu traktuję sytuacje jako specjalną.

    Tak więc odradzał bym ponoszenie kosztów na kabel ekranowany. Jeżeli działa, to znaczy, że lepszej jakości urządzenia sobie poradziły. Jak wystąpią problemy najpewniejszym rozwiązaniem będzie dodatkowy switch po drodze.

    Ping nie daje duzej rozległej informacji diagnostycznej. Raczej powinieneś sprawdzić ilość błędów.

    Posłuchaj jeszcze rady @VooVoo i postaraj sie sprawdzić, czy masz możliwość zmiany ustawień parametrów kart sieciowych. Na początek warto sprawdzić, czy ustawienia są takie same. Nie może być np. na jednym końcu połączenia autonegocjacja, a na drugi ustawienie na sztywno,
  • Poziom 30  
    Ciężko mówić o ustawieniu kart sieciowych bo problem występował nawet jeśli nie było urządzenia (laptop, telefon czy coś innego)"na końcu druta". Obecnie problem jest jakby rozwiązany bo wszystko działa już od ponad doby. Nie mniej jednak zdecyduję się na switcha po drodze. Rozwiązanie dla mnie praktycznie bez ponoszenia kosztów.
  • Poziom 30  
    Napiszę co wykonałem w temacie - około 45m od końca skrętki postawiłem switcha Gb/s, na końcu wymieniłem airlive na trochę starego, ale obsługującego 150Mb/s N Asusa RT-10LX ustawionego jako ap router. Dlaczego tak? Dlatego, że ma stary soft i jako AP nie można "wbijać się" na niego zdalnie z poza sieci. Dopiero jako AP router daje możliwość ustawienia portu dla zdalnego dostępu. I teraz ciekawostka - prędkość jaką uzyskuję to około 10Mb/s bez znaczenia czy poprzez wifi czy kablem. Kabel wpięty bezpośrednio do kompa z pominięciem Asusa daje taki sam wynik. Najlepsze na koniec - bez switcha prędkość była na poziomie ~70Mb/s :-) Grunt, że działa i jest stabilne. Pobawię się w niedziele jeszcze tp-linkiem (brrrr) coś z modelu chyba 704ND. Co myslicie o tym spadku wydajności łącza?
  • Poziom 27  
    Za niecałe 500zł możesz mieć stabilne połączenie światłowodowe, mam na myśli materiały, do tego spawacz po godzinach.