Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - przypisanie dla danej wartości, wartości z sąsiedniej kolumny

21 Paź 2015 13:53 2136 4
  • Poziom 2  
    Witam szanownych forumowiczów:)
    Mam problem z pewna formułka w Excelu. Mianowicie:

    posiadam dwie kolumny 10-wierszowe (nazwa kontrahenta oraz nr jego rachunku bankowego). W innej komórce zrobiłem listę rozwijaną z kolumny z nazwą kontrahenta, a obok chcę przypisać nr rachunku do danego kontrahenta.

    Załóżmy, że:
    - moje kolumny to A1:A10 oraz B1:B10,
    - komórka z lista rozwijaną to C1,
    - komórka, w której chcę mieć automatycznie przypisany na rachunku to C2;

    Stworzyłem następującą, błędną jak sie okazuje, formułę:

    INDEKS(B1:B10;PODAJ.POZYCJĘ(C1;A1:A10))

    moje pytanie: co jest nie tak?

    Z góry dziękuję za odpowiedź:)
  • Poziom 9  
    Witam.
    Rozwijana lista to przykładowo komórka c1 natomiast dane a1 do b10 gzie w kolumnie A nazwa, w kolumnie b nr rachunku
    Formuła w komórce w której ma pojawić się nr konta
    = WYSZUKAJ.PIONOWO(C1;A1:B10;2;)
    Pozdrawiam

    Dodano po 29 [minuty]:

    Witam ponownie
    oczywiście musi być
    = WYSZUKAJ.PIONOWO(C1;A1:B10;2;0)
  • Specjalista - VBA, Excel
    MaadRaz napisał:
    INDEKS(B1:B10;PODAJ.POZYCJĘ(C1;A1:A10))

    Może to być tak, ale z małe korekty
    INDEKS(B1:B10;PODAJ.POZYCJĘ(C1;A1:A10;0))
    T.z. Szukaj na dokładne dopasowanie
  • Poziom 2  
    Dzięki, wystarczyło proste WYSZUKAJ.PIONOWO z "FAŁSZ-em" w formule:)
    pozdrawiam:)
  • Poziom 9  
    = WYSZUKAJ.PIONOWO(C1;A1:B10;2;0)
    oraz
    = WYSZUKAJ.PIONOWO(C1;A1:B10;2;FAŁSZ)
    działa tak samo