Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Naprawa ruchomych głów Stairville MV-250H

Payfer 26 Paź 2015 12:33 753 14
  • #1 26 Paź 2015 12:33
    Payfer
    Poziom 9  

    Witam,

    Naprawiam 2 głowy ruchome Stairville MV-250H.
    Silniki od Gobo i koloru pracują normalnie. Lampa Świeci

    Po włączeniu jest proces kalibracji. Wtedy głowa obraca się płynnie w obu osiach.

    Po kalibracji zaczynają dziać się cuda:

    Silniki od PAN i TILT dziwnie pracują - drżą, buczą i trochę się poruszają w losowych kierunkach na zadany ruch z programu Freestyler. Zauważyłem, że jeśli zada się małą zmianę pozycji w osi x lub y to silniki trochę lepiej pracują. Jeśli zwiększy się zakres ruchu to silniki się zatrzymują ale słychać dziwny efekt dźwiękowy jakby obracał się wałek w zembatce.
    Oczywiście zębatka na wałku jest bardzo dobrze dokręcona i dźwięki wydają silniki niemogące się poruszyć.

    Mając dwie głowy zacząłem przekładać poszczególne elementy ale efekt jest dokładnie taki sam dla silników krokowych w głowie nr 1 jak i nr 2.

    Silniki napędzane są driverami NJM 3771 z przyklejonymi radiatorkami.
    Silniki osi X i Y to MOONS typ 17HS1004-16.
    Na stronie MOONS niestety nie znalazłem danych do tych silników. Najprawdopodobniej zmieniono nazewnictwo.
    Napisałem do firmy MOONS, żeby wysłali mi jakiegoś DATASHEETA do tego modelu silnika.
    Poniżej link do tego silnika ze strony części od ADJ AUTO SPOT 150
    Silnik 17HS1004-16

    W związku z tym proszę o odpowiedzi na pytania:

    1. Jak skutecznie stwierdzić czy silniki są uszkodzone? Sprawdziłem rezystancję 1 i 2 uzwojenia i jest na poziomie ok. 8 Ohm.
    Silnik nie stwarza nierównomiernego oporu podczas kręcenia wałkiem.
    2. Jeśli silniki okażą się być uszkodzone to proszę o pomoc w doborze jakiegoś zaminnika ponieważ oryginał to 45 dolarów/szt.
    3. Czy jesteście w stanie rozkodować te oznaczenie 17HS1004-16 na jakieś cenne informację.
    4. Dlaczego podczas kalibracji silniki pracują poprawnie a w czasie normalnej pracy np. w trybie DMX wariują?

    Dodatkowo co zrobiłem:
    -Sprawdziłem Zasilania Logic 5V na wszystkich układach - ok
    -Sprawdziłem Zasilanie od transformatora 12,24 VAC - ok
    -Sprawdziłem Zasilanie po stabilizacji - ok
    -Wymieniłem kondensatory elektrolityczne.
    -Wyczyściłem płytki, posprawdzałem złączki i przedmuchałem wszystko sprężonym powietrzem.


    Proszę o jakieś porady.
    Z góry serdecznie dziękuję i pozdrawiam

    0 14
  • #2 26 Paź 2015 13:27
    398216 Usunięty
    Poziom 43  

    Silniki są sprawne. Przyjrzyj się samemu układowi sterowania.

    0
  • #3 26 Paź 2015 17:12
    Payfer
    Poziom 9  

    Czyli obstawiasz że oba drivery na jednej i na drugiej płycie są uwalone?

    Dodano po 2 [godziny] 55 [minuty]:

    Zrobiłem sobie na szybko sterownik do silnika krokowego na Atmedze i mostku L298.
    Przetestowałem wszystkie 4 silniki no i działają pięknie stabilnie i nie gubią żadnych kroków.

    Zamówiłem już Drivery NJM3771D2. Wymienię i zobaczę.
    Pozdrawiam

    0
  • #4 28 Paź 2015 10:59
    Payfer
    Poziom 9  

    Wymieniłem w jednej z głów drivery NJM3771D2 i zaczęła działać normalnie:D

    Natomiast w drugiej głowie po wymianie driverów działa tylko oś PAN a TILT nawet nie drgnie a co więcej oś jest wiodka, nie stwarza oporu przy próbie ręcznego popychania, zupełnie inaczej jest ze sprawną osią PAN - silnik jest usztywniony i stwarza opór przy próbie ruchu.

    Sam silnik krokowy z Tilt jest na pewno jest sprawny.
    Sam driver NJM3771 również jest sprawny. Sprawdzałem na drugiej głowie.
    Same połączenia na PCB również są ok. Elektrolit na zasilaniu driverów wymieniłem ponieważ był 2200uF/63V zamiast 2200uF/35V (zgodnie z sugerowanym napisem na płycie). Czy kondensator na 63V mógł uszkodzić stare,wcześniej zainstalowane drivery?

    Odtworzyłem na szybko schemacik głównych torów sterowania oraz obok schematu wkleiłem typowe podłączenie z karty katalogowej dla układu NJM3771D2.
    Dodaje w załączniku również karty katalogowe do układów ze schematu.
    Dodaję również zdjęcia przed wlutowaniem driverów do płyty głównej.

    Jak ktoś ma dokumentację serwisową to będę bardzo wdzięczny o podesłanie.

    Proszę o sugestię i wskazówki oraz odpowiedzi na poniższe pytania.
    1. Co waszym zdaniem najprawdopodobniej mogło ulec uszkodzeniu?
    2. Czy uszkodzzenie części wejść/wyjść układów TLC7226C i MM74HC57C są bardzo prawdopodobne?
    3. Jak sprawdzić te układy, bez użycia oscyloskopu?
    4. Czy uszkodzeniu mógły ulec również wyjścia układ U1 - procesor W78E54B40

    Z góry dziękuję wszystkim za pomoc.

    0
  • #5 28 Paź 2015 12:57
    398216 Usunięty
    Poziom 43  

    Payfer napisał:
    TILT nawet nie drgnie a co więcej oś jest wiodka, nie stwarza oporu przy próbie ręcznego popychania,
    Czyli albo silnik nie dostaje napięcia z drivera, albo driver nie ma prawidłowego sterowania. Masz drugą sprawną głowę - możesz sprawdzić i porównać przebiegi jakie występują na wejściach drivera i wyciągnąć wnioski... "Trzymanie" wirnika silnika krokowego wynika z tego, że przez jedną jego sekcję płynie cały czas prąd. Jak nie płynie - nie trzyma wirnika i można go swobodnie obracać.
    Payfer napisał:
    . Elektrolit na zasilaniu driverów wymieniłem ponieważ był 2200uF/63V zamiast 2200uF/35V
    Zupełnie niepotrzebnie. Jak ma większe napięcie nominalne, to tylko lepiej (dłużej będzie pracować). W każdym razie na uszkodzenie driverów nie ma to żadnego wpływu.

    0
  • #6 29 Paź 2015 13:36
    adambyw
    Moderator Akustyka

    Payfer napisał:
    Elektrolit na zasilaniu driverów wymieniłem ponieważ był 2200uF/63V zamiast 2200uF/35V (zgodnie z sugerowanym napisem na płycie). Czy kondensator na 63V mógł uszkodzić stare,wcześniej zainstalowane drivery?

    Nie. Jeżeli pojemność się zgadza to wyższe dopuszczalne napięcie nie ma wpływu na jego pracę. Będzie miał tylko większe gabaryty, i lepsze niektóre mniej istotne parametry.
    Payfer napisał:
    4. Czy uszkodzeniu mógły ulec również wyjścia układ U1 - procesor W78E54B40

    Tak. Mogły. Ale to najlepiej będzie sprawdzić oscyloskopem. Albo podmieniając procesor pomiędzy głowami.

    0
  • #7 29 Paź 2015 14:07
    Payfer
    Poziom 9  

    Będę dzisiaj podmieniał i sprawdzał.

    Takie hipotetyczne pytanie:
    Czy jeśli okazałoby się, że układ W78E54B40 ma uwalone jakieś wyjścia to czy istnieje taka możliwość aby zgrać program z dobrej kości i wgrać do nowej?
    Czy raczej te programy zabezpieczone są przed kopiowaniem?

    0
  • #8 29 Paź 2015 15:31
    adambyw
    Moderator Akustyka

    Marna szansa. Po pierwsze musiał byś sobie zbudować programator i napisać oprogramowanie do niego. Po drugie układ na 99% będzie zabezpieczony przed odczytem i po dobroci go nie zmusisz.

    Układ możesz zastąpić procesorem z takim samym pinoutem, np Atmega8515 i napisać własne oprogramowanie. Co w cale nie musi być takie skomplikowane.

    0
  • #10 30 Paź 2015 12:19
    398216 Usunięty
    Poziom 43  

    398216 Usunięty napisał:
    możesz sprawdzić i porównać przebiegi jakie występują na wejściach drivera i wyciągnąć wnioski...

    0
  • #11 30 Paź 2015 13:15
    Payfer
    Poziom 9  

    Nie mam oscyloskopu:( Mam świadomość, że zwykłym multimetrem tego nie pomierzę:( ale próbowałem....

    Sprawdzałem i porównałem ze sobą oba drivery zwykłym multimetrem (ustawionym na ACV ) podłączając pomiędzy masą drivera a poszczególnymi pinami a wejściami sygnałów sterujących.

    Odczyty praktycznie identyczne na jednym jak i na drugim NJM3771D2

    0
  • #12 30 Paź 2015 14:11
    398216 Usunięty
    Poziom 43  

    Drivery sprawne, silnik sprawny, procesor - skoro wysyła impulsy - też, a silnik napięcia nie dostaje... Cud? Jakoś w cuda (w elektronice)nie wierzę...

    0
  • #14 30 Paź 2015 14:45
    398216 Usunięty
    Poziom 43  

    Nie masz oscyloskopu, więc albo pożycz od kogoś, albo jeśli nie masz takiej możliwości - oddaj tę głowę do serwisu...

    0
  • #15 30 Paź 2015 23:55
    Payfer
    Poziom 9  

    Okazuje się, że nie trzeba mieć czasami oscyloskopu....choć napewno byłoby łatwiej. Może sobie nazbieram:D

    Rozwiązanie mojego problemu:

    Uszkodzony był kondensator 820pF na linii RC, który odpowiedzialny był za ustalenie odpowiedniej częstotliwości pracy drivera. Po jego wymianie brakująca oś odżyła:D

    Dziękuję wszystkim za odpowiedzi i za cenne wskazówki.
    Pozdrawiam

    0