Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

excel - naliczanie nadgodzin i ujmowanie w jednej komórce

raffic 25 Lis 2015 14:13 687 7
  • #1 25 Lis 2015 14:13
    raffic
    Poziom 11  

    Witam próbuję rozgryźć regułę żeby w jednej komórce naliczała i nadgodziny a zarazem w tej samej odejmowała jeśli będzie mniej niż 8 godzin. komórki E6, E7, E8, E9.
    Pomoże ktoś rozwiązać mi ten problem ? z góry dziękuję.

    0 7
  • #3 25 Lis 2015 15:58
    raffic
    Poziom 11  

    Dzięki oto mi chodziło tylko zamiast zera wpisałem -5

    =MAKS(-5;ZAOKR((D9-C9)*24;0)-$B$3)

    i jest tak jak chciałem z góry dzięki mam nadzieję że się nie wysypie przy zmianach godzin od do :)

    no niestety jak nic nie wpiszę w komórki to wyskakuje mi -5 :(

    0
  • #4 26 Lis 2015 11:39
    Maciej Gonet
    Poziom 31  

    Jeśli praca jest w obrębie jednej doby, to można dodać warunek:

    Kod: text
    Zaloguj się, aby zobaczyć kod

    Na końcu tekst pusty lub zero, jak wygodniej.
    Jeśli może być praca na nocnej zmianie, np. od 22 do 6, to te formuły trzeba rozbudować, ewentualnie czas wprowadzać z datą.

    0
  • #5 26 Lis 2015 17:37
    raffic
    Poziom 11  

    niestety ta funkcja nie działa
    =JEŻELI(D6-C6>0;MAX(-5;ZAOKR((D6-C6)*24;0)-$B$3);"")

    dla lepszego ogarnięcia wpisałem kilka podpowiedzi w arkusze bardzo bym prosił kolegów o przeanalizowanie i w komórkach zmiany niestety w moim przypadku po wpisaniu tej funkcji

    =JEŻELI(D6-C6>0;MAX(-5;ZAOKR((D6-C6)*24;0)-$B$3);"")

    nie zadziałała.

    0
  • Pomocny post
    #7 27 Lis 2015 11:15
    Maciej Gonet
    Poziom 31  

    Cytat:
    niestety ta funkcja nie działa
    =JEŻELI(D6-C6>0;MAX(-5;ZAOKR((D6-C6)*24;0)-$B$3);"")

    Ale co nie działa? Zaokrąglenie? Ja w zaokrąglaniu nic nie zmieniałem, zostawiłem tak jak było. Przecież ja nie wiem jak to ma być zaokrąglane, a to jest sprawą użytkownika wzoru.

    0
  • #8 27 Lis 2015 16:27
    raffic
    Poziom 11  

    Maciej Gonet - i o to chodziło dzięki śliczne właśnie takiej reguły szukałem podziękowałem punkty poleciały w twoją stronę

    co do odpowiedzi po co mi -5 np. przy naliczaniu nadgodzin a potem oddawaniu oraz niepełnych godzin pracy w miesiącu jeśli ktoś pracuje 10 a potem 7 godzin i jest wahadło godzinowe ciężko nad tym zapanować ułatwi to pracę w ewidencji czasu pracy moich pracowników.

    jeszcze raz dziękuje za pomoc.

    0