Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Assembly - Visual Studio blad

Escapadro 25 Nov 2015 20:54 786 2
  • #1
    Escapadro
    Level 14  
    Witam!

    Z gory przepraszam za brak polskich znakow, nie ma na uczelni polskiej klawiatury.

    Od razu przejde do rzeczy. Mam dwa pytania odnosnie mojego programu.

    Mielismy za zadanie napisac funkcje w Assembly, ktora jest wywolywana z glownego programu .cpp. Wszystko pieknie, napisalem i .cpp i .asm, ale wyskakuja mi dwa bledy. Nie do konca wiem jak je zniwelowac, lub co robie zle.

    Oto screenshoty:

    Assembly - Visual Studio blad Assembly - Visual Studio blad Assembly - Visual Studio blad Assembly - Visual Studio blad

    Czy to wina kodu? Przy kompilacji nie ma zadnego problemu.

    Aha, program po prostu pyta uzytkownika o dziesiec liczb i ustawia je w kolejnosci od najmniejszej do najwiekszej (Bubble Sort Algborithm).

    Z gory dziekuje za jakakolwiek pomoc, rwe wlosy na glowie!
  • #3
    Escapadro
    Level 14  
    Niestety, probowalem juz i zmienic Incremental Linking, chcialem zmienic nazwe cvtres w folderze Microsoft Studio ale nie mam uprawnien administratora, czytalem o tym bledzie jak i o bledzie 4042 (ktory tez wyskakuje).

    Niestety - nie pomaga. Slyszalem, ze to czesty blad przy VC 2010?

    Dodano po 38 [minuty]:

    UPDATE:

    Wylaczylem manifesty i zadzialalo. Pozostaje mi tylko jedno pytanie, ale to juz z natury bardzo pedantycznej:

    Czy moj program moglby byc inaczej napisany? Poprzez inaczej, mam na mysli, oczywisce, "lepiej". Nie jestem urodzonym programista, wiec moglem popelnic jakies bledy "stylistyczne". Moze istnieje lepsza metoda na wcielenie tego algorytmu? Moze poprzez jakas inna petle? Albo i bez petli?

    Ma ktos jakies pomysly jak mozna by to rozwinac, albo napisac inaczej? Na pewno zerkne, albo i napisze dwa, dla porownania!

    Dzieki!