Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Raspbery Pi2 - Instalacja QT Creatora

Damian7546 15 Gru 2015 21:42 1002 11
  • #1 15 Gru 2015 21:42
    Damian7546
    Poziom 21  

    Witam,

    Mam problem z instalacja QT creatora w Raspberry Pi 2.
    Postąpiłem zgodnie z instrukcją:
    https://wiki.qt.io/Apt-get_Qt4_on_the_Raspberry_Pi

    I qtcreator się nie uruchamia. Po kliknięciu w ikonke nic się nie dzieje, natomiast wpisanie qtcreator w konsoli :

    libEGL warning: DIR2: failed to authenticate
    ...

    Co radzicie ?

    0 11
  • #3 16 Gru 2015 16:41
    Damian7546
    Poziom 21  

    Raspbery Pi2 - Instalacja QT Creatora

    W ten sposob ?

    0
  • #5 16 Gru 2015 17:34
    Damian7546
    Poziom 21  

    Teraz mam:

    qtcreator: error while loading shared libraries: libGLESv2.so.2: cannot shared object file: No such file or directory

    0
  • #6 18 Gru 2015 12:56
    Damian7546
    Poziom 21  

    Pomoże ktoś ?

    0
  • #8 18 Gru 2015 14:05
    Damian7546
    Poziom 21  

    @lekto Zaużmy ze mam czystego Raspbiana i wpisuję komendy po kolei :
    sudo apt-get install qt4-dev-tools
    sudo apt-get install qtcreator
    sudo apt-get install gcc
    sudo apt-get install xterm
    sudo apt-get install git-core
    sudo apt-get install subversion

    sudo ln -fs /opt/vc/lib/libGLESv2.so /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2

    i ma działać ?

    0
  • #9 18 Gru 2015 14:31
    lekto
    Poziom 35  

    Błędy które dostajesz to braki biblioteczek, a w zasadzie to problemy ze znalezieniem ich.
    Chodzi o to że jeśli masz przykładowo biblioteczkę libdupa.so.3.1.4 to program który potrzebuje biblioteczki libdupa.so.3.1.4 ją znajdzie, ale program który potrzebuje jakąkolwiek wersje libdupa.so.3.1 lub libdupa.so.3 lub libdupa.so nie znajdzie jej. Dlatego przy instalacji libdupa.so.3.1.4 powinno utworzyć się dowiązania symbolicznie: libdupa.so, libdupa.so.3 i libdupa.so.3.1, ale zdarza się że się nie tworzy.
    Jeśli program nie potrafi znaleźć libdupa.so, mimo że jest zainstalowane libdupa.so.3.1.4 to wystarczy utworzyć dowiązanie symbolicznie żeby libdupa.so wskazywało na libdupa.so.3.1.14.

    0
  • #10 19 Gru 2015 14:56
    Damian7546
    Poziom 21  

    Dalej nic z tego,

    i błąd:

    qtcreator: error while loading shared libraries: libGLESv2.so.2: cannot shared object file: No such file or directory
    :/

    Dodano po 2 [godziny] 29 [minuty]:

    Dziwna sprawa....

    Zainstalowałem jeszcze raz Raspbiana.
    Potem:
    sudo apt-get install qt4-dev-tools
    sudo apt-get install qtcreator
    sudo apt-get install gcc
    sudo apt-get install xterm
    sudo apt-get install git-core
    sudo apt-get install subversion


    i taki problem jak to po instalcji:
    libEGL warning: DIR2: failed to authenticate
    ...


    Następnie zainstalowałem VNC. Po wejściu przez vnc na Mailne próba uruchomienia Qt powiodła się. ktoś mi to wyjaśni ?

    0
  • #11 20 Gru 2015 12:41
    Damian7546
    Poziom 21  

    Kolejny problem to jak używam qtcreator przez VNC to źle działa klawiatura.. Kompletnie wymieszane znaki. Np w notatniku jest OK.
    :/

    0
  • #12 21 Gru 2015 16:32
    Damian7546
    Poziom 21  

    No i udało się :)

    Dla tych co będą chcieć używać Qt Creatora w Raspbery Pi 2 na monitorze (HDMI).

    Po instalacji :

    sudo apt-get install qt4-dev-tools
    sudo apt-get install qtcreator

    u mnie nie otwierał się Qt creator. Po dostaniu się do RPi przez VNC , Qt o dziwo się otworzył. Teraz aby pomyślnie Qt otworzyć na monitorze RPi nalezy w uruchomionym Qt Przejść:

    Help -> About Plugins...
    Uncheck Qt Creator --> Welcome
    Restart Qt Creator

    I od tej pory można kodzić na monitorku podłączonym do RPi

    0