Elektroda.pl
Elektroda.pl
X
Przedłużacze helukabelPrzedłużacze helukabel
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

"Zamrażające" się komputery

27 Gru 2015 20:49 1119 17
  • Poziom 9  
    Witam.

    Jestem adminem, posiadającym pod sobą ponad 50 komputerów oraz kilka serwerów. Od pewnego czasu zmagam się z problemem zamrażania niektórych z nich. Problem polega na tym, że nie mogę wychwycić reguły, która kierowałaby tymi zdarzeniami.
    Mamy ponad 20 komputerów 1,5 rocznych (HP). Dwa z nich się tak zamrażają. Myślałem, że wada sprzętu, ale testowanie procka, ramu, dysku twardego nic nie przyniosło. Co więcej w jednym z nich padł dysk, ale po wymianie, wgraniu systemu od nowa, problem nie ustąpił.
    Teraz znowu kupiliśmy kilkanaście komputerów (DELL) i w trakcie gdy przygotowywałem sprzęt dla użytkownika jeden z nich się zamroził w identyczny sposób. Później sytuacja powtórzyła się na stanowisku u użytkownika. W przypadku tego komputera było to 2 razy, ale jednak. Objawy te same jak u poprzednich. Co więcej, przed świętami zadzwonił do mnie kolejny użytkownik, który zgłosił mi problem zawieszania się komputera (komputer 3-letni z zupełnie innej serii). Gdy przyszedłem do niego okazało się, że także cały system jest zamrożony. Użytkownik powiedział, że to już któryś raz tak się stało. Podobnie było z jeszcze jedną maszyną.

    W dziennikach zdarzeń nie ma nic co mogłoby coś sugerować. Ot poranne uruchomienie kompa, jakieś techniczne informacje i potem jest odnotowane ponowne uruchomienie z nieprawidłowym zamknięciem.

    Może jakimś nakierowaniem będzie sytuacja jaką miałem z drukarkami na wakacjach. Jedna z nich (OKI b6500) zawieszała się podczas uruchamiania. Włączała się do pewnego momentu i nic. Na ekranie nic. Zero życia. Podejrzenie padło na płytę główną. Serwis był, wymienił i okazało się, że to nie to. Kolejnym podejrzanym był zasilacz. Tutaj wymiana pomogła. Drukarka tydzień chodziła i problem powrócił. Ta poszła do serwisu, a podstawiłem kolejną. Na drugi dzień, takie same objawy ma zastępcza drukarka.... Uruchamia się do pewnego momentu i stop. Podstawiłem trzecią i po kilku dniach tak samo. Serwis nie wiedział o co chodzi, więc kupił identyczną drukarkę i ją podstawił. Na niej problem się powtórzył. Gdy już nie miałem nic w zapasie, spróbowałem je zamieniać i bawić się kablami (wcześniej wymieniałem kabel zasilający i LAN). Po kilku zamianach jedna się uruchomiła. Potem wszystkie następne, które nie działały....

    Diagnoza moja i serwisu była, że to coś z prądem. Wezwany elektryk niestety nic nie znalazł (w sumie to chyba tylko napięcia posprawdzał...) Prosiliśmy potem zakład energetyczny o interwencję, bowiem na jednej z faz komputerowych, po włączeniu wszystkich komputerów, napięcie spadało do 217V. W jakiś tam magiczny sposób (coś na zewnątrz budynku było robione) podnieśli napięcie do ~240V.
    Problem nie ustąpił. Zgodnie z ich sugestią wezwaliśmy gościa z kamerą IR aby przelookał rozdzielnie. Może gdzieś coś niedobrego tam się działo. Nic nie znaleziono. Kolejną ich sugestią było, że to sterowniki w komputerach. Nic nie pomagało tłumaczenie, że to są różne komputery i że były diagnozowane (13 lat już administruję).

    Dużo pisania, ale jak widać i problem złożony. Gdy napiszę, że jestem zdesperowany to może będzie trochę za dużo, ale jestem bardzo zdeterminowany aby problem rozwiązać.

    Mam dwie koncepcje, które mogą być przyczyną takiego stanu rzeczy:
    1. Problem z zasilaniem (jakieś składowe harmoniczne, itd.) Za tym przemawiałby zapach "spalenizny kabla" w pokoju u jednego z użytkowników mającego opisane wyżej problemy z komputerem (ale nie od komputera). Elektryk nic nie znalazł...
    2. Różnie napięcia na kablach LAN (komputerówka oparta jest na 2 fazach). Za tym przemawia fakt, że drukarki z którymi był problem są też wpięcie w sieć ethernet.

    Nie mam innych pomysłów. Myślę już nad tym aby kupić multimetr Brymen 525s, który posiada funkcję logowania parametrów sieci, ale nie jestem pewien czy coś dzięki niemu wyłapię (np. nie ma funkcji THD).

    Nie liczę, że ktoś rozwiąże problem za mnie, ale chciałbym się Was doradzić, gdzie szukać, czego użyć, do jakich drzwi zapukać...


    Pozdrawiam
    Daniel.
  • Przedłużacze helukabelPrzedłużacze helukabel
  • Użytkownik usunął konto  
  • Poziom 9  
    Jakieś 100 - 150m mam wieżę telekomunikacyjną. Serwery zasilane są z upsów online'owych, więc tutaj się nie martwię.
  • Użytkownik usunął konto  
  • Przedłużacze helukabelPrzedłużacze helukabel
  • Poziom 9  
    Budynek jest tylko nasz. A jakieś sugestie jak wyłapać takie "sianie" po sieci? Mogę już nawet zainwestować w jakiś sprzęt, tylko żebym wiedział, że się przyda. Wstępnie myślałem o wspomnianym wcześniej Brymenie 525s, ale nie jestem przekonany, że on mi pokaże coś poza napięciem, ewentualnie natężeniem.
  • Użytkownik usunął konto  
  • Poziom 9  
    Bolce są, komputery są podłączone przez listwy (chociaż ostatnio i je poodłączałem przy problematycznych maszynach). Są też UPS-y, ale nie online, tylko offline, czyli puszczają prąd, a uruchamiają się dopiero jak padnie napięcie. Takie zwykłe UPS-y.
    Jeżeli chodzi o zabezpieczenia przeciwprzepięciowe to są w rozdzielniach (ale nie znam się - mógłbym najwyżej zrobić ich zdjęcia) oraz na łączach lan do serwerów podłączone są ograniczniki przepięć. Od strony switcha takie -
    929 121 Ethernet Surge Protector - zaś od strony serwerów takie - APC PNET1GB ProtectNet Standalone Surge Protector for 10/100/1000 Base.
  • Użytkownik usunął konto  
  • Poziom 9  
    Przyznam, że nie wiem... W serwerowni na tablicy rozdzielczej widzę, że są 2 fazy, ale jak one są potem rozdzielone na budynek to już nie wiem... Musiałbym spróbować to ustalić.
  • Użytkownik usunął konto  
  • Poziom 9  
    Z tego co wiem, to nie udało się ustalić co śmierdziało. Teraz już nie czuć spalenizny.
    Jutro będę w pracy to jeszcze się temu wszystkiemu poprzyglądam. Na razie dzięki za pomoc :)
  • Poziom 9  
    Na razie nie miałem czasu zerknąć do dokumentacji, ale zrobiłem te 2 zdjęcia.
    Na pierwszym widać (chyba) dwa obwody TK-1 i TK2.
    TK-2 to są komputery i zrobiłem też zdjęcie tej tablicy.
    Większość komputerów działa na tym obwodzie, przy czym nie wszystkie, bo mamy jeszcze część komputerów na "dodatkowy" obwodzie....

    "Zamrażające" się komputery
    "Zamrażające" się komputery
  • Użytkownik usunął konto  
  • Poziom 9  
    Wziąłem się i ja za sprawdzanie kołków w gniazdkach poprzez przykładanie jednej końcówki multimetru do uziemienia z ustawionym multimetrem na prąd zmienny.

    Nie jestem ekspertem, ale zastanowiło mnie, że przy pomiarze jednego z bolców przeskoczyła iskra. Potem napięcie badane było poniżej 1V, ale ta iskra mnie zaniepokoiła... Gdzie jak gdzie, ale na uziemieniu chyba nie powinno czegoś takiego być.
    Pochodziłem jeszcze po budynku i poprzykładałem sondę multimetru do innych uziemień w komputerówce i w zwykłych gniazdkach i wychodziły różne napięcia, w tym m.in. 8V w pokoju, w którym był swąd swego czasu
    Z braku czasu tylko pobieżnie je sprawdziłem, ale chyba będę musiał to dokładnie zrobić.

    Co do dociągnięć w tablicach. Elektryk wziął kamerę IR i patrzył, czy nie ma jakichś źródeł ciepła. Chyba tylko jedną tablicę rozebrał.

    Aha. Zapomniałem dodać, że jak chciałem "pogrzebać" z tyłu jednego z kompów, to mnie prąd kopnął... Czyli też chyba uziemienie nie działa jak należy.
  • Poziom 31  
    Zasilacze komputerowe mają do obudowy podłączone kondensatory. Wiec 110V jest zjawiskiem raczej spodziewanym (dzielnik). Nie zabija, ale też trzeba uważać bo można rozwalić elektronikę.
    Ale jeżeli jest napięcie pomiędzy dwoma punktami to może lepiej sprawdzić żarówką (jeżeli się zaświeci to masz problem :-)). Masz w tej instalacji osobny przewód ochronny PE?
    Poza tym sprawdziłbym też czy na linii nie ma włączonych obwodów zasilającymi świetlówki. Kiedyś zauważyłem, że przy włączaniu takiej głupiej lampki resetuje mi się procesor zasilany z z zasilacza transformatorowego i separowanego (powtarzalne)! Mam wrażenie, że generują się wtedy spore przepięcia, których w prosty sposób nie da się zablokować i które przechodzą przez wszystkie pojemności.
  • Użytkownik usunął konto  
  • Poziom 31  
    Jeżeli pomiędzy dwoma kołkami ochronnymi jest napięcie to jest po między nimi przerwa lub duża rezystancja (można odłączyć zasilanie i sprawdzić omomierzem rezystancję przejścia). I taka sytuacja to rzeczywiście proszenie się o kłopoty. Kiedyś zakłócał się enkoder i okazało się, że pomiędzy ekranem a szyną wyrównującą potencjał miałem rezystancję 50 ohm.
    Nie chodziło mi o warystory, ale o kondensatory do obudowy (z tego co pamiętam to patent eliminował jakieś zjawiska elektrostatyczne) i może na obudowie pojawić się napięcie (np. jak nie w gniazdku nie będzie bolca ochronnego albo jak będzie wisiał w powietrzu).
    Wszystko zależy od podłączenia. Jeżeli masz prawidłowe połaczenia to żadne dziwne potencjały (na stałe) pojawić się nie mogą. W sumie to nie wiadomo jak autor tematu robi pomiary i czy iskra nie była np. pochodzenia elektrostatycznego. Zdecydowanie zacząłbym od sprawdzenia ciągłości kabla ochronnego.
  • Użytkownik usunął konto