Elektroda.pl
Elektroda.pl
X
AM TechnologiesAM Technologies
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory

06 Sty 2016 18:33 4011 21
  • Poziom 11  
    Witam! Mam problem z płytą indukcyjną ( jak w temacie) która nie reaguje na sensory. Po wyłączeniu zasilania i ponownym włączeniu na sekundę zapala się leda startu i wentylator. Po zdjęciu szkła czasami uda się załączyć start i wyświetlacze wyświetlają zero, ale nic więcej nie da się włączyć. Wymaga to chaotycznego nigdy powtarzalnego wielokrotnego dotykania sensorów i czasem załączy się start plusem jednego pola a czasem minusem innego pola a czasem też startem.
    Sprawdziłem napięcia 12V, 9V I 5V nawet oscyloskopem i są ok. Nie ma żadnych tętnień. Wydaje mi się że problem jest w module sterującym, ale nie jestem pewien, a jego cena jest taka że nie mogę sobie pozwolić na pomyłkę. Poza tym może ktoś miał coś podobnego i może można to naprawić bez wymiany całego modułu. Jak myślicie czy ponowne zaprogramowanie modułu ma sens w tym przypadku? Chodzi o to że żeby go przeprogramować muszę dosyć daleko pojechać.

    Pozdrawiam i z góry dziękuję za pomoc.
  • AM TechnologiesAM Technologies
  • Poziom 32  
    Cyrculator napisał:

    Sprawdziłem napięcia 12V, 9V I 5V nawet oscyloskopem i są ok. Nie ma żadnych tętnień. Wydaje mi się że problem jest w module sterującym, ale nie jestem pewien, a jego cena jest taka że nie mogę sobie pozwolić na pomyłkę. Poza tym może ktoś miał coś podobnego i może można to naprawić bez wymiany całego modułu.

    Jeśli napięcia zasilania i filtracja są ok to za takie chaotyczne reakcje modułu może odpowiadać uszkodzony rezonator kwarcowy taktujący mikrokontroler. Nie wiem jaki tam jest mikrokontroler i czy ma zewnętrzny rezonator, ale jeśli jest to spróbuj go wymienić na identyczny. Koszt to kilka złotych więc warto spróbować.
    Miałem podobny przypadek w innym urządzeniu i po wymianie rezonatora jak ręką odjął.
  • AM TechnologiesAM Technologies
  • Poziom 38  
    Wrzuć zdjęcie elektroniki.
  • Poziom 11  
    Witam! Rezonatory kwarcowe są dwa, ale nie na module sterującym tylko na płytach mocy. Dołączam zdjęcia elektroniki , ale robię to pierwszy raz i nie wiem czy się uda. Jeśli rezonatory sa dwa to chyba mało prawdopodobne aby dwa były uszkodzone. Ponadto są one nie na tym module z którym jest problem.
  • Poziom 32  
    Cyrculator napisał:
    Dołączam zdjęcia elektroniki , ale robię to pierwszy raz i nie wiem czy się uda.


    Chyba się nie udało, bo ja tych zdjęć nie widzę. W międzyczasie zerknąłem na płytę, która mam akurat rozkręconą (Electrolux). Faktycznie na płytach generatorów są po dwa rezonatory kwarcowe, ale na płytce z sensorami i mikrokontrolerem jest również rezonator kwarcowy. Bardzo mały, trzynóżkowy, może dlatego go nie zauważyłeś. Wrzucam zdjęcia mojej płytki z sensorami na których zaznaczyłem ten rezonator.
    Czy sprawdzałeś dokładnie napięcie zasilające samą płytkę sensorów? Czy jest dobrze odfiltrowane? Do mojej płytki doprowadzone są tylko trzy przewody +5V, BUS i masa.
    Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory
    Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory
  • Poziom 11  
    Przepraszam, ale nie podałem adresu tych fotek, bo chyba o to chodzi. W tej płycie na płytce z sensorami jest stabilizator 5V i te 5V jest ok.

    Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory Płyta indukcyjna Ariston, KIC642C - Nie reaguje na sensory
  • Poziom 32  
    Jakie jest oznaczenie tego mikrokontrolera, który jest na płytce bezpośrednio współpracującej z sensorami? Na zdjęciach nie bardzo to widać.
  • Poziom 11  
    Właśnie już znalazłem tego mikrokontrolera w internecie i chyba go zamówię żeby go wymienić. Jest to CY8C 21534. Próbowałem oscyloskopem na tej magistrali między nim a kontrolerem głównym wyłapać czy jest jakiś impuls od aktywowanych sensorów. Niestety albo nie ma żadnej reakcji albo nie potrafiłem tego zmierzyć. Jest tam 5 przewodów sygnałowych i na co drugim w stosunku do masy oscyloskop wyłapuje paczki nieregularnych ( w sensie szerokości i nawet polaryzacji amplitudy) impulsów z bardzo małą częstotliwością pomiędzy tymi paczkami bo około 1 sekundy czyli 1 Hz. Natomiast nie widać zauważalnych zmian od sensorów. Jest to jakieś takie dziwne szczególnie to że impulsy maja czasem amplitudę ujemną , co jest dla mnie niewytłumaczalne.
    Jeśli chodzi o tego rezonatora kwarcowego to na pewno go nie ma na tych dwóch płytkach.
    Dziękuję za zaangażowanie szczególnie kris 8888 i liczę. na jeszcze
  • Poziom 32  
    Cyrculator napisał:
    Właśnie już znalazłem tego mikrokontrolera w internecie i chyba go zamówię żeby go wymienić. Jest to CY8C 21534.


    Masz możliwość zakupu już zaprogramowanego mikrokontrolera pod tą konkretną płytę? Czy sam go oprogramujesz? Masz odpowiedni wsad dla tego układu?
    Ten układ faktycznie ma wewnętrzny zegar 24/48 MHz nie wymagający zewnętrznego oscylatora kwarcowego.
  • Poziom 11  
    Niestety w cyfrówce jestem słaby i myślałem że ten mikrokontroler nie musi być zaprogramowany. Myślałem że program jest w pamięci tego głównego kontrolera.
    Wiem że cały ten moduł mogę zaprogramować . ale muszę pojechać dosyć daleko.
    Możesz mi przybliżyć trochę jak to jest z tym programowaniem i coś więcej na temat komunikacji między tymi dwoma kontrolerami?
  • Pomocny post
    Poziom 32  
    Cyrculator napisał:
    Myślałem że program jest w pamięci tego głównego kontrolera.

    Moim zdaniem to właśnie ten CY8C 21534 jest głównym kontrolerem całej płyty, te dodatkowe nadzorują tylko prace konkretnych generatorów i służą do komunikacji z głównym kontrolerem. Z oprogramowaniem układu już niestety nie pomogę, bo takiego konkretnie nigdy nie robiłem, nie mam też wsadu do tej płyty.
  • Poziom 11  
    Chyba się źle zrozumieliśmy, to znaczy ja źle Ciebie zrozumiałem. Podałem Ci typ mikrokontrolera który jest na tej osobnej płytce z sensorami, jest prostokątny i ma 2x14 nóżek. On współpracuje z tym głównym na tej drugiej płytce z wyświetlaczami a tamten z dwoma mniejszymi na płytach mocy czy też inwerterów. Na moje wyczucie to najbardziej podejrzany jest ten na płytce z sensorami a on może korzystać z wsadu tego na płytce z wyświetlaczami. To są takie moje dywagacje ale nie wiem czy sensowne. Co Ty na to? Oznaczenie tego wiekszego mikrokontrolera na płytce z wyswietlaczami jest tródno czytelne nawet pod lupą i nie jestem pewien czy dobrze spisałem. Jest to : 36078 GHV lub CHV a w drugiej linii: H6/36076
    Jeśli chodzi o wsad do całości czyli tych dwóch płytek to pojadę do serwisu żeby to zaprogramować , ale wolałbym być przekonany że jest znaczne prawdopodobieństwo że to coś da.
  • Poziom 32  
    A to przepraszam, nie zauważyłem, że tam są dwa mikrokontrolery. Swoja drogą bardzo przekombinowany moduł, z oddzielnym mikrokontrolerem do sensorów i oddzielnym do wyświetlaczy oraz kontroli reszty płyty. Tak czy inaczej każdy z nich musi mieć wgrany swój własny program, nawet jeśli realizuje tak ograniczoną funkcję jak obsługa sensorów.
    Ten większy to układ firmy Renesas. Chyba musisz zaryzykować przeprogramowanie obydwu układów.
  • Poziom 11  
    Ok , przeprogramować obydwa, ale jak to się robi . Czy to jest tak że to co w serwisie mi mogą zrobić, tzn. przeinstalować softwear prze złącze zewnętrzne które jest tylko jedno i wtedy oni przeprogramują obydwa kontrolery, czy tylko ten główny? Jeśli tylko ten główny to jak zaprogramować ten na płytce z sensorami?
  • Poziom 25  
    Do zaprogramowania np CY8C 21534 potrzebujesz programatora który nie jest tani oraz "wsadu" czyli programu który masz wgrać do tego mikrokontrolera.
    Robi się to najczęściej wkładając mikrokontroler do programatora lub też po przez złącze np. ISP czyli programuje się mikrokontroler wlutowany w sterownik po przez dolutowanie kabelków z programatora do płyty sterownika o ile takie wejście posiada.
    Programator może i byś znalazł w jakimś serwisie ale gorzej pewnie będzie z wsadem gdyż producent go nie udostępnia a z czytać wsad z działającego mikrokontrolera za pewnie się nie da gdyż jest on chroniony przed odczytem.
    Lepiej szukaj nowego sterownika.
  • Poziom 11  
    Witam po dłuższym czasie. Nie miałem ostatnio czasu i temat zawiesiłem. W serwisie mogą mi przeprogramować cały moduł sterujący razem, tylko nie wiem czy w praktyce to będzie przeprogramowanie obu mikro kontrolerów czy tylko tego głównego. Czy na pewno jest tak w tym przypadku że oba mikro kontrolery mają osobny wsad?
  • Poziom 25  
    Cyrculator napisał:
    W serwisie mogą mi przeprogramować cały moduł sterujący razem, tylko nie wiem czy w praktyce to będzie przeprogramowanie obu mikro kontrolerów czy tylko tego głównego.

    To się zapytaj, być może chcą tylko przelutować mikrokontroler albo mają faktycznie wsady.
    Pisałeś wcześniej że coś się wyświetla na wyświetlaczu czyli główny procesor jest raczej sprawny.

    Cyrculator napisał:
    Czy na pewno jest tak w tym przypadku że oba mikro kontrolery mają osobny wsad?

    Na 100% mają różny wsad.

    Sprawdź napięcie bezpośrednio na pinach 9 oraz 28 ( CY8C 21534) powinno być tam od 3.0 V do 5.25 V.
    Wydaję mi się że na pinach 13 oraz 15 jest magistrala I2C przez którą odbywa się komunikacja z głównym mikrokontrolerem, sprawdź przejścia aż do samego głównego mikrokontrolera może gdzieś ci taśma nie łączy.

    A może po prostu sensory są uszkodzone.
  • Poziom 11  
    Dzięki Daro za radę. Posprawdzam to ale nie bardzo wiem jak mogłyby się uszkodzić sensory i to wszystkie? Prawdę mówiąc nie wiem jak one dokładnie działają ale tam nic nie ma. Same sensory to tylko ścieżki i sprężynki. Czy to jest jakieś działanie pojemnościowe, ale jak to działa że działa nawet na zbliżenie? Przecież nie ma tam żadnych elementów foto optyki?
  • Pomocny post
    Poziom 38  
    CY8C21534 "robi" za obsługę przycisków pojemnościowych. Objawy wskazują albo na rozkalibrowanie przycisków (być może w jakimś trybie serwisowym jest procedura kalibracji) albo błędy w komunikacji z procesorem "aplikacyjnym".
    Sprawdź tasiemkę łączącą obie płytki.
  • Pomocny post
    Poziom 25  
    Cyrculator napisał:
    Dzięki Daro za radę. Posprawdzam to ale nie bardzo wiem jak mogłyby się uszkodzić sensory i to wszystkie? Prawdę mówiąc nie wiem jak one dokładnie działają ale tam nic nie ma. Same sensory to tylko ścieżki i sprężynki. Czy to jest jakieś działanie pojemnościowe, ale jak to działa że działa nawet na zbliżenie? Przecież nie ma tam żadnych elementów foto optyki?


    Czytałeś TEN temat?

    Piszą tam że są 2 rodzaje sensorów pojemnościowe oraz optyczne, u ciebie wygląda na to że są pojemnościowe ale nie wiem w jaki sposób reaguje na zbliżenie.
  • Poziom 11  
    Przed chwilą skończyłem naprawiać płytę TEKA i tam były sensory optyczne. Tutaj są zapewne pojemnościowe które działają na zbliżenie i to przez szkło?? Loker o co chodzi z tą kalibracją sensorów? Czy jest to przypisanie sensora do konkretnej funkcji czy raczej o jakieś parametry elektryczne. Na tej płytce sensorów nie ma prawie nic oprócz tego microcontrolera, stabilizatora 5v i kilku rezystorów. Ścieżki z sensorów wchodzą poprzez rezystor na wejścia microcontrolera a wyjścia z niego też przez rezystory na taśmę i wchodzą na drugą płytkę.
    Skończyłem TEKĘ to wracam do Aristona. Ponieważ klient już zrezygnował z naprawy i zostawił mi płytę to nie ma pośpiechu, ale naprawić by się przydało.
  • Poziom 11  
    Dziękuję wszystkim za pomoc i temat uważam za zamknięty. Przeprogramowanie pomogło.
    Pozdrawiam