Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Kłopoty z wymuszeniem operatora przy połączeniu z Internetem.

kuferekczasu 09 Sty 2016 13:01 774 1
  • #1 09 Sty 2016 13:01
    kuferekczasu
    Poziom 31  

    Korzystam z Play - działa u mnie w roamingu, najlepiej w T-Mobile. Nie umiem wymusić aby działał tylko tam, gdy przełącza do Plus to Internet działa tragicznie.

    W informacji o połączeniu wychodzi że modem mam jako ttyUSB1

    echo -e "AT+COPS=1,2,\"26002\"\r" > /dev/ttyUSB1

    nic to nie daje. Skoro to ttyUSB1 więc wyłączyłem modem, i wstukałem
    cat /dev/ttyUSB1 i pokazuje że zasoby są zajęte. Natomiast pod ttyUSB0 nic się nie dzieje i nie ma komunikatu ostrzegawczego.

    Zainstalowałem rozszerzenie klasycznego menedżera połączeń o nazwie Modem Manager GUI http://www.unixmen.com/modem-manager-gui-linux-mobile-partner-application-usb-modems/

    Kłopoty z wymuszeniem operatora przy połączeniu z Internetem. Kłopoty z wymuszeniem operatora przy połączeniu z Internetem.

    Wyszukuje jak widać sieci ale nie ma opcji wymuszania.

    Jest opcja uruchomienia ppd ale z listy nic się nie dzieje, a ja nie wiem gdzie wpisywać komendy i czy to działa https://wiki.archlinux.org/index.php/3G_and_GPRS_modems_with_pppd#Operator_selection

    Modemy to E180/E3131s2. SparkyLinux na Debianie.

    0 1
  • #2 12 Sty 2016 13:25
    kuferekczasu
    Poziom 31  

    Koszmarne problemy wynikły z instalacją Mobile Partner. Z tego co piszą najlepsza jest wersja MoviStar 3.5G
    specjalnie pod Debiana. U mnie zadziałała inna ale tylko na krótko, ponieważ po restarcie całkowicie nie wykrywa modemu
    w domyślnym menedżerze połączeń ani w Mobile Partner.

    W dodatku podczas instalacji Mobile artner zgłasza brak sterownika NSDIS.
    Install NDIS driver failed.
    The compliling enviroment is not all ready.
    Please check gcc, make and kernel buid [etc]

    Częściowo poradziłęm sobie poprzez poradę tutaj http://askubuntu.com/questions/323031/how-to-...is-driver-for-huawei-mobile-broadband-devices

    Tyle że nigdzie nie pisza tam, że mogę mieć coś nie wgranego przez Synaptic jak sugeruje komunikat.

    Nadpisywałem kilka wersji Mobile Partnera w dodatku on instalował się w dwóch różnych katalogach, ale poprawnie. Tylko z jednego mogę go odinstalować ale instalacja nie rusza. Natomiast z paska menu jest skrót "Odinstaluj" ale on prosi
    o wykonanie tego polecenia poprzez Administratora też nie wiem jak to wszystko odinstalować?

    Została mi płytka z OEM Windows XP. Widać że nikt nie chcę mi pomóc, a walczę z problemem już drugi dzień.

    0