Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Cisco 861-W - Router Cisco 861-W jak skonfigurować?

09 Sty 2016 14:24 2199 30
  • Poziom 11  
    Witam Szanownych Forumowiczów.
    Dostałem od znajomego powyższy router, ale nie potrafię go skonfigurować. Zrobiłem stosowny kabelek do RS-232, łączę się z routerem poprzez Putty i na tym moja wiedza się kończy.
    Chciałbym skonfigurować router, aby działał jak standardowy router wifi.
    Wszelka pomoc mile widziana.
  • PCBway
  • Poziom 24  
    Witam,
    Po tym jak podłączysz się konsolą czyli tym kabelkiem RS232 do portu oznaczonego jako Console powinieneś dostać prompt ">". Wpisz polecenie "enable" powinieneś dostać prompt "#". Wpisz komendę "show run" a potem podaj co Ci wyświetliło. Może być na forum może być na PW. A potem powiedz co jak masz podłączone i jak ma to pracować. Wydaje się że będę w stanie pomóc :)
  • Poziom 17  
    konfiguracja tego urzadzenia nie jest prosta, w szczegolnosci jesli nie masz pojecia o cisco. 861W to router z wbudowanym AP, musisz osobno zaprogramowac router i osobno access pointa.
    Zobacz https://www.youtube.com/watch?v=BnaA0_zmpXA jest tam opisana konfiguracja od zera.
  • Poziom 11  
    Po twardym resecie podałem login i hasło cisco, pojawiło się ostrzeżenie o konieczności zmiany loginu i hasła i poniżej
    yourname#
    wpisałem show run - poniżej wynik
    Building configuration...

    Current configuration : 5114 bytes
    !
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boo-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    memory-size iomem 10
    !
    crypto pki trustpoint TP-self-signed-1776935157
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1776935157
    revocation-check none
    rsakeypair TP-self-signed-1776935157
    !
    !
    crypto pki certificate chain TP-self-signed-1776935157
    certificate self-signed 01
    tutaj cały ciąg ośmioznakowych liczb szesnastkowych
    quit
    ip souce-route
    !
    !
    ip dhcp exluded-address 10.10.10.1
    !
    ip dhcp pool ccp-pool
    import all
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    lease 0 2
    !
    !
    ip cef
    no ip domain lookup
    ip domain name yourdomain.com
    !
    !
    license udi pid CISCO861W-GN-E-K9 sn FCZ........
    !
    ...
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered Vlan1
    arp timeout 0
    !
    interface Wlan-GigabitEthernet0
    description Internal switch interface connecting to the embedded AP
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-WHIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    ip tcp adjust-mss 1452
    !
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    access-list 23 permit 10.10.10.0 0.0.0.7
    no cdp run

    !
    control-plane
    !
    banner exec ^C
    % Password expiration warning.


    a dalej znowu ostrzeżenia o potrzebie zmiany hasła i takie tam...
    na końcu pojawia się linia zachęty w formie
    yourname#
  • Poziom 24  
    No to tera powiedz jak ma to dzialac a powiem jak to skonfigurowac. Jakies adresy od operatora jaki rodzaj zabezpieczenia wifi itp.
    Na razie wyglada to tak ze jak podepniesz sie komputerem pod porty fasteth 0-3 to powinienes z dhcp dostac adres z puli 10.10.10.2-6
    Prawdopodobnie 10.10.10.2

    Dodano po 2 [godziny] 14 [minuty]:


    "Takie tam" z Twojego posta mogą mieć znaczenie. Zależy co tam jest.

    zaloguj się na router, wpisz "enable" potem "conf t"
    a następnie skopiuj to co poniżej i wklej na router
    potem podłacz portem Fe4 do swojego dostawcy Internetu i wydaj polecenie
    ping 8.8.8.8 source 10.10.10.1
    "sh ip route" "sh ip nat trans"

    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 10.100.1.1
    ip dhcp pool ccp-pool
    import all
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    lease 0 2

    ip dhcp pool wifi
    import all
    network 10.100.1.0 255.255.255.0
    default-router 10.100.1.1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    ip address dhcp
    no shutdown
    duplex auto
    speed auto
    ip nat outside
    ip virtual-reassembly

    !
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered Vlan100
    arp timeout 0

    interface Wlan-GigabitEthernet0
    description Internal switch interface connecting to the embedded AP
    switchport trunk native vlan 100
    switchport mode trunk
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-WHIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    ip tcp adjust-mss 1452
    ip nat inside

    interface vlan100
    ip address 10.100.1.1 255.255.255.0
    ip nat inside
    !
    ip forward-protocol nd
    no ip http server
    no ip http access-class 23
    no ip http authentication local
    no ip http secure-server
    no ip http timeout-policy idle 60 life 86400 requests 10000

    access-list 1 permit 10.0.0.0 0.255.255.255

    ip nat inside source list 1 interface fastethernet 4 overload


    !
    dot11 ssid moj_ssid
    vlan 100
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 moje_tajne_haslo

    bridge irb

    interface Dot11Radio0
    no ip address
    ip ip route-cache

    encryption vlan 100 mode ciphers tkip
    station-role root

    interface Dot11Radio0.100
    encapsulation dot1Q 100 native
    no ip route-cache
    bridge-group 1
    bridge-grouo 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled

    interface GigabitEthernet0
    description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache

    interface GigabitEthernet0.100
    encapsulation dot1Q 100 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled


    ip default-gateway 10.100.1.1
    no ip http server
    no ip http secure-server
    bridge 1 protocol ieee
    bridge 1 route ip
  • Poziom 11  
    Wpisywałem wszystkie podane przez Ciebie polecenia, ale przy komendzie dot11 coś się zbuntowało

    % Invalid input detected at '^' marker.

    Czy dobrze rozumiem, że nie rozpoznaje komendy dot11 ?

    Do tego miejsca wszystko szło dobrze...
  • Poziom 24  
    witam,

    Po komendzie "ip nat inside source ...." wpisz "service-module wlan-ap 0 session", otworzy coś co wygląda jak druga sesja telnet'a do urządzenia. Po połączeniu znowu "enable i tam wpisz wszystko co było od dot11...
    To wygląda trochę tak jakby Cisco połączyło ze sobą dwa różne urządzenia i trzeba w sumie skonfigurować najpierw router, potem access point, i jeszcze wszystko ze sobą połączyć logicznie :)

    I jeszcze wyjscie z tego trybu
    Control-Shift-6 x
    Disconnect
    2x Enter
  • Poziom 11  
    Chyba nie rozpoznaje komendy service-module...
    Otrzymuję:
    % Invalid input detected at '^' marker.
  • Poziom 24  
    Jak jesteś na poziomie enable co wyświetla po wpisaniu znaku zapytania? powinien pokazać początek wszystkich dostępnych komend - choć zdarza sie że niektóre komendy nie są widoczne aczkolwiek istnieją :)
  • Poziom 11  
    Podam tylko same komendy - bez opisów
    Exec commands:

    access-profile
    archive
    beep
    bfe
    cd
    clear
    clock
    cns
    configure
    connect
    copy
    crypto
    debug
    delete
    dir
    disable
    disconnect
    dot1x
    enable
    eou
    erase
    exit
    format
    fsck
    help
    if-mgr
    license
    lock
    login
    logout
    mkdir
    monitor
    more
    mrinfo
    mstat
    mtrace
    name-connection
    no
    partition
    ping
    ppp
    pwd
    radius
    release
    reload
    rename
    renew
    restart
    resume
    rmdir
    rsh
    send
    service-module
    set
    setup
    show
    slip
    spec-file
    ssh
    start-chat
    systat
    tclquit
    telnet
    terminal
    test
    traceroute
    tunnel
    undebug
    upgrade
    verify
    vlan
    vtp
    webvpn
    where
    write
    xconnect
  • PCBway
  • Poziom 24  
    jak widać service-module jest, może burzy się dalej
    wpisz albo pełna komendę i pokaz wynik albo wpisz "service-module ?" - powinien wyświetlić kolejna listę dostępnych komend czyli to co można wpisać po service-module. Szukaj wlan-ap lub nawet wlan-ap0 jak będzie znów pisz "service-module wlan-ap0 ?" powinno być session
    a jak czegoś nie ma po np jest "serwice-module wlan-ap0" a nie ma dalej session pokaz wynik "service-module wlan-ap0 ?"
  • Poziom 11  
    Po wpisaniu service-module ? otrzymuję tylko jeden wynik:

    wlan-ap

    a po wpisaniu service-module wlan-ap ? otrzymuję

    <0-0> wlan-ap interface number

    natomiast wpisanie service-module wlan-ap0 kwituje

    % Incomplete command.
  • Poziom 24  
    może dlatego że jak napisałem wcześniej pełna komenda to "service-module wlan-ap 0 session"
    jak wpiszesz "ervice-module wlan-ap 0 ?" to otrzymasz dalsze możliwości tej komendy.
    przy niektórych komendach jest tak że mozna wpisac komende opdstawową ,albo ją rozszerzyć, np na switchach czyms takim będzie:
    show interface fast0/0
    podanie takiej komendy spowoduje wyświetlenie pewnych informacji, ale jest tez komenda:
    sh interface fast0/0 switchport i ta wyświeli coś nieco innego :)
    za to po wpisaniu "show interface fast0/0 ?" w odpowiedzi dostarniem coś a'la
    <cr>
    switchport
    ....

    <cr> oznacza że po tym show interface fast0/0 można wcisnąc Enter, jeśli tego <cr> nie ma to znaczy ze komenda jest niekompletna i trzeba brnąć dalej :)

    No ale wydaje sie że jesteśmy już blisko ostatecznej konfiguracji urządzenia.
  • Poziom 24  
    No to tera powiedz jak ma to dzialac a powiem jak to skonfigurowac. Jakies adresy od operatora jaki rodzaj zabezpieczenia wifi itp.
    Na razie wyglada to tak ze jak podepniesz sie komputerem pod porty fasteth 0-3 to powinienes z dhcp dostac adres z puli 10.10.10.2-6
    Prawdopodobnie 10.10.10.2
  • Poziom 11  
    Zależy mi na tym, aby urządzenie to działało jako standardowy router wifi - obecnie używam d-link DIR-600, ale jego zasięg wifi jest "niezadowalający".
    Usługodawca dostarcza mi usługę internetu przez modem - dynamiczne IP, mac adres nieistotny.
    W domu posiadam kilka urządzeń połączonych z routerem przez RJ-45 jak i kilka po wifi. Sieć wifi zabezpieczona jest protokołem WPA/WPA2 TKIP/AES.
    Nie korzystam z ustawień QoS, NAT, port forwarding itp.
    Jedyne na czym by mi zależało to możliwość wyboru kanału (częstotliwości) pracy wifi.
    Chciałbym też, aby router sam przydzielał adresy nowo przyłączanym urządzeniom - DHCP.

    Przy okazji pytanie: czy w urządzeniu tym można aktualizować oprogramowanie a jeżeli tak, to czy warto?
    I czy w ogóle jest jakieś oprogramowanie pozwalające na bardziej ludzką obsługę i konfigurację tego routera?
  • Poziom 24  
    daj znać czy udało Ci się wydać komendę "service-module wlan-ap 0 session"
    powinno isc jak pisałem jak nie bedzie chciało wejśc podaj co widać po "service-module wlan-ap 0 ?"
    Wg mnie jednak chcesz NAT bo inaczej to razej działaś nie będzie
    DHCP juz masz

    Oprogramowianie można aktualizowac ale trzeba mieć ważna umowę serwisową - to kwestia licencyjna. Oczywiscie.... sam wiesz

    Jest program graficzny do konfiguracji routerów. z tym że próbowałem go używać może ze dwa razy. Nie lubie, nie znam, wolę CLI :) Program nazywa się chyba Cisco Configuration Professional. Piszę chyba bo pewności nie mam.
    Tu jest link do obejrzenia jak działa:
    http://www.cisco.com/assets/cdc_content_eleme...dded-video/video-data-sheets/ccp-overview.swf
    Kwestii licencyjnych nie znam

    Jeśli uda się odpalić to wifi to podana konfiguracja powinna załatwić wszystkie Twoje potrzeby. Jedyne czego może brakować to:

    ip dhcp pool ccp-pool
    dns-server 8.8.8.8 8.8.4.4

    ip dhcp pool wifi
    dns-server 8.8.8.8 8.8.4.4


    masz adres publiczy od operatora czy prywatny?
    podłacz router do modemu usługodawcy i wydaj komendę "sho ip int brie"
    i pokaż jaki tam adres widać na FastEthernet4 - możesz to wysłac na PW
  • Poziom 11  
    Sorki za tak długą przerwę, ale nie samą Elektrodą człowiek żyje...
    Po kolei:
    1. Zrobiłem Hard reset
    2. enable, conf t a potem wszystkie komendy do nieszczęsnej dot11 ssid...
    3. Wyszedłem komendą exit
    4. Teraz ponownie enable i service-module wlan-ap 0 session - poszło!
    5. Pojawiła się zachęta ap#
    i tutaj się zaciąłem...
    może przedstawię Ci listę komend wyświetloną po wpisaniu ?:
    access-enable
    access-template
    archive
    cd
    clear
    clock
    cns
    configure
    connect
    copy
    crypto
    debug
    delete
    dir
    disable
    disconnect
    dot11
    dot1x
    enable
    erase
    exit
    format
    fsck
    help
    led
    lock
    login
    logout
    mkdir
    monitor
    more
    name-connection
    no
    ping
    pwd
    radius
    release
    reload
    rename
    renew
    resume
    rmdir
    rsh
    save
    send
    set
    show
    ssh
    systat
    telnet
    terminal
    test
    traceroute
    tunnel
    undebug
    upgrade
    verify
    where
    write
  • Pomocny post
    Poziom 24  
    No i ciągniesz dalej:

    być może

    enable secret tajnehaslo

    a potem

    dot11 ssid moj_ssid
    vlan 100
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 moje_tajne_haslo

    bridge irb

    interface Dot11Radio0
    no ip address
    ip ip route-cache

    encryption vlan 100 mode ciphers tkip
    station-role root

    interface Dot11Radio0.100
    encapsulation dot1Q 100 native
    no ip route-cache
    bridge-group 1
    bridge-grouo 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled

    interface GigabitEthernet0
    description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache

    interface GigabitEthernet0.100
    encapsulation dot1Q 100 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled


    ip default-gateway 10.100.1.1
    no ip http server
    no ip http secure-server
    bridge 1 protocol ieee
    bridge 1 route ip
  • Poziom 11  
    Muszę robić jakiś podstawowy błąd...
    W końcu udało mi się wpisać twoje komendy do AP (trzeba było wejść do konfiguracji przez komendę conf t). Poprawiłem kilka literówek, ale właściwie router zachowuje się jakby był po resecie.
    Nie znam się zbytnio na programowaniu takich routerów więc moje pytanie zabrzmieć może śmiesznie: czy wprowadzonych zmian nie trzeba jakoś zatwierdzić/zapisać? Czy po restarcie router na pewno wykonuje wprowadzone polecenia?
  • Poziom 24  
    Hmmmm
    Po wydaniu komendy na cisco jest ona uwzgledniana natychmiast. Za to nie jest zapisywana. Zatem po resecie nie bedzie nic.
    Po skonfigurowaniu tego co trzeba nalezy wyjsc z trybu konfiguracii np przez ctrl+z (dziala jeszcze exit lub end- nie pamietam ktore) powinno sie pojawic w promotor
    hostname#
    I wpisac komende "wri" lub "copy runn start"
    Blednie zakladalem ze taka podstawowa wiedza jest :(
  • Poziom 11  
    Obecne spostrzeżenia:
    1. Zapisałem pracę po konfiguracjach, system wstaje już z wpisywanymi ustawieniami - tak sądzę.
    2. Internet po kablach śmiga dobrze.
    3. Wifi nie działa - router "nie nadaje".
    4. Wcześniej o tym nie wspominałem, ale zawsze podczas startu routera gdzieś w środku wyświetlanych różnych linii informacji w terminalu pojawia się komenda control-plane a pod spodem
    % Invalid input detected at '^' marker.
    potem uruchamianie trwa dalej.
  • Poziom 24  
    jak widać komenda ma znacznik ^
    można zobaczyć na co on wskazuje bo to jest właśnie to co mu sie nie podoba
    Wszystkie podane wcześniej komendy weszły bez problemu?
  • Poziom 11  
    Wspomniany znacznik wskazuje na komendę control.
    Router zapewne skonfigurowany jest prawidłowo, bo po kabelkach działa.
    Nie działa AP, a przynajmniej ja nie znajduję tworzonej sieci wifi.

    [Aktualizacja]

    Coś jednak się posypało, bo dzisiaj router już po kabelku nawet nie śmiga. Może coś spaprałem?.... Zresetuję go i zacznę od początku

    Przy okazji mam pytanie: co oznaczają (w znaczeniu jaką pełnią rolę) wykrzykniki? Czy wielkość liter ma znaczenie, a jeżeli tak to kiedy?

    Zrestartowałem na fabrycznych, wpisałem ustawienia na nowo - znowu działa....
  • Poziom 24  
    Wykrzykniki nic nie znaczą. Tak na prawde sa po to zeby przy wyswietlaniu konfiguracji byla ona bardziej czytelna.

    W konfiguracji wielkosc liter w komendach nie ma zazwyczaj znaczenia. Jedyne miejsce w konfiguracji ktore kojarze i gdzie wielkosc liter ma znaczenie to hasła.

    Jesli chcesz to daj znac jak mozna zalogować sie na ten Twoj router o ile masz publiczne IP to moze tak dam rade Ci pomóc.
  • Poziom 11  
    Chyba znalazłem rozwiązanie: brakowało komendy interface dot11radio 0

    I teraz mam sieć wifi widoczną.

    Zaczynam testy :D
  • Poziom 11  
    Niestety chyba router nie całkiem jest sprawny. Pomimo połączenia się z routerem po wifi transfery są raczej żałosne... I teraz nie wiem, czy jest to wina sprzętu czy może nie do końcac dobrej konfiguracji...
  • Poziom 24  
    co znaczy żałosne? ile masz a ile chciałbyś osiagnąć?
    której wersji protokołu 802.11 używasz?
  • Poziom 11  
    Strasznie namieszałem.... Podczas różnych prób zmieniałem trochę konfigurację, aż w końcu router przestał działać poprawnie. Postanowiłem przywrócić router do stanu "zerowego" komendami write erase i potem reload. Po restarcie router proponuje wstępną konfigurację, której za diabła nie potrafię przejść.
  • Poziom 24  
    nie dotykaj :)

    na pytanie odpowiedz że nie chcesz tej autokonfiguracji - chyba na pierwsze pytanie wystarczy odpowiedzieć "no" i dostaje się w miarę czysta konfigurację routera.
  • Poziom 11  
    Musiałem coś straszliwie namieszać. Teraz router nie funkcjonuje poprawnie - niezależnie od tego czy przejdę wstępną konfigurację czy nie. Wpisuję Twoje konfiguracje i nic.
    Prośba: jak przywrócić "fabryczne" ustawienia i co zrobić, aby przywrócić router do życia?