Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Generator drgań RC, nie działa

danio8522 11 Sty 2016 23:11 483 5
  • #1 11 Sty 2016 23:11
    danio8522
    Poziom 12  

    Jest to podobno (generator z przesuwnikiem RC. Przesunięcie fazy wzmacniacza WE w tym układzie wynosi 180o , ale przesunięcie drabinki ­też 180o , co zapewnia warunki konieczne do wystąpienia generacji warunki Barkhausena). Trzy tranzystory BFP521. Kondensator który wskazałem jest prawdopodobnie nie odpowiedni (teraz jest elektrolityczny 10uf). Pozostałe kondensatory to 2x cbb22 630V 684j, reszta to oporniki i termistor. Wymieniłem wszystko oprócz oporników a układ po podaniu napięcia dalej milczy.
    Generator drgań RC, nie działa

    0 5
  • #2 11 Sty 2016 23:24
    rb401
    Poziom 32  

    Ten czarny kabel jest coś dziwnie. Czy to zasilanie?

    Po za tym, te części z lewej (dwa oporniki, kondensator i tranzystor) wydają się być nie związane z resztą układu. Dochodzi do nich tylko zasilanie.


    A tak ogólnie to nie wygląda mi to na generator z przesuwnikiem fazy, tylko na klasyczny multiwibrator astabilny. brakuje tylko opornika (tam gdzie ten dziwny kabel dochodzi). I przede wszystkim brakuje charakterystycznego "skrzyżowania" obydwóch połówek multiwibratora.

    0
  • #3 11 Sty 2016 23:25
    danio8522
    Poziom 12  

    Nie, to jest termistor.

    0
  • Pomocny post
    #4 12 Sty 2016 00:00
    rb401
    Poziom 32  

    Teraz już mi się rozjaśnia. Rozumiem że na końcu tego czarnego kabelka jest jakiś element, którego zmiany oporności mają zmieniać wysokość dźwięku.

    Ale masz ewidentny błąd w połączeniach bo te duże kondensatory powinny być podłączone od kolektora jednego tranzystora do bazy drugiego (i vice versa), a Ty masz je połączone do bazy tego samego tranzystora, z którego kolektora wychodzą. Tak na krzyż. Wygoogluj sobie obrazek jakiegoś "multiwibratora astabilnego" to zauważysz o co chodzi.
    A w takiej postaci jak teraz to ten układ z pewnością nie ruszy.

    Ten kondensator, który zaznaczyłeś nie jest jakiś krytyczny. Sprzęga on tylko multiwibrator z tranzystorem sterującym głośnikiem. Taki jaki dałeś powinien być dobry.

    0
  • #5 12 Sty 2016 16:27
    danio8522
    Poziom 12  

    Po obróceniu kondensatorów układ zaczął działać, dźwięk wydawany podobny do transformatora. Im większa temp termistora tym częstotliwość dźwięku rośnie. Ja tak podgrzałem termistor że doszło chyba do najwyższej częstotliwości i zamilkło. Po wymianie środkowego tranzystora znów działa. Czy istnieje możliwość zabezpieczenia?

    0
  • Pomocny post
    #6 12 Sty 2016 20:31
    rb401
    Poziom 32  

    Powód awarii jest oczywisty. Termistor jest włączony w zasilania szeregowo ze złączem baza-emiter. Zmniejszając jego oporność (przez podgrzanie) zwiększał się prąd płynący przez tranzystor aż do przekroczenia limitu. A w przypadku BF521 producent podawał absolutne maksimum prądu bazy na poziomie 5mA.

    W celu zapobiegania takim wypadkom, klasyczne rozwiązanie to dodanie szeregowo ze zmiennym oporem (potencjometr, termistor itp. ), opornika o takiej wartości, by dla minimalnej wartości zmiennego elementu (w tym nawet czystego zwarcia), w tej gałęzi płynął prąd, który jest w najgorszym wypadku taki jak podaje producent tranzystora jako maksymalny.

    W Twoim przypadku tak pi razy drzwi ten dodatkowy opornik obliczasz ze wzoru:
    (Uz-0,7V)/0,005A gdzie Uz to napięcie zasilania. Oczywiście te wyliczenie to dolna granica, można dać większą (omowo) wartość, ale nie warto przesadzać bo większa wartość zmniejsza "czułość" układu, czyli zamianę zmian oporu na zmianę wysokości dźwięku.

    0