Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nie działający programator AVRmkII

pawelcb33 16 Sty 2016 16:14 846 9
  • #1 16 Sty 2016 16:14
    pawelcb33
    Poziom 24  

    Witam


    Posiadam klon programatora jak w temacie, nie używałem go jeszcze i tak przeleżał trochę. Wcześniej posiadałem uniwersalny jakiś VP*** z którym nie było problemów.

    Do rzeczy.
    Programator taki jak na zdjęciu wraz z adapterem
    Nie działający programator AVRmkII

    Nie działający programator AVRmkII

    Po podłączeniu i zainstalowaniu jest widziany:

    Nie działający programator AVRmkII

    Wcześniej wgrany firmware dla avrdude, uruchamiam program AVR Burn o Mate i konfiguruję tak:

    Nie działający programator AVRmkII

    Po zrestartowaniu programu i podłączeniu adaptera z uC Amtega8 oraz wczytaniu wsadu wywala mi takie błędy:

    Nie działający programator AVRmkII


    Tak jakby nie widział programatora. Ustawiałem już w settings->avrdude asbasp tak jak w opisie Mirleya ale i tak nic z tego. Instalowałem także jakąś paczkę sterowników pod Win7 64bit i to samo.

    Czy miał ktoś już coś podobnego ?
    Czytałem gdzieś że ten programator ma problem z systemami 64 bitowymi, czy to prawda ?

    0 9
  • #2 17 Sty 2016 06:12
    emarcus
    Poziom 35  

    pawelcb33 napisał:
    Witam


    Posiadam klon programatora jak w temacie,

    Po podłączeniu i zainstalowaniu jest widziany:

    Nie działający programator AVRmkII

    Wcześniej wgrany firmware dla avrdude, uruchamiam program AVR Burn o Mate i konfiguruję tak:

    Nie działający programator AVRmkII



    Tak jakby nie widział programatora. ?


    Bo go nie widzi....
    Musisz mu wskazac gdzie podłączony.
    W Device Manager (Manager urządzeń (?) -górny obrazek - odszukaj numer portu do którego jest podłączony ten programmer i wpisz ten numer w 'AVRDUDE Settings' w okienku 'Port' zamiast 'usb' wpisz aktualny comx - gdzie x to ten numer. na przykład com4

    e marcus

    0
  • #3 17 Sty 2016 13:14
    pawelcb33
    Poziom 24  

    Próbowałem wszystkie Com-y oraz to samo na drugim komputerze i nic z tego. Nie wiem może po prostu jest uszkodzony.
    Ale dzięki za zainteresowanie tematem.

    Znalazłem na A...o taki programator TL866CS, myślisz że będzie dobrym wyborem ?

    0
  • #4 17 Sty 2016 13:35
    tmf
    Moderator Mikrokontrolery Projektowanie

    Chcesz za ponad 500 zł kupić programator, umożliwiający programowaine tylko poza układem? Określ co chcesz programować. Jeśli tyko AVRy to kup oryginalny AVR ISP MkII lub Atmel-ICE, który ma także debugger. Z drugiej strony to zapewne twój klon MkII też da się przywrócić do życia - ja bym się w tym celu skontaktował z producentem.

    0
  • #5 17 Sty 2016 13:55
    373522
    Użytkownik usunął konto  
  • #6 17 Sty 2016 15:17
    pawelcb33
    Poziom 24  

    Ten programator z A...o kosztuje ok. 250zł niby nie dużo ale też nie za mało. Jasne że bym wolał uruchomić ten niż wydawać 250zł.

    Zrobiłem jak piszesz niveasoft, avrdude mam na c: ale nadal bez zmian.
    Mógłbyś wrzucić lub podać linka do ściągnięcia firmware który ty używasz bo może to wina jego.


    Teraz mam oto taki błąd:

    Nie działający programator AVRmkII

    Próbowane na kilku uC. Czyli nie znajduje urządzenia usb z tego co rozumiem.

    0
  • #7 17 Sty 2016 15:31
    373522
    Użytkownik usunął konto  
  • #8 17 Sty 2016 16:06
    pawelcb33
    Poziom 24  

    Robiłem wg. instrukcji ze strony plus wgrałem soft tam dany ale nadal to samo.
    Może po prostu jest coś z samym programatorem ?

    0
  • #9 17 Sty 2016 16:23
    373522
    Użytkownik usunął konto  
  • #10 21 Sty 2016 18:57
    pawelcb33
    Poziom 24  

    Programator jak nie działał tk nadal nie działa, nie mam już chęci na zabawę z nim więc zakupiłem programator ten który pisałem, działa bez problemu. Ten idzie na razie do szuflady.
    Dzięki wam na pomoc.

    0