Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Cisco 3800 - konfiguracja BGP, HSRP - mulacy router

19 Sty 2016 20:19 942 2
  • Poziom 9  
    Witam,
    Mam mały problem z którym nie potrafię sobie poradzić, gdzieś coś pominąłem lub nie doczytałem.
    Mam dwa routery 3800 Cisco, dwóch operatorów, publiczną adresację 24bitowa i swojego -AS
    Chciałbym ustawić na tym BGP oraz HSRP.
    Dziele adresację 24b na osiem podsieci i przy pomocy HSRP ustawiam, że pierwsze 4 podsieci idą przez jednego operatora a kolejne 4 przez następnego.
    I to w konfiguracji działa - sesje się nawiązują, podsieci wychodzą przez danego operatora.
    Przy próbie awarii jednego operatora/linku/routera cały ruch przełącza się na działająca końcówkę. Czyli wydawałoby się, że wszystko działa. Ale niestety. Jeden router (operator1) bardzo się muli przez 10-15sekund i powraca na kolejne 10-15 sekund i tak w kółko. Sesja BGP cały czas trwa nic się nie przełącza ale w tym czasie dostęp do neta (przez ten zawieszony router) jest praktycznie nie możliwy.
    Czy macie jakiś pomysł jak to usprawnić???
    Ręce już mi opadają...
    Pozdrawiam
    Marcin.
    ----------------------------------------------------
    Router1

    username xxxxx
    track 14 ip sla 14

    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/0.16
    description LINK do operator1
    encapsulation dot1Q 16
    ip address 88.88.88.26 255.255.255.252
    ip access-group 100 in
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/1.2
    encapsulation dot1Q 2
    ip address 12.12.12.8 255.255.255.0
    !
    interface GigabitEthernet0/1.22
    encapsulation dot1Q 22
    ip address 11.11.11.39 255.255.255.224
    standby 22 ip 11.11.11.33
    standby 22 priority 120
    standby 22 preempt delay minimum 30
    standby 22 track 14 decrement 25
    !
    interface GigabitEthernet0/1.26
    encapsulation dot1Q 26
    ip address 11.11.11.11 255.255.255.224
    standby 26 ip
    standby 26 preempt delay minimum 30
    !
    router bgp 33333
    no synchronization
    bgp log-neighbor-changes
    network 11.11.11.0
    network 11.11.11.0 mask 255.255.255.224
    network 11.11.11.32 mask 255.255.255.224
    network 11.11.11.64 mask 255.255.255.224
    network 11.11.11.96 mask 255.255.255.224
    network 11.11.11.128 mask 255.255.255.224
    network 11.11.11.160 mask 255.255.255.224
    network 11.11.11.192 mask 255.255.255.224
    network 11.11.11.224 mask 255.255.255.224
    neighbor 12.12.12.9 remote-as 20656
    neighbor 88.88.88.25 remote-as 12968
    neighbor 88.88.88.25 filter-list 10 out
    auto-summary
    !
    ip forward-protocol nd
    ip route 11.11.11.0 255.255.255.0 Null0 255
    no ip http server
    no ip http secure-server
    !
    ip as-path access-list 10 permit ^$
    ip as-path access-list 10 deny .*
    !
    !
    ip sla 14
    icmp-echo 8.8.8.8 source-ip 11.11.11.39
    frequency 20
    ip sla schedule 14 life forever start-time now

    route-map trzy permit 10
    match ip address 2
    set as-path prepend 33333 33333 33333
    !
    route-map jeden permit 10
    match ip address 2
    set as-path prepend 33333
    !
    route-map dwa permit 10
    match ip address 2
    set as-path prepend 33333 33333
    !
    line con 0
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input ssh
    !
    scheduler allocate 20000 1000
    end

    ----------------------------------------------------
    Roiter 2
    username xxx
    archive
    log config
    hidekeys
    track 15 ip sla 15
    !
    interface GigabitEthernet0/0
    description LINK WAN
    no ip address
    ip access-group 100 in
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/0.15
    description link do operator2
    encapsulation dot1Q 15
    ip address 33.33.33.146 255.255.255.252
    !
    interface GigabitEthernet0/1
    description LINK LOCAL
    no ip address
    duplex auto
    speed auto
    media-type rj45
    !
    interface GigabitEthernet0/1.2
    encapsulation dot1Q 2
    ip address 12.12.12.9 255.255.255.0
    !
    interface GigabitEthernet0/1.22
    encapsulation dot1Q 22
    ip address 11.11.11.37 255.255.255.224
    standby 22 ip
    standby 22 preempt delay minimum 30
    !
    interface GigabitEthernet0/1.26
    encapsulation dot1Q 26
    ip address 11.11.11.162 255.255.255.224
    standby 26 ip 11.11.11.161
    standby 26 priority 120
    standby 26 preempt delay minimum 30
    standby 26 track 15 decrement 25
    !
    !
    router bgp 333333
    bgp log-neighbor-changes
    neighbor 12.12.12.8 remote-as 20656
    neighbor 4.4.4.175 remote-as 8374
    neighbor 4.4.4.175 description PLUS
    neighbor 4.4. 4.175 ebgp-multihop 16
    neighbor 4.4.4.176 remote-as 8374
    neighbor 4.4.4.176 description PLUS
    neighbor 4.4.4.176 ebgp-multihop 16
    !
    address-family ipv4
    neighbor 12.12.12.8 activate
    neighbor 4.4.4.175 activate
    neighbor 4.4.4.175 weight 100
    neighbor 4.4.4.175 filter-list 10 out
    neighbor 4.4.4.176 activate
    neighbor 4.4.4.176 weight 100
    neighbor 4.4.4.176 filter-list 10 out
    auto-summary
    no synchronization
    network 11.11.11.0
    network 11.11.11.0 mask 255.255.255.224
    network 11.11.11.32 mask 255.255.255.224
    network 11.11.11.64 mask 255.255.255.224
    network 11.11.11.96 mask 255.255.255.224
    network 11.11.11.128 mask 255.255.255.224
    network 11.11.11.160 mask 255.255.255.224
    network 11.11.11.192 mask 255.255.255.224
    network 11.11.11.224 mask 255.255.255.224
    exit-address-family
    !
    ip forward-protocol nd
    ip route 11.11.11.0 255.255.255.0 Null0 255
    no ip http server
    ip http secure-server
    !
    ip as-path access-list 10 permit ^$
    ip as-path access-list 10 deny .*
    !
    !
    ip sla 15
    icmp-echo 8.8.8.8 source-ip 11.11.11.162
    frequency 20
    ip sla schedule 15 life forever start-time now

    logging 10.10.10.10
    access-list 100 deny ip 11.11.11.0 0.0.0.255 any log
    access-list 100 permit ip any any
    !
    !
    !
    !
    route-map trzy permit 10
    match ip address 2
    set as-path prepend 33333 33333 33333
    !
    route-map jeden permit 10
    match ip address 2
    set as-path prepend 33333
    !
    route-map dwa permit 10
    match ip address 2
    set as-path prepend 33333 33333
    !
    control-plane
    !
    !
    !
    !
    line aux 0
    line vty 0 4
    access-class 101 in
    privilege level 15
    password 7 14251D210D0A
    transport input ssh
    line vty 5 15
    scheduler allocate 20000 1000
    end





    Już mi ręce opadają. Będę wdzięczny za sugestie...
    Pozdrawiam
    Marcin
  • Poziom 23  
    Czy trzymasz całą tablicę BGP u siebie czy tylko część? Sprawdź wykorzystanie pamięci przez router, bo może jej po prostu brakować.
  • Poziom 9  
    Hej,.
    Dzięki za odpowiedź,
    No fakt od tego trzeba było zacząć:(
    Musze z tym poczekać do jutra.
    Czy jest jakiś szybki/dobry sposób na ograniczenie wpisów do tablicy.
    Pamiętam, że jeden z routerów miał o połowę mniejszą pamięć i to może być to.

    Z drugiej jednak strony, jak "puszczałem" oba routery oddzielnie bez powyższego połączenia-tylko jeden router-jeden usługodawca i BGP to śmigało u jednego operatora i u drugiego...hmm brak pomysłu.

    Jakbyś miał chwilę, co tu wykombinować z tą tablicą ograniczeniem wpisów byłoby mniej do gdybania.

    Pozdrawiam
    Marcin