Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
IGE-XAO
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

OPCOM.5 2007 - nie przechodzi testu po flash-owaniu PIC18F458 różnymi FW

Karhen90 25 Jan 2016 18:52 2487 7
  • #1
    Karhen90
    Level 2  
    Hej czy ktoś wie co może być problemem z opcom-em (opcom.5 2007) kiedy nie może przejść testu interface-u z programem OP-COM CHINA 08-2010 PL? Poniższe metody nie dały rady:
    -wymieniłem procka (pic18f458) na takiego samego oryginalnego pic18f458
    -zaprogramowałem go pickit3-em (programowalem go przeróżnymi wersjami wsadu od 1.33 do 1.44)
    -ftdi poprawnie odpowiada (znajduje sterownik oraz na oscyloskopie widze ze do procka leci ramka z wiadomoscią, procek nie odpowiada i jest fail na programie kompa)
    -świeci się normalnie żółty led (chyba Tx) od włączenia zasilania opcom-a
    -ogólnie różnymi programami na PC nie odpowiadał
    Słyszał ktoś o podobnym problemie? czego to może być wina?
    nie moge znaleźć na necie opowiedniego dobrego schematu tej wersji opcoma
    Możliwe że to jest najprawdopodobnie wina hardware-u?
    Ethernet jednoparowy (SPE) - rozwiązania w przemyśle. Szkolenie 29.09.2021r. g. 11.00 Zarejestruj się za darmo
  • IGE-XAO
  • IGE-XAO
  • #3
    Karhen90
    Level 2  
    część PEB-a już czytałem, nie miałem jeszcze czasu na przeczytanie tych wszystkich postów. Na astrze podobnie. Możliwe, że gdzieś będzie odpowiedź ale tak czy inaczej nie znalazłem takiego problemu. Liczę na to, że któryś z szanownych forumowiczów zetknął się z czymś takim albo będzie mieć jakiś ciekawy pomysł, bo jak na prostotę tego układziku to zabrakło mi pomysłów czego to może być wina
  • #4
    MasterP88
    Level 9  
    Witam. Borykam się z dokładnie tym samym problemem. Po wylutowaniu układu i zaprogramowaniu go w PICkit 3 wszystko niby jest ok, po wlutowaniu PICa w układ i odczycie w OPCOMFUT nie wykrywa niczego. Ma ktoś pomysł co może być przyczyną ?

    Pozdrawiam
  • #5
    tabul
    Level 12  
    Witam, ustawienia configuracji wsadu są inne, właśnie z tym walcze
  • #6
    zaradny2
    Level 9  
    Temat od dawna nie ruszany lecz przy porządkach znalazłem uszkodzonego opcoma postanowieniem go ożywić, wymieniłem pic18f458 podpoiłem do pickita 3 zainstalowałem program''PICkit 3 v3.10'' lecz nie ma wnim tego microchipa ., mam tez program ''PICPgm Programmer'' jest w nim ten chip lecz niełaczy sie za pomoca przystawki pickit3. Skąd ściągnąć oprogramowanie dla PICkita3 by polaczyl sie microchipem.?
  • #7
    piotrekwoj1
    Level 39  
    Witam, przecież OP-COM-a fleszuję się po USB a nie jakimiś dziwnymi programatorami.
  • #8
    Sivyx
    Level 16  
    Ocflash próbowałeś? W paczce dodatkowo stery + skrypt do czyszczenia innych driverów ftdi. Jaki program do tego chce używać? Jak masz jakąś wysoką wersję, to wgraj najniżesz fw i opcom sam zaktualizuje do tej co trzeba.