Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ram - Użycie ramu nie spadające po wyłączeniu programów

leaveskk 05 Lut 2016 21:46 1689 30
  • #1 05 Lut 2016 21:46
    leaveskk
    Poziom 8  

    Tak jak w temacie niestety ale użycie ramu pomimo wyłączenia programów nie spada do wartości początkowej i jedyne co w takim momencie pomaga to restart systemu po, którym to wszystko wraca do normy. Niestety nie jestem w stanie sobie z tym poradzić i prosiłbym o pomoc.

    Tutaj screeny zaraz po włączeniu komputera

    Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów

    Oraz po czasie w momencie gdy użycie ramu już jest wysokie pomimo wyłączenia wszystkich programów, które były użytkowane w tym czasie.

    Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów

    Płyta główna: Gigabyte GA-Z97X-Gaming 5, Z97
    Procesor: Intel Core i7-4790K 4 GHz
    Pamięć ram: G.Skill TridentX DDR3 2x4GB 2400MHz CL10 (F3-2400C10D-8GTX)
    Karta graficzna: Gigabyte GeForce GTX 970, 4GB GDDR5 (256bit)
    Zasilacz: Cooler Master G550M 550W Modularny 120mm 80+ (RS-550-AMAA-B1)
    System operacyjny: Microsoft Windows 8.1 PL 64-bit

    0 29
  • #3 06 Lut 2016 00:50
    leaveskk
    Poziom 8  

    Tutaj procesy akurat podczas sciągania czegoś na steam co z tego co zauważyłem zawsze powodowało zwiększanie użycia ramu aż do wyczerpania zasobów. Aczkolwiek to jest tylko jeden z przypadków gdy to się dzieje lecz przy ściąganiu akurat da się to najszybciej wywołać.

    Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów Ram - Użycie ramu nie spadające po wyłączeniu programów

    0
  • #4 06 Lut 2016 01:03
    safbot1st
    Poziom 43  

    To, co "zjada" te 7GB nie figuruje w ogóle na liście, dlatego podejrzewam infekcję.
    Coś w stylu wirusa atakującego "dllhost.exe" czy "svhost.exe" - posilającego się całą pamięcią RAM.
    W Process Explorer widać "toto"?

    Dodano po 1 [minuty]:

    Poza tym, wydaje mi się, albo masz wyłączoną pamięć wirtualną - ile jest ustawione?

    0
  • #5 06 Lut 2016 01:19
    leaveskk
    Poziom 8  

    Co do infekcji to raczej ciężko ponieważ od zakupu komputera w październiku ubiegłego roku, miało to już miejsce lecz nie byłem tego świadomy toteż później nie miałem za bardzo czasu się tym zająć.

    A co do pamięci wirtualnej to tutaj screen aczkolwiek nie wiem czy o to dokładnie chodziło

    Ram - Użycie ramu nie spadające po wyłączeniu programów

    0
  • #6 06 Lut 2016 07:59
    safbot1st
    Poziom 43  

    Wirtualna jest ok. Pokaż: Process Explorer, Monitor zasobów no i chyba potrzebne będą logi z FRST.

    0
  • #9 06 Lut 2016 13:25
    safbot1st
    Poziom 43  

    Od razu mówię, że są to infekcje cholernie trudne do wytępienia. Przynajmniej ja miałem dllhost.exe jeden raz tak zagnieżdżony, że tylko format pomógł (5 dni walki).

    Spoiler:

    CloseProcesses:
    (Microsoft Corporation) C:\Windows\System32\dllhost.exe
    (Microsoft Corporation) C:\Windows\System32\dllhost.exe
    (Microsoft Corporation) C:\Windows\SysWOW64\svchost.exe
    (Microsoft Corporation) C:\Windows\System32\dllhost.exe
    (Hi-Rez Studios) D:\Program Files (x86)\Hi-Rez Studios\HiPatchService.exe
    HKU\S-1-5-19\...\Winlogon: [Shell] C:\Windows\explorer.exe [2757072 2015-08-11] (Microsoft Corporation) <==== UWAGA
    HKU\S-1-5-20\...\Winlogon: [Shell] C:\Windows\explorer.exe [2757072 2015-08-11] (Microsoft Corporation) <==== UWAGA
    HKU\S-1-5-21-2710135483-3048943547-2186431749-1001\...\Run: [GoogleChromeAutoLaunch_D1E03BA2FBED2293602476C8815D41EF] => C:\Program Files (x86)\Google\Chrome\Application\chrome.exe [748872 2016-02-03] (Google Inc.)
    HKU\S-1-5-21-2710135483-3048943547-2186431749-1001\...\Policies\Explorer: []
    HKU\S-1-5-21-2710135483-3048943547-2186431749-1001\...\MountPoints2: {4e2bbccc-9d31-11e5-82c5-fcaa149ed088} - "G:\Startme.exe"
    HKU\S-1-5-21-2710135483-3048943547-2186431749-1001\...\Winlogon: [Shell] C:\Windows\explorer.exe [2757072 2015-08-11] (Microsoft Corporation) <==== UWAGA
    HKU\S-1-5-18\...\Winlogon: [Shell] C:\Windows\explorer.exe [2757072 2015-08-11] (Microsoft Corporation) <==== UWAGA
    S3 npggsvc; C:\Windows\SysWOW64\GameMon.des [3190784 2015-05-19] (INCA Internet Co., Ltd.)
    Task: {D280DABB-44CD-4295-9AD9-24B7B2DD1911} - System32\Tasks\GoogleUpdateTaskMachineUA => C:\Program Files (x86)\Google\Update\GoogleUpdate.exe [2015-09-08] (Google Inc.)
    Task: {DC328689-A255-489D-9485-7F27B28C06A7} - System32\Tasks\Adobe Acrobat Update Task => C:\Program Files (x86)\Common Files\Adobe\ARM\1.0\AdobeARM.exe [2015-12-13] (Adobe Systems Incorporated)
    Task: {F09447D5-7AFE-4DF8-B147-45F9B8D00393} - System32\Tasks\Microsoft\Windows\Setup\GWXTriggers\ScheduleUpgradeReminderTime => C:\Windows\system32\GWX\GWXUXWorker.exe [2015-12-05] (Microsoft Corporation)
    Task: {FEC4E2C5-D007-4AC7-A5FD-D899A0B481EE} - System32\Tasks\Microsoft\Windows\Setup\GWXTriggers\ScheduleUpgradeTime => C:\Windows\system32\GWX\GWXUXWorker.exe [2015-12-05] (Microsoft Corporation)

    EmptyTemp:

    Uruchom FRST jako administrator - to ważne.
    Zapisz kod jako fixlist.txt w folderze z FRST.exe i w FRST wybierz "napraw".

    Dodano po 2 [minuty]:

    Zamieść log z usuwania.

    Dodano po 7 [minuty]:

    Dodatkowo ADWcleaner i MBAM + to samo:
    safbot1st napisał:
    Zamieść log z usuwania.

    0
  • #11 06 Lut 2016 14:34
    TRupII
    Poziom 8  

    Mam dokładnie to samo i próbowałem jakoś temu zaradzić, nic nie wskórałem, mój wątek był tak samo tutaj na forum. Pogrzebałem po necie i bardzo prawdopodobne że to jest właśnie memory leak, dużo ludzi na to narzeka po aktualizacji do win10, ale podobno na 8/8.1 też to może występować.

    Spróbuj tego, niektórym pomaga:
    1. Wejdź do rejestru HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
    2. Zmień wartość ClearPageFileAtShutDown z 0 na 1

    0
  • #12 06 Lut 2016 14:50
    safbot1st
    Poziom 43  

    TRupII napisał:
    bardzo prawdopodobne że to jest właśnie memory leak

    Podasz jakieś linki? Ja znalazłem infekcję dokładnie tam gdzie się spodziewałem.
    Gorzej, że pewnie całą będzie ciężko usunąć, jak pisałem wyżej.
    @leaveskk
    Problem pozostał?
    TRupII napisał:
    2. Zmień wartość ClearPageFileAtShutDown z 0 na 1

    Jeśli masz ochotę skasować pagefile.sys to można go usunąć z pod bootowalnego linuxa.

    0
  • #13 06 Lut 2016 15:02
    leaveskk
    Poziom 8  

    Problem niestety pozostał.

    0
  • #14 06 Lut 2016 15:04
    TRupII
    Poziom 8  

    @safbot1st
    Jak wpiszesz w guglu win 10 ram to Cię zasypie artykułami na ten temat, pierwszy z brzegu: http://www.ibtimes.co.uk/how-fix-windows-10-high-memory-usage-issue-1514199

    Nie jestem w żaden sposób specjalistą w temacie, powtarzam tylko to co przeczytałem na innych stronach ;) Mnóstwo ludzi ma ten problem więc niekompatybilne sterowniki powodujące jakieś wycieki ramu brzmią sensownie.

    U mnie żadne programy nic nie wykrywają. I tak w przeciągu tygodnia miałem plan wyczyścić dysk i postawić wszystko na świeżo (przesiadka na wyższą wersję win10), mam nadzieje że to rozwiąże problem, bo póki co muszę go restartować średnio raz dziennie.

    0
  • #15 06 Lut 2016 15:33
    safbot1st
    Poziom 43  

    @TRupII Ja czytałem, że to błędna ciasna pętla w kodzie programowym.
    @leaveskk Poczekaj do wieczora, może nasi spece od komputerów coś podpowiedzą.
    Pod W7 problem "rozwiązywało" włączenie opcji "nigdy nie pokazuj miniatur".
    W W10 jak i wielu innych rzeczy - tej opcji brak.
    Prawda jest taka, że powinieneś przyszykować się na format.
    Im wcześniej się zdecydujesz tym lepiej. Jak pisałem - w podobnej sytuacji straciłem 5 dni.
    Niczego się nie dowiedziałem, a próbując zwalczyć "infekcję?" jedynie uszkodziłem system.

    0
  • #16 06 Lut 2016 15:51
    leaveskk
    Poziom 8  

    Tak jak piszesz poczekam do wieczora, może ktos na coś wpadnie i za ten czas przygotuje bootowalny pendrive. I ogólnie dzięki wielkie za zaangażowanie.

    0
  • #17 06 Lut 2016 15:52
    safbot1st
    Poziom 43  

    leaveskk napisał:
    przygotuje bootowalny pendrive.

    Zrób bootowalnego linuksa i poszukaj nim na dysku podejrzanych plików EXE.

    0
  • #18 06 Lut 2016 15:57
    leaveskk
    Poziom 8  

    Jedyne co mnie martwi to fakt ze problem z tym ram-em jest w sumie od samego początku jak zakupiłem komputer i nie chce mi się wierzyć w fakt ze mogło to być spowodowane infekcją.

    0
  • #19 06 Lut 2016 16:01
    safbot1st
    Poziom 43  

    To wyjmij 1 kość, zobaczymy co się stanie.

    0
  • #20 06 Lut 2016 16:43
    leaveskk
    Poziom 8  

    Przy podłączeniu jednej kości niestety to samo, a posprawdzałem oby dwie. Dalej rośnie ta pula niestronnicowa i pozostaje po wyłączeniu procesu, który się przyczynia do obciążenia ramu.

    0
  • #21 06 Lut 2016 16:50
    speedy9
    Pomocny dla użytkowników

    safbot1st napisał:
    TRupII napisał:
    2. Zmień wartość ClearPageFileAtShutDown z 0 na 1

    Jeśli masz ochotę skasować pagefile.sys to można go usunąć z pod bootowalnego linuxa.

    To nie kasuje pagefile.sys a jedynie czyści jego zawartość. Bez związku z tematem.
    TRupII napisał:
    Jak wpiszesz w guglu win 10 ram

    Rozmawiamy o Win 8.1.
    Zaktualizuj sterowniki, zwłaszcza do płyty głównej i dźwięku.

    0
  • #23 06 Lut 2016 18:40
    safbot1st
    Poziom 43  

    speedy9 napisał:
    Zaktualizuj sterowniki, zwłaszcza do płyty głównej i dźwięku.

    Czy ja wiem? Wg. mnie nic to nie da.
    Niestety speców bym się nie spodziewał, za to mam konsultację:
    post #8, screen #1 i 2:
    DasHost.exe
    WUDFhost.exe
    conhost.exe
    Ani to podpisane, brak producenta, ani nie wiadomo co to robi.
    W skrócie - masz mega-bałagan w systemie, co widziałem jak sprawdzałem logi.
    Gdybyś choć trochę "odgruzował" system problem może by sam zniknął.
    Dlatego "przywracanie oprogramowania układowego" (windows) nie jest złym krokiem - już to pisałem.
    Nie wspomnę o dużej ilości i gier z/i (?) programów P2P, miejmy nadzieję, że legalnych.

    Użyj "Wise Memory Optimizer". Ciekawym, czy zwolni pamięć. Jest całkiem sprytny i w 100% bezpieczny pod warunkiem, że zaptaszkujesz "Run when CPU is idle".

    0
  • #24 06 Lut 2016 18:58
    leaveskk
    Poziom 8  

    Co do wise memory optimizer to użyciu ramu spadło z 2200 do 1800 choć po chwili znowu było już około 2100. Co do legalności zapewniam ze wszystko jest ok, poza tym głupio było by mi prosić o pomoc mając coś nielegalnego na kompie, dziwnie by to wyglądało. Teraz pytanie bawić się w "odgruzowywanie" jak to napisałeś czy jednak zrobić format?

    0
  • #25 06 Lut 2016 19:12
    safbot1st
    Poziom 43  

    leaveskk napisał:
    Teraz pytanie bawić się w "odgruzowywanie" jak to napisałeś czy jednak zrobić format?

    Tylko jak długo to potrwa zanim wykryjesz sprawcę "przecieku" w RAM?
    Szczerze? Zrób format.(nie format) tylko przywracanie - wcześniejszego stanu albo najlepiej oprogramowania układowego z partycji recovery (będziesz musiał wykonać backup danych usera z C:\).
    Rzadko mi się zdarza zalecanie reinstalacji windows - jednak teraz to po prostu oszczędność czasu.

    Dodano po 2 [minuty]:

    Tylko ostrożnie z instalowaniem i otwieraniem starych danych na świeżym systemie - może w nich coś ciągle "czyhać".

    0
  • #26 06 Lut 2016 21:58
    speedy9
    Pomocny dla użytkowników

    safbot1st napisał:
    Czy ja wiem? Wg. mnie nic to nie da.

    A ja wiem, że to właśnie sterowniki są najczęstszą przyczyną memory leaków. Nie twierdzę oczywiście, że to na 100% ten problem. Na stronie Intela jest aplikacja, która sama wyszuka Ci najnowsze sterowniki do płyty.

    safbot1st napisał:
    Zrób (nie format) tylko przywracanie - wcześniejszego stanu albo najlepiej oprogramowania układowego z partycji recovery

    Skąd on ma mieć partycję recovery? Po konfiguracji wnioskuję, że to składak. Poza tym co ma dać przywracanie do wcześniejszego stanu skoro problem występował od początku?

    DasHost.exe - składnik Windows
    WUDFhost.exe - j.w.
    conhost.exe - j.w.
    Pliki są w C:\Windows\System32\. Jeśli mają prawidłowe podpisy, to raczej są w porządku. Możesz przeskanować antywirusem.

    0
  • #27 06 Lut 2016 22:40
    safbot1st
    Poziom 43  

    speedy9 napisał:
    A ja wiem, że to właśnie sterowniki są najczęstszą przyczyną memory leaków.

    Przepraszam, w takim razie, że w kolegi wiedzę nie zainwestowałem wystarczającego zaufania.
    W takim razie zostanę tylko przy stanowisku, że sformatować będzie po prostu szybciej i duża szansa na pozbycie się problemu.

    Dodano po 7 [minuty]:

    speedy9 napisał:
    Skąd on ma mieć partycję recovery? Po konfiguracji wnioskuję, że to składak. Poza tym co ma dać przywracanie do wcześniejszego stanu skoro problem występował od początku?

    Rozumiem - brak recovery.
    leaveskk napisał:
    od zakupu komputera w październiku ubiegłego roku, miało to już miejsce lecz nie byłem tego świadomy

    Ciężko wywnioskować kiedy "to" się zaczęło.

    0
  • #29 06 Lut 2016 22:49
    safbot1st
    Poziom 43  

    Gnębią mnie po prostu te wpisy:
    HKU\S-1-5-19\...\Winlogon: [Shell] C:\Windows\explorer.exe [2757072 2015-08-11] (Microsoft Corporation) <==== UWAGA
    HKU\S-1-5-20\...\Winlogon: [Shell] C:\Windows\explorer.exe [2757072 2015-08-11] (Microsoft Corporation) <==== UWAGA
    Wygląda jak naruszenie powłoki NT. Tego tam nie powinno być. W tych miejscach się rootkity przyklejają, nieprawdaż?

    0
  • #30 06 Lut 2016 23:07
    leaveskk
    Poziom 8  

    Co do aktualizacji sterowników to jedyne co mi wyświetla intelowski program do update-owania to Intel Chipset Device Software zaznaczając, że mam wersje 6.3.9600.17238 przy czym najnowsza to 10.0.27 więc pobrałem ale instalacja się nie powiodła. Gdy pobrałem manualnie ze strony niby instalacja się udała lecz gdy sprawdzam ponownie to sterowniki dalej pozostają w starej wersji.

    0