Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Mikrotik [RouterOS] - Rsync pomiedzy dwoma NAS w sieci lokalnej nie działa

08 Lut 2016 20:39 975 20
  • Poziom 13  
    Mam kłopot z replikacją w mojej sieci LAN. Codziennie w godzinach nocnych mam ustawiona replikacje danych z jednego NASa na drugiego. Kiedy używalem 'zwykłego' routera (Fritzbox) z replikacją nie miałem żadnego kłopotu. W momencie kiedy zmieniłem router na RB951g-2hnd replikacja przestała działac. Komunikaty jakie pojawiaja sie w logach Qnapa to:

    Code:
     [Remote Replication] (Sync) foto failed: [sender] io timeout after 600 seconds -- exiting  Begin 6th retry. 


    Code:
    [Remote Replication] (Sync) foto failed: Connection closed by 10.0.0.20
    
      Begin 2nd retry.   






    NASy sa podpięte odpowiednio w porty LAN2, LAN3. NIe dokonywałem żadnej korekty ustawień w NASach. Kiedy zmienię router replikacja rusza natychmiast. Co w takim razie blokuje ją w Mikrotiku? Prosze o podpowiedź jakie ustawienia wprowadzić aby replikacja zaskoczyła.

    RB951g-2hnd pracuje jako zwykly 'ethernet-router' z kablówką. Wifi ma wylączone. Bardzo proszę o pomoc bo mi to nie daje spokoju.

    Pozdrawiam serdecznie
  • Pomocny post
    Specjalista Sieci, Internet
    Jakie IP/maskę mają NASy ?
  • Pomocny post
    Poziom 31  
    No i najwazniejsze jakie reguly masz w firewallu.
    Jesli to domyslna konfiguracja to duze szanse ze firewall blokuje
  • Poziom 13  
    bogiebog napisał:
    Jakie IP/maskę mają NASy ?


    Odpowiednio:
    Qnap: 10.0.0.15; maska: 255.0.0.0
    Synology: 10.0.0.20; maska: 255.0.0.0

    Dodano po 2 [minuty]:

    smario11 napisał:
    No i najwazniejsze jakie reguly masz w firewallu.
    Jesli to domyslna konfiguracja to duze szanse ze firewall blokuje


    W firewallu są aktualnie domyśłne reguły.Jako, że router dopiero przyszedł nic nie było jeszcze ustawiane. Żadnych kolejek etc.
  • Poziom 37  
    whizzo napisał:
    bogiebog napisał:
    Jakie IP/maskę mają NASy ?


    Odpowiednio:
    Qnap: 10.0.0.15; maska: 255.0.0.0
    Synology: 10.0.0.20; maska: 255.0.0.0

    Dodano po 2 [minuty]:

    smario11 napisał:
    No i najwazniejsze jakie reguly masz w firewallu.
    Jesli to domyslna konfiguracja to duze szanse ze firewall blokuje


    W firewallu są aktualnie domyśłne reguły.Jako, że router dopiero przyszedł nic nie było jeszcze ustawiane. Żadnych kolejek etc.

    A takie trywialne sprawdzenia jak pingowanie z jedno NASa na drugi to działa?

    W mikrotiku kazdy port moze byc sobie osobno skonfigurowany z osobna adresacja. Zeby 4 porty działały jak switch to tez trzeba skonfigurowac, np poprzez ustawienie portu master dla wszystich podrzednych. Czyli np portom 3,4,5 ustawiasz master jako port 2. Zakladam ze port 1 to "WAN".
    Ale to jest tylko zgadywanie.
  • Poziom 13  
    m.jastrzebski napisał:
    whizzo napisał:
    bogiebog napisał:
    Jakie IP/maskę mają NASy ?


    Odpowiednio:
    Qnap: 10.0.0.15; maska: 255.0.0.0
    Synology: 10.0.0.20; maska: 255.0.0.0

    Dodano po 2 [minuty]:

    smario11 napisał:
    No i najwazniejsze jakie reguly masz w firewallu.
    Jesli to domyslna konfiguracja to duze szanse ze firewall blokuje


    W firewallu są aktualnie domyśłne reguły.Jako, że router dopiero przyszedł nic nie było jeszcze ustawiane. Żadnych kolejek etc.

    A takie trywialne sprawdzenia jak pingowanie z jedno NASa na drugi to działa?

    W mikrotiku kazdy port moze byc sobie osobno skonfigurowany z osobna adresacja. Zeby 4 porty działały jak switch to tez trzeba skonfigurowac, np poprzez ustawienie portu master dla wszystich podrzednych. Czyli np portom 3,4,5 ustawiasz master jako port 2. Zakladam ze port 1 to "WAN".
    Ale to jest tylko zgadywanie.



    Pingowanie do Synology:

    Code:
    [~] # ping 10.0.0.20
    
    PING 10.0.0.20 (10.0.0.20): 56 data bytes
    64 bytes from 10.0.0.20: icmp_seq=0 ttl=64 time=0.4 ms
    64 bytes from 10.0.0.20: icmp_seq=1 ttl=64 time=0.2 ms
    64 bytes from 10.0.0.20: icmp_seq=2 ttl=64 time=0.2 ms
    64 bytes from 10.0.0.20: icmp_seq=3 ttl=64 time=0.1 ms
    64 bytes from 10.0.0.20: icmp_seq=4 ttl=64 time=0.2 ms
    64 bytes from 10.0.0.20: icmp_seq=5 ttl=64 time=0.2 ms
    64 bytes from 10.0.0.20: icmp_seq=6 ttl=64 time=0.1 ms
    64 bytes from 10.0.0.20: icmp_seq=7 ttl=64 time=0.1 ms
    64 bytes from 10.0.0.20: icmp_seq=8 ttl=64 time=0.2 ms
    64 bytes from 10.0.0.20: icmp_seq=9 ttl=64 time=0.2 ms
    64 bytes from 10.0.0.20: icmp_seq=10 ttl=64 time=0.2 ms



    Co do interfejsów jest tak jak napisałeś. LAN1 to WAN. LAN2 to 'ether2-master'
    a pozostałe (LAN3,LAN4,LAN5) mają ustawione master port 'ether2-master'
  • Poziom 37  
    whizzo napisał:

    Co do interfejsów jest tak jak napisałeś. LAN1 to WAN. LAN2 to 'ether2-master'
    a pozostałe (LAN3,LAN4,LAN5) mają ustawione master port 'ether2-master'

    To skoro sie pinguja, to tez bym stawiał na firewall.
    Moze zapodaj tutaj wszystkie regulki?
  • Poziom 13  
    m.jastrzebski napisał:
    whizzo napisał:

    Co do interfejsów jest tak jak napisałeś. LAN1 to WAN. LAN2 to 'ether2-master'
    a pozostałe (LAN3,LAN4,LAN5) mają ustawione master port 'ether2-master'

    To skoro sie pinguja, to tez bym stawiał na firewall.
    Moze zapodaj tutaj wszystkie regulki?


    Wrzucam screeny. NIe wiem jak wyciagnąć kod z Winboxa. Wybaczcie;-)

    'Address List' i 'Layer7 Protocol' są puste.
  • Pomocny post
    Poziom 37  
    Ja czasami robia takie cus. Czyszcze liczniki przy regulkach firewalla. Natychmiast odpalam co nie działą i czasem mozna zobaczyc ktora regulce sie zmienia licznik.
  • Pomocny post
    Poziom 31  
    A ja podejrzewam dlaczego nie dziala :)

    Ustaw na nasach maske podsieci 255.255.255.0 i zadziala.
    Jestem pewny ze w ustawieniach ip mikrotikach masz maske /24 i tak samo z dhcp przydziela z taka maska dlatego nie masz komunikacji.

    Na PW wysle adres gdzie czteropaka wyslac ;)
  • Poziom 13  
    m.jastrzebski napisał:
    Ja czasami robia takie cus. Czyszcze liczniki przy regulkach firewalla. Natychmiast odpalam co nie działą i czasem mozna zobaczyc ktora regulce sie zmienia licznik.


    Mam zbyt dużo urządzeń, które muszą być w chwili obecnej połączone z netem by sobie móc pozwolić na ich odłączenie.

    Rozumiem, że nic interesującego nie ma w regułach firewalla. Pytanie gdzie dalej szukać przyczyny blokowania replikacji?

    Dziękuję za pomoc oczywiście. Mam nadzieję, że uda sie wreszcie drania dopaść;-)
  • Pomocny post
    Specjalista Sieci, Internet
    w terminalu
    /ip firewall export file=fw

    załącz fw.rsc
  • Poziom 13  
    bogiebog napisał:
    w terminalu
    /ip firewall export file=fw

    załącz fw.rsc



    Proszę bardzo:
    Code:
    # feb/09/2016 14:02:50 by RouterOS 6.34.1
    
    # software id = KQLY-9T90
    #
    /ip firewall filter
    add chain=input comment="defconf: accept ICMP" protocol=icmp
    add chain=input comment="defconf: accept establieshed,related" \
        connection-state=established,related
    add action=drop chain=input comment="defconf: drop all from WAN" \
        in-interface=ether1
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
        connection-state=established,related
    add chain=forward comment="defconf: accept established,related" \
        connection-state=established,related
    add action=drop chain=forward comment="defconf: drop invalid" \
        connection-state=invalid
    add action=drop chain=forward comment=\
        "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
        connection-state=new in-interface=ether1
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" \
        out-interface=ether1


    Dodano po 3 [minuty]:

    smario11 napisał:
    A ja podejrzewam dlaczego nie dziala :)

    Ustaw na nasach maske podsieci 255.255.255.0 i zadziala.
    Jestem pewny ze w ustawieniach ip mikrotikach masz maske /24 i tak samo z dhcp przydziela z taka maska dlatego nie masz komunikacji.

    Na PW wysle adres gdzie czteropaka wyslac ;)


    Co do maski wszędzie była ustawiona poprawnie. Tak w RouterOS gdzie ustawienia sieciowe to:

    IP: 10.0.0.5
    netmask: 255.0.0.0/8
    DHCP SRV: 10.0.0.10-10.0.0.100

    Identyczne ustawienia sieciowe wprowadzilem do Synology jak i Qnapa. Oczywiście z pominięciem IP, które to są ustawione dla NASów statyczne.
  • Pomocny post
    Poziom 37  
    Ja w tym FW nic nie widze. Zreszta same defaultowe ustawienia chyba. :cry:
  • Pomocny post
    Specjalista Sieci, Internet
    Na próbę, w chain forward daj na 1szej pozycji, ACCEPT,

    Jak oba komputery w tej samej sieci, to nie powinno iść przez firewall, tylko switch L2 mikrotika powinien przesyłać pakiety automatycznie.


    /int export file=int.rsc
    załacz int.rsc plik

    z obu komputerów pokaż

    ping IP_DRUGIEGO_KOMP
    tracert -d IP_DRUGIEGO_KOMP
    ipconfig /all
    route print
    arp -a
  • Poziom 13  
    Mam chyba jednak trop i jest on związany z DNS-ami.
    Trochę zmieniałem ustawienia w NASach. Z reguły miałem DNSy ustawione ręcznie. Były to Google'owe:
    8.8.8.8
    8.8.4.4

    Skąd taki trop? W czasie kiedy zmieniałem ustawienia DNS jedno z uruchomionych zadań replikacji zostało wykonane. Pytanie czy to właśnie DNSy były (są) przyczyną. Być może w zwykłych routerach nie ma to znaczenia (takie ustawienie DNS), ale w Mikrotiku zauważyłem drobny błąd może pogrzebać sporo.

    Być może tu sie czai błąd. Czy nie powinienem jako pierwszy DNS (jeśli je oczywiście edytuje i ustawiam ręcznie) pozostawić Bramę, czyli w moim przypadku 10.0.0.5?

    Jak właściwie to powinno być ustawione w urządzeniach za NATem?

    Wklejam ustawienia sieciowe Qnapa i Synology
  • Poziom 13  
    m.jastrzebski napisał:
    Ja w tym FW nic nie widze. Zreszta same defaultowe ustawienia chyba. :cry:


    Tak. To są defaultowe ustawienia. Nic jeszcze nie zdążyłem zmienić.
  • Pomocny post
    Poziom 37  
    A to ja bym jeszcze na probe wylaczyl te jambo frame na NASach. Bo mikrotik slynie z nieobslugiwania duzych ramek.
  • Poziom 13  
    m.jastrzebski napisał:
    A to ja bym jeszcze na probe wylaczyl te jambo frame na NASach. Bo mikrotik slynie z nieobslugiwania duzych ramek.


    Pijemy! Poszło. Co dziwne w Qnapie nie zauważyłem możliwości wyłączenia 'ramki'
    Można ustawić tylko wartość MTU ręcznie.

    Bardzo dziękuję wszystkim za pomoc i zaangażowanie. Problem wygląda na rozwiązany.
  • Poziom 37  
    whizzo napisał:
    m.jastrzebski napisał:
    A to ja bym jeszcze na probe wylaczyl te jambo frame na NASach. Bo mikrotik slynie z nieobslugiwania duzych ramek.


    Pijemy! Poszło. Co dziwne w Qnapie nie zauważyłem możliwości wyłączenia 'ramki'
    Można ustawić tylko wartość MTU ręcznie.

    Bardzo dziękuję wszystkim za pomoc i zaangażowanie. Problem wygląda na rozwiązany.

    Smario, oddawaj 4-paka :P ;-)
  • Poziom 13  
    Cytat:
    Smario, oddawaj 4-paka :P ;-)


    No panowie, któremu mam wysłać? Określcie się;-)
    Pozdrawiam