Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zabezpieczenie portu rezystorem i kondensatorem

TMEA 24 Lut 2016 08:27 837 15
  • #1 24 Lut 2016 08:27
    TMEA
    Poziom 16  

    Mam problem a właściwie sprzeczkę z pewnym gościem ponieważ on twierdzi, że ten schemat czujnika silnika jest dobry a ja uważam, że rezystor 4.7k jest zbyt duży. Jak uważacie? Może w ogóle usunąć ten rezystor? Przewody do silnika mają długość 15cm.

    0 15
  • #2 24 Lut 2016 09:12
    BlueDraco
    Specjalista - Mikrokontrolery

    Ba, a skąd my mamy wiedzieć, co kryje się pod nazwą "sensor silnika"? Póki co można tylko powiedzieć, że schemat jest fatalnie narysowany - wejście z dołu zamiast z lewej, plus na dole razem z masą - tego się nie da czytać przy większej komplikacji.

    0
  • #3 24 Lut 2016 09:15
    jesion40
    Poziom 27  

    Rozumiem, że nie widzisz potrzeby informowania nas o tym, jaki czujnik podłączasz do jakiego układu? Cóż, w takim razie mogę ci tylko odpowiedzieć tak;

    Może dobry, może nie, zależnie od impedancji wejścia U$1, do którego jest podłączony. Prawdopodobnie dobry. Usuwanie go to proszenie się o kłopoty - zakłócenia mogą nawet uszkodzić układ.

    0
  • #4 24 Lut 2016 09:32
    TMEA
    Poziom 16  

    a sorry zapomniałem - sensor to zwykła krańcówka zrobiona na mikroswitchu :)

    0
  • #5 24 Lut 2016 09:36
    excray
    Poziom 39  

    Zmniejszyłbym R6, reszta bez zmian.

    0
  • #6 24 Lut 2016 09:38
    TMEA
    Poziom 16  

    A ja się zastanawiam nad zmniejszeniem R7 bo czasem wydaje mi się że samo mi stan zmienia. Co o tym myślicie? 1k będzie czy nawet 100 ohm dać jako R7?

    0
  • #7 24 Lut 2016 09:58
    jesion40
    Poziom 27  

    TMEA napisał:
    A ja się zastanawiam nad zmniejszeniem R7 bo czasem wydaje mi się że samo mi stan zmienia. Co o tym myślicie? 1k będzie czy nawet 100 ohm dać jako R7?
    Co to znaczy "samo stan zmienia"?

    Przy zwartej krańcówce nie widzi chwilami zwarcia? Czy przy rozwartej chwilami widzi pozorne zwarcie? To zupełnie różne sytuacje!

    0
  • #8 24 Lut 2016 10:06
    BlueDraco
    Specjalista - Mikrokontrolery

    Zgaduję, że o drgania styków chodzi - trzeba to programowo obsłużyć - przerwanie timera, czyli coś, co wraca tu 2 razy na tydzień (ostatnio wczoraj).

    0
  • #9 24 Lut 2016 10:13
    TMEA
    Poziom 16  

    Czasem wygląda na to, że gdy styki są zwarte to on twierdzi ze są rozwarte czyli jakby ten rezystor 4.7k był za duży.

    0
  • #10 24 Lut 2016 11:04
    jesion40
    Poziom 27  

    TMEA napisał:
    Czasem wygląda na to, że gdy styki są zwarte to on twierdzi ze są rozwarte czyli jakby ten rezystor 4.7k był za duży.
    Co to znaczy w praktyce? Jak często się to zdarza? Jak długo trwa?

    Rozumiem, że nie jest to kwestia błędnego zliczania zmiany stanu, ale w stabilnej sytuacji, przy zwartej krańcówce nagle widzi rozwarcie?

    Czy masz możliwość zmierzenia napięcia na końcówce układu? Jeżeli tak, to zewrzyj na krótko zaciski, pod które podłączasz czujnik i zmierz jakie wtedy będzie napięcie.

    0
  • #11 24 Lut 2016 11:11
    TMEA
    Poziom 16  

    nie wiem jak długo to trwa ale układ odczytuje zmianę i zapisuje w pamięci że coś takiego nastąpiło a nie powinno tak pokazywać. Wszystko dzieje się w stabilnej sytuacji bo czasem nawet nie ruszam układu i układ wskazuje że była zmiana stanu. Hmm sprawdze napięcie jak będę miał oscyloskop. Przy zwartej krancówce nagle widzi rozwarcie właśnie czasem.

    0
  • #12 24 Lut 2016 11:24
    jesion40
    Poziom 27  

    TMEA napisał:
    Hmm sprawdze napięcie jak będę miał oscyloskop.
    Na ogół wystarcza najzwyklejszy woltomierz :D Skoro możesz obserwować działanie układu a problemy zdarzają się dostatecznie często, by je obserwować to zewrzyj na głucho zaciski - odpadną wszystkie przyczyny związane z połączeniem z czujnikiem, zakłóceniami itp.

    0
  • #13 24 Lut 2016 11:26
    TMEA
    Poziom 16  

    właśnie testuje. zalutowałem na sztywno sensor i będę sprawdzał ale jaki założyc ten opornik zamiast 4.7k aby to zabezpieczało? 1k może być?

    0
  • #14 24 Lut 2016 16:18
    jesion40
    Poziom 27  

    TMEA napisał:
    właśnie testuje. zalutowałem na sztywno sensor i będę sprawdzał ale jaki założyc ten opornik zamiast 4.7k aby to zabezpieczało? 1k może być?
    Proponuję najpierw solidnie zdiagnozować problem, potem go rozwiązać.

    Zmniejszenie R7 pomoże tylko w przypadku, gdy problem wynika ze zbyt wysokiego napięcia na wejściu U$1 przy zwarciu na wejściu czujnika. To wydaje się mało prawdopodobne o ile program prawidłowo ustawił tę końcówkę jako wejście (wysoka impedancja). Łatwo to zdiagnozować - wystarczy przy zwartych na krótko zaciskach zmierzyć napięcie za R7 (czyli na końcówce U$1).

    Proszę też zwrócić uwagę na czytelność przekazywanych informacji. Czytając ostatni wpis można przyjąć, że nadal podłączony jest czujnik, tylko jego przewody są przylutowane. Pewnie tak nie jest, ale czy mamy to rozumieć tak, że zamiast sensora jest zwora na zaciskach płytki? Pewności nie ma....

    0
  • #15 24 Lut 2016 20:19
    Piotr Piechota
    Poziom 21  

    Nie wiem jaka to krańcówka ale często styki mechaniczne mają podany przez producenta minimalny prąd jaki powinien płynąć przez zamknięte styki. Np. dla popularnych przekaźników R15 minimalny prąd to o ile pamiętam 5mA. Poniżej tego prądu nie ma gwarancji, że zamknięty styk będzie przewodził. Osobiści miałem do czynienia z tego typu problemami.

    0
  • #16 07 Mar 2016 07:52
    TMEA
    Poziom 16  

    tak zalutowana jest zwora na porcie a czujnik odpięty :)

    0